Lumin Development Requirements

Magic Leap's Lumin development requirements including hardware, software, and SDK information.

Windows
MacOS
Linux

In this page you'll find hardware and software development kit (SDK) requirements needed to start developing for the Lumin platform. 

Unreal Engine 4.26

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements.

Supported AR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements.

SDK Version

0.24.0

Unreal Engine 4.25

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements.

Supported AR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements.

SDK Version

0.23.0

Unreal Engine 4.24

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements.

Supported AR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements.

SDK Version

0.22.0

Unreal Engine 4.23

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements.

Supported AR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements.

SDK Version

0.19.0

Unreal Engine 4.22

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements.

Supported AR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements.

SDK Version

0.19.0

Unreal Engine 4.21

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements.

Supported AR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements.

SDK Version

0.16.0

Unreal Engine 4.20

Hardware Requirements

Recommended Desktop Hardware

See Magic Leap's Developer System Requirements.

Supported AR Headset

Magic Leap One

Software Requirements

Desktop Operating System

Windows 10 64-bit or later.
MacOS 10.11 or later.
See Magic Leap's Developer System Requirements.

SDK Version

0.12.0

Help shape the future of Unreal Engine documentation! Tell us how we're doing so we can serve you better.
Take our survey
Dismiss