Google VR Development Requirements

Google VR development requirements including hardware, software, and SDK information.

Windows
MacOS
Linux

In this page you'll find hardware and software development kit (SDK) requirements needed to start developing for the Google VR platform.

Unreal Engine 4.24

As of engine release 4.24, UE4 support for Google VR has been deprecated.

Unreal Engine 4.23

Hardware Requirements

Recommended Desktop Hardware

See Hardware and Software Specifications.

Supported VR Headsets

Daydream View

Recommended Device Hardware

For Daydream, see Google's Daydream Device Compatibility.

Software Requirements

Desktop Operating System

See Hardware and Software Specifications.

SDK Version

Android SDK 8 (API level 26) or higher.

Android Studio Version

2.3.3 or higher.

Unreal Engine 4.22

Hardware Requirements

Recommended Desktop Hardware

See Hardware and Software Specifications.

Supported VR Headsets

Cardboard viewer; Daydream View

Recommended Device Hardware

Cardboard requires an Android device running 4.4 'Kit Kat' (API level 19) or higher.
For Daydream, see Google's Daydream Device Compatibility.

Software Requirements

Desktop Operating System

See Hardware and Software Specifications.

SDK Version

Android SDK 8 (API level 26) or higher.

Android Studio Version

2.3.3 or higher.

Unreal Engine 4.21

Hardware Requirements

Recommended Desktop Hardware

See Hardware and Software Specifications.

Supported VR Headsets

Cardboard viewer; Daydream View

Recommended Device Hardware

Cardboard requires an Android device running 4.4 'Kit Kat' (API level 19) or higher.
For Daydream, see Google's Daydream Device Compatibility.

Software Requirements

Desktop Operating System

See Hardware and Software Specifications.

SDK Version

Android SDK 7.1.1 'Nougat' (API level 25) or higher.

Android Studio Version

2.3.3 or higher.

Unreal Engine 4.20

Hardware Requirements

Recommended Desktop Hardware

See Hardware and Software Specifications.

Supported VR Headsets

Cardboard viewer; Daydream View

Recommended Device Hardware

Cardboard requires an Android device running 4.4 'Kit Kat' (API level 19) or higher.
For Daydream, see Google's Daydream Device Compatibility.

Software Requirements

Desktop Operating System

See Hardware and Software Specifications.

SDK Version

Android SDK 7.1.1 'Nougat' (API level 25) or higher.

Android Studio Version

2.3.3 or higher.

Unreal Engine 4.19

Hardware Requirements

Recommended Desktop Hardware

See Hardware and Software Specifications.

Supported VR Headsets

Cardboard viewer; Daydream View

Recommended Device Hardware

Cardboard requires an Android device running 4.4 'Kit Kat' (API level 19) or higher.
For Daydream, see Google's Daydream Device Compatibility.

Software Requirements

Desktop Operating System

See Hardware and Software Specifications.

SDK Version

Android SDK 7.1.1 'Nougat' (API level 25) or higher.

Android Studio Version

2.3.3 or higher.

Help shape the future of Unreal Engine documentation! Tell us how we're doing so we can serve you better.
Take our survey
Dismiss