HoloLens 2 用アプリをパッケージ化する

HoloLens 2 用のアプリをパッケージ化する手順を説明します。

Windows
MacOS
Linux

Unreal プロジェクトをユーザーに配布する前に、適切にパッケージ化する必要があります。次の説明に従って、HoloLens 2 用のパッケージをビルドします。

HoloLens のための Plugin 設定

手順

  1. Unreal プロジェクトで、HoloLens Plugin ([Plugins (プラグイン)] > [AR] > [HoloLens]) が有効になっていることを確認します。HoloLens プラグインが有効になっていない場合は、プラグインを有効にし、プロンプトが表示されたらエディタを再起動します。

  2. Unreal プロジェクトで、Microsoft Windows Mixed Reality Plugin ([Plugins (プラグイン)] > [Virtual Reality (仮想現実)] > [Microsoft Windows Mixed Reality]) が有効になっていることを確認します。Microsoft Windows Mixed Reality Plugin が有効になっていない場合は、有効にしてプロンプトが表示されたらエディタを再起動します。

Epic Games Launcher からサポート ファイルをインストールする

今回が HoloLens 用パッケージの初めてのビルドであれば、Epic Games Launcher よりサポート ファイルをダウンロードいただく必要がある場合があります。

手順

  1. Epic Games Launcher[Library (ライブラリ)] タブへ移動します。

    Launcher.png

  2. [Launch (起動)] の隣にあるプルダウンメニューを選択後、[Options (オプション)] を選択します。

    LauncherOptionsButton.png

  3. [Unreal Engine Installation Options (Unreal Engine インストール オプション)] のメニューより [HoloLens] を選択し、[Apply (適用)] をクリックします。

    UEInstallationOptionsMenu.png

HoloLens をパッケージ化するためのプロジェクト設定を行う

手順

  1. [Project Settings (プロジェクト設定)] > [Project] > [About] > [Project Name] へ移動し、プロジェクト名を入力します。

  2. [Project Settings] > [Project] > [Publisher] > [Company Name] へ移動し、企業名を入力します。

  3. [Project Settings] > [Project] > [Publisher] > [Company Distinguished Name (会社識別名)] へ移動し、前項で入力した企業名に続けて CN= と入力します。

  4. [Project Settings] > [Project] > [Settings] の順に選択して [Start in VR] を有効にします。

  5. [Project Settings] > [Platforms] > [HoloLens] > [Packaging] > [Signing Certificate (証明書に署名)] へ移動し、[Generate New (新規生成)] を選択します。

  6. 秘密鍵パスワード (Private Key Password) を作成するためのプロンプトが表示されます。テスト目的のため、[None (なし)] をクリックします。

  7. HoloLens Emulation をパッケージ化するには、[Project Settings] > [Platforms] > [HoloLens] > [Holo Lens] へ移動し、[Build for Hololens Emulation (Hololens Emulation 用にビルド)] を選択します。

  8. HoloLens Emulation をパッケージ化するには、[Project Settings] > [Platforms] > [HoloLens] > [Holo Lens] へ移動し、[Build for Hololens Device (Hololens Device 用にビルド)] を選択します。

HoloLens 用プロジェクトをパッケージ化する

手順

  1. [File (ファイル)] > [Package Project (プロジェクトをパッケージ化)] > [HoloLens] を選択します。

    PackageProjectForHoloLens.png

  2. パッケージ作成先のフォルダを入力します (またはデフォルトを選択)。

  3. パッケージ化のステータスは、画面の右下に表示されます。処理の詳細は [Output Log (アウトプットログ)] で確認できます。

    PackagingProjectStatus.png

結果

パッケージ化処理が終了すると、下に示すスクリーンショットに似た画面がプロジェクト ディレクトリに表示されます。デフォルトの作成先フォルダを選択した場合、パッケージ化処理中に HoloLens ディレクトリが作成されています。アプリをデプロイするには、「HoloLens 2 Emulator」または「HoloLens 2 Device」を参照してください。

DefaultFolderContents.png

タグ
Unreal Engine のドキュメントを改善するために協力をお願いします!どのような改善を望んでいるかご意見をお聞かせください。
調査に参加する
閉じる