スタティックメッシュのインポート

スタティックメッシュを UE4 にインポートする方法

Windows
MacOS
Linux

UE4 にはレベルのアセット作成を支援するさまざまなツールがあります。しかし、外部のアプリケーションでアセットを作成する場合は、それを UE4 にインポートしなければなりません。この操作ガイドでは、別の 3D アプリケーションで作成されたスタティックメッシュを UE4 にインポートしてレベルで使用できるようにする基本的な方法を説明します。

セットアップ

UE4 でレベルを作成するとき、別のアプリケーションで作成した 3D モデルは UE4 に入れる必要があります。それらを 3D モデリング ソフトウェアから確実に移行するには、Maya、 3ds Max などのモデリング プログラムに関係なく、いくつかの確認事項があります。まず、UE4 で使用される寸法は、アンリアル単位であり、1 アンリアル単位は 1 cm に相当するということを覚えておくとモデリング中およびエクスポート前に非常に役立ちます。また、UE4 にインポート可能なのは一部のファイル タイプに限られており、FBX は 3D オブジェクトに推奨されるファイル形式です。スタティック メッシュに適用されるテクスチャやマテリアルについても同様に、サポートされているファイル タイプであることを確認してください。

エクスポート

この例では、この木箱のモデルを Maya からエクスポートして UE4 のレベルに入れます。

CrateModel.png

モデルを完成したら、UE4 にインポートするために、まずメッシュが作成された 3D アプリケーションからエクスポートします。この例では、Maya を使用しています。FBX ファイルのエクスポート機能のあるアプリケーションはすべて使用できます。各アプリケーションのファイル メニューに進み [Export] を選択します。

MayaFileMenu.png

選択したら、メッシュの保存先のパスを選択します。ファイルに名前を付けて、メッシュをエクスポートするファイル タイプを選択します。(ここでも FBX を推奨します)。

ExportAll2.png

インポート

メッシュが 3D アプリケーションからエクスポートされました。次にメッシュのインポート先のプロジェクトが必要になります。作業対象プロジェクトがある場合は、この手順を飛ばしてください。作業対象プロジェクトがない場合は、ランチャーを開いて新規プロジェクトを選択することができます。選択したプロジェクト カテゴリとテンプレート、スターター コンテンツ の有無は、この操作ガイドには影響しません。保存先のパスを選択し、プロジェクトに名前を付けて [Create Project (プロジェクト作成)] をクリックします。

プロジェクトが読み込まれたら コンテンツ ブラウザ を見つけます。コンテンツ ブラウザ でフォルダをブラウズし、インポートするメッシュの保存先を探します。この例では、木箱のメッシュを Meshes とラベル付けされているフォルダにインポートします。メッシュを保存するフォルダで、以下の 2 つの簡単な方法のひとつを使用してインポートすることができます。最初の方法では、コンテンツ ブラウザ のフォルダ内で空きスペースで 右クリック して、コンテキスト メニューから [Import to...] を選択します。コンテンツ ブラウザ の一番上にある以下の画像で緑にハイライトされている [Import] ボタンをクリックすることもできます。

ImportContentBrowser.png

[Import to...] オプションを選択、または[Import] ボタンをクリックのいずれかを行ったら、3D アプリケーションからのエクスポート時にメッシュを保存した先にブラウズします。メッシュが見つかったら、それを ダブルクリック または [Open] をクリックしてインポートすることができます。

OpenFBX.png

インポート対象のメッシュを選択し、ファイルを ダブルクリック または [Open] をクリックのいずれかを行うと、 [FBX Import Options] メニューが表示されます。デフォルトで左側の画像に非常に類似したものになります。ただし、右の画像のようにメッシュ インポート時に操作できる数多くのオプションがあります。この操作ガイドの用途では、すべてのデフォルトは問題がなく、そのままの状態でメッシュをインポートすることができます。

ImportOptionsDefault.png ImportOptionsExpanded.png

以下のように注意事項がいくつかあります。メッシュをスケルタルメッシュとしてインポートする場合のプロセスもほぼ同じですが、[Import as Skeletal] メッシュ セクションの最初のチェックボックスにチェックが入っていることを確認してください。この例ではスタティックメッシュとしてメッシュをインポートするので、このチェックは入れません。また、多くのメッシュにこのプロセスを繰り返す代わりに、前述で説明したインポート対象のメッシュを選択するときに複数のメッシュを選択することもできます。その場合、[Import] をクリックすると各メッシュのインポート オプションを選択できます。また、[Import All] をクリックすると、同じオプションを用いてすべてのメッシュがインポートされます。

[Import] をクリックすると、インポート選択時のフォルダの コンテンツ ブラウザ にメッシュが表示されます。複数のメッシュをインポートした場合、[Import] クリック後に別の [FBX Import Options] メニューが表示されます。この例ではメッシュをひとつだけインポートしたため、[Import] または [Import All] をクリックしても同じ結果になり、 コンテンツ ブラウザ に戻ります。また、メッシュのインポート時にデフォルトで FBX Import Options にある Import MaterialsImport Textures の両方で true のチェックが入れられます。そのため、ご利用の 3D アプリケーションでメッシュに適用したマテリアルやテクスチャがあれば合わせてインポートされます。サムネイルの下にある様々な色付きのラインはアセットのタイプを示しています。一番下に水色のラインが付いているアセットが、スタティックメッシュです。

AfterMeshIsImported.png

これで UE4 にメッシュがインポートされて保存されたので、レベルで利用可能になります。これは、他のアセットを扱う場合と同様に コンテンツ ブラウザ からビューポートにドラッグするだけの簡単な操作で行うことができます。

Unreal Engine のドキュメントを改善するために協力をお願いします!どのような改善を望んでいるかご意見をお聞かせください。
調査に参加する
閉じる