ムービー レンダー キュー

汎用性の高いムービー レンダー キュー ツールを使用して、シネマティックスをレンダリングしたり、バッチ レンダリングしたりすることができます。

Windows
MacOS
Linux

ムービー レンダー キューは、Unreal Engine の画像 シーケンスおよびムービー レンダリング ソリューションです。ムービー レンダー キューは、高品質のレンダリング画像、プロダクション パイプラインへの簡素化された統合、ユーザーによる拡張性を実現するために作成されました。

ムービー レンダー キュー は、高品質の放射状モーション ブラーを生成できる時間サブサンプリング機能など、高品質なレンダリングを生成するための複数の機能をサポートしています。また、適切なプロジェクト/シーン設定を使用して、半透明のピクセル値を含む画像をエクスポートしたり、リニア データを使用して 16 ビット HDR 画像を生成したり、レンダリング設定をアセットに保存して再利用や共有することもできます。複数のジョブとその設定は、バッチ レンダリング ジョブの実行をサポートするレンダー キューを使用して一度に管理できます。

前提条件

  • ムービー レンダー キューは、プラグイン であるため、使用する前に有効にしておく必要があります。Unreal Engine メニューで [Edit (編集)] > [Plugins (プラグイン)] に移動して、 [Rendering (レンダリング)] セクションで [Movie Render Queue (ムービー レンダー キュー)] を見つけて有効にします。有効にしたら、エディタを再起動する必要があります。

    movie render queue plugin

ムービー レンダー キューは、プラグイン であるため、使用する前に有効にしておく必要がります。Unreal Engine メニューで [Edit (編集)] > [Plugins (プラグイン)] に移動して、 [Rendering (レンダリング)] セクションで [Movie Render Queue (ムービー レンダー キュー)] を見つけて有効にします。有効にしたら、エディタを再起動する必要があります。

ムービー レンダー キューを開く

[Movie Render Queue (ムービー レンダー キュー)] ウィンドウは次の 2 通りの方法で開くことができます。

1 つ目の方法では、Unreal Engine のメインメニュー バーから、 [Window (ウィンドウ)] > [Cinematics (シネマティックス)] > [Movie Render Queue (ムービー レンダー キュー)] をクリックします。

open movie render queue

または、 シーケンサー で、ツールバーの [Render Movie (ムービー レンダリング)] ボタンをクリックします。ドロップダウン メニューをクリックして、デフォルトのレンダリング ツールが [Movie Render Queue (ムービー レンダー キュー)] に設定されていることを確認してください。設定されていない場合は、代わりにシーケンサーの従来のレンダラ ツールが開きます。

open movie render queue

この 2 つのどちらかのオプションを実行すると、[Movie Render Queue (ムービー レンダー キュー)] ウィンドウが開きます。

movie render queue window

インターフェースの概要

Movie Render Queue インターフェ-スは次の 4 つの主要な領域で構成されています。

movie render queue interface

1.ツールバー: レンダリング ジョブの追加や削除、現在のジョブ リストのロードや保存のメニューが含まれています。

2.ジョブ: レンダリングするシーケンスをキューに入っている順に表示します。リストの最上位の項目がジョブとみなされます。これらの項目には、各ジョブのコンフィギュレーション設定も含まれています。

3.ジョブの詳細: 選択されたジョブの詳細です。名前、レベル シーケンス アセット、ジョブ中に実行するレベル、このジョブの作成者をリストします。

4.レンダリングを開始: マシンでローカルに、つまり、マシンの個別のプロセスで、レンダリングを開始します。

ツールバー

ツールバーには、ジョブを追加および削除するメニューがあります。レンダリング キューに新しいシーケンスを追加するには、 [+ Render (+ レンダリング)] ボタンをクリックし、 Level Sequence アセット を選択します。また、コンテンツ ブラウザからジョブ領域にシーケンスをドラッグして、ジョブ リストにシーケンスを追加することもできます。

add render job

ジョブ リストからシーケンスを削除するには、ジョブを選択して [-] ボタンをクリックするか、キーボードの Delete キーを押します。

remove render job

また、ツールバーを使用して、現在のジョブ リストを Queue Preset アセットとして保存することもできます。[Load/Save Queue (キューのロード/保存)] ボタンをクリックして、 [Save As Asset (アセットに名前を付けて保存)] を選択します。次に、 Movie Pipeline Queue アセットに名前を付けて、プロジェクトの任意の場所に保存するように求められます。

save render queue preset

保存すると、プリセットが [Load/Save Queue (キューのロード/保存)] ボタンの下に表示されます。そのプリセットを選択すると、保存されたプリセットに一致するジョブ リストが設定されます。

これにより、キューのコピーがジョブ領域にインポートされます。また、ジョブ リストに加えられた変更は、 [Save as Asset (アセットに名前を付けて保存)] を選択して既存のプリセットに保存しない限り、アセットに作用することはありません。

load render queue preset

ジョブ

ジョブ領域には、レンダリング対象のレベル シーケンスのリストと、そのレンダリング設定や出力ディレクトリが表示されます。

シーケンスを展開すると、シーケンスのカメラを表示することができます。このリストはシーケンスの任意の カメラ カットを操作する セクションから生成されます。また、カメラの有効化/無効化を切り替えて、そのセクションがレンダリングされないようにすることもできます。

camera cut render queue

ジョブの [Settings (設定)] エントリをクリックすると [Settings (設定)] ウィンドウが開き、出力ディレクトリ、レンダリング設定、エクスポート形式を指定できます。

movie render settings

ドロップダウン矢印をクリックしてプリセットを選択すると、保存されたプリセットをジョブに適用できます。

movie render settings preset

[Output (出力)] 領域には、[Output (出力)] 設定で設定された、画像やビデオがレンダリングの出力先のフォルダ ディレクトリが表示されています。ここをクリックすると、このフォルダをターゲットとする、 [File Explorer (ファイル エクスプローラー)] ウィンドウが開きます。

render directory explorer

レンダーのカスタマイズの詳細については、「レンダリング設定」ページをご覧ください。

TopicIcon.png

エクスポート形式

ムービー レンダー キューでは、さまざまな形式でレンダリングを出力することができます。

ムービー レンダー キューでは、さまざまな形式でレンダリングを出力することができます。

TopicIcon.png

画像設定

ムービー レンダー キューの画像設定を使用してレンダリングの画質を調整します

ムービー レンダー キューの画像設定を使用してレンダリングの画質を調整します

TopicIcon.png

レンダリング パス

ムービー レンダー キューのさまざまなレンダリング パス レイヤーについて説明します。

ムービー レンダー キューのさまざまなレンダリング パス レイヤーについて説明します。

ジョブの詳細

ジョブを選択すると、ジョブ詳細領域でジョブの詳細を確認できます。

render job details

この領域には、選択したジョブの次のフィールドが表示されます。

名前

説明

Job Name (ジョブ名)

ジョブの名前。これは、デフォルトでは、レベル シーケンス アセットの名前に設定されていますが、変更することができます。[Job Name (ジョブ名)] フィールドは、デフォルトの [Burn In (バーンイン)] オーバーレイにも表示されます。

Sequence (シーケンス)

シーケンス アセットの参照。ジョブに別のシーケンスを指定したい場合は、ここで参照するシーケンスを変更できます。

Map (マップ)

レンダリング時に実行するレベル。シーケンスが Spawnables を使用している場合、同じシーンを異なるレベルでレンダリングできます。

Author (作成者)

ジョブの作成者。このフィールドには、オペレーティング システムのユーザー名が自動的に入力されます。

レンダリングを開始

render local remote

[Render (Local) (レンダリング (ローカル))] のレンダリング プロセスは、Unreal Engine と同じで、プレイ イン エディタ セッションを起動して、そのセッションでレンダリングを行います。ローカル レンダリングを行う際には、変更内容を保存する必要はありません。

[Render (Remote) (レンダリング (リモート))] は、ジョブをレンダリングする別のプロセスを起動します。外部のプロセスでファイルをディスクから保存したファイルを読み取れるよう、プロジェクトの変更を保存しておく必要があります。

[Remote (リモート)] オプションを使用すると、リモート レンダリング ファームを実装することができます。各レンダリング オプションのデフォルトの動作は プロジェクト設定 で定義されており、独自のコードを実行するように調整することもできます。これは、サードパーティ製のレンダリング ファーム管理ソフトウェアを使用する場合に役立ちます。また、リモート レンダリング プロセスの起動に使用されたコマンドは、アウトプット ログに書き込まれます。これは、独自の自動化レンダリング ファームを構築する際に参考として使用することができます。

[Job Details (ジョブ詳細)] でレンダリングする Level アセットを指定するため、レンダリング時に同じレベルを開いておく必要はありません。ムービー レンダー キューは、レンダリング ジョブの実行時に指定されたレベルを自動的に開きます。

レンダリング プレビュー

レンダリング ジョブが実行されると、ムービー レンダー キューはレンダリング プレビュー ウィンドウを表示し、現在のレンダリングのビジュアル状態を関連情報とともに表示します。レンダリングが完了すると、プレビュー ウィンドウは自動的に閉じます。

render preview

  1. Render Preview (レンダリング プレビュー): このビューには、レンダリングの現在のビジュアル ステータスが表示されます。各フレームがここに表示されると同時に、出力ディレクトリにも保存されます。こちらのプレビューは、GPU の最新のサンプル データに基づいており、最終的なレンダリングよりも低い品質で表示される場合があります。レンダリングでタイリングが有効になっている場合、プレビューでは右下のタイルのみが表示されます。

  2. Overall Render Progress (全体的なレンダリングの進行状況): この詳細情報では、現在レンダリングされているシーケンスと、全体の進行状況、経過時間、残り時間の推定値を表示します。

  3. Current Camera Cut Progress (現在のカメラ カットの進行状況): この詳細情報では、現在レンダリングされているカメラと、現在のカメラ カットの進行状況が表示されます。

基本的なレンダリングを作成する

シネマティック シーケンスの基本的なレンダリングを作成するには、次の手順を実行します。

ジョブの設定

まず、 [Window (ウィンドウ)] > [Cinematics (シネマティックス)] > [Movie Render Queue (ムービー レンダー キュー)] をクリックして、ムービー レンダー キュー ツールを開きます。

open movie render queue

次に、 [+ Render (+ レンダリング)] ボタンをクリックして、シーケンスを選択し、シーケンス アセットをジョブ リストに追加します。

add render job

Map プロパティで正しいレベルが設定されていることを確認します。

map setting render

出力設定

シーケンスを追加すると、出力先フォルダ、解像度、ファイル タイプなどの出力設定を調整できます。

[Unsaved Config (保存されていない設定)] テキストをクリックすると、そのジョブの レンダリング設定 ウィンドウが開きます。

open movie render queue setting

デフォルトでは、ムービー レンダー キューは、.jpg 画像のシーケンスとしてレンダリングを出力します。この出力形式を変更したい場合は、 .jpg Sequence [8bit] エントリを削除して、 [+ Setting (+ 設定)] ボタンをクリックすると、他の出力形式を選択することができます。

.jpg Sequence [8bit] エントリを選択して、 Delete キーを 押し、次に [+ Setting] ボタンをクリックして、.png Sequence [8bit] を選択します。

movie render queue png sequence

[Deferred Rendering (ディファード レンダリング)] エントリを使用すると、ビューポートに表示されている画像をそのままレンダリングするように出力します。このような基本的なレンダリングでは、この設定をそのままにしておくことができますが、画像をレンダリングするためには、この設定が 必要 です。

deferred render

[Output (出力)] をクリックすると、ファイル名、ディレクトリ、解像度などの一般的な出力関連の設定が表示されます。

[Output Directory (出力ディレクトリ)] フィールドを変更したい場合は、エントリの横にある […] ボタンをクリックして、新しいフォルダに移動し、 [Select Folder (フォルダを選択)] を押します。これで、画像シーケンスがここに出力されます。

render output settings

変更が終わったら、 [Render (レンダリング)] 設定 ウィンドウを閉じます。

レンダリング

これでシーケンスをレンダリングすることができます。

[Render (Local) (レンダリング (ローカル))] をクリックすると、シーケンスのレンダリング ジョブが開始します。現在のレンダリングの進行状況を表示する Render Preview ウィンドウが表示されます。

local move render

レンダリングが完了したら、プレビュー ウィンドウが閉じます。これで、ジョブのリンクされた出力テキストをクリックして、出力フォルダに移動し、出力画像シーケンスを表示できます。

output windows explorer

ブループリントでの使用

ムービー レンダー キュー を使用して、ランタイム ビルドでムービーをレンダリングしたら、 ブループリント を使用してユーザーのコンピュータにファイルを出力することができます。詳細については、「ランタイム ビルドでムービー レンダー キューを使用する」を参照してください。

Unreal Engine のドキュメントを改善するために協力をお願いします!どのような改善を望んでいるかご意見をお聞かせください。
調査に参加する
閉じる