VRED から Datasmith コンテンツをエクスポートする

Autodesk VRED 用のエクスポート プラグイン スクリプトをインストールする方法と、Datasmith で Unreal にインポート可能な FBX に VRED シーンをエクスポートする方法について説明します。

Windows
MacOS
Linux

エクスポータ プラグイン スクリプトをインストールする

Unreal Engine で VRED のコンテンツを使用した作業を開始する前に、VRED 用のプラグイン スクリプトをインストールする必要があります。

エクスポータ プラグインで現在サポートされている VRED Professional のバージョンについては、「Datasmith でサポートされているソフトウェアとファイル形式」 を参照してください。

次の手順に従って、コンピュータにインストールした、サポートされているバージョンの VRED の Datasmith Exporter プラグイン スクリプトをインストールしてください。

  1. Unreal Engine のインストール フォルダから「Enterprise\Plugins\Editor\DatasmithFBXImporter\Extras\VREDPlugin」フォルダを見つけます。

  2. このフォルダとそのすべてのコンテンツを VRED によるプラグインの検索先にコピーします。
    例えば Windows プラットフォームでは、プライグインの検索先は`C:\Users[username]\Documents\Autodesk\VRED-[internalVersion]\ScriptPlugins です ( はご使用の Windows ユーザー ID、` はインストールした VRED のバージョンになります)。
    このパスを見つけるための詳細については、『creating, editing, and using scripts』を参照してください。

    VRED の [Terminal] ウィンドウからこのパスを見つけることもできます。メイン メニューから [View (表示)] > [Terminal (ターミナル)] を選択して [Terminal] ウィンドウを開き、Looking for script plugins in で始まる行を探します。以下に例を示します。
    VRED terminal window

  3. VRED を再起動します。

Datasmith にエクスポートする

VRED シーンを仕上げてバリアントを登録したら、次の手順を実行して、シーンを FBX にエクスポートします。

  1. VRED のメイン メニューから次を選択します。

    • [File (ファイル)] > [Export (エクスポート)] > [Export to Datasmith... (Datasmith にエクスポート)] (VRED 2018 の場合)

    • [File (ファイル)] > [Export Scene Data (シーン データのエクスポート)] > [Export to Datasmith... (Datasmith にエクスポート)] (VRED 2019 の場合)
      Datasmith export from VRED

  2. フォルダを参照してファイル名を選択します。

エクスポータによって選択した場所に.FBXファイルが作成されます。

最終結果

これで、新規の「.FBX」ファイルを Unreal Editor にインポートする準備が整いました。「Unreal Engine 4 に Datasmith コンテンツをインポートする」を参照してください。

エクスポータは .FBX の横に追加のファイルを作成することもできます。

  • シーンのライトに関する追加情報を含む「.lights」ファイル。

  • 登録したバリアントに関する情報を含む「.var」ファイル。

  • アニメーションを含む「.clips」ファイル。

  • マテリアルに関する追加情報を含む「.mats」ファイル。

これらのファイルに含まれている情報は Datasmith インポータで必要になります。「.FBX」ファイルを別の場所に移動する場合は、必ずこれらのファイルも移動して、同じ相対パスに配置してください。

Unreal Engine のドキュメントを改善するために協力をお願いします!どのような改善を望んでいるかご意見をお聞かせください。
調査に参加する
閉じる