Android开发要求

包括虚幻引擎4适用参考和指南在内的产品文档

Windows
MacOS
Linux

在本页中,你将了解开始为Android平台开发所需的硬件和软件开发工具包(SDK)要求。 

目前支持的SDK版本可以在 UEBuildAndroid.cs 中找到。它位于
[UE4根目录]/Engine/Source/Programs/UnrealBuildTool/Platform/Android 文件夹。

虚幻引擎 4.27

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

NDK r21b

Android Studio版本

Android Studio版本4.0

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.26.2

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

NDK r21b

Android Studio版本

Android Studio版本4.0

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.26.2

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

NDK r21b

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.25

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

NDK r21b

Android Studio版本

Android Studio版本3.5.3

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.24

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

Android NDK R14b

Codeworks for Android 1R7u1安装程序替代了Windows和Mac上先前的Codeworks。Linux使用1R6u1 Plus修改版。

Codeworks SDK版本

Windows和Mac: 1R7u1
Linux: 1R6u1

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.23

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

Android NDK R14b

Codeworks for Android 1R7u1安装程序替代了Windows和Mac上先前的Codeworks。Linux使用1R6u1 Plus修改版。

Codeworks SDK版本

Windows和Mac: 1R7u1
Linux: 1R6u1

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.22

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

Android NDK R14b

Codeworks for Android 1R7u1安装程序替代了Windows和Mac上先前的Codeworks。Linux使用1R6u1 Plus修改版。

Codeworks SDK版本

Windows和Mac: 1R7u1
Linux: 1R6u1

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.21

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

Android NDK R14b

Codeworks for Android 1R7u1安装程序替代了Windows和Mac上先前的Codeworks。Linux使用1R6u1。

Codeworks SDK版本

Windows和Mac: 1R7u1
Linux: 1R6u1

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.20

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

Android NDK R12b

注:Codeworks for Android 1R6u1安装程序替代了Windows、Mac和Linux上先前的Codeworks。

Codeworks SDK版本

1R6u1

支持的IDE版本

Visual Studio 2017 15.6版或更高。
Visual Studio 2015 Update 3
Visual Studio 2013

虚幻引擎4.19

硬件要求

推荐桌面硬件

请参阅硬件和软件规格

支持的设备硬件

请参阅Android设备兼容性

软件要求

桌面操作系统

请参阅硬件和软件规格

NDK版本

Android NDK R12b

Codeworks for Android 1R6u1安装程序替代了Windows、Mac和Linux上先前的Codeworks。

Codeworks SDK版本

1R6u1

支持的IDE版本

Visual Studio 2015 Update 3
Visual Studio 2013

欢迎帮助改进虚幻引擎文档!请告诉我们该如何更好地为您服务。
填写问卷调查
取消