IPluginManager::CheckModuleCompatibility

Checks whether modules for the enabled plug-ins are up to date.

Choose your operating system:

Windows

macOS

Linux

References

Module

Projects

Header

/Engine/Source/Runtime/Projects/Public/Interfaces/IPluginManager.h

Include

#include "Interfaces/IPluginManager.h"

Syntax

bool CheckModuleCompatibility
(
    TArray< FString > & OutIncompatibleModules,
    TArray< FString > & OutIncompatibleEngineModules
)

Remarks

Checks whether modules for the enabled plug-ins are up to date.

Returns

true if the enabled plug-in modules are up to date.

Parameters

Parameter

Description

OutIncompatibleModules

Array to receive a list of incompatible module names.

OutIncompatibleEngineModules

Array to receive a list of incompatible engine module names.