Rewind Debugger

With the Rewind Debugger you can record real-time segments of projects and preserve the data for debugging workflows.

Choose your operating system:

Windows

macOS

Linux

With the Rewind Debugger you can record a segment of a project during run time, and rewind the simulation to observe information about animation behaviors and interactions. Building off of the Animation Insights foundation, the Rewind Debugger provides a refreshed visual interface to debug animation content in Unreal Engine.

Prerequisites

  • Enable the Animation Insights plugin. Navigate in the Menu Bar to Edit > Plugins and locate the Animation Insights in the Animation section, or use the Search Bar. Enable the plugin and restart the editor.

animation insights plugin

Overview

When creating a project in Unreal Engine, it can be difficult to debug a project during run time. With the Rewind Debugger you can record a segment of a project during run time, and then scrub back through the recording to debug animation content in a more functional and stable work environment. The Rewind Debugger provides information about animation variables, thresholds, triggers, notifies, and more. While scrubbing through the recorded segment, information is contextually populated in the Rewind Debugger Details panel.

demonstration of the rewind debugger

To open the Rewind Debugger window, navigate in the Menu Bar to Tools > Debug > Rewind Debugger.

open the rewind debugger by navigating to the menu bar and then tools and then debug and then select rewind debugger

Interface

The Rewind Debugger window is populated with a unique interface you can use while navigating recorded animations.

rewind debugger window overview with highlighted regions

Feature

Image

Description

1. Project Simulation Controls

project simulation controls play pause stop eject

Controls the project's simulation with features such as Play, Pause and Stop. For more information, refer to the Unreal Editor Interface documentation.

2. Rewind Debugger Menu

rewind debugger menu featuring camera mode and view options for available data tabs

Lets you control camera behavior and toggle which tabs are visible. The Camera Modes are as follows:

Disabled disables camera movement, leaving the camera unattached and untethered to any game object.

Follow Target Actor locks the camera to the selected object from a pre-positioned location. You can position the camera anywhere in the level, and the camera will move along the same track as the selected object.

This option does not track the selected object, it moves the camera based on the same movement data as the character.

Replay Recorded Camera locks the camera to the position it occupied in the simulation, following the same movements if there were any.

For view options, refer to the Data Tabs section.

Ensure you eject the player control in the Project Simulation Controls before attempting to change the Camera Control Mode.

3. Object Outliner

rewind debugger object outliner with dropper tool highlighted

After taking a recording, choose a subject here to populate the Rewind Debugger's Details panel. You can manually choose the subject by selecting it within the Viewport window, or by using the Dropper tool, and selecting the subject within the viewport window.

After selecting an object, the Object Outliner will list the selected object, and all child objects and components, including any that are created or destroyed during runtime as well as any attached controllers.

Ensure you eject the player control in the Project Simulation Controls before attempting to select an object in the Object Outliner.

Some objects are composed of many components, such as a movement component, an Animation Blueprint, and more. Each of these components will be listed as separate objects in the Object Outliner, and must be selected individually to see their respective data.

4. Playback Controls

rewind debugger playback controls play pause forward back with record highlighted

Lets you control the playback of the recorded segment of project simulation. Here you also find the record button, used for starting and stopping the recording process when simulating a project.

5. Rewind Timeline

rewind debugger timeline with red playhead highlighted

Lets you scrub through the recorded segment of project simulation manually.

6. Details Panel and Data Tabs

rewind debugger details panel with data tabs and view options highlighted

The Details panel displays all available data depending on the selected subject and the Data Tab open. Displayed information can include variable values, boolean states, and more.

Depending on the subject you have selected in the Object Outliner, different tabs are automatically populated across the top of the rewind debugger details panel.

You can open or re-open additional tabs when available, using the Rewind Debugger Menu.

Within the AnimGraph Data Tab, a View Options menu is present. Here you can toggle different columns to be displayed within the details panel.

Workflow

  1. To use the Rewind Debugger, first start the game simulation by clicking the Green Play Button in the Project Simulation Controls.

  2. Then click Record in the Rewind Debugger Playback controls to begin recording the project simulation.

    To disconnect your cursor from the simulation, without stopping or pausing the simulation, use the hot key Shift + F1.

  3. When you have recorded a sufficient amount of the project simulation, pause the simulation and eject the camera using the Project Simulation Controls.

    in the simulation controls pause and then eject the game controller

  4. Stop the recording by clicking Record again.

The recorded section of gameplay is now prepared for use. You can begin debugging game objects by selecting a game object with the Object Outliner or using the Dropper tool.

Within the Rewind Debugger Menu you can also select a different Camera Mode to obtain a different view of the subject while debugging. For example, with the Disabled option, you can detach the camera and position it freely and observe your animated subject from any angle to assist in your workflow.

playback scrubbing demonstration

After selecting an object in the Rewind Debugger's Object Outline, the Rewind Debugger Details panel contextually populates with tabs and information relevant to the object and the current moment in the recording. You can scrub through the Rewind Debugger Timeline with the Playhead or the Playback Controls, to see the information dynamically update and change in conjunction with the simulation and its behaviors as they were recorded in real time.

Animation Blueprints

After obtaining a segment of recorded project simulation you can double-click an Animation Blueprint component in the Object Outliner to open it in a new window. While scrubbing through the recorded segment, the Animation Blueprint Editor will display the recorded state of the selected Animation Blueprint corresponding to the recorded moment of the character.

Data Tabs

Within each object's components, specific tabs automatically populate the Rewind Debugger window by default. Within these tabs is useful data pertaining to the object component you selected. Depending on the component selected, there may be other tabs you can open to find other available data insights. To open a new tab, open the menu in the top left of the editor and each available tab can be toggled.

Tab

Description

Animation Curves

When the selected object contains Animation Curves, such as a Skeletal Mesh, this tab displays animation curves by their defined name and lists their values relevant to the simulation recording.

Notifies

The Notifies tab displays the selected object's Notifies and Sync Markers as they are activated.

Montages

When the selected object uses animation montages, this tab populates with montage switches and other relevant data.

Blend Weights

This tab displays any present Blend Weight information, such as transitions occurrences.

Anim Graph

With the Anim Graph tab, you can see variable, states, and slot updates, as well as additive animation changes and more. To add additional columns of information, navigate to the View Options menu to toggle any available traces for observation.

view option menu in the anim graph data tab in the rewind debugger details panel

The common View Options are as follows:

  • Type: Describes the type of data being displayed.

  • Name: Lists the defined name for the data type.

  • Alpha: Lists the Alpha (displacement) value if there is an alpha in use.

  • Playback Time: A readout of the duration an element has been playing, when relevant.

The list of available View Options will populate automatically based on the Nodes present or previously present within the selected AnimGraph.

Custom AnimGraph traces can be added to the Rewind Debugger and will appear as toggleable View Options. You can add custom traces for existing or custom AnimGraph Nodes using a TRACE_ANIM_NODE_VALUE macro within an if statement in the AnimNodes .cpp file.

Properties

This is a default tab present in all component types and displays relevant property information of the selected component.

To populate this tab with information, first enable the Trace Properties feature for any Game Object or Component before recording a segment of project simulation.

Do this by right-clicking the object or component in the Rewind Debugger's Object Outliner and selecting Trace Properties.

In the Rewind Debugger Menu you can also select Show All Views, to open all relevant tabs for the selected component.

Data Tab Management

Tabs for specific components can be pinned to the Rewind Debugger and viewed in conjunction with tabs of another component. Right clicking a tab will reveal the option to Keep View Open which docks the tab so you can see different object properties side by side.

For example, you can pin an Animation Blueprint Anim Graph tab and open a character's Movement Component, to compare data about each component simultaneously.

lock tabs to prevent them from closing by right clicking and selecting keep view open

Extensibility

The Rewind Debugger's usages extend beyond the base version packaged with the Animation Insights Plugin. Teams can develop and add their own custom Rewind Debuggers to projects to debug and highlight specific components.

Tags