Quixel Bridge Plugin for Unreal Engine

Quixel Bridge lets you access the Megascans library to bring environments, materials, and MetaHumans into Unreal Engine.

Choose your operating system:

Windows

macOS

Linux

Overview

Quixel Bridge plugin for Unreal Engine gives you full featured access to the Megascans library within the Level Editor. You can browse collections, search for specific assets, and add assets to your Unreal Engine projects.

Get Bridge for Unreal Engine

Bridge for Unreal Engine is a plugin included with your installation of Unreal Engine 5. To ensure that your Quixel Bridge plugin is enabled, select Edit > Plugins. Type bridge into the search bar and click the checkbox to enable the plugin.

Click image for full size.

If you don't see the Quixel Bridge plugin here, then you may need to install it from the Epic Games Launcher. Open the Epic Games Launcher, click Library, then scroll down to the section called Vault. Type Bridge into the search bar. Select Install to Engine. When you relaunch the engine, you should be able to enable the plugin as described above.

Click image for full size.

Launching Bridge in Unreal Engine

Quixel Bridge can be accessed from a number places inside the editor:

  1. Click the Content dropdown in the toolbar and select Quixel Bridge.

    Click image for full size.

  2. From the top menu, select Window > Quixel Bridge.

    Click image for full size.

  3. From the Content Drawer, right-click and select Add Quixel Content.

    Click image for full size.

If you can't find Quixel Bridge as directed above, select Edit > Plugins. Type Bridge in the search bar, and click the checkbox to enable the plugin.

You may be prompted to restart Unreal Engine for the changes to take effect.

Click image for full size.

Updating Bridge

When you launch Unreal Engine, and open the Bridge tab, you may see a message indicating that Bridge is out of date.

Click image for full size.

To update Bridge, close Unreal Engine and return to the Epic Games Launcher. In the Unreal Engine > Library tab, locate the version of Unreal Engine that you have installed. Underneath it, you will see Installed Plugins. If a new version of an installed plugin is available, you will see an exclamation mark.

Engine Version Installed Plugins

Click Installed Plugins. From the pop-up window, next to Quixel Bridge click Update.

Update the Quixel Bridge Plugin

You can now relaunch Unreal Engine.

Sign up or Log in to Bridge for Unreal Engine

Bridge for Unreal Engine works with your Epic Games account and currently supports the Unreal Unlimited plan.

To log in, click the user icon in the top right corner of the Quixel Bridge panel and select Sign In.

Click image for full size.

You can log in using your existing Epic Games account, or sign up for a new account. To get free, unlimited access to the Megascans library, make sure you're on the Unreal Unlimited plan.

What is the Unreal Unlimited plan?

Megascans is completely free for all users of Unreal Engine. If you have an Unreal Engine license, sign in with your Epic Games account and go to quixel.com/pricing to get unlimited access to the Megascans library. You will also have unlimited downloads within Bridge and Mixer.

This unlimited Megascans access is licensed for use with Unreal Engine and Twinmotion only and treats Megascans assets as UE-Only Content under the Unreal Engine End User License Agreement.

You can find more details on the Quixel Bridge FAQ page.

Using Bridge for Unreal Engine

System requirements

Quixel Bridge for Unreal Engine runs on Windows, MacOS, and Linux.

Bridge requires an active internet connection to display and download the content library. When you do not have an internet connection available, you can access local content that is on disk by navigating to the Local tab in the left navigation pane.

On the left of the Quixel Bridge panel, there are buttons to navigate to the different tabs:

  • Home

  • Collections

  • MetaHumans

  • Favorites

  • Local

Home

The Home tab is split into sections displaying the latest collections, trending assets, and the newest uploads across every category.

Click image for full size.

The left navigation is structured as a category tree with different levels of subcategories.

Click image for full size.

All the available asset types are listed in the Home tab. You can filter by category and subcategories.

Atlases, Displacements, and Brushes are not supported in Bridge for Unreal Engine.

Collections

The Collections section contains curated content with references and renders across different biomes as well as essentials, architectural selections, tutorial assets and community collections.

Click image for full size.

MetaHumans

If you're using the MetaHuman Creator app to create characters, you can access them in Quixel Bridge for Unreal from the My Metahumans tab in the left navigation panel.

Click image for full size.

Favorites

Any asset in Quixel Bridge can be marked as a Favorite for quick access in the future.

Click image for full size.

To mark an asset as a favorite, hover over the asset and click the heart icon.

Local

The Local section shows all the assets that you have already downloaded and are available on your machine.

Click image for full size.

Search & Filter

The Megascans content library contains thousands of assets and is continuously growing.

To search for an asset or a collection, click in the search bar. As you begin typing, suggested results will appear below the search bar.

Click image for full size.

If one of the suggested results is the item you need, select it to be taken to that asset. To see all the results for your search query, press Enter/Return. The search results will list all of the matching content, including suggestions of popular assets, related collections, and matching asset categories.

Additionally, you can use the filter bar to refine any search result with specific filters such as: asset type, color, biome, state, size, and more. To hide or show the filter bar, click the Filter icon in top right.

Click image for full size.

Asset Information

To view more information for an asset, select the asset to open its information panel.

Click image for full size.

Icons display information about the asset, for example asset size or whether a surface is tileable or not. You also see related assets that are similar to the current asset.

At the bottom of the asset right panel, choose the download resolution before downloading or adding an asset to your project.

Click the Export Settings button to adjust how to import the assets into your scene.

Download Settings

Preferences

By default, all the assets you download from Bridge for Unreal Engine are placed at the following location on disk:

  • Win: C:\Users\user\Documents\Megascans Library

  • Mac: ~\Documents\Megascans Library

  • Linux: ~\Documents\Megascans Library

To change this path, click the user icon in the top right corner of the Bridge window and select Preferences.

Click image for full size.

In the Preferences dialog enter the Library Path that you want to save your assets to and click Save.

Click image for full size.

Format & Resolution

Download Settings of assets are available in the asset's information panel.

All 3D assets in Bridge for Unreal Engine are downloaded in UAsset format and are available in the following resolutions:

  • Nanite

  • High

  • Medium

  • Low

All other asset types, such as Surfaces, 3D plants, Decals and Imperfections are available in the following resolutions:

  • Highest

  • High

  • Medium

  • Low

Nanite

Bridge for Unreal Engine 5 now serves in a fully Nanite-ready tier for 3D assets. These assets are downloaded as pre-converted Nanite meshes which are loaded into the project upon import.

The assets work right out of the box and do not require any project settings to be configured beforehand.

Export Settings

Export Settings of assets are available in the asset's information panel. Click the Export Settings button to open them.

Click image for full size.

The Export Settings dialog allows you to specify parameters to control how the assets will be exported or added into your project. They must be configured before adding an asset into the scene.

Click image for full size.

  • Auto-Populate Foliage Painter: enabling this will automatically populate foliage editor's asset list in the project with the latest imported assets. This setting must be checked before exporting assets and is only applicable to scatter and plant assets.

  • Apply to Selection: enabling this will apply the exported material to the selected objects in the scene.

  • Master Material Overrides: This section lets you choose your own custom master materials instead of the default master materials provided by the plugin.

  • Material Blend Settings: This section allows you to blend materials using already imported materials in the content browser. The plugin comes with a Vertex Blend Shader which is used for material blending.

Adding Assets to Your Project

There are a couple of ways to download and add assets to your UE project.

  1. Drag and Drop.

  2. Download and Add to Scene.

These two methods are described further in the following sections.

Drag & Drop

You can drag and drop a single asset or multiple assets together into your scene.

To add an asset to your scene, select the asset in the Bridge panel. Drag it into the viewport.

Click image for full size.

If the asset has not previously been downloaded, this will automatically initiate download. It will download the resolution specified in the asset's information panel.

While the asset is downloading, a preview of the asset will appear in your scene. This preview is a placeholder until the full asset finishes downloading.

If this is the first time you are downloading something in Bridge for Unreal Engine, the following new folders are created in your Content browser.

  • Megascans: this is where the assets are saved inside your UE project.

  • MSPresets: this contains all the template master materials that are used to render the downloaded assets in your scene.

Once the final asset has been downloaded, it will replace the preview in the scene.

All surfaces, imperfections, and decals appear on a spherical mesh when dragged and dropped into the viewport.

Download and Add to Scene

You can also download then add assets to your scene in two separate steps.

Download to Project

One way to download an asset is to hover over the asset in the grid, then click the green Quick Download button.

Click image for full size.

Alternatively, select the asset to open the Asset Information panel and click Download. You can choose at which resolution to download the asset.

Click image for full size.

Once downloaded, all assets are accessible from the Local tab.

Click image for full size.

To navigate to the asset's location on disk, right-click the downloaded asset and select Go to Files.

Click image for full size.

Inside the Editor, the downloaded assets appear in the Content > Megascans folder in the Content Drawer.

Click image for full size.

Add to Scene

After downloading, there are two ways to add to scene. The first way is to hover over the downloaded asset. Click the blue Quick Add button.

Click image for full size.

Alternatively, select the asset to open the asset information panel. Then, click the Add button at the bottom of the panel. You can choose at which resolution to export the asset.

Click image for full size.

Make sure you have set up your Export Settings before adding assets to your scene. This will ensure that the assets are downloaded and added at the proper resolution for your project.

Updating to the latest version

New version updates are available often for Quixel Bridge. These include feature improvements and bug fixes.

To check what version you're using or if an update is available, click the User button, then About Bridge.

Click image for full size.

A dialog displays information about the current version, and whether an update is available.

Click image for full size.

If you've installed Unreal Engine using the Epic Games Launcher, you can also make sure you have the latest version installed there. From the Library tab, locate the installed engine version you are using. Under it, click Installed Plugins to see a list of all plugins you have installed to that engine version. If an update is available, click Update to install it.

Live changes to source code are available through GitHub. You can access C++ source code via GitHub.