Unreal Engine 用 Quixel Bridge プラグイン

Quixel Bridge を使用して Megascans ライブラリにアクセスすることで、環境、マテリアル、MetaHuman を Unreal Engine に取り込むことができます。

Choose your operating system:

Windows

macOS

Linux

概要

Unreal Engine 用 Quixel Bridge プラグインは、レベル エディタ内から Megascans ライブラリへのフル機能アクセスを提供します。コレクションを参照したり、特定のアセットを検索したり、アセットを Unreal Engine プロジェクトに追加したりできます。

Unreal Engine 用 Bridge を取得

Unreal Engine 用 Bridge は、Unreal Engine 5 のインストールに含まれているプラグインです。Quixel Bridge プラグインを有効にするには、[Edit] > [Plugins] を有効にします。検索バーに「bridge」と入力し、チェックボックスをクリックしてプラグインを有効にします。

画像をクリックするとフルサイズで表示されます。

Quixel Bridge ブリッジがない場合は、Epic Games Launcher からインストールする必要があるかもしれません。Epic Games Launcher を開いて、[ライブラリ] をクリックし、Vault というセクションまで下にスクロールしてください。検索バーに「Bridge」と入力しします。[Install to Engine (Engine にインストール)] を選択します。エンジンを起動すると以下のようにプラグインを有効にすることができるようになります。

画像をクリックするとフルサイズで表示されます。

Unreal Engine で Bridge を起動する

Quixel Bridge はエディタ内の様々な場所からアクセスできます。

  1. ツールバーの [Content (コンテンツ)] ドロップダウンをクリックし [Quixel Bridge] を選択します。

    画像をクリックするとフルサイズで表示されます。

  2. トップメニューで [Window] > [Quixel Bridge] の順に選択します。

    画像をクリックするとフルサイズで表示されます。

  3. コンテンツ ドロワー[Add Quixel Content] を選択します。

    画像をクリックするとフルサイズで表示されます。

上記の指示に従っても Quixel Bridge が見つからない場合は、[Edit (編集)] > [Plugins (プラグイン)] を選択します。検索バーに「Bridge」と入力し、チェックボックスをクリックしてプラグインを有効にします。

変更を有効にするために、Unreal Engine を再起動するように求められる場合があります。

画像をクリックするとフルサイズで表示されます。

Bridge を更新する

Unreal Engine を起動して [Bridge] タブを開くと、Bridge が最新ではないことを示すメッセージが表示される場合があります。

画像をクリックするとフルサイズで表示されます。

Bridge を更新するには、Unreal Engine を閉じ、Epic Game Launcher に戻ります。[Unreal Engine] > [Library] タブで、インストールした Unreal Engine のバージョンを見つけます。バージョンの下に「Installed Plugins (インストール済みプラグイン)」と表示されます。新しいバージョンのインストール済みプラグインを使用できる場合、感嘆符が表示されます。

Engine Version Installed Plugins

[Installed Plugin (インストール済みプラグイン)] をクリックします。ポップアップ ウィンドウの [Quixel Bridge] の横で [Update (更新)] をクリックします。

Update the Quixel Bridge Plugin

これで、Unreal Engine を再起動できるようになりました。

Unreal Engine の Bridge にサインアップまたはログインする

Unreal Engine 用 Bridge は、Epic Games アカウントで動作し、現在 Unreal 無制限 プランをサポートしています。

ログインするには、[Quixel Bridge] パネルの右上隅にあるユーザー アイコンをクリックし、[Sign In (サインイン)] を選択します。

画像をクリックするとフルサイズで表示されます。

既存の Epic Games アカウントを使用してログインするか、新規アカウントのためにサインアップすることができます。Megascans ライブラリへの無料アクセスを無制限で利用するには、Unreal Unlimited プランに登録している必要があります。

Unreal Unlimited プランとは何ですか?

Unreal Engine のユーザーはもれなく、完全無料で Megascans をお使いいただけます。Unreal Engine のライセンスをお持ちであれば、Epic Games アカウントでサインインし、quixel.com/pricing に移動して、Megascans ライブラリへの無制限アクセスを取得してください。Bridge と Mixer 内で無制限にダウンロードできるようになります。

この Megascans の無制限アクセスは、Unreal Engine および Twinmotion での使用のみを目的としており、Megascans のアセットは Unreal Engine エンドユーザー ライセンス契約に基づく UE-Only コンテンツとして扱われます。

詳細については、Quixel Bridge FAQ page (Quixel Bridge FAQ ページ) を参照してください。

Unreal Engine 用 Bridge を使用する

システム要件

Unreal Engine 用 Quixel Bridge は、Windows、MacOS、Linux で動作します。

Bridge は、コンテンツ ライブラリを表示、ダウンロードするために、アクティブなインターネット接続を必要とします。インターネット接続が利用できない場合は、左側のナビゲーション ペインの [Local (ローカル)] タブに移動して、ディスク上のローカル コンテンツにアクセスします。

ナビゲーション

[Quixel Bridge] パネルの左側に、別のタブに移動するためのボタンがあります。

  • ホーム

  • コレクション

  • MetaHuman

  • お気に入り

  • ローカル

ホーム

[Home (ホーム)] タブは、最新のコレクション、トレンドアセット、各カテゴリの最新のアップロードを表示するセクションに分割されています。

画像をクリックするとフルサイズで表示されます。

左側のナビゲーションは、異なるレベルのサブカテゴリを持つカテゴリ ツリーとして構成されています。

画像をクリックするとフルサイズで表示されます。

すべての使用可能なアセット タイプは、[Home] タブに表示されます。カテゴリおよびサブカテゴリでフィルタできます。

Unreal Engine 用 Bridge では、アトラス、変位、ブラシはサポートされていません。

コレクション

[Collections (コレクション)] セクションには、様々なバイオーム、基本情報、アーキテクチャ特集、チュートリアル アセット、コミュニティ コレクションなどの参考資料とレンダリングなどから成る厳選されたコンテンツが収録されています。

画像をクリックするとフルサイズで表示されます。

MetaHumans

MetaHuman Creator アプリを使ってキャラクターを作成している場合は、Unreal 用 Quixel Bridge の左ナビゲーションパネルにある [自分の Metahumans] タブからアクセスできます。

画像をクリックするとフルサイズで表示されます。

お気に入り

Quixel Bridge のすべてのアセットを お気に入り としてマークすると、アクセスしやすくなります。

画像をクリックするとフルサイズで表示されます。

アセットをお気に入りとしてマークするには、アセットにカーソルを合わせて、ハート アイコンをクリックします。

ローカル

[Local (ローカル)] セクションには、ダウンロード済みで、お使いのマシンで使用可能なアセットがすべて表示されます。

画像をクリックするとフルサイズで表示されます。

検索とフィルタ

Megascans コンテンツ ライブラリには数千のアセットが登録されていますが、今なお大きくなり続けています。

アセットまたはコレクションを検索するには、検索バーをクリックします。入力を開始すると、検索バーの下に結果の候補が表示されます。

画像をクリックするとフルサイズで表示されます。

提案された結果の中に探していたアイテムがある場合、それを選択すると、直接そのアイテムにアクセスできます。検索クエリに対する結果をすべて表示するには、「Enter/Return」キーを押します。検索結果には、人気のアセット、関連コレクション、一致するアセット カテゴリなどの提案とともに、一致するコンテンツがすべて一覧表示されます。

さらに、フィルタ バーを使用して、アセット タイプ、色、バイオーム、状態、サイズなど特定のフィルタを使用して検索結果を絞り込むことができます。フィルタ バーの表示 / 非表示を切り替える場合は、右上の フィルタ アイコンをクリックします。

画像をクリックするとフルサイズで表示されます。

アセット情報

アセットの詳細情報を表示するには、アセットを選択して情報パネルを開きます。

画像をクリックするとフルサイズで表示されます。

アイコンから、アセット サイズやサーフェスがタイル可能かどうかなどのアセットに関する情報が表示されます。現在のアセットに類似した関連アセットも表示されます。

アセットの右パネルの下部で、アセットをプロジェクトにダウンロードまたは追加する前にダウンロード解像度を選択します。

[Export Settings (エクスポート設定)] ボタンをクリックして、アセットをシーンに読み込む方法を調整します。

ダウンロード設定

環境設定

デフォルトでは、Unreal Engine 用の Bridge からダウンロードしたアセットはすべて、ディスク上の以下の場所に配置されます。

  • Win: C:\Users\user\Documents\Megascans Library

  • Mac: ~\Documents\Megascans Library

  • Linux: ~\Documents\Megascans Library

このパスを変更するには、Bridge のウィンドウ右上隅にあるユーザー アイコンをクリックし、[Preferences (環境設定)] を選択します。

画像をクリックするとフルサイズで表示されます。

[Preferences] ダイアログで、アセットを保存したい ライブラリ パス を入力し、[Save (保存)] をクリックします。

画像をクリックするとフルサイズで表示されます。

フォーマットと解像度

アセットのダウンロード設定は、アセットの情報パネルから行えます。

Unreal Engine 用 Bridge の 3D アセットはすべて UAsset 形式でダウンロードされます。対応している解像度は以下の通りです。

  • Nanite

  • High (高)

  • Medium (中)

  • Low (低)

サーフェス、3D プラント、デカール、欠陥など、その他すべてのアセット タイプは、次の解像度で使用できます。

  • Highest (最高)

  • High (高)

  • Medium (中)

  • Low (低)

Nanite

Unreal Engine 5 用 Bridge は、Nanite 完全対応ティアで 3D アセットを提供するようになりました。これらのアセットは、Nanite の事前変換されたメッシュとしダウンロードされ、インポート時にプロジェクトにロードされます。

アセットは、すぐに機能し、事前にプロジェクト設定を構成する必要はありません。

Export Settings (エクスポート設定)

アセットのエクスポート設定は、アセットの情報パネルから行えます。[Export Settings (エクスポート設定)] ボタンをクリックすると開きます。

画像をクリックするとフルサイズで表示されます。

[Export Settings (エクスポート設定)] ダイアログで、アセットをプロジェクトにエクスポート、または追加する方法を制御するためのパラメータを指定できます。シーンにアセットを追加する前にこれらを設定する必要があります。

画像をクリックするとフルサイズで表示されます。

  • Auto-Populate Foliage Painter (フォリッジ ペインターの自動入力): 有効にすると、プロジェクト内のフォリッジ エディタのアセット リストに、インポートされた最新アセットが自動的に反映されます。この設定は、アセットをエクスポートする前にチェックする必要があります。また、適用されるのはアセットのスキャッターとプラントのみです。

  • Apply to Selection (選択に適用): 有効にすると、エクスポートしたマテリアルがシーン内で選択したオブジェクトに適用されます。

  • Master Material Overrides (マスターマテリアルの上書き): このセクションでは、プラグインが提供するデフォルトのマスター マテリアルの代わりに、独自のカスタム マスター マテリアルを選択できます。

  • Material Blend Settings (マテリアル ブレンド設定): このセクションでは、コンテンツ ブラウザで既にインポートされているマテリアルを使用して、マテリアルをブレンドすることができます。プラグインには、マテリアルのブレンドで使用するための頂点ブレンド シェーダが付属しています。

アセットをプロジェクトに追加する

アセットをダウンロードして UE プロジェクトに追加する方法はいくつかあります。

  1. ドラッグアンドドロップ。

  2. シーンへのダウンロードと追加。

これらの 2 つの方法について、次のセクションで説明していきます。

ドラッグアンドドロップ

1 つまたはまとめて複数のアセットをシーンにドラッグアンドドロップできます。

シーンにアセットを追加するには、[Bridge] パネルのアセットを選択します。これをビューポートにドラッグします。

画像をクリックするとフルサイズで表示されます。

アセットがまだダウンロードされていない場合、これは自動的にダウンロードを開始します。アセットの情報パネルで指定された解像度がダウンロードされます。

アセットのダウンロード時に、アセットのプレビューがシーンに表示されます。このプレビューは、すべてのアセットのダウンロードが完了するまでのプレースホルダーです。

初めて Unreal Engine 用の Bridge に何かをダウンロードする場合は、コンテンツ ブラウザに以下の新規フォルダが作成されます。

  • Megascans:アセットが保存される UE プロジェクト内の場所です。

  • MSPresets: ダウンロードしたアセットをシーンでレンダリングするために使用されるすべてのテンプレート マスター マテリアルが格納されます。

最後のアセットがダウンロードされると、シーン内のプレビューが置き換えられます。

ビューポートにドラッグアンドドロップすると、すべてのサーフェス、欠陥、デカールが球状のメッシュに表示されます。

シーンへのダウンロードと追加

また、アセットをダウンロードしてからシーンに追加することを 2 つのステップに分けることもできます。

プロジェクトへのダウンロード

アセットをダウンロードする方法の 1 つとして、グリッド内のアセットにカーソルを合わせて、緑色の クイックダウンロード ボタンをクリックします。

画像をクリックするとフルサイズで表示されます。

または、アセットを選択して [Asset Information (アセット情報)] パネルを開き、[Download (ダウンロード)] をクリックします。アセットをダウンロードする対象の解像度を選択できます。

画像をクリックするとフルサイズで表示されます。

ダウンロードしたアセットはすべて [Local (ローカル)] タブからアクセスできます。

画像をクリックするとフルサイズで表示されます。

ディスク上のアセットの場所に移動するには、ダウンロードしたアセットを右クリックし、[Go to Files (ファイルへ移動)] を選択します。

画像をクリックするとフルサイズで表示されます。

エディタ内では コンテンツ ブラウザ の「Content > Megascans」フォルダにダウンロードしたアセットが表示されます。

画像をクリックするとフルサイズで表示されます。

シーンへの追加

ダウンロード後、シーンに追加するには、次の 2 つの方法があります。最初の手順は、ダウンロードしたアセットにカーソルを合わせることです。[Quick Add (クイック追加)] ボタンをクリックします。

画像をクリックするとフルサイズで表示されます。

または、アセットを選択して [Asset Information] パネルを開きます。次に、パネルの下部にある [Add (追加)] ボタンをクリックします。アセットをエクスポートする対象の解像度を選択できます。

画像をクリックするとフルサイズで表示されます。

シーンにアセットを追加する前に、エクスポート設定が済んでいることを確認してください。これにより、プロジェクトに適切な解像度でアセットがダウンロードおよび追加されます。

最新バージョンへの更新

Quixel Bridge の新しいバージョン更新が使用可能な場合があります。これには、機能の改善点とバグ修正が含まれています。

使用中のバージョンや、更新の有無を確認するには、ユーザー ボタンをクリックし、[About Bridge (Bridge について)] を選択します。

画像をクリックするとフルサイズで表示されます。

ダイアログが表示され、使用中のバージョンと更新が可能かどうかについての情報が表示されます。

画像をクリックするとフルサイズで表示されます。

Epic Games Launcher を使用して Unreal Engine をインストールした場合は、最新のバージョンがインストールされていることを確認することもできます。[Library] タブで、使用しているインストール済みエンジンのバージョンを見つけます。その下にある [Installed Plugins] をクリックすると、そのエンジンのバージョンにインストールしたすべてのプラグインのリストが表示されます。更新が利用できれば、[Update] をクリックしてインストールします。

ソース コードへのライブの変更は、GitHub を通じて使用可能です。C++ のソース コードは、GitHub からアクセスできます。