マテリアル エディタの UI

マテリアル エディタのユーザー インターフェースの詳細。

Choose your operating system:

Windows

macOS

Linux

マテリアル エディタ UI は、下図のように、メニューバー、ツールバー、5 つの主な領域で構成されています。

番号

説明

1

メニュー バー

2

ツールバー

3

ビューポート パネル

4

詳細パネル

5

マテリアル グラフ パネル

6

統計パネル

7

パレット パネル

  • パネルを閉じるには、タブの右上隅にある小さい「X」をクリックします。また、タブを右クリックして表示されるコンテキスト メニューで [Hide Tab (タブを非表示にする)] をクリックすると、パネルが非表示になります。閉じたパネルをもう一度表示するには、[Window] メニューでパネル名をクリックします。

  • F1 キーを押すと、Unreal Engine のマテリアルに関するドキュメントが表示されます。

メニュー バー

Material Editor menu bar

File (ファイル)

  • Open Asset (アセットを開く) -アセットをすばやく見つけて適切なエディタを開くことができるグローバル アセットピッカーを開きます。

  • Save All (すべて保存) - プロジェクトにある未保存のレベルとアセットをすべて保存します。

  • Choose Files to Save (保存するファイルを選択) - プロジェクトに保存するレベルとアセットを選択できるダイアログ ボックスが表示されます。

  • Save (保存) - 現在、作業中のアセットを保存します。

  • Save As (名前を付けて保存) - このアセットを別の名前で保存します。

Edit (編集)

  • Undo (元に戻す) - 最新の操作を元に戻します。

  • Redo (やり直す) - アンドゥが最後に実行した操作があれば、その最後に実行したアンドゥをやり直します。

  • Undo History (元に戻した履歴) - 元に戻した操作の履歴を表示します。

  • Editor Preferences (エディタの環境設定) - オプションがリスト表示され、任意のものを選択すると、該当する [Editor Preferences] ウィンドウが開き、Unreal Editorの環境設定を変更できます。

  • Project Settings (プロジェクト設定) - オプションがリスト表示され、任意のものを選択すると、該当する[Project Settings] ウィンドウが開き、 Unreal Engine プロジェクトの様々な設定を変更できます。

  • Plugins - プラグインのブラウザ タブを開きます。

Asset (アセット)

  • Find in Content Browser (コンテンツブラウザで検索) - コンテンツ ブラウザ で現在のアセットを検索して選択します。

  • Reference Viewer (参照ビューア) - 選択したアセットの参照を表示する参照ビューアを起動します

  • Size Map (サイズマップ) - アセットのおよそのサイズと、そのアセットが参照するすべてのオブジェクトを表示する、インタラクティブなマップを表示します。

  • Audit Assets (アセットの監査) - Asset Audio の UI を開き、選択したアセットに関する情報を表示します。

  • Shader Cook Statistics (シェーダー クック統計情報) – シェーダー クック統計情報の UI を開きます。

Window (ウィンドウ)

  • Graph (グラフ) - [Graph] パネルの表示を切り替えます

  • Viewport (ビューポート) - [Viewport] パネルの表示を切り替えます。

  • Details (詳細) - [Details] パネルの表示を切り替えます。

  • Palette (パレット) - [Palette] パネルの表示を切り替えます。

  • Find Results (検索結果) - マテリアル グラフの項目を検索できます。

  • Preview Scene Settings (プレビュー シーン設定)マテリアル プレビュー ビューポート オプションを変更できるタブを開きます。

  • Parameters (パラメータ)マテリアル グローバル パラメータの表示/非表示を切り替えます。

  • Custom Primitive Data (カスタム プリミティブ データ) – カスタム プリミティブ データが有効になっている、現在のマテリアルにあるすべてのパラメータが表示されるタブを開きます。

  • Layer Parameters (レイヤー パラメータ) – 現在のマテリアルに追加されているすべてのマテリアル レイヤーを表示します。

  • Platform Stats - プラットフォームごとの マテリアル コストの表示を切り替えます。

  • Stats - マテリアル コスト を切り替えます。

  • Shader Code - 選択したプラットフォームの マテリアル HLSL コードの表示を切り替えます。

    • HLSL Code - HLSL コードの表示を切り替えます。

      • Desktop - さまざまなデスクトップ レンダリングの HLSL コードの表示を切り替えます。

        • DirectX SM5 - Windows SM5HLSL コードの表示を切り替えます。

        • DirectX SM6Windows SM6 用の HLSL コードの表示を切り替えます。

        • DirectX ES 3.1ES 3.1 用の HLSL コードの表示を切り替えます。

        • Vulkan SM5 - Vulkan SM5HLSL コードの表示を切り替えます。

        • Metal SM5 - Metal SM5HLSL コードの表示を切り替えます。

        • OpenGL SM4 - OpenGL SM4HLSL コードの表示を切り替えます。

      • Android- さまざまな Android レンダリングの HLSL コードの表示を切り替えます。

        • Android GLES 3.1 - Android GLES 3.1HLSL コードの表示を切り替えます。

        • Android Vulkan - Android VulkanHLSL コードの表示を切り替えます。

        • iOS – さまざまな iOS レンダラ用の HLSL コードの表示を切り替えます。

      • iOS- さまざまな iOS レンダリングの HLSL コードの表示を切り替えます。

        • Metal SM5Metal 用の HLSL コードの表示を切り替えます。

        • Metal MRTMetal MRT 用の HLSL コードの表示を切り替えます。

  • Cinematics (シネマティックス) – Cinematics Sequence Recorder、Take Recorderor、Takes Browser のいずれかを新しいウィンドウで開きます。

  • Content Browser (コンテンツ ブラウザ)コンテンツ ブラウザ を個別のウィンドウで開きます。

  • Virtual Production (バーチャル プロダクション) – [Live Link Streaming Manager (Live Link ストリーミング マネージャー)] タブを開きます。

  • Reset Layout (レイアウトをリセット) - レイアウトをデフォルトの配置にリセットします。変更を保存し、設定のバックアップを作成後にエディタを再起動する必要があります。

  • Save Layout (レイアウトを保存) - パネルの現在のレイアウトを新しいデフォルト レイアウトとして保存します。

  • Remove Layout (レイアウトを削除) – 現在のレイアウトを削除します。

  • Enable Fullscreen (画面を最大化) - アプリケーションの全画面モードを有効にして、モニタ全体に表示します。

Tools (ツール)

  • New C++ Class (新規 C++ クラス) – C++ コードをプロジェクトに追加します。このコードは、Visual Studio がインストールされている場合にのみコンパイルできます。

  • Generate Visual Studio Project (Visual Studio プロジェクト ファイルを生成) – Visual Studio で C++ コード プロジェクトを生成します。

  • [Find in Blueprints (ブループリントを検索)] - 関数、イベント、変数を参照するオブジェクトを全ブループリントから検索します。

  • Cache Statistics (キャッシュ統計情報) – 派生データ キャッシュに関する統計情報を表示します。

  • Class Viewer (クラス ビューア) – このプロジェクトに存在するすべてのクラスを表示します。

  • CSV to SVG (CSV から SVG) – CSV プロファイルから生成されたカンマ区切り値ファイルからベクター ライン グラフを生成するツールを開きます。

  • Localization Dashboard (ローカライゼーション ダッシュボード) – このプロジェクトのローカライゼーション ダッシュボードを開きます。

  • Merge Actors (アクタをマージ) – [Merge Actors] ダイアログを開きます。

  • Project Launcher (プロジェクトランチャー) – [Project Launcher] タブを開きます。

  • Resource Usage (リソース使用状況) – 派生データのリソース使用状況の詳細を表示します。

  • Session Frontend (セッション フロントエンド) – [Session Frontend] タブを開きます。

  • Struct Viewer (構造ビューア) – このプロジェクトに存在するすべての構造を表示します。

  • Virtual Assets (仮想アセット) – このプロジェクトに存在するすべての仮想アセットに関する統計情報を表示します。

  • Debug (デバッグ) – ブループリント、コリジョン、Niagara などのデバッグ ツール。

  • Profile (プロファイル) – [Profile Data Visualizer (プロファイル データ ビジュアライザ)] タブまたは [Trace Data Filtering (トレース データ フィルタリング)] タブを開きます。

  • Audit (監査) – [Asset Audit (アセットの監査)] ウィンドウまたは Material Analyzer を開きます。

  • Platforms (プラットフォーム) – デバイス マネージャーまたはデバイス プロファイルの UI を開きます。

  • Source Control (ソース コントロール) – ソース コントロールへの接続、変更リストの表示、または コンテンツの送信を行います。

  • Run Unreal Insights (Unreal Insights を実行) – Unreal Insights スタンドアローン アプリケーションを実行します。

Help (ヘルプ)

  • Material Editor Documentation (マテリアル エディタのドキュメント) – このツールに関するドキュメントをブラウザ ウィンドウで表示します。

  • Documentation Home (ドキュメント ホーム) – ドキュメントのホームページをブラウザ ウィンドウで開きます。

  • Online Learning (オンライン ラーニング)Unreal Online Learning のホームページをブラウザ ウィンドウで開きます。

  • Forums (フォーラム) – Unreal Engine のフォーラムにアクセスして、アナウンスを確認したり、他のデベロッパーと議論したりします。

  • Answer HUB () – AnswerHub にアクセスして、質問をしたり、既存の回答を検索したり、他の UE4 デベロッパーと知識を共有したりします。

  • Support (サポート) – Unreal Developers Network (UDN) のフォーラム ページをブラウザ ウィンドウで開いて、Unreal Engine について質問できます。

  • Report a Bug (バグの報告) – Unreal Engine のバグ報告フォームをブラウザ ウィンドウで開きます。

  • Issue Tracker (問題トラッカー) – Unreal Engine の問題と修正に関する検索可能なデータベースをブラウザ ウィンドウで開きます。

  • About Unreal Editor (Unreal Editor について) – アプリケーションのクレジット、著作権情報、ビルド情報を表示します。

  • Credits (クレジット) – アプリケーションのクレジットを表示します。

  • Visit UnrealEngine.com (UnrealEngine.com にアクセス) – Unreal Technology に関する詳細情報を確認できる UnrealEngine.com サイトをブラウザ ウィンドウで開きます。

ツールバー

以下の表に、ツールバーのオプションとその説明を示します。

アイコン

説明

Save icon

現在のアセットを保存します。

Browse icon

コンテンツ ブラウザで現在のアセットを検索して選択します。

Apply Icon

マテリアル エディタで行った変更を、元のマテリアルおよびワールドでこのマテリアルを使用しているすべての箇所に適用します。

Search icon

現行マテリアルの表現式とコメントを検索します。

Home Icon

Main Material ノードを マテリアル グラフ の中央に配置します。

Hierarchy icon

現在のマテリアルを親として使用しているすべてのマテリアル インスタンスを一覧表示します。

Live Update options

マテリアル エディタの UI でリアルタイムでアップデートする要素を切り替えます。

Clean Graph icon

現在のマテリアルと接続されていないマテリアル ノードをすべて削除します。

Preview State toggle

ノードの状態をプレビューして、指定されている機能レベル、マテリアルの品質、スタティック スイッチの値を確認します。

Hide unrelated nodes

選択されているノードと関連がないすべてのノードを非表示にします。

Material stats toggle

[Stats (統計情報)] パネルでのマテリアルの統計値の表示/非表示を切り替えます。

Platform Stats toggle

複数のプラットフォームのマテリアル統計情報とコンパイルエラーが表示されているウィンドウを切り替えます。

ビューポート パネル

Material Editor Viewport panel

ビューポート パネルには、現在編集中のマテリアルが表示されます。

ビューポート パネル内のナビゲーションで使用可能な操作を次の表に示しています。

アクション

説明

マウスの左ボタンでドラッグ

メッシュの回転

マウスホイールのドラッグ

パン

マウス右ボタンでドラッグ

ズーム

L キーを押しながらマウスの左ボタンでドラッグ

ライトの方向の回転

関連付けられているツールバー コントロール (ビューポートの右下隅にある 5 の形状のボタン) を使用して、ビューポートのプレビュー メッシュを変更できます。カスタム プレビュー メッシュを使用するには、コンテンツ ブラウザ内で Static Mesh アクタ を選択し、ビューポートにある レンガ アイコンをクリックします。ビューポート メッシュはマテリアルと一緒に保存されているので、次回そのマテリアルがマテリアル エディタで開かれると、同じメッシュが表示されます。

マテリアル エディタの プレビュー ビューポートで使用可能なオプションの詳細を次の表に示しています。

アイコン

説明

Preview meshes

それぞれのプリミティブ形状での現在のマテリアルの結果を [Preview (プレビュー)] パネルに表示します。

Viewport options

マテリアルの ビューポート オプション を切り替えます

Viewport type

使用されている ビューポート のタイプを変更します。

Viewport lighting

ビューポート で使用されているライティングのタイプを変更します。

Viewport show options

マテリアル ビューポートへの追加オプションを有効にします。

詳細パネル

Details Panel

このパネルには、現在選択されているマテリアルのすべての表現式と関数ノードが表示されるプロパティ ウィンドウがあります。ノードが選択されていない場合は、マテリアルの基本プロパティが表示されます。

すべてのマテリアル プロパティの説明については、「マテリアル プロパティ」を参照してください。

マテリアルグラフ パネル

Material Graph

このパネルには、このマテリアルに属するすべてのマテリアル表現式のグラフがあります。デフォルトでは、各マテリアルに 1 つのベース マテリアル ノードがあります。このノードには一連の入力があり、それぞれの入力がマテリアルのさまざまな側面と関連付けられていて、他のマテリアル ノードはそれに接続できます。

MaterialEditor_MaterialNode.png

メイン マテリアル ノードのさまざまなの入力の説明については、「マテリアル入力」を参照してください。

パレット パネル

Material Editor palette

Palette (パレット) パネルには、マテリアルにドラッグできるすべてのマテリアル ノードの分類済みリストがあります。新しいマテリアル ノードを配置するには、ノードを [Palette] パネルから [Material Graph] パネルにドラッグします。

パレット パネルはデフォルトでは表示されていません。マテリアル エディタの右上隅にある [Palette] タブをクリックすると、パレット パネルが表示されます。作業中にパレット パネルを表示したままにするには、Pin アイコンをクリックします。

Open Material Palette

[Category] ドロップダウン リストから [Expressions (表現式)] または [Functions (関数)] を選択すると、[Palette] パネルに一覧表示されるマテリアル ノードをフィルタリングできます。

マテリアル関数の詳細については、「マテリアル関数」を参照してください。

統計パネル

Stats panel

このパネルには、マテリアルで使用されているシェーダー命令数とコンパイラ エラーが表示されます。シェーダー命令数が少ないほど、マテリアルのコストは低くなります。ベース マテリアル ノードに接続されていないマテリアル表現式ノードは、そのマテリアルの命令数に寄与せず、コストが増えることはありません。

HLSL コード パネル

HLSL Code panel

このパネルには、現在のマテリアルで生成された High Level Shader Language (HLSL) が表示されます。これはエディタではないので、HLSL コードを変更することはできません。これは、マテリアル ネットワークで定義されているコードを視覚化するだけのビューアです。

デフォルトでは、[Code View (コード表示)] パネルは表示されていません。[Code View] パネルを表示するには、[Window] メニューを開いて [HLSL Code] をクリックします。

プラットフォームの統計情報

Platform Stats アイコンをクリックすると、さまざまなプラットフォームでのマテリアルのコストを表示できます。

Platform Stats

Unreal Engine でサポートされている各レンダリング API の統計情報を表示するには、[Settings] オプションをクリックしてから、統計情報を表示するレンダラを選択します。

Platform Stats settings

Android での統計情報を確認するには、次の手順に従って、まず Mali オフライン コンパイラ をインストールする必要があります。

  1. Mali オフライン コンパイラ をダウンロードしてインストールします。

  2. Mali オフライン コンパイラをインストールした後に、メニューバーで [Edit] > [Editor Preferences] を選択します。

    Editor Preferences

  3. [Content Editors (コンテンツ エディタ)] にある [Material Editor] を選択します。

    Material Editor preferences

  4. [Mali Offline Compiler] オプションの右側にある [...] をクリックし、Mali Offline Compiler と一緒にインストールされている malisc.exe ファイルを見つけます。malisc.exe のデフォルトのファイル パスを次に示しています。

    Mali Compiler

  5. 前のステップが完了したら、Unreal Engine でサポートされているさまざまな Android レンダラの統計情報を確認することができます。

    Android platform stats

Mali オフライン コンパイラをインストールせずに Android プラットフォームの統計情報を確認することはできません。

グラフ コントロール

マテリアル エディタにあるコントロールは、Unreal Editor の他のツールのコントロールほとんど同じです。例えば、他のノード ベースのオブジェクト エディタ (ブループリント) と同様に、マテリアル表現式グラフをナビゲートできます。他のメッシュ ツールのように、マテリアル プレビュー メッシュの向きを変えることができます。

マウス操作

コントロール

アクション

背景をマウスの右ボタンでドラッグ

マテリアル表現式グラフをパン

背景をマウスの左ボタンでドラッグ

ボックスの選択

マウス ホイールを回転

ズームインおよびズームアウト

マウスの右ボタンと左ボタンでドラッグ

ズームインおよびズームアウト

オブジェクトを左クリック

式/コメントを選択

Ctrl キーを押しながらオブジェクトを左クリック

式/コメントの選択を切り替え

左クリックしてドラッグ

現在の選択/コメントを移動

Ctrl キーを押しながら左ボタンでドラッグ

ボックスを選択 (現在の選択に追加)

左ボタンでコネクタをドラッグ

接続を作成 (コネクタ上にドロップ)

Ctrl キーを押しながら左ボタンでドラッグ

接続を移動 (同じタイプのコネクタにドロップ)

Shift キーを押しながら左ボタンでコネクタをダブルクリック

コネクタをマーク。マークしたコネクタでこの操作をもう一度行うと、2 つのコネクタ間に接続が作成されます。これは、距離が離れているノード間の接続を素早く作成する方法です。

背景を右クリック

[New Expression] メニューを表示

オブジェクトを右クリック

メニューを表示

コネクタを右クリック

メニューを表示

Alt キーを押しながらコネクタを左クリック

コネクタへのすべての接続を切断

Ctrl キーを押しながらコネクタを左クリック

コネクタに沿って新規ノードを追加

キーボード操作

操作

アクション

Ctrl + B キー

コンテンツ ブラウザで検索

Ctrl + C キー

選択されている式をコピー

Ctrl + S キー

マテリアルを保存

Ctrl + V キー

貼り付け

Ctrl + D キー

選択されているオブジェクトを複製

Ctrl + Y キー

やり直す

Ctrl + Z キー

元に戻す

Delete キー

選択されているオブジェクトを削除

スペース キー

すべてのマテリアル表現式のプレビューを強制的に更新

Enter キー

([Apply] をクリックするのと同じ)

ホットキー

ホットキーを使用して、よく使うマテリアル表現式タイプを配置できます。ホットキーを押しながら 左クリック すると、ノードにドロップされます。ホットキーは以下のように割り当てられています。

ホットキー

A キー

Add

B キー

BumpOffset

C キー

Comment

D キー

Divide

E キー

Power

F キー

MaterialFunctionCall

I キー

If

L キー

LinearInterpolate

M キー

Multiply

N キー

Normalize

O キー

OneMinus

P キー

Panner

R キー

ReflectionVector

S キー

ScalarParameter

T キー

TextureSample

U キー

TexCoord

V キー

VectorParameter

1

Constant

2

Constant2Vector

3

Constant3Vector

4

Constant4Vector

Shift + C キー

ComponentMask