Development Requirements

Android development requirements including compatible hardware, software, and SDK information.

Choose your operating system:

Windows

macOS

Linux

This page contains the software development kit (SDK) requirements needed to develop Unreal Engine (UE) projects for Android devices, as well as compatible hardware for the current version of UE.

Current Development Requirements

Current SDK Information

  • Current UE Version: 5.0

    • Android Studio Version: 4.0

    • Minimum SDK Version: 23

    • Required for Android File Server: SDK 26

    • NDK Version: r21e

Current Compatible Devices

UE 5.0 supports Android devices meeting the following specifications:

  • Android 8 or higher

  • 64-bit Arm-based CPU

  • Compatible GPUs

    • Mali T8xx, G71, G72, G76, G77, G78 and G710 series

    • Adreno 5xx, 6xx or 7xx series

    • PowerVR GM9xxx

    • Xclipse 920

  • Compatible Graphics APIs

    • OpenGL ES 3.2

    • Vulkan supported on Android 10 or later devices with compatible drivers

Version History

UE Version

Android Studio Version

Minimum Android SDK Version

Android NDK Version

Notes

5.0

Android Studio 4.0

SDK 23

NDK r21e

[INCLUDE #Notes-5.0]