스태틱 메시 임포트

언리얼 엔진 5로 스태틱 메시를 임포트하는 방법을 살펴봅니다.

Choose your operating system:

Windows

macOS

Linux

언리얼 엔진 5는 레벨에 사용할 에셋을 제작하는 데 도움이 되는 다양한 툴을 제공합니다. 하지만 외부 애플리케이션에서 에셋을 제작하여 언리얼 엔진 5로 임포트해야 하는 경우도 많습니다. 이 하우투에서는 다른 3D 애플리케이션에서 제작한 스태틱 메시를 언리얼 엔진 5 레벨에서 사용할 수 있도록 임포트하는 기본적인 방법을 살펴봅니다.

구성

언리얼 엔진 5에서 레벨을 제작하는 경우 일부 3D 모델이 다른 애플리케이션에서 제작되는 경우가 있는데, 이제 해당 모델을 언리얼 엔진 5로 가져올 수 있게 되었습니다. Maya, 3ds Max 또는 그 외 모델링 프로그램 같은 3D 모델링 소프트웨어에서 전환하려면 확인해야 할 사항이 몇 가지 있습니다. 먼저 모델링 동안이나 익스포트 전에 언리얼 엔진 5에서 사용된 단위가 언리얼 유닛이며, 1 언리얼 유닛은 1cm와 같다는 점을 기억해 두면 매우 유용합니다. 또한 언리얼 엔진 5로는 특정 파일 유형만을 임포트할 수 있는데, 3D 오브젝트에 대해 권장되는 파일 포맷은 FBX입니다. 마찬가지로, 스태틱 메시에 적용된 모든 텍스처 및 머티리얼도 지원되는 파일 유형인지 참고하세요.

익스포트하기

이 예시에서는 이 구체 모델을 Maya에서 언리얼 엔진 5 레벨로 익스포트해 보겠습니다.

구체 모델

완료된 모델을 언리얼 엔진 5로 임포트하는 첫 번째 단계는, 바로 메시가 제작된 3D 애플리케이션에서 모델을 익스포트하는 것입니다. 이 예시에서는 Maya를 사용했지만 FBX 파일을 익스포트할 수 있는 애플리케이션이라면 무엇이든 자유롭게 사용해도 좋습니다. 해당하는 애플리케이션의 '파일(File)' 메뉴로 이동하여 익스포트(Export) 를 선택합니다.

Maya 파일 메뉴

선택을 마쳤다면 이제 메시를 저장할 경로를 선택합니다. 메시를 익스포트할 이름을 짓고 파일 유형도 선택해야 합니다. 권장되는 유형은 FBX입니다.

전체 크기로 보려면 이미지를 클릭하세요.

임포트하기

이제 3D 애플리케이션에서 메시가 익스포트 되었다면 메시를 임포트할 프로젝트가 필요합니다. 이미 작업 중이던 프로젝트가 있다면 이 단계를 건너 뛸 수 있습니다. 하지만 작업할 프로젝트가 필요한 경우에는 런처를 실행하고 새 프로젝트를 선택할 수 있습니다. 어떤 프로젝트 카테고리 및 템플릿을 선택할지 또 시작용 콘텐츠(Starter Content) 를 포함할지 여부는 이 하우투의 목적상 중요하지 않습니다. 저장 경로를 선택하고 프로젝트의 이름을 지은 다음 프로젝트 생성(Create Project) 을 클릭합니다.

프로젝트가 로드되면 콘텐츠 브라우저(Content Browser) 로 이동합니다. 콘텐츠 브라우저 에서 폴더를 탐색하여 임포트한 메시를 저장할 경로를 찾습니다. 이 예시에서는 Meshes 폴더에 구체 메시를 임포트합니다. 메시를 저장할 폴더를 정했다면 간단한 방법 한두 가지로 메시를 임포트할 수 있습니다. 첫 번째 방법은 콘텐츠 브라우저 의 폴더에서 빈 공간을 우클릭 하고 컨텍스트 메뉴에서 (ImportLocation)에 임포트(Import to (ImportLocation)...) 를 선택하는 것입니다. 또는 콘텐츠 브라우저 상단의 임포트(Import) 버튼을 클릭해도 됩니다.

전체 크기로 보려면 이미지를 클릭하세요.

(ImportLocation)에 임포트 옵션을 사용하든 임포트 버튼을 클릭하든 3D 애플리케이션에서 메시를 익스포트할 때 저장한 위치로 이동합니다. 해당 메시를 찾았다면 더블클릭 또는 열기(Open) 를 클릭하여 임포트할 수 있습니다.

전체 크기로 보려면 이미지를 클릭하세요.

임포트할 메시를 선택하고 파일을 더블클릭 하거나 열기 를 클릭하면 FBX 임포트 옵션(FBX Import Options) 메뉴가 표시됩니다. 기본적으로 아래 이미지와 비슷하게 표시됩니다.

전체 크기로 보려면 이미지를 클릭하세요.

이외에도 메시를 임포트할 때 사용할 수 있는 옵션은 많습니다.

전체 크기로 보려면 이미지를 클릭하세요.

이번 하우투의 목적상 어떤 디폴트를 사용하든 상관 없으며, 메시를 있는 그대로 가져올 수 있습니다.

몇 가지 명심할 사항이 있습니다. 스켈레탈 메시로 임포트할 메시가 있는 경우 프로세스 자체는 매우 비슷하지만 메시 섹션에서 '스켈레탈로 임포트(Import as Skeletal)'라는 첫 번째 체크박스가 체크되어 있어야 합니다. 이 메시를 스태틱 메시로 임포트하려면 체크하지 않아도 됩니다. 또한 메시의 수와 종류가 많다면 굳이 이 프로세스를 반복하기보다는 이전 단계에서 임포트할 메시를 선택할 때 여러 개를 선택하면 됩니다. 그러면 임포트 를 클릭했을 때 메시별로 임포트 옵션을 선택할 수 있으며, 모두 임포트(Import All) 를 클릭하면 동일한 옵션으로 모든 메시를 임포트하게 됩니다.

임포트 를 클릭하면 콘텐츠 브라우저 에서 임포트하기로 선택했던 폴더에 메시가 표시됩니다. 메시를 하나 이상 임포트한 경우에는**임포트 를 클릭한 후 FBX 임포트 옵션(FBX Import Options) 메뉴가 표시됩니다. 이 예시에서는 메시를 하나만 임포트했으므로 임포트 또는 모두 임포트 를 클릭하면 동일한 결과가 생성되어 콘텐츠 브라우저 로 돌아가게 됩니다. 또한 메시를 임포트할 때는 기본적으로 FBX 임포트 옵션) , 머티리얼 임포트(Import Materials)텍스처 임포트(Import Textures)** 가 모두 true로 체크되어 있기 때문에 3D 애플리케이션에 적용했던 머티리얼 또는 텍스처도 모두 임포트 되었을 수 있습니다. 또한 섬네일 하단의 다양한 색상 막대를 통해 에셋 유형을 알 수 있습니다. 하단에 하늘색 막대가 있는 에셋은 스태틱 메시입니다.

전체 크기로 보려면 이미지를 클릭하세요.

언리얼 엔진 5로 메시를 임포트하여 저장했으므로 이제 다른 에셋과 마찬가지로 콘텐츠 브라우저 에서 뷰포트로 드래그하여 레벨에서 사용할 수 있습니다.