무비 렌더 큐 개요

활용도가 높은 무비 렌더 큐 툴로 시네마틱을 렌더링하고 배치로 렌더링합니다.

Choose your operating system:

Windows

macOS

Linux

무비 렌더 큐는 언리얼 엔진의 이미지 시퀀스&무비 렌더링 솔루션으로 고퀄리티의 렌더링 이미지를 제작하고, 프로덕션 파이프라인을 쉽게 통합하고, 뛰어난 사용자 확장 가능성을 지원할 수 있도록 제작되었습니다.

무비 렌더 큐는 고퀄리티의 방사형 모션 블러 생성이 가능한 템포럴 서브샘플링처럼 고퀄리티 렌더를 생성할 수 있는 다양한 기능을 지원합니다. 그리고 적절한 프로젝트/씬 세팅을 사용하여 반투명 픽셀 값이 포함된 이미지를 익스포트하고, 단방향 데이터로 16비트 HDR 이미지를 생성하고, 렌더링 환경설정을 에셋에 저장하여 재사용하고 공유할 수 있습니다. 배치 렌더링 작업의 실행을 지원하는 렌더 큐를 사용하면 여러 작업과 각 세팅을 한 번에 관리할 수 있습니다.

전제조건

  • 무비 렌더 큐를 사용하려면 먼저 활성화해야 합니다. 언리얼 엔진 메뉴의 편집 > 플러그인 으로 이동하여 Rendering 섹션에서 Movie Render Queue 를 찾아 활성화합니다. 활성화하고 나면 에디터를 다시 시작해야 합니다.

    무비 렌더 큐 플러그인

  • 렌더링할 레벨 시퀀스가 포함된 프로젝트가 있어야 합니다. 아직 프로젝트를 만들지 않았다면 미리 만들어 놓은 콘텐츠 예제 샘플 및 튜토리얼Meerkat 데모 를 사용하셔도 됩니다.

무비 렌더 큐 열기

2가지 방법으로 무비 렌더 큐 창을 열 수 있습니다.

첫 번째 방법은 언리얼 엔진의 메인 메뉴에서 창 > 시네마틱 > 무비 렌더 큐 를 클릭하는 것입니다.

무비 렌더 큐 열기

다른 방법으로는 시퀀서 에서 툴바에서 무비 렌더 버튼을 클릭하면 됩니다. 이 경우 드롭다운 메뉴를 클릭하여 기본 렌더 툴이 무비 렌더 큐로 설정되어 있는지 확인하세요. 그렇지 않으면 시퀀서의 레거시 렌더러 툴이 대신 열립니다.

무비 렌더 큐 열기

위의 2가지 옵션 중 하나로 진행하면 무비 렌더 큐 창이 열립니다.

무비 렌더 큐 창

인터페이스 개요

무비 렌더 큐 인터페이스는 4개의 메인 영역으로 구성되어 있습니다.

무비 렌더 큐 인터페이스

  1. 툴바: 렌더 작업을 추가 또는 제거하거나, 현재 작업 목록을 로드 또는 저장할 때 사용되는 메뉴가 포함되어 있습니다.

  2. 작업: 큐에 있는 순서대로 렌더링하는 시퀀스를 보여 줍니다. 목록에서 최상위 레벨의 아이템이 작업으로 간주되며, 작업별로 환경설정 세팅도 포함되어 있습니다.

  3. 작업 디테일: 선택한 작업에 대한 디테일을 보여 줍니다. 이름, 레벨 시퀀스 에셋, 작업 중 실행할 레벨, 그리고 이 작업의 제작자를 확인할 수 있습니다.

  4. 렌더 시작: 머신에서 로컬로 또는 별도의 프로세스로 렌더를 시작합니다.

툴바

툴바에는 작업을 추가하고 제거할 수 있는 메뉴가 포함되어 있습니다. 렌더 큐에 새로운 시퀀스를 추가하려면 + 렌더 버튼을 클릭하고 레벨 시퀀스 에셋(Level Sequence Asset) 을 선택합니다. 콘텐츠 브라우저에서 작업 영역으로 드래그하여 작업 목록에 추가할 수도 있습니다.

렌더 작업 추가

작업 목록에서 시퀀스를 제거하려면 - 버튼을 클릭하거나 키보드에서 Delete 키를 누르면 됩니다.

렌더 작업 제거

툴바에서 현재 작업 목록을 큐 프리셋 에셋으로 저장할 수도 있습니다. 큐 로드/저장 버튼을 클릭한 다음 에셋으로 저장 을 선택하면 이름을 지정할 창이 나타나고 무비 파이프라인 큐 에셋을 프로젝트 내에 저장하면 됩니다.

렌더 큐 프리셋 저장

이제 프리셋이 큐 로드/저장 아래 목록으로 나타납니다. 프리셋을 선택하면 저장된 프리셋에 맞게 작업 목록이 세팅됩니다.

이렇게 하면 작업 영역에 큐 복사본이 임포트되며, 변경된 작업 목록은 에셋으로 저장 을 선택하고 기존 프리셋에 덮어 저장하지 않는 한 에셋에는 영향을 주지 않습니다.

렌더 큐 프리셋 로드

작업

작업 영역에는 렌더링할 레벨 시퀀스 목록과 각 렌더 세팅과 출력 디렉터리가 포함되어 있습니다.

시퀀스를 확장하면 카메라를 볼 수 있습니다. 목록은 시퀀스의 카메라 컷 트랙 섹션에서 생성되었으며, 해당 섹션이 렌더링되지 않도록 카메라를 활성화하거나 비활성화할 수도 있습니다.

카메라 컷 렌더 큐

작업에서 세팅 항목을 클릭하면 세팅 창이 열리고 여기에서 출력 디렉터리, 렌더링 세팅, 그리고 익스포트 포맷을 지정할 수 있습니다.

무비 렌더 세팅

드롭다운 화살표를 클릭하고 프리셋을 선택하면 저장된 프리셋을 작업에 적용할 수 있습니다.

무비 렌더 세팅 프리셋

출력 영역에는 출력 세팅에서 설정한 대로 이미지나 비디오를 렌더링할 폴더 디렉터리가 표시됩니다. 디렉터리를 클릭하면 이 폴더를 보여주는 파일 탐색기 창이 열립니다.

렌더 디렉터리 탐색기

렌더 커스터마이징에 대한 자세한 내용은 렌더 세팅 페이지를 참고하세요.

ue4_icon.png

무비 렌더 큐 출력 포맷

무비 렌더 큐가 현재 지원하는 출력 포맷 레퍼런스

무비 렌더 큐가 현재 지원하는 출력 포맷 레퍼런스

ue4_icon.png

무비 렌더 큐 세팅 레퍼런스

고품질 미디어 익스포트 UI 및 세팅 레퍼런스 가이드입니다.

고품질 미디어 익스포트 UI 및 세팅 레퍼런스 가이드입니다.

작업 상세 정보

작업을 선택하면 작업 디테일 영역에서 자세한 정보를 볼 수 있습니다.

render job details

이 영역에는 선택한 작업에 대한 다음 필드가 나타납니다.

이름

설명

작업 이름(Job Name)

작업의 이름으로 기본적으로는 레벨 시퀀스 이름으로 설정되지만 수정할 수 있습니다. 작업 이름 필드는 디폴트 번 인 오버레이에도 표시됩니다.

시퀀스(Sequence)

시퀀스 에셋 레퍼런스입니다. 작업에 다른 시퀀스를 지정하려면 참조되는 시퀀스를 변경할 수 있습니다.

맵(Map)

렌더링할 때 실행할 레벨입니다. 시퀀스에서 스포너블 을 사용하면 서로 다른 레벨에서 동일한 씬을 렌더링할 수 있습니다.

작성자(Author)

작업을 만든 사람으로, OS 사용자 이름으로 자동 입력됩니다.

렌더 시작

렌더 로컬 원격

렌더(로컬) 은 언리얼 엔진과 동일한 프로세스로 렌더링하고 렌더링할 에디터에서 플레이 세션을 실행합니다. 로컬 렌더 작업의 경우 변경 사항을 저장하지 않아도 됩니다.

렌더(원격) 은 작업을 렌더링하는 별도의 프로세스를 실행합니다. 이 경우 프로젝트에 변경 사항을 저장해야 외부 프로세스에서 저장된 파일을 디스크에서 읽을 수 있습니다.

원격 옵션은 원격 렌더 팜을 구현하는 데 사용할 수 있습니다. 렌더 옵션의 기본 동작은 프로젝트 세팅 에서 정해지고, 사용자 본인의 코드를 실행하여 조정할 수 있어 타사의 렌더 팜 관리 소프트웨어를 사용할 때 유용합니다. 그리고 원격 렌더 프로세스 실행 시 사용하는 명령은 출력 로그에 기록되어 자신만의 자동화된 렌더 팜을 만들 때 레퍼런스로 사용할 수 있습니다.

작업 디테일 에 렌더링할 레벨 에셋이 지정되어 있으므로 렌더링할 때 동일한 레벨을 열고 있지 않아도 됩니다.

렌더 프리뷰

렌더 작업을 실행 중이면 무비 렌더 큐에 렌더의 현재 비주얼 상태를 보여주는 렌더 프리뷰 창이 관련 정보와 함께 나타납니다. 프리뷰 창은 렌더가 완료되면 자동으로 닫힙니다.

렌더 프리뷰

  1. 렌더 프리뷰: 렌더의 현재 비주얼 상태가 표시됩니다. 각 프레임이 여기에 나타날 때 출력 디렉터리에도 저장됩니다. 여기서 프리뷰는 GPU의 최신 샘플 데이터를 기반으로 하며 최종 렌더보다는 더 낮은 퀄리티로 보일 수도 있습니다. 렌더에 타일링을 활성화하면 프리뷰는 우측 하단 타일로 나타납니다.

  2. 전체 렌더 진행률: 렌더링 중인 현재 시퀀스와, 전체 진행률, 경과 시간, 남은 예상 시간이 표시됩니다.

  3. 현재 카메라 컷 진행률: 현재 렌더링되고 있는 카메라 정보와 현재 카메라 컷에 대한 진행률이 표시됩니다.

기본 렌더 만들기

다음 단계에 따라 시네마틱 시퀀스의 기본 렌더를 만들 수 있습니다.

작업 구성

먼저 창 > 시네마틱 > 무비 렌더 큐 를 클릭하여 무비 렌더 큐를 엽니다.

무비 렌더 큐 열기

+ 렌더 버튼을 클릭하고 시퀀스를 선택하여 작업 목록에 시퀀스 에셋을 추가합니다.

렌더 작업 추가

그리고 프로퍼티에 올바른 레벨이 설정되어 있는지 확인합니다.

맵 세팅 렌더

출력 세팅

시퀀스를 추가하고 나면 대상 폴더, 해상도, 파일 타입 등 출력 세팅을 조정해볼 수 있습니다.

저장되지 않은 환경설정 텍스트를 클릭하여 해당 작업에 대한 렌더 세팅 창을 엽니다.

무비 렌더 큐 세팅

기본적으로 무비 렌더 큐는 .jpg 이미지 시퀀스로 렌더링됩니다. 이 세팅을 변경하려면 .jpg Sequence [8bit] 항목을 삭제하고 + 세팅 버튼을 클릭해서 다른 출력 포맷을 선택하면 됩니다.

.jpg Sequence [8bit] 항목을 선택하고 Delete 키를 누른 다음, + 세팅 버튼을 클릭하고 .png Sequence [8bit] 를 선택하세요.

무비 렌더 큐 png 시퀀스

디퍼드 렌더링 항목은 출력 시 뷰포트에 표시되는 정확한 이미지를 렌더링합니다. 이와 같은 기본 렌더를 위해 이 세팅을 그대로 유지할 수는 있지만 이미지 렌더를 위해서는 이 세팅이 반드시 있어야 합니다.

디퍼드 렌더

출력 을 클릭하면 파일 이름, 디렉터리, 해상도 등 출력과 관련된 일반적인 세팅이 나타납니다.

Output Directory(출력 디렉터리) 필드를 변경하려면 ... 버튼을 클릭하고 새로운 폴더를 지정한 다음 폴더 선택 을 누르면 됩니다. 이렇게 하면 이미지 시퀀스가 해당 위치에서 출력합니다.

렌더 출력 세팅

변경을 하고 나서는 렌더 세팅 창을 닫습니다.

렌더

이제 시퀀스를 렌더링할 수 있습니다.

렌더(로컬) 를 클릭하고 시퀀스 렌더 작업을 시작하세요. 렌더 프리뷰 창이 열리고 현재 렌더 진행률이 나타납니다.

로컬 무비 렌더

렌더가 완료되면 프리뷰 창이 닫힙니다. 이제 작업에 연결된 출력 텍스트를 클릭하면 출력 폴더로 이동하여 출력 이미지 시퀀스를 볼 수 있습니다.

출력 창 탐색기

블루프린트에서 사용

무비 렌더 큐 를 사용하여 런타임 빌드에서 무비를 렌더링하고 블루프린트 를 사용하여 사용자 컴퓨터에 파일을 출력할 수 있습니다. 자세한 내용은 런타임 빌드에서 무비 렌더 큐 사용하기 를 참조하세요.

언리얼 엔진의 이전 버전을 위해 작성된 페이지입니다. 현재 언리얼 엔진 5 버전을 위해 업데이트되지 않았습니다.