에디터 Python 스크립팅의 자동 완성 세팅

에디터 Python 스크립팅의 자동 완성 세팅에 관한 짧은 가이드입니다.

전제조건 개발자 모드 활성화

자동 완성을 세팅하기에 앞서 언리얼 엔진(UE) Python 플러그인 이 필요한 스텁을 생성하도록 지시해야 합니다. 그렇게 하려면 에디터 개인설정(Editor Preferences) > 플러그인(Plugins) > Python 에서 개발자 모드(Developer Mode) 에 체크하고 에디터를 재시작합니다. 생성된 스텁 파일의 위치는 [현재 프로젝트 디렉터리]/Intermediate/PythonStub 입니다.

PyCharm

세팅(Settings) 창을 열고 프로젝트(Project) > Python 인터프리터(Python Interpreter) 로 가서 톱니바퀴 아이콘을 클릭한 후 모두 표시(Show all) 를 선택합니다. Python 인터프리터(Python Interpreter) 창에서 경로(Paths) 버튼을 클릭하고 + 표시를 클릭하여 스텁 파일의 위치를 추가합니다.

Python 스텁 파일 경로 추가

또한 Intellisense 파일의 최대 크기를 늘리기 위해 도움말(Help) > 커스텀 프로퍼티 편집(Edit Custom Properties) 으로 가서 다음을 추가해야 합니다.

    idea.max.intellisense.filesize = 25000

PyCharm을 재시작한 후 UE API의 자동 완성 메뉴에서 함수를 볼 수 있습니다.

VSCode

설정(Settings) > 확장(Extension) > Python 으로 이동하여 자동 완성: 추가 경로 (Auto Complete: Extra Paths) 를 찾습니다. 링크를 클릭하여 settings.json 파일을 열고 python.autoComplete.extraPaths 아래에 스텁 파일의 경로를 추가합니다.

Python 자동 완성 경로 세팅

settings.json 파일 내 경로 세팅

Visual Studio Code (VSCode) 를 재시작한 후 UE API의 자동 완성 메뉴에서 함수를 볼 수 있습니다.

스텁 파일은 에디터가 시작될 때마다 재생성됩니다. 결과적으로 새 함수를 Python에 노출하거나 새 플러그인을 활성화한 후 에디터를 재시작하여 스텁 파일을 최신 상태로 유지할 수 있습니다.