머티리얼 에디터 UI

머티리얼 에디터 유저 인터페이스를 분석합니다.

Choose your operating system:

Windows

macOS

Linux

머티리얼 에디터 UI는 메뉴 바, 툴바, 아래와 같은 5가지 메인 영역으로 이루어집니다.

번호

설명

1

메뉴 바

2

툴바

3

뷰포트 패널

4

디테일 패널

5

머티리얼 그래프 패널

6

통계 패널

7

팔레트 패널

  • 어느 패널이든 오른쪽 상단의 작은 'X' 표시를 클릭하여 닫을 수 있습니다. 탭에 우클릭하여 뜨는 컨텍스트 메뉴에서 탭 숨김(Hide Tab) 을 클릭하여 패널을 숨길 수도 있습니다. 닫았던 패널을 다시 불러오려면, 창(Window) 메뉴에서 패널 이름을 클릭하면 됩니다.

  • F1 키를 누르면 언리얼 엔진 머티리얼 문서를 표시합니다.

메뉴 바

머티리얼 에디터 메뉴 바

파일(File)

  • 에셋 열기(Open Asset) - 글로벌 에셋 선택 툴을 열어 빠르게 에셋을 찾아 적합한 에디터를 엽니다.

  • 모두 저장(Save All) - 프로젝트의 미저장 레벨과 에셋을 모두 저장합니다.

  • 저장할 파일 선택(Choose Files to Save) - 프로젝트에서 저장할 레벨과 에셋을 선택할 수 있는 대화 상자를 띄웁니다.

  • 저장(Save) - 현재 작업 중인 에셋을 저장합니다.

  • 다른 이름으로 저장(Save As) - 이 에셋을 다른 이름으로 저장합니다.

편집(Edit)

  • 실행 취소(Undo) - 가장 최근 동작의 실행을 취소합니다.

  • 다시 실행(Redo) - 실행 취소한 동작이 있을 경우 가장 최근에 실행 취소한 동작을 다시 실행합니다.

  • 실행 취소 히스토리(Undo History) - 실행 취소 동작 내역을 표시합니다.

  • 에디터 개인설정(Editor Preferences) - 옵션 목록이 표시됩니다. 각 옵션으로 에디터 개인설정 창에서 언리얼 에디터의 개인설정을 변경할 수 있습니다.

  • 프로젝트 세팅(Project Settings) - 옵션 목록이 표시됩니다. 각 옵션으로 프로젝트 세팅 창에서 언리얼 엔진 프로젝트의 여러 가지 세팅을 변경할 수 있습니다.

  • 플러그인(Plugins) - 플러그인 브라우저 탭을 엽니다.

에셋(Asset)

  • 콘텐츠 브라우저에서 찾기(Find in Content Browser) - 콘텐츠 브라우저(Content Browser) 에서 현재 에셋의 위치를 찾아 선택합니다.

  • 레퍼런스 뷰어(Reference Viewer) - 선택된 에셋의 레퍼런스를 표시하는 레퍼런스 뷰어를 실행합니다.

  • 사이즈 맵(Size Map) - 이 에셋과 거기 참조된 모든 것의 대략 크기를 표시하는 대화식 맵을 표시합니다.

  • 에셋 검사(Audit Assets) - 에셋 검사 UI를 열고, 선택한 에셋 관련 정보를 표시합니다.

  • 셰이더 쿡 통계(Shader Cook Statistics) - 셰이더 쿡 통계 UI를 엽니다.

창(Window)

  • 그래프(Graph) - 그래프 패널 표시를 토글합니다.

  • 뷰포트(Viewport) - 뷰포트 패널 표시를 토글합니다.

  • 디테일(Details) - 디테일 패널 표시를 토글합니다.

  • 팔레트(Palette) - 팔레트 패널 표시를 토글합니다.

  • 찾기 결과(Find Results) - 머티리얼 그래프에서 항목을 검색할 수 있습니다.

  • 프리뷰 씬 세팅(Preview Scene Settings) - 머티리얼 프리뷰 뷰포트 옵션을 변경할 수 있는 탭을 엽니다.

  • 파라미터 디폴트(Parameters) - 머티리얼 글로벌 파라미터 표시를 토글합니다.

  • 커스텀 프리미티브 데이터(Custom Primitive Data) - 커스텀 프리미티브 데이터가 활성화된 현재 머티리얼의 모든 파라미터를 표시하는 탭을 엽니다.

  • 레이어 파라미터(Layer Parameters) - 현재 머티리얼에 추가된 모든 머티리얼 레이어를 표시합니다.

  • 플랫폼 통계(Platform Stats) - 플랫폼별 머티리얼 비용 표시를 토글합니다.

  • 통계(Stats) - 머티리얼 비용을 토글합니다.

  • 셰이더 코드(Shader Code) - 선택된 플랫폼에 대한 머티리얼 HLSL 코드 표시를 토글합니다.

    • HLSL 코드(HLSL Code) - HLSL 코드 표시를 토글합니다.

      • 데스크톱(Desktop) - 다양한 데스크톱 렌더의 HLSL 코드 표시를 토글합니다.

        • DirectX SM5 - Windows SM5HLSL 코드 표시를 토글합니다.

        • DirectX SM6 - Windows SM6HLSL 코드 표시를 토글합니다.

        • DirectX ES 3.1 - ES 3.1HLSL 코드 표시를 토글합니다.

        • Vulkan SM5 - Vulkan SM5HLSL 코드 표시를 토글합니다.

        • Metal SM5 - Metal SM5HLSL 코드 표시를 토글합니다.

        • OpenGL SM4 - OpenGL SM4HLSL 코드 표시를 토글합니다.

      • Android - 다양한 Android 렌더의 HLSL 코드 표시를 토글합니다.

        • Android GLES 3.1 - Android GLES 3.1HLSL 코드 표시를 토글합니다.

        • Android Vulkan - Android VulkanHLSL 코드 표시를 토글합니다.

        • Android Vulkan SM5 - Android Vulkan SM5HLSL 코드 표시를 토글합니다.

      • iOS 다양한 iOS 렌더의 HLSL 코드 표시를 토글합니다.

        • Metal SM5 - MetalHLSL 코드 표시를 토글합니다.

        • Metal MRT - Metal MRTHLSL 코드 표시를 토글합니다.

  • 시네마틱(Cinematics) - 시네마틱 시퀀스 레코더, 테이크 레코더 또는 테이크 브라우저를 새 창에서 엽니다.

  • 콘텐츠 브라우저(Content Browser) - 콘텐츠 브라우저 를 별도의 창에서 엽니다.

  • 버추얼 프로덕션(Virtual Production) - 라이브 링크 스트리밍 매니저 탭을 엽니다.

  • 레이아웃 리셋(Reset Layout) - 레이아웃을 기본 배치로 리셋합니다. 변경 사항을 저장하고 세팅을 백업한 뒤 에디터를 재시작해야 합니다.

  • 레이아웃 저장(Save Layout) - 현재 패널 레이아웃을 새 디폴트 레이아웃으로 저장합니다.

  • 레이아웃 제거(Remove Layout) - 현재 레이아웃을 제거합니다.

  • 전체화면 활성화(Enable Fullscreen) - 앱을 모니터 전체로 확장시키는 전체화면 모드를 활성화합니다.

  • 새로운 C++ 클래스(New C++ Class) - 프로젝트에 C++ 코드를 추가합니다. 이 코드는 Visual Studio를 설치한 경우에만 컴파일할 수 있습니다.

  • Visual Studio 프로젝트 생성(Generate Visual Studio Project) - Visual Studio에서 C++ 코드 프로젝트를 생성합니다.

  • 블루프린트에서 찾기(Find in Blueprints) - 모든 블루프린트에서 함수, 이벤트, 변수로의 레퍼런스를 찾습니다.

  • 캐시 통계(Cache Statistics) - 파생 데이터 캐시에 대한 통계를 표시합니다.

  • 클래스 뷰어(Class Viewer) - 이 프로젝트에 존재하는 모든 클래스를 표시합니다.

  • CSV에서 SVG로(CSV to SVG) - CSV 프로파일에서 생성된, 쉼표로 구분된 값 파일로부터 벡터 선 그래프를 생성하는 툴을 엽니다.

  • 현지화 대시보드(Localization Dashboard) - 이 프로젝트의 현지화 대시보드를 엽니다.

  • 액터 병합(Merge Actors) - 액터 병합 대화창을 엽니다.

  • 프로젝트 런처(Project Launcher) - 프로젝트 런처 탭을 엽니다.

  • 리소스 사용(Resource Usage) - 파생 데이터 리소스 사용 분석을 표시합니다.

  • 세션 프론트엔드(Session Frontend) - 세션 프론트엔드 탭을 엽니다.

  • 구조체 뷰어(Struct Viewer) - 이 프로젝트에 존재하는 모든 구조체를 표시합니다.

  • 가상 에셋(Virtual Assets) - 이 프로젝트 내에 존재하는 모든 가상 에셋에 대한 통계를 표시합니다.

  • 디버그(Debug) - 블루프린트, 콜리전, 나이아가라 등을 위한 디버깅 툴입니다.

  • 프로파일(Profile) - 프로파일 데이터 시각화 툴(Profile Data Visualizer) 또는 트레이스 데이터 필터링(Trace Data Filtering) 탭을 엽니다.

  • 검사(Audit) - 에셋 검사(Asset Audit) 창 또는 머티리얼 분석 툴(Material Analyzer)을 엽니다.

  • 플랫폼(Platforms) - 디바이스 매니저(Device Manager) 또는 디바이스 프로파일(Device Profiles) UI를 엽니다.

  • 소스 컨트롤(Source Control) - 소스 컨트롤에 접속하거나, ChangeList를 보거나, 콘텐츠를 제출합니다.

  • 언리얼 인사이트 실행(Run Unreal Insights) - 언리얼 인사이트 독립형 애플리케이션을 실행합니다.

도움말(Help)

  • 머티리얼 에디터 문서(Material Editor Documentation) - 브라우저 창을 열어 이 툴에 관련된 문서를 탐색합니다.

  • 문서 홈(Documentation Home) - 브라우저 창을 열어 문서 홈페이지를 탐색합니다.

  • 온라인 러닝(Online Learning) - 브라우저 창을 열어 언리얼 온라인 러닝 홈페이지를 탐색합니다.

  • 포럼(Forums) - 언리얼 엔진 포럼으로 이동하여 공지사항 확인 및 다른 개발자와의 토론에 참여합니다. (영문)

  • 앤서허브(Answer HUB) - 질문을 올리고, 기존 답변을 검색하고, 다른 언리얼 엔진 개발자와 지식을 공유하는 앤서허브로 이동합니다. (영문)

  • 지원(Support) - 언리얼 엔진 관련 질문을 할 수 있는 언리얼 개발자 네트워크(UDN) 포럼 페이지를 브라우저 창에 엽니다.

  • 버그 신고하기(Report a Bug) - 브라우저 창을 열어 언리얼 엔진 버그 제출 양식을 탐색합니다.

  • 이슈 트래커(Issue Tracker) - 브라우저 창을 열어 언리얼 엔진 문제 및 해결에 관한 검색가능 데이터베이스를 탐색합니다.

  • 언리얼 에디터에 대하여(About Unreal Editor) - 앱 제작진, 저작권 정보, 빌드 정보를 표시합니다.

  • 크레딧(Credits) - 앱 제작진을 표시합니다.

  • UnrealEngine.com 방문(Visit UnrealEngine.com) - 언리얼 테크놀로지에 대해 더욱 자세히 알아볼 수 있는 UnrealEngine.com으로 이동합니다.

툴바

다음 표는 툴바의 옵션과 역할을 나타냅니다.

아이콘

설명

저장 아이콘

현재 에셋을 저장합니다.

탐색 아이콘

콘텐츠 브라우저에서 현재 에셋을 찾아 선택합니다.

적용 아이콘

머티리얼 에디터에서 원본 머티리얼에 가한 변경사항을 월드에 그 머티리얼이 사용된 곳에 적용합니다.

검색 아이콘

현재 머티리얼에서 표현식과 코멘트를 찾습니다.

홈 아이콘

머티리얼 그래프(Material Graph) 패널에서 메인 머티리얼 노드를 가운데에 배치합니다.

계층구조 아이콘

현재 머티리얼을 부모로 사용하는 모든 머티리얼 인스턴스 목록을 표시합니다.

라이브 업데이트 옵션

머티리얼 에디터 UI에서 실시간으로 업데이트되는 요소를 토글합니다.

그래프 정리 아이콘

머티리얼에 연결되지 않은 모든 머티리얼 노드를 삭제합니다.

상태 미리보기 토글

주어진 피처 레벨, 머티리얼 퀄리티, 스태틱 스위치 값에 대한 그래프 상태를 미리 봅니다.

관련 없는 노드 숨김

선택한 노드와 관련 없는 모든 노드를 숨깁니다.

머티리얼 통계 토글

통계(Stats) 패널에서 머티리얼 통계를 표시하거나 숨깁니다.

플랫폼 통계 토글

멀티 플랫폼용 머티리얼 통계와 컴파일 오류를 표시하는 창을 토글합니다.

뷰포트 패널

머티리얼 에디터 뷰포트 패널

뷰포트 패널에는 현재 편집 중인 머티리얼이 표시됩니다.

다음 표의 옵션을 사용하여 뷰포트 패널을 탐색할 수 있습니다.

동작

설명

좌클릭 드래그

메시를 회전합니다.

가운데 마우스 버튼으로 드래그

패닝합니다.

우클릭 드래그

줌입니다.

L 키를 누른 상태에서 왼쪽 마우스 버튼으로 드래그

라이트 방향을 회전합니다.

뷰포트 프리뷰 메시는 연관된 툴바 컨트롤(뷰포트 우측 하단의 모양 버튼5개)을 사용하여 변경할 수 있습니다. 커스텀 프리뷰 메시를 사용하려면 '콘텐츠 브라우저(Content Browser)'에서 스태틱 메시 액터 를 선택하고 뷰포트에서 벽돌 아이콘을 클릭합니다. 뷰포트 메시는 머티리얼과 함께 저장되므로 다음에 머티리얼 에디터에서 머티리얼을 열었을 때 같은 메시가 표시됩니다.

다음 표는 머티리얼 에디터 프리뷰 뷰포트에서 사용 가능한 옵션을 자세히 설명합니다.

아이콘

설명

프리뷰 메시

프리뷰(Preview) 패널에 각 프리미티브 셰이프에 현재 머티리얼 결과를 표시합니다.

뷰포트 옵션

머티리얼 뷰포트 옵션 을 토글합니다.

뷰포트 유형

사용되는 뷰포트 유형을 변경합니다.

뷰포트 라이팅

뷰포트 에서 사용하는 라이팅 유형을 변경합니다.

뷰포트 표시 옵션

머티리얼 뷰포트에 부가 옵션을 활성화합니다.

디테일 패널

디테일 패널

이 패널에는 현재 선택된 모든 머티리얼 표현식과 함수 노드에 대한 프로퍼티 창이 있습니다. 노드를 선택하지 않으면 머티리얼의 베이스 프로퍼티가 표시됩니다.

모든 머티리얼 프로퍼티에 대한 설명은 머티리얼 프로퍼티 문서를 참조하세요.

머티리얼 그래프 패널

머티리얼 그래프

이 패널에는 이 머티리얼에 속한 모든 머티리얼 표현식의 그래프가 포함되어 있습니다. 기본적으로 각 머티리얼에는 하나의 베이스 머티리얼 노드가 있습니다. 이 노드에 있는 여러 개의 입력 각각은 머티리얼의 여러 부분에 연관되어 있어, 다른 머티리얼 노드를 연결할 수 있습니다.

MaterialEditor_MaterialNode.png

메인 머티리얼 노드의 다양한 입력에 대한 설명은 머티리얼 입력 문서를 참조하세요.

팔레트 패널

머티리얼 에디터 팔레트

팔레트(Palette) 패널에는 모든 머티리얼 노드의 분류된 목록이 있으며, 노드를 드래그하여 머티리얼에 놓을 수 있습니다. 새 머티리얼 노드를 배치하려면 '팔레트(Palette)'에서 드래그하여 머티리얼 그래프(Material Graph) 패널에 놓으면 됩니다.

팔레트는 기본적으로 숨겨져 있습니다. 팔레트를 표시하려면 머티리얼 에디터 오른쪽 상단에서 팔레트(Palette) 탭을 클릭합니다. 작업하는 동안 팔레트를 계속 표시하고 싶다면 아이콘을 클릭합니다.

머티리얼 팔레트 열기

카테고리(Category) 드롭다운 목록에서 표현식(Expressions) 또는 함수(Functions) 를 선택하여 팔레트(Palette) 패널에 나열된 머티리얼 노드에 필터를 적용할 수 있습니다.

머티리얼 함수에 대한 추가 정보는 머티리얼 함수 문서를 참조하세요.

통계 패널

통계 패널

컴파일러 오류는 물론 머티리얼에 사용되는 셰이더 인스트럭션 수도 이 패널에 표시됩니다. 인스트럭션 수가 적을수록 머티리얼 비용이 낮습니다. 머티리얼 표현식 노드는 베이스 머티리얼 노드에 연결되지 않으면 머티리얼의 인스트럭션 수(비용)에 영향을 끼치지 않습니다.

HLSL 코드 패널

HLSL 코드 패널

이 패널에는 현재 머티리얼로 인해 생성된 고급 셰이딩 언어 (High Level Shading Language, HLSL) 코드가 표시됩니다. 이 패널은 에디터가 아니므로 HLSL 코드를 변경할 수 없다는 점에 유의하세요. HLSL 코드 패널은 머티리얼 네트워크로 정의된 코드를 시각화해 보여주는 뷰어에 불과합니다.

코드 뷰(Code View) 패널은 기본적으로 표시되지 않습니다. 코드 뷰 패널을 표시하려면 창(Window) 메뉴를 열어 HLSL 코드(HLSL Code) 를 클릭합니다.

플랫폼 통계

플랫폼 통계(Platform Stats) 아이콘을 클릭하면 다양한 플랫폼에서의 머티리얼 비용을 확인할 수 있습니다.

플랫폼 통계

세팅(Settings) 옵션을 클릭하고 통계를 확인하고 싶은 렌더러를 선택하면 언리얼 엔진에서 지원하는 각 렌더링 API에 대한 통계를 확인할 수 있습니다.

플랫폼 통계 세팅

Android 통계를 확인하려면 먼저 Mali Offline Compiler 를 설치해야 합니다. 설치 방법은 다음과 같습니다.

  1. Mali Offline Compiler를 다운로드하여 설치합니다.

  2. Mali Offline Compiler를 설치한 후, 메뉴 바에서 편집(Edit) > 에디터 개인설정(Editor Preferences) 으로 이동합니다.

    에디터 개인설정

  3. 콘텐츠 에디터(Content Editors) 에서 머티리얼 에디터(Material Editor) 를 선택합니다.

    머티리얼 에디터 개인설정

  4. Mali Offline Compiler 옵션 오른쪽의 점 3개 를 클릭한 다음 Mali Offline Compiler와 함께 설치된 malisc.exe 파일을 찾아 선택합니다. 기본 파일 경로는 아래와 같습니다.

    Mali 컴파일러

  5. 위 단계들을 완료하면 언리얼 엔진에서 지원하는 다양한 Android 렌더러에서의 통계를 확인할 수 있습니다.

    Android 플랫폼 통계

Mali Offline Compiler를 설치하지 않으면 Android 플랫폼 통계를 확인할 수 없습니다.

그래프 컨트롤

머티리얼 에디터의 컨트롤은 일반적으로 언리얼 에디터 내 다른 툴의 컨트롤과 일치합니다. 예를 들어, 머티리얼 표현식 그래프는 다른 노드 기반 오브젝트 에디터(블루프린트)와 같은 방식으로 탐색할 수 있으며, 머티리얼 프리뷰 메시는 다른 메시 툴과 마찬가지로 방향 설정이 가능합니다.

마우스 컨트롤

컨트롤

동작

배경에 우클릭 드래그

머티리얼 표현식 그래프 패닝입니다.

배경에 좌클릭 드래그

범위를 선택합니다.

마우스 휠 굴리기

줌 인/아웃을 실행합니다.

좌클릭 + 우클릭 드래그

줌 인/아웃을 실행합니다.

오브젝트에 좌클릭

표현식/코멘트를 선택합니다.

오브젝트에 Ctrl + 좌클릭

표현식/코멘트 선택을 토글합니다.

좌클릭 + 드래그

현재 선택/코멘트를 이동합니다.

Ctrl + 좌클릭 드래그

범위를 선택합니다. (현재 선택에 추가)

핀에 좌클릭 드래그

연결합니다. (핀에 드롭)

핀에서 Ctrl + 좌클릭 드래그

연결을 이동합니다. (동일 유형 핀에 드롭)

핀에 Shift + 좌클릭 1번

핀을 마킹합니다. 핀 하나가 마킹된 상태에서 다른 핀에 다시 이 동작을 하면 두 핀이 연결됩니다. 거리가 멀리 떨어진 핀끼리 연결하는 데 좋은 방법입니다.

배경에 우클릭

새로운 표현식(New Expression) 메뉴를 띄웁니다.

오브젝트에 우클릭

오브젝트(Object) 메뉴를 띄웁니다.

핀에 우클릭

오브젝트(Object) 메뉴를 띄웁니다.

핀에 Alt + 좌클릭

핀으로의 모든 연결을 끊습니다.

핀에 Ctrl + 좌클릭

핀에 새로운 노드를 추가합니다.

키보드 컨트롤

컨트롤

동작

Ctrl + B

콘텐츠 브라우저에서 찾습니다.

Ctrl + C

선택된 표현식을 복사합니다.

Ctrl + S

머티리얼을 저장합니다.

Ctrl + V

붙여넣습니다.

Ctrl + D

선택된 오브젝트를 복제합니다.

Ctrl + Y

다시 실행합니다.

Ctrl + Z

실행 취소합니다.

Delete

선택된 오브젝트를 삭제합니다.

스페이스 바

모든 머티리얼 표현식 미리보기를 강제 업데이트합니다.

Enter

(클릭 적용과 동일)

단축키

자주 사용되는 머티리얼 표현식 유형을 단축키에 배치할 수 있습니다. 단축키를 누른 상태로 좌클릭 하면 노드가 배치됩니다. 단축키는 다음과 같습니다.

단축키

표현식

A

Add

B

BumpOffset

C

Comment

D

Divide

E

Power

F

MaterialFunctionCall

I

If

L

LinearInterpolate

M

Multiply

N

Normalize

O

OneMinus

P

Panner

R

ReflectionVector

S

ScalarParameter

T

TextureSample

U

TexCoord

V

VectorParameter

1

Constant

2

Constant2Vector

3

Constant3Vector

4

Constant4Vector

Shift + C

ComponentMask