Rhino

데이터스미스를 사용하여 McNeel Rhinoceros 3D 씬을 언리얼 에디터에 임포트할 때 적용되는 특별히 고려해야 하는 사항에 대해 설명합니다.

이 페이지에서는 데이터스미스(Datasmith) 를 사용하여 McNeel Rhinoceros(Rhino) 에서 언리얼 엔진으로 씬을 임포트하는 방법에 대해 설명합니다. 이 설명은 데이터스미스 개요데이터스미스 임포트 프로세스에 나와 있는 기본적인 프로세스를 따르지만, Rhino에 한정되는 특수한 변환 동작이 일부 추가됩니다. 데이터스미스를 사용하여 Rhino에서 언리얼 에디터로 씬을 임포트할 계획인 경우, 이 페이지는 씬이 변환되는 방식과 언리얼 에디터에서 해당 결과물을 사용하여 작업하는 방법을 이해하는 데 도움이 될 수 있습니다.

Rhino 워크플로

익스포트 워크플로

데이터스미스는 Rhino용 익스포트 워크플로를 사용합니다. 즉, 데이터스미스를 사용하여 Rhino 콘텐츠를 언리얼 엔진으로 옮기려면 다음 작업을 수행해야 합니다.

  1. Rhino용 데이터스미스 익스포터 플러그인을 설치합니다. 자세한 내용은 아래의 설치 노트 를 참고하세요.

  2. '다른 이름으로 저장(Save As)' 또는 '익스포트(Export)' 프로세스를 사용하여 Rhino 콘텐츠를 익스포트합니다. 자세한 내용은 Rhino에서 데이터스미스 콘텐츠 익스포트 페이지를 참고하세요.

  3. 언리얼 에디터 툴바에 있는 데이터스미스 임포터를 사용하여 .udatasmith 파일을 임포트합니다. 자세한 내용은

    [](working-with-content/datasmith/tutorial/importing-content/)
    페이지를 참고하세요.

다이렉트 링크 워크플로

언리얼 엔진에서 Rhino 씬의 변경 사항을 실시간으로 프리뷰하기 위해 둘 사이에 데이터스미스 다이렉트 링크를 구성할 수 있습니다. 이렇게 하면 변경 사항이 발생할 할 때마다 전체 씬을 언리얼 엔진에 다시 임포트할 필요가 없습니다. 자세한 내용은

[](working-with-content/datasmith/tutorial/using-datasmith-directlink/)
페이지를 참고하세요.

데이터스미스 툴바 사용

데이터스미스 플러그인을 설치하면 Rhino에 도킹 가능한 툴바가 추가됩니다.

데이터스미스 툴바

Rhino의 데이터스미스 툴바

Rhino의 명령줄에 관련된 명령을 입력하여 동일한 연산을 트리거할 수 있습니다.

데이터스미스 명령을 모두 보려면 명령줄에서 'PlugInManager'를 실행하여 Rhino에서 플러그인 매니저(Plugin Manager) 창을 열고 데이터스미스 익스포터(Datasmith Exporter) 플러그인을 선택합니다.

버튼

설명

명령줄

동기화(Synchronize)

선택한 모델을 다이렉트 링크 연결을 통해 푸시합니다.

씬의 모든 것을 빠르게 선택하려면 Ctrl+A (Windows) 또는 Cmd+A (Mac)를 누릅니다.

DatasmithDirectLinkSync

연결(Connections)

'연결 상태(Connection Status)' 대화창을 실행합니다.

DatasmithDirectLinkConnections

3D 뷰 익스포트(Export 3D View)

기존 .udatasmith 익스포터를 실행하여 .udatasmith 파일을 디스크에 저장합니다.

DatasmithExport

메시지(Messages)

메시지 및 로깅 창을 실행합니다. 오류, 누락된 텍스처, 기타 정보를 보고하는 데 유용합니다.

DatasmithMessages

플러그인을 설치하면 Rhino가 데이터스미스 툴바를 인터페이스에 추가합니다. 플러그인을 삭제하면 이 툴바는 자동으로 제거됩니다. 옵션(Options) 메뉴의 툴바 섹션에서 드래그하여 디폴트 툴바에 추가한 데이터스미스 툴바 사본은 삭제 프로세스로 제거되지 않으며 수동으로 제거해야 합니다.

설치 노트

데이터스미스 익스포트 플러그인 페이지에서 Rhino용 데이터스미스 익스포터(Datasmith Exporter for Rhino) 플러그인을 다운로드하여 설치해야 Rhino 콘텐츠를 익스포트할 수 있습니다.

플러그인이 지원하는 Rhino 버전을 확인하려면 데이터스미스 지원 소프트웨어 및 파일 타입 페이지를 참고하세요.

데이터스미스 익스포트 플러그인 다운로드 링크는 조직 내외부에 제한 없이 공유할 수 있습니다. 하지만 데이터스미스 익스포트 플러그인 자체를 배포하는 것은 허용되지 않습니다.

Rhino 플러그인용 데이터스미스 익스포터를 설치하기 전에 다음 사항을 확인합니다.

  • Rhino가 실행 중이 아니어야 합니다.

  • 사용하려는 언리얼 엔진 버전에 맞는 익스포터 플러그인용 인스톨러를 다운로드해야 합니다.

  • Rhino 플러그인용 데이터스미스 익스포터의 이전 버전을 먼저 모두 삭제해야 합니다.

인스톨러를 다운로드한 후 더블클릭하여 연 다음에 화면의 지시 사항을 따릅니다.

Rhino 플러그인용 데이터스미스 익스포터를 제거해야 하는 경우 다른 애플리케이션과 같이 다음 단계를 따릅니다.

  • Windows: 제어판(Control Panel) 에서 플러그인을 삭제합니다.

  • macOS: 파인더(Finder) 에서 플러그인을 찾아 도크의 휴지통 아이콘으로 드래그하거나 우클릭 후 휴지통으로 이동(Move to Trash) 을 선택합니다.

지오메트리를 스태틱 메시로 변환

데이터스미스는 Rhino 파일에 각 메시, 입체, 표면별로 개별 스태틱 메시 에셋을 생성합니다. 아래 이미지의 왼쪽에서와 같이 Rhino의 프로퍼티(Properties) 패널에 오브젝트의 이름(Name) 프로퍼티가 설정되어 있는 경우 데이터스미스는 아래 이미지의 오른쪽에서와 같이 해당 이름을 스태틱 메시 에셋에 사용합니다. 데이터스미스가 레벨에 생성하는 액터 중 해당 스태틱 메시 에셋을 참조하는 액터는 모두 이 이름을 동일하게 사용합니다.

인스턴싱

데이터스미스가 Rhino 씬에서 동일한 블록의 인스턴스를 여러 개 감지할 경우, 해당 블록의 지오메트리에 대해서는 하나의 스태틱 메시 에셋 세트만 생성합니다. 그런 다음 해당 스태틱 메시의 인스턴스 다수를 씬에 배치합니다. 보통 프로젝트의 런타임 메모리 요구사항과 퍼포먼스 측면에서 더 좋을 뿐만 아니라 콘텐츠 브라우저(Content Browser) 에서 스태틱 메시 수를 관리하기도 더 쉬워집니다.

가능하다면 씬에서 반복적으로 사용되는 창, 문, 의자 같은 요소는 Rhino에서 블록으로 만들어 이러한 이점을 활용하는 것이 권장됩니다.

자세한 내용은 Rhino 문서를 참고하세요.

테셀레이션 및 렌더 메시

언리얼 엔진은 항상 트라이앵글 메시를 사용하여 오브젝트를 렌더링합니다. Rhino 파일에 파라메트릭 표면이나 NURBS로 정의된 오브젝트가 있는 경우, 이러한 표면은 트라이앵글 메시로 트랜스폼 또는 테셀레이트해야 합니다. 데이터스미스는 파일(File) > 문서 프로퍼티(Document Properties) | 메시(Mesh) 에 있는 Rhino 테셀레이션 옵션을 활용합니다.

이름

설명

매끄럽지 않지만 빠름(Jagged and Faster)

퀄리티를 일부 희생하여 오브젝트를 빠르게 셰이딩하는 낮은 밀도의 메시를 생성합니다.

매끄럽지만 느림(Smoother and Slower)

속도를 일부 희생하여 오브젝트를 보다 정확하게 셰이딩하는 높은 밀도의 메시를 생성합니다.

커스텀(Custom)

생성된 메시를 보다 세부적으로 제어합니다. 밀도 슬라이더는 NURBS 표면에서 생성된 폴리곤의 밀도와 수를 대략적으로 제어합니다. 세부 제어(Detailed controls) 버튼을 클릭하여 추가적인 사항을 제어할 수 있습니다.

Rhino에서 커스텀 렌더 옵션을 사용하는 방법에 대한 자세한 내용은 Rhino 문서에서 폴리곤 메시 세부 옵션을 참고하세요.

메시 모디파이어

Rhino는 메시를 직접 편집하지 않고 메시의 외형을 변경할 수 있는 몇 가지 방법을 지원합니다.

데이터스미스를 사용하여 Rhino에서 데이터를 익스포트할 때 다음의 메시 모디파이어가 보존됩니다.

트라이앵글이 향하는 방향

데이터스미스로 익스포트될 때 표면은 오리엔테이션을 유지합니다. Rhino에서는 후면을 밝은 녹색으로 설정하는 방식으로 표면의 오리엔테이션을 시각화합니다. 이렇게 하려면 문서 프로퍼티 를 실행하여 보기(View) > 디스플레이 모드(Display Modes) > 렌더링됨(Rendered) 을 선택합니다. 해당 메뉴의 셰이딩 세팅(Shading Settings) 에서 후면 세팅(Backface settings) 옵션이 나타납니다. 마지막으로, 모든 후면에 대해 단일 컬러 사용(Single color for all backfaces) 컬러를 밝은 녹색으로 바꿉니다.

데이터스미스로 익스포트하기 전에 이런 방식을 통해 오리엔트가 향하는 방향이 정확한지 확인할 수 있습니다:

뒤를 향한 모습

앞을 향한 모습

이 주제에 대한 자세한 내용과 권장 솔루션은 데이터스미스 임포트 프로세스 페이지를 참고하세요.

Rhino 머티리얼

데이터스미스는 Rhino 씬에서 찾은 서로 다른 각 표면 머티리얼마다 언리얼 엔진에서 동일한 이름을 사용하여 개별

[머티리얼 에셋](RenderingAndGraphics/Materials)
을 생성합니다. 그런 다음 각 머티리얼은 데이터스미스 씬 에셋 옆의 Materials 폴더에 배치됩니다.

  • Materials 폴더의 각 머티리얼은 Rhino 파일에서 설정된 프로퍼티를 노출하는

    [머티리얼 인스턴스](RenderingAndGraphics/Materials/MaterialInstances)
    입니다. 여기에는 컬러 값, 텍스처 맵 등이 있습니다. 이렇게 노출된 프로퍼티를 변경하여 머티리얼이 표면에 적용되었을 때 표시되는 방식을 수정할 수도 있습니다. 데이터스미스는 이러한 머티리얼 에셋을 스태틱 메시 에셋에 할당하여 Rhino 렌더러에 표시된 것과 동일한 방식으로 표면에 셰이딩을 생성합니다. 데이터스미스는 Rhino 오브젝트의 머티리얼만 언리얼 엔진으로 임포트합니다. Rhino 디스플레이 컬러는 완전히 무시합니다. 이는 언리얼 엔진으로 임포트한 내용의 시각적 결과를 Rhino의 렌더링 결과와 최대한 유사하게 만듭니다.

  • 데이터스미스는 Materials/Master 폴더에 부모 머티리얼 세트도 생성합니다. 이들 각각은 '머티리얼' 폴더에 있는 최소 하나 이상의 머티리얼 에셋에 대한 부모입니다. 머티리얼 그래프를 보다 세부적으로 제어하여 표면의 표시 방식을 정의하거나, 추가적인 파라미터를 자손 인스턴스에 노출하거나, 노출된 파라미터가 렌더링 동안 참조되는 방식을 변경하고 싶은 경우에는 이러한 부모 머티리얼을 편집할 수 있습니다. 부모 머티리얼을 변경할 경우 해당 부모로부터 상속을 받는 모든 머티리얼 인스턴스도 자동으로 변경된다는 점에 유의해 주세요. 부모 머티리얼을 수정하기 전에 먼저 복제하고, 복제본을 변경한 다음에 최종적으로 특정 머티리얼 인스턴스가 새 복제본을 부모로 사용하도록 업데이트하는 것이 좋습니다. 자세한 내용은

    [데이터스미스 마스터 머티리얼 수정](WorkingWithContent/Importing/Datasmith/HowTo/ModifyDSParentMaterial)
    을 참고하세요.

명명된 뷰

Rhino의 명명된 뷰(Named Views) 는 언리얼 엔진의 카메라와 같습니다. 데이터스미스를 통해 언리얼 엔진으로 임포트할 때 각 명명된 뷰는 씬에서 별도의 CineCameraActor 가 됩니다.

Rhino 메타데이터

어트리뷰트 사용자 텍스트(Attribute User Text) 메뉴에서 입력한 데이터는 데이터스미스 메타데이터로 익스포트됩니다.

데이터는 키/값 짝으로 테이블에 입력됩니다. '어트리뷰트 사용자 텍스트'를 활용하는 방법에 대한 자세한 내용은 Rhino 문서에서 Attribute User Text를 참고하세요.

데이터스미스 씬 계층구조 생성

데이터스미스는 Rhino 모델에서 씬 계층구조를 다음과 같이 빌드합니다.

  • 데이터스미스는 Rhino 씬의 각 레이어마다 해당 레이어의 모든 오브젝트에 대한 부모 역할을 하는 액터를 언리얼 엔진에 하나씩 생성합니다. 언리얼 에디터의 '레이어(Layers)' 패널에서 생성되는 레이어와 달리, 이 액터의 계층구조는 평탄화되지 않습니다. 이 액터들은 Rhino 씬의 레이어와 정확히 똑같이 중첩됩니다.

  • 각 레이어를 나타내는 액터 아래에서 해당 레이어의 모든 인스턴스드 블록은 다른 액터로 나타납니다.

  • 마지막으로, 각 레이어와 블록을 나타내는 액터는 해당 레이어 또는 블록을 구성하는 실제 지오메트리 오브젝트를 나타내는 스태틱 메시 액터를 포함합니다. Rhino의 포인트는 언리얼 엔진에서 기본 액터로 나타납니다. 이를 통해 해당 포인트가 원래 그대로 유지됩니다.

  • Rhino의 그룹은 언리얼 엔진의 씬 계층구조에 영향을 주지 않으며, 이는 씬 계층구조에서 중요한 요소가 아닌 선택을 도와주는 요소로만 간주되기 때문입니다.

예를 들어 아래 이미지에서 Rhino 계층구조의 모든 레이어에 대응하는 액터를 언리얼 에디터에서도 가지고 있음을 알 수 있습니다. '라이트(lights) > 턴 시그널(turn signal)'처럼 Rhino에서 지오메트리 오브젝트만 포함하는 레이어의 경우, 언리얼 에디터에서는 이에 대응하는 스태틱 메시 액터만 포함합니다. Rhino의 '라이트' 레이어는 또한 두 개의 블록 인스턴스를 포함하며, 각각 'left_headlight'와 'right_headlight'로 명명됩니다. 언리얼 에디터에서는 2개 모두가 중첩된 액터로 나타나며, 해당 블록을 구성하는 지오메트리 오브젝트를 포함합니다.

이 페이지에 사용된 모델은 Turbosquid 사용자 tomashorin.design이 제공해 주셨습니다.

언리얼 엔진의 이전 버전을 위해 작성된 페이지입니다. 현재 언리얼 엔진 5 버전을 위해 업데이트되지 않았습니다.