欢迎使用虚幻引擎5抢先体验版

了解虚幻引擎5抢先体验版有哪些值得期待的内容。

Windows
MacOS
Linux

虚幻引擎5 是虚幻引擎的一个重要里程碑,是我们专为次世代的游戏、实时可视化项目以及沉浸式交互体验做的精心准备。它将赋予各行业开发者前所未有的自由度、真实度和灵活性,帮助他们开发出各种次世代实时3D内容和体验。

UE5抢先体验版 让你有机会一睹UE5的最新面貌,了解它包含了哪些跨世代的创新工具。抢先体验版是我们专为那些喜欢尝鲜的游戏开发者准备的。我们很高兴能提前与大家分享UE5的新功能,因为这能让你更好地规划未来项目,并向我们提供你们的宝贵反馈。

不过,抢先体验版还无法用于正式项目。我们建议只把它用来测试新功能,探索新系统,或者用于为次世代游戏制作原型。就抢先体验版而言,我们重点希望的是与大家分享新功能,并同时不断开展优化工作和平台支持。

我们不建议将抢先体验版用于正式项目开发。

抢先体验版适合你吗?

如果以下大部分情况你都符合,则不妨考虑尝试下UE5抢先体验版。

  • 你正在开发游戏或其他类似的交互体验。

    UE5抢先体验版的目的是让游戏工作室尽快获得颠覆性的新技术,帮助他们设计次世代项目的原型。然而,UE5 抢先体验版中的新功能还没有在其他类型的工作流程中获得客户的广泛验证。

  • 你拥有大量UE4开发经验。

    熟悉UE4的用户应该会觉得过渡到UE5会相对轻松。UE5抢先体验版发布的同时会发布 遗迹峡谷(Valley of the Ancient) 项目示例项目,其中展示了大量引人注目的新功能。不过,除了这个项目,相比UE4现有的学习资源,抢先体验版的学习资源还是比较有限的。另外,抢先体验版中的功能和工作流程会随着时间不断调整,因此我们建议虚幻初学者还是先学习UE4直到UE5可用于正式项目。

  • 你计划在2022年底或更晚时间发布项目。

    抢先体验版的主要目的是让游戏团队在正式使用UE5前,率先体验各种新功能和工作流程。这有助于你的团队在UE5正式版发布后进行平稳过渡。如果你计划在2021年或2022年年初发布项目,我们强烈建议你继续在UE4的基础上开发,因为它更加稳定且久经考验。

  • 你不介意遇到各种疑难杂症。

    UE5抢先体验版会涉及大量的频繁变动。抢先体验版的功能在能够用于实际开发前,还需要在性能、稳定性和优化方面做大量工作。如果你的目标积累新功能和工作流程方面的经验,以便为今后的项目做准备,这点不应该不会你的障碍。但是我们希望你能明白,使用UE5 抢先体验版中的过程中可能会遇到一些不可预测的问题。不过好消息是,你可以通过提交反馈来帮助我们改善这些疑难杂症。

如果上面的大部分情况或所有情况都 符合你的情况,例如你刚开始接触虚幻引擎,或者你计划近期发布项目,或者你需要一个稳定的、可用于正式项目的引擎,我们建议你先使用UE4,尽管我们欢迎你尝试抢先体验版。

关于抢先体验版的其他信息,请参阅主页

关于UE5抢先体验版的文档

本网站中的资料旨在为你介绍抢先体验版中的大致内容,并通过提供详细资料帮助你了解那些最为重要的新功能,以便你能够自行尝试。

如需查阅虚幻引擎的已有信息和功能细节,最佳资料仍然是UE4文档

你可以使用页面左上方的下拉菜单在UE4和UE5文档之间进行切换。

获得UE5抢先体验版

对于大多数人来说,有两种办法可以获取UE5抢先体验版:

如果你已经是一个可以访问Epic Games Perforce仓库的许可证持有者,你可以从那里获得源代码代替。

从启动程序获取UE5抢先体验版

获取UE5抢先体验版的最简单方法是通过Epic Games启动程序。

  • 如果你想下载预先编译好的二进制文件,以便立即使用,请使用此方法。

  • 没有必要预计Epic会对预编译的二进制文件进行频繁重大更新。Epic有可能会定期发布热更新或其他更新内容,但我们不会在UE5正式版发布前大幅扩充抢先体验版的功能。

通过启动程序下载UE5抢先体验版:

  1. 下载并安装Epic Games启动程序

  2. 运行启动程序并用你的Epic账户登录。

  3. 在左侧菜单中点击 虚幻引擎 部分。

  4. 找到 虚幻引擎5抢先体验版(Unreal Engine 5 Early Access) 标签。

  5. 参照链接 下载抢先体验版

从GitHub获取UE5抢先体验版

你可以从GitHub下载UE5抢先体验版的源代码。

  • 如果你想自己对引擎源码进行修改,或者你想在UE5正式版发布前随时获得虚幻引擎开发团队的最新提交内容,请使用此方法。

  • 但是,你需要自己编译源代码来生成引擎。

为虚幻引擎使用GitHub的基本原理与4.x版本相同。有关详细信息,请参见最新的UE4文档

就抢先体验版而言,请同步以下分支中的一个:

  • ue5-early-access - 此分支包含的代码与启动程序中预编译二进制文件所用的源码相同。如果你希望使用稳定的、经过QA测试的UE5新功能,请使用该分支。随着时间推移,我们可能会对此分支中的内容进行升级和改进。

  • ue5-main - 此分支是UE5的开发主分支。在UE5抢先体验版过渡到最终正式版的过程中,如果你希望获得Epic工程师提交的UE5最新内容,请使用该分支。不过请注意,这个分支的稳定性会差一些。

获取源代码后,编译UE5抢先体验版的方法与UE4完全相同。详情请见最新的UE4文档。唯一的区别是Visual Studio 2015和2017不再被支持。你必须使用Visual Studio 2019(v16.4或更高版本)。

从Perforce获取UE5抢先体验版

如果你是签订了许可的用户,可以访问Epic Games的Perforce仓库,你可以用以下方式获得源代码:

  • /UE5/Release-5.0-EarlyAccess - 此分支包含的代码与启动程序中的预编译二进制文件所用的源码相同。如果你希望使用的UE5新功能足够稳定并且经过QA测试,请使用此分支。随着时间推移,我们可能会对此分支中的内容进行升级和改进。

  • //UE5/Main - 此分支是UE5的开发主分支。在UE5抢先体验版过渡到最终正式版的过程中,如果你希望获得Epic工程师提交的UE5最新内容,请使用该分支。不过请注意,这个分支的稳定性会差一些。

获取源代码后,编译UE5抢先体验版的方法与UE4完全相同。详情请见最新的UE4文档。唯一的区别是Visual Studio 2015和2017不再被支持。你必须使用Visual Studio 2019(v16.4或更高版本)。

兼容性

UE5抢先体验版是一个全新的独立开发路径,它会与即将发布的4.27版本同时存在。它应该能与之前发布的4.x版本兼容,但不保证与未来的4.x版本兼容。

抢先体验版兼容性

一般准则:

  • 你应该能把基于UE4.26或更早版本的项目升级到UE5抢先体验版。除了迁移指南中列出的限制情况和无法升级的部分外,你的现有内容应该可以平稳升级。

  • UE4.27发布后,请勿预计你在4.27中创建的项目或你升级到4.27的项目能在UE5抢先体验版中工作。

  • UE5.0正式版将兼容UE4.27以及UE5抢先体验版的内容。

  • 请勿期待UE5项目能降级到UE4。

目标平台和设备

UE5抢先体验版支持UE4所支持的所有目标平台和设备,但有以下例外:

  • 对32位平台的支持已去除。

  • UE5抢先体验版现在能够支持Apple Silicon设备作为本地运行时目标。(但请注意,虚幻编辑器会通过Rosetta 2的转译运行)。

  • 不是所有平台目前都支持全部的新功能。例如,Lumen和Nanite目前不支持移动设备或上一代主机;它们需要PC平台使用NVIDIA或AMD的显卡。在抢先体验版过渡到UE5正式版的过程中,相关的平台支持和显卡要求可能会有所变化,也可能不变。

    有关目前平台限制的更多信息,请参见版本说明以及各功能的具体文档。

    如需查看哪些系统受到支持,以及各种目标平台的和SDK版本要求,请参阅版本说明中的平台SDK升级

开发相关的硬件要求

就基础硬件要求而言,虚幻引擎5抢先体验版与UE4没有变化。详情请参阅最新的UE4文档

不过,抢先体验版中的某些新功能只有在高端硬件的支持下才能获得最佳效果。

例如,为了发挥Nanite和Lumen的最大效果,我们目前建议至少使用 NVIDIA GTX 1080或AMD VEGA 64 级别的设备。我们还建议升级到最新的显卡驱动程序。

我们正持续改进性能和品质,并针对更多配置进行测试。因此,在抢先体验版期间,我们的建议可能视情况而改变,并可能在正式版发布时改变。

提供反馈以及获取帮助

发布UE5抢先体验版的目标之一是提供一个渠道,以便我们能与社区用户围绕新功能以及未来方向进行探讨。听取这些早期反馈对于虚幻引擎开发团队提升工作来说非常宝贵。

我们期待你的反馈,无论好坏,因为这能帮助我们更好地工作。

  • 如需参与产品特性、功能设计和未来计划相关的讨论,请访问我们的社区论坛

  • 你可以使用我们的公开问题追踪工具来报告经证实的错误。

欢迎帮助改进虚幻引擎文档!请告诉我们该如何更好地为您服务。
填写问卷调查
取消