开发要求

介绍Android开发要求,包括兼容的硬件、软件和SDK信息。

Choose your operating system:

Windows

macOS

Linux

本页包含了为Android设备开发**虚幻引擎(UE)**项目所需的软件开发工具包(SDK)要求,以及当前版本UE的兼容硬件。

当前开发要求

当前SDK信息

  • 当前UE版本:5.0

    • Android Studio版本:4.0

    • 最低SDK版本:23

    • Android文件服务器版本要求:SDK 26

    • NDK版本:r21e

当前兼容的设备

UE5.0支持满足以下硬件规格的Android设备。

  • Android 8或更高版本

  • 64位Arm CPU

  • 兼容的GPU

    • Mali T8xx、G71、G72、G76、G77、G78和G710系列

    • Adreno 5xx、6xx或7xx系列

    • PowerVR GM9xxx

    • Xclipse 920

  • 兼容的图形API

    • OpenGL ES 3.2

    • Vulkan(需要安装Android 10或更高版本的设备,以及兼容的驱动程序)

版本历史

UE版本

Android Studio版本

最低Android SDK版本

Android NDK版本

备注

5.0

Android Studio 4.0

SDK 23

NDK r21e

使用Android文件服务器(AFS)所需的最低SDK版本是26。