倒回调试器

通过倒回调试器,你可以录制项目的实时片段并保留数据用于调试工作流程。

Choose your operating system:

Windows

macOS

Linux

通过 倒回调试器(Rewind Debugger) ,你可以在运行时期间录制项目的片段,并倒回模拟来观察有关动画行为和互动的信息。倒回调试器以 动画洞察(Animation Insights) 为基础构建,提供了全新的视觉接口来调试虚幻引擎中的动画内容。

先决条件

  • 启用 动画洞察(Animation Insights) 插件。在 菜单栏 中找到 编辑(Edit)> 插件(Plugins) 并找到 动画(Animation) 分段中的 动画洞察(Animation Insights) ,或使用 搜索栏 。启用插件并重启编辑器。

动画洞察插件

概述

在虚幻引擎中创建项目时,可能很难在运行时期间调试项目。通过倒回调试器,你可以在运行时期间录制项目的片段,然后在录制内容中向后推移,在功能更齐备、更稳定的工作环境中调试动画内容。倒回调试器提供了有关动画变量、阈值、触发器、通知等的信息。在录制的片段中推移时,会在倒回调试器 细节(Details) 面板中填充带有上下文的信息。

倒回调试器的演示

要打开倒回调试器(Rewind Debugger)窗口,在 菜单栏 中找到 工具(Tools) > 调试(Debug) > 倒回调试器(Rewind Debugger)

在菜单栏中依次找到工具和调试,然后选择倒回调试器来打开倒回调试器

接口

倒回调试器(Rewind Debugger)窗口填充了独特的接口,供你在导航录制的动画时使用。

带有高亮显示区域的倒回调试器窗口

功能

图像

说明

1.项目模拟功能按钮(Project Simulation Controls)

项目模拟功能按钮播放暂停停止弹出

使用播放、暂停和停止等功能控制项目的模拟。如需了解更多信息,请参阅虚幻编辑器接口文档。

2.倒回调试器菜单(Rewind Debugger Menu)

包含可用数据选项卡的摄像机模式和视图选项的倒回调试器菜单

让你控制摄像机行为并切换哪些选项卡可见。摄像机模式(Camera Modes) 如下所示:

禁用(Disabled) 将禁用摄像机移动,使摄像机不绑缚游戏对象。

跟随目标Actor(Follow Target Actor) 会将摄像机锁定到预定位置中的所选对象。你可以将摄像机定位到关卡中的任意位置,并且摄像机将沿与所选对象相同的轨道移动。

该选项不会追踪所选对象,而是根据与角色相同的移动数据来移动摄像机。

重播录制的摄像机(Replay Recorded Camera) 将摄像机锁定到它在模拟中占用的位置,跟随相同的移动(如有)。

对于视图选项,请参阅数据选项卡小节。

确保你在尝试更改摄像机控制模式之前,先弹出项目模拟功能按钮(Project Simulation Controls)中的播放器功能按钮。

3.对象大纲视图(Object Outliner)

高亮显示滴管工具的倒回调试器对象大纲视图

录制之后,在此处选择主题以填充倒回调试器的细节(Details)面板。你可以在视口窗口中手动选择主题,也可以使用 滴管(Dropper) 工具并在视口窗口中选择主题。

选择对象之后,对象大纲视图将列出所选对象以及所有子对象和组件,包括在运行时期间创建或销毁的子对象和组件,以及所有附加的控制器。

确保你在对象大纲视图中尝试选择对象之前,先弹出项目模拟功能按钮(Project Simulation Controls)中的播放器功能按钮。

一些对象由许多组件构成,例如移动组件、动画蓝图,等等。其中每个组件将列为对象大纲视图中的单独对象,并且必须单独选择以查看其各自的数据。

4.播放功能按钮(Playback Controls)

高亮显示录制的倒回调试器播放功能按钮播放暂停前进后退

让你控制项目模拟的录制片段的播放。你还会在这里发现录制按钮,用于在模拟项目时开始和停止录制过程。

5.倒回时间轴(Rewind Timeline)

高亮显示红色播放头的倒回调试器时间轴

让你在项目模拟的录制片段中手动推移。

6.细节(Details)面板和数据选项卡

高亮显示数据选项卡和视图选项的倒回调试器细节面板

细节(Details)面板根据所选主题和打开的数据选项卡显示所有可用数据。显示的信息可能包括变量值、布尔值状态,等等。

根据你在对象大纲视图中选择的主题,系统会在倒回调试器细节面板顶部自动填充不同的选项卡。

你可以使用倒带调试器(Rewind Debugger)菜单在可用时打开或重新打开更多选项卡。

AnimGraph 数据选项卡中,存在视图选项菜单。此处你可以切换不同的列以在器细节面板中显示。

工作流程

  1. 要使用倒回调试器,首先点击项目模拟功能按钮(Project Simulation Controls)中的 绿色播放按钮 ,启动游戏模拟。

  2. 然后点击倒回调试器播放功能按钮中的 录制 以开始录制项目模拟。

    要将光标从模拟断开连接而不停止或暂停模拟,请使用热键 Shift + F1

  3. 当你录制了足够数量的项目模拟时,使用项目模拟功能按钮(Project Simulation Controls)暂停模拟并弹出摄像机。

    在模拟功能按钮中暂停,然后弹出游戏控制器

  4. 再次点击 录制 以停止录制。

Gameplay的录制片段现在已准备好,可供使用。你可以通过对象大纲视图或使用滴管工具选择游戏对象,开始调试游戏对象。

在倒回调试器(Rewind Debugger)菜单中,你还可以选择不同的摄像机模式以在调试时获取不同的主题视图。例如,通过 禁用(Disabled) 选项,你可以分离摄像机并随意放置它,从任意角度观察你的动画主题来辅助工作流程。

播放推移演示

在倒回调试器的对象大纲视图中选择对象后,倒回调试器的细节(Details)面板将使用与该对象和录制中的当前时刻相关的选项卡和信息填充上下文。你可以使用播放头或播放功能按钮在倒回调试器时间轴中推移,查看信息如何随着实时录制的模拟及其行为而动态更新和变化。

动画蓝图

获取录制的项目模拟片段之后,你可以在对象大纲视图中双击动画蓝图组件,在新窗口中将其打开。在录制的片段中推移时,动画蓝图编辑器将根据角色的录制时刻显示所选动画蓝图的录制状态。

数据选项卡

在每个对象的组件中,特定选项卡在默认情况下会自动填充倒回调试器(Rewind Debugger)窗口。这些选项卡中显示了与你选择的对象组件相关的有用数据。根据所选组件,你也许可以打开其他选项卡查找其他可用的数据见解。要打开新选项卡,请打开编辑器左上角的菜单,每个可用的选项卡都可以切换。

选项卡

说明

动画曲线(Animation Curves)

所选对象包含动画曲线时,例如骨骼网格体,此选项卡将按定义的名称显示动画曲线,并列出与模拟录制相关的值。

通知(Notifies)

通知选项卡在所选对象的通知和同步标识激活时显示它们。

蒙太奇(Montages)

所选对象使用动画蒙太奇时,此选项卡将填充蒙太奇开关和其他相关数据。

混合权重(Blend Weights)

此选项卡将显示现有混合权重信息,例如过渡发生。

动画图表(Anim Graph)

在动画图表(Anim Graph)选项卡中,你可以查看变量、状态和插槽更新,以及叠加动画更改,等等。要添加更多信息列,请找到视图选项(View Options)菜单,切换可用追踪进行观察。

倒回调试器细节面板中的动画图表数据选项卡中的视图选项菜单

常见 视图选项(View Options) 如下所示:

  • 类型(Type) :说明所显示的数据类型。

  • 名称(Name) :列出数据类型的定义名称。

  • Alpha :列出Alpha(置换)值(如果使用了alpha)。

  • 播放时间(Playback Time) :在相关的情况下,一个元素已播放的时长读数。

可用 视图选项(View Options) 列表将根据所选AnimGraph中存在或之前存在的节点自动填充。

自定义AnimGraph追踪可以添加到倒回调试器,并将显示为可切换的 视图选项(View Options) 。你可以使用AnimNodes .cpp文件中if语句中的 TRACE_ANIM_NODE_VALUE 宏添加现有或自定义AnimGraph节点的自定义追踪。

属性(Properties)

这是所有组件类型中存在的默认选项卡,将显示所选组件的相关属性信息。

要在此选项卡中填充信息,首先为游戏对象或组件启用追踪属性(Trace Properties)功能,然后再录制项目模拟片段。

具体做法是,在倒回调试器的对象大纲视图中右键点击该对象或组件,并选择追踪属性(Trace Properties)。

在倒回调试器(Rewind Debugger)菜单中,你还可以选择 显示所有视图(Show All Views) ,打开所选组件的所有相关选项卡。

数据选项卡管理

特定组件的选项卡可以固定到倒回调试器,并与其他组件的选项卡一起查看。右键点击选项卡将显示 将视图保持打开(Keep View Open) 选项,它用于停靠选项卡,这样你可以并排查看不同的对象属性。

例如,你可以固定动画蓝图动画图表选项卡并打开角色的移动组件,同时比较有关每个组件的数据。

通过右键点击并选择将视图保持打开,锁定选项卡以防止关闭

可扩展性

倒回调试器不仅限于在打包了动画洞察(Animation Insights)插件的基础版本中使用。团队可以开发自己的自定义倒回调试器并添加到项目,以调试和高亮显示特定组件。

标签