使用ARKit先决条件和准备工作

使用苹果ARKit进行增强现实开发的先决条件与步骤。

Choose your operating system:

Windows

macOS

Linux

本页面的内容

虚幻引擎本就支持iOS设备。如果你已经在使用虚幻引擎和iOS设备,你不需要任何额外配置就可以开始使用增强现实和虚幻引擎。

常规先决条件

虚幻引擎和iOS设备的基本配置详见虚幻引擎文档的iOS游戏开发部分。

从虚幻引擎4.23.1起,所有ARKit版本都需要Xcode 11或更高版本。

ARKit 1.5 先决条件

  • 一个符合我们的推荐规格的开发工具。

  • 已安装虚幻引擎4.20或更高版本。

  • 已安装Xcode 9或更高版本。

  • 一台受支持、已配置并已连接的手持式iOS设备。

ARKit 2.0 先决条件

  • 一个符合我们的推荐规格的开发工具。

  • 已安装虚幻引擎4.20或更高版本。

  • 已安装Xcode 10或更高版本。

  • 一台受支持、已配置并已连接的手持式iOS设备,并且搭载了A12仿生芯片或更高配置芯片。

ARKit 3.0 先决条件

  • 一个符合我们的推荐规格的开发工具。

  • 安装虚幻引擎4.23.1或更高版本。

  • 安装了iOS 14或更高版本的iOS系统。

  • 一台受支持、已配置并已连接的手持式iOS设备 device.

ARKit 4.0 先决条件

  • 一台符合我们的推荐规格的开发工具。

  • 安装虚幻引擎4.26或更高版本。

  • 安装Xcode 12或更高版本。

  • 安装iOS 14或更高版本的iOS系统。

  • 一台受支持、已配置并已连接的手持式iOS设备,并且搭载了A12仿生芯片或更高配置芯片。

标签
本文基于此前的虚幻引擎版本编写,未针对当前的虚幻引擎5.0版本更新过。