硬件和软件规格

使用虚幻引擎进行开发的最低和推荐硬件规格及必要软件。

Choose your operating system:

Windows

macOS

Linux

本页介绍 虚幻引擎5 的硬件和软件要求, 以及虚幻引擎安装程序中包含的先决条件安装程序所安装的内容。

推荐使用的硬件

操作系统

Windows 10 64位

处理器

四核Intel或AMD处理器,2.5 GHz或更快

内存

8 GB内存

显卡

兼容DirectX 11或DirectX 12的显卡

RHI版本

  • DirectX 11: 最新驱动程序

  • DirectX 12: 最新驱动程序

  • Vulkan: AMD (21.11.3+) 和 NVIDIA (496.76+)

操作系统

最新版MacOS Monterey

处理器

四核Intel处理器,2.5 GHz或更快

内存

8 GB内存

视频采集卡

兼容Metal 1.2的显卡

截至虚幻引擎5.0,Ubuntu 22.04不兼容虚幻引擎。该问题将在未来的版本中修复。与此同时,我们推荐你使用Ubuntu 20.04,而不是升级到22.04

操作系统

Ubuntu 18.04

处理器

四核Intel或AMD处理器,2.5 GHz或更快

内存

32 GB内存

视频采集卡

搭载最新NVIDIA二进制驱动程序的NVIDIA GeForce 960 GTX或更高版本

显存

8 GB或更多

RHI版本

  • DirectX 11: 最新二进制驱动程序

  • Vulkan: AMD(21.11.3+)和NVIDIA(496.76+)

为了充分发挥虚幻引擎5中的新渲染功能,例如Nanite和Lumen,请参阅本文的UE5渲染功能使用要求

最低软件要求

下面列出了运行引擎或编辑器的最低要求。

运行引擎

操作系统

Windows 10

DirectX Runtime

DirectX End-User Runtime(2010年6月)

运行引擎

操作系统

最新版macOS Monterey

运行引擎

操作系统

CentOS 7.x及更高版本的任何较新的Linux发行版

Linux内核版本

内核3.x或更高版本

其他依赖项

glibc 2.17或更高版本

下面列出了程序员使用引擎进行开发时的最低软件要求。

使用引擎进行开发

满足"运行引擎"的所有要求(已自动安装)

Visual Studio版本

  • Visual Studio 2019 v16.11.5或更高版本(推荐)

  • Visual Studio 2022

iOS App开发

iTunes版本

iTunes 12或更高版本

使用引擎进行开发

Xcode版本

12.4

使用引擎进行开发

操作系统

Ubuntu 20.04

编译器

clang 11.0.1

选配

IDE

Visual Studio Code、CLion、QtCreator

先决条件安装程序所安装的软件

虚幻引擎包括一个先决条件安装程序,用于安装运行编辑器和引擎所需的全部软件,包括多个DirectX组件和Visual C++可再分发组件。在通过Epic Games启动程序安装虚幻引擎时,启动程序会自动安装这些先决条件软件。但是,如果要从源代码构建虚幻引擎,或者出于特定目的需要准备一台装有虚幻引擎所有先决条件软件的计算机,你可能需要自行运行先决条件安装程序。例如,如果要设置一台新计算机以作为Swarm Agent

该安装程序可在虚幻引擎安装位置下的 Engine/Extras/Redist/en-us 文件夹中找到。

虚幻引擎5取消了对32位平台的支持。

如果使用Perforce获取虚幻引擎源代码,你还将在Perforce资源库的同一 Engine/Extras/Redist/en-us 文件夹中找到预编译的二进制代码。该安装程序的源文件位于 Engine/Source/Programs/PrereqInstaller 下。

下表列出了由先决条件安装程序所安装的软件。

DirectX组件

Visual C++可再分发组件

XInput 1.3(2007年4月)

Visual C++ 2010 CRT

X3DAudio 1.7(2010年2月)

Visual C++ 2010 OpenMP库

XAudio 2.7(2010年6月)

Visual C++ 2012 CRT

D3D Compiler 4.3(2010年6月)

Visual C++ 2013 CRT

D3DCSX 4.3(2010年6月)

Visual C++ 2015 CRT

D3DX9 4.3(2010年6月)

Visual Studio 2019可再分发组件

D3DX10 4.3(2010年6月)

D3DX11 4.3(2010年6月)

该列表中最重要的DirectX组件是XInput、X3DAudio和XAudio依赖项。它们未包含在DirectX的标准安装包中(默认情况下不随Windows分发),因此必须手动安装或随应用程序分发。

显卡驱动程序

目前我们建议使用各显卡制造商推出的最新稳定版本:

性能说明

此列表代表Epic使用的典型系统,为使用虚幻引擎4开发游戏提供合理的指导:

  • Windows 10 64位

  • 64 GB内存

  • 256 GB固态硬盘(操作系统盘)

  • 2 TB固态硬盘(数据盘)

  • NVIDIA GeForce RTX 2080 SUPER

  • Xoreax Incredibuild(开发工具包)

  • 六核Xeon E5-2643,3.4 GHz

如果无法获取Xoreax Incredibuild(开发工具包),建议使用具有12到16个核心的计算机进行编译。

UE5渲染功能使用要求

虚幻引擎5某些渲染功能的系统要求和最低要求有所不同。

UE5功能

系统要求

Lumen全局光照和反射系统

软件光追:

  • 使用DirectX 11的显卡,并且支持Shader Model 5

硬件光追:

  • 带有DirectX 12支持的Windows 10系统

  • 显卡必须是NVIDIA RTX-2000系列(或更新),或者AMD RX-6000系列(或更新)

Nanite虚拟化几何体

  • 凡是支持DirectX 12 Agility SDK的较新版Windows 10(高于版本1909.1350)和Windows 11都受支持。

    • Windows 10版本1909 — 修订版号应该超过或等于.1350。

    • Windows 10版本2004和20H2 — 修订版号应该超过或等于.789。

  • DirectX 12(支持Shader Model 6.6 atomics)或者Vulkan(支持VK_KHR_shader_atomic_int64)

  • 最新的显卡驱动程序

虚拟阴影贴图

  • 凡是支持DirectX 12 Agility SDK的较新版Windows 10(高于版本1909.1350)和Windows 11都受支持。

    • Windows 10版本1909 — 修订版号应该超过或等于.1350。

    • Windows 10版本2004和20H2 — 修订版号应该超过或等于.789。

  • DirectX 12(支持Shader Model 6.6 atomics),或者Vulkan(支持VK_KHR_shader_atomic_int64)

时序超分辨率

可以在所有支持Shader Model 5的显卡上运行,但着色器的UAV数量限制(8个)会产生性能影响。时序超分辨率着色器使用16比特类型编写(在D3D12上启用,支持Shader Model 6)。