开发要求

iOS开发要求,包括兼容的硬件、软件和SDK信息。

Choose your operating system:

Windows

macOS

Linux

本文介绍了为iOS、iPadOS和tvOS设备开发 虚幻引擎(UE) 项目所需的软件开发工具包(SDK),以及当前UE版本的兼容硬件。

当前开发要求

当前SDK信息

  • 当前UE版本:5.0

    • 支持目标SDK版本:iOS 14或更高版本

    • 推荐的MacOS和Xcode版本

      • 最新的MacOS Monterey

      • 最新的Xcode 13

    • 支持的MacOS版本

      • MacOS Big Sur 11.6.4

    • 最低的MacOS和Xcode版本

      • MacOS Catalina 10.15.7

      • Xcode 12.4。请注意,需要Xcode 13才能使用iOS 15设备进行本地测试。

当前兼容设备

UE 5.0支持那些支持版本14及更高版本的相应SDK并使用Apple A8处理器或更高版本的iOS、iPadOS和tvOS设备。下面是最低的兼容设备型号:

  • iOS 14

    • iPhone 6S或更高版本

    • iPod Touch第7代

  • iPadOS 14

    • iPad第5代或更高版本

    • iPad Air 2或更高版本

    • iPad Mini 4或更高版本

    • iPad Pro(所有型号)

  • tvOS 14

    • Apple TV HD

    • Apple TV 4K(第一代)

    • Apple TV 4K(第二代)

如需了解如何使用M1芯片或更高版本支持设备,请参阅支持Apple Arcade的通用二进制文件

版本历史记录

UE版本

支持的MacOS版本

Xcode版本

iOS、iPadOS和tvOS SDK版本

支持的iOS设备

支持的iPadOS设备

支持的tvOS设备

说明

5.0

  • MacOS Catalina 10.15.7

  • MacOS Big Sur 11.6.4

  • 最新的MacOS Monterey

Xcode 13、Xcode 12.4

操作系统版本14或更高版本。

  • iPhone 6S或更高版本

  • iPod Touch第7代

  • iPad第5代或更高版本

  • iPad Air 2或更高版本

  • iPad Mini 4或更高版本

  • iPad Pro(所有型号)

  • Apple TV HD

  • Apple TV 4K(第一代)

  • Apple TV 4K(第二代)

支持Xcode 12.4,但需要Xcode 13才能在iOS 15设备上进行本地测试。