项目设置界面

介绍虚幻引擎中的项目设置。

Choose your operating system:

Windows

macOS

Linux

通过 项目设置(Project Settings) 窗口,你可以为以下内容设置选项:

  • 你的虚幻引擎项目。

  • 引擎运行项目时的行为。

  • 项目如何在特定平台上运行。

启用某些插件后,"项目设置(Project Settings)"窗口中还会出现该插件的相关设置。

窗口中的所有设置都保存在项目的默认引擎配置文件(Engine.ini)中。"项目设置(Project Settings)"窗口提供了编辑这些设置的可视化界面。不过,你也可以手动编辑 Engine.ini 文件,来更改各项设置。

访问项目设置

要打开"项目设置(Project Settings)"窗口,请在虚幻引擎的主菜单转至 编辑(Edit)> 项目设置(Project Settings)

Selecting Project Settings in Edit menu

选择"编辑"菜单中的"项目设置"

类别和分段

"项目设置(Project Settings)"窗口按相关选项划分为各个类别和分段。类别显示为标题,而每个分段显示为超链接,点击超链接后会在右侧面板中打开该分段的选项。

你可以将项目设置导出为文件,也可以通过文件导入项目设置。方法是点击"项目设置(Project Settings)"窗口右上角的 导出(Export)导入(Import)

每次更改"项目设置(Project Settings)"中的某个设置时,编辑器的 .ini 文件都会更新,并且修改的参数会应用到所有平台。编辑器的 .ini 文件位于 <ProjectDirectory>\Config\DefaultEngine.ini

平台的 .ini 文件必须在文本编辑器中手动编辑,并且仅影响对应的平台。平台 .ini 文件的示例路径: <ProjectDirectory>\Config\Windows\WindowsEngine.ini

"项目设置(Project Settings)"窗口包含以下分段和类别:

此小节还在编写中,最终将涵盖所有虚幻引擎项目设置。

标签