电影渲染队列

使用多功能电影渲染队列工具渲染和批量渲染过场动画。

Choose your operating system:

Windows

macOS

Linux

电影渲染队列是虚幻引擎的图像序列和电影渲染解决方案。它专为高质量渲染图像、简化的生产管线集成以及用户可扩展性而构建。

电影渲染队列支持多种用于生成高质量渲染的功能,例如它的时间子采样功能,使你能够生成高质量的径向动态模糊。你还可以导出包含半透明像素值的图像(使用适当的项目/场景设置),生成具有线性数据的16位HDR图像,并将渲染配置保存到你可以重复使用和共享的资产中。使用渲染队列可以一次管理多个作业及其设置,支持运行批量渲染作业。

先决条件

  • 电影渲染队列是一个 插件 ,必须在使用前启用。在虚幻引擎菜单中,找到 编辑(Edit)> 插件(Plugins) ,在 渲染(Rendering) 分段中找到 电影渲染队列(Movie Render Queue) ,并启用它。之后你将需要重启编辑器。

    电影渲染队列插件

  • 你已经创建一个带有关卡序列的项目供你渲染。如果你尚未创建项目,也可使用预制的内容示例 示例与教学Meerkat演示

打开电影渲染队列

你可以用两种不同的方式打开电影渲染队列(Movie Render Queue)窗口

第一种方式是,在虚幻引擎的主菜单栏中点击 窗口(Window)> 过场动画(Cinematics)> 电影渲染队列(Movie Render Queue)

打开电影渲染队列

或者,在 Sequencer 中,点击工具栏中的 渲染电影(Render Movie) 按钮。点击下拉菜单,确保你的默认渲染工具设置为电影渲染队列(Movie Render Queue)。如果没有,Sequencer的旧版渲染器工具将打开。

打开电影渲染队列

按上述两种方式之一操作后,电影渲染队列(Movie Render Queue)窗口将打开。

电影渲染队列窗口

界面概述

电影渲染队列界面由四个主要区域组成:

电影渲染队列界面

  1. 工具栏:包含用于添加或删除渲染作业以及加载或保存当前作业列表的菜单。

  2. 作业:按排队顺序显示要渲染的序列。列表中的每个顶层项目都被视为作业。这些项目还包含每个作业的配置设置。

  3. 作业细节:所选作业的细节。列出名称、关卡序列资产、作业期间要运行的关卡以及此作业的作者。

  4. 开始渲染:在你的机器上本地启动渲染,或在你机器上的单独进程中启动渲染。

工具栏

工具栏包含用于添加和删除作业的菜单。要将新序列添加到渲染队列,请点击 + 渲染(+ Render) 按钮并选择 关卡序列资产(Level Sequence Asset) 。将序列从内容浏览器拖到作业区域,也可以将序列添加到你的作业列表中。

添加渲染作业

要从作业列表中删除序列,请选择作业并点击 - 按钮或按键盘上的删除键

删除渲染作业

你还可以从工具栏中将当前作业列表保存为 队列预设(Queue Preset) 资产。点击 加载/保存队列(Load/Save Queue) 按钮,然后选择 另存为资产(Save As Asset) 。然后,系统将提示你命名并将 电影管线队列(Movie Pipeline Queue) 资产保存在项目中的某处。

保存渲染队列预设

预设现在将列在 加载/保存队列(Load/Save Queue) 按钮下。选择它将设置你的作业列表,以便匹配保存的预设。

这会将队列的副本导入作业区域,除非你选择 另存为资产(Save as Asset) 并保存现有预设,否则你对作业列表所做的更改不会影响资产。

加载渲染队列预设

作业

作业区域包含将渲染的关卡序列列表,以及它们的渲染设置和输出目录。

你可以展开序列,查看其摄像机。该列表从序列中的任意 **使用摄像机镜头切换* 分段生成。你还可以启用或禁用摄像机以防止该分段被渲染。

镜头切换渲染队列

点击作业的 设置(Settings) 条目将打开设置窗口,你可以在其中指定输出目录、渲染设置和导出格式。

电影渲染设置

点击下拉箭头并选择预设,可以将保存的预设应用到你的作业。

电影渲染设置预设

输出(Output) 区域将显示你的图像或视频将要渲染到的文件夹目录,如输出设置中设置的那样。点击此处将打开一个以该文件夹为目标的 文件资源管理器(File Explorer) 窗口。

渲染目录资源管理器

访问 渲染设置 页面,了解有关自定义渲染的更多信息。

TopicIcon.png

导出格式

使用影片渲染队列中的各种格式输出你的渲染。

使用影片渲染队列中的各种格式输出你的渲染。

TopicIcon.png

图像设置

使用电影渲染队列的图像设置调整渲染的图片质量

使用电影渲染队列的图像设置调整渲染的图片质量

作业细节

选择作业后,你可以在作业细节区域查看其细节。

渲染作业细节

此区域列出了所选作业的以下字段:

名称

说明

作业名称(Job Name)

作业的名称。默认设置为关卡序列资产的名称,但可以修改。作业名称(Job Name) 字段也显示在默认的 烧入(Burn In) 覆层中。

序列(Sequence)

序列资产引用。如果要为作业指定不同的序列,你可以在此处更改引用序列的顺序。

贴图(Map)

渲染时要运行的关卡。如果你的序列使用 可生成对象 ,你可以在不同的关卡中渲染相同的场景。

作者(Author)

作业作者。此字段会使用你的操作系统用户名自动填充。

开始渲染

本地和远程渲染

渲染(本地)(Render (Local)) 在与虚幻引擎相同的过程中渲染,并启动在编辑器中运行会话进行渲染。执行本地渲染时,你无需保存更改。

渲染(远程)(Render (Remote)) 将启动一个单独的进程来渲染你的作业。你必须将更改保存在项目中,外部进程才可以从磁盘读取保存的文件。

远程(Remote) 选项可用于实现远程渲染农场。渲染选项的默认行为由

[](understanding-the-basics/projects-templates/unreal-engine-project-settings)
确定,并且可以调整以运行你自己的代码,这在使用第三方渲染农场管理软件时很有帮助。此外,用于启动远程渲染过程的命令将写入输出日志,在构建你自己的自动渲染农场时,这可以用作参考。

因为你在 作业细节(Job Details) 中指定了要渲染的 关卡 资产,所以渲染时不需要打开相同的关卡。运行渲染作业时,影片渲染队列将自动打开指定的关卡。

渲染预览

当渲染作业运行时,电影渲染队列将显示渲染预览窗口,向你展示渲染的当前视觉效果状态以及相关信息。渲染完成后预览窗口将自动关闭。

渲染预览

  1. 渲染预览(Render Preview) :此视图将显示渲染的当前视觉效果状态。由于每一帧都显示在此处,它们也将保存到你的输出目录中。此处的预览基于你的GPU的最新示例数据,并且可能以低于最终渲染的质量显示。如果你为渲染启用了平铺(Tiling),则预览将仅显示右下角平铺。

  2. 整体渲染进度(Overall Render Progress) :这些细节将显示正在渲染的当前序列,以及整体进度、耗时和估计的剩余时间。

  3. 当前镜头切换进度(Current Camera Cut Progress) :这些细节将显示当前正在渲染的摄像机,以及当前镜头切换的进度。

创建基本渲染

你可以按照以下步骤创建电影序列的基本渲染。

作业设置

首先,点击 窗口(Window)> 过场动画(Cinematics)> 电影渲染队列(Movie Render Queue) ,打开电影渲染队列(Movie Render Queue)工具。

打开电影渲染队列

然后,点击 + 渲染(+ Render) 按钮并选择你的序列,将你的序列资产添加到作业列表中。

添加渲染作业

你还要确保在 贴图(Map) 属性中设置了正确的关卡。

关卡设置渲染

输出设置

添加序列后,你可能需要调整一些输出设置,例如目标文件夹、分辨率和文件类型。

点击 未保存配置(Unsaved Config) 文本,打开该作业的 渲染设置(Render Settings) 窗口。

打开电影渲染队列设置

默认情况下,电影渲染队列将渲染为一系列.jpg图像。要更改此设置,你可以删除 .jpg序列[8位](.jpg Sequence [8bit]) 条目,并点击 + 设置(+ Setting) 按钮,选择不同的输出格式。

选择 .jpg序列[8位](.jpg Sequence [8bit]) 条目并按 删除(Delete) ,然后点击 + 设置(+ Setting) 按钮并选择 .png序列[8位](.png Sequence [8bit])

电影渲染队列png序列

延迟渲染(Deferred Rendering) 条目将使得输出渲染你在视口中看到的确切图像。对于像这样的基本渲染,你可以按原样保留此设置,但它 必须 在此处存在才能渲染你的图像。

延迟渲染

点击 输出(Output) 将显示典型的输出相关设置,例如文件名、目录和分辨率。

如果你要更改输出目录(Output Directory)字段,请点击条目旁边的 ... 按钮,找到新文件夹,然后按 选择文件夹(Select Folder) 。你的图像序列现在将在此处输出。

渲染输出设置

完成更改后关闭 渲染设置(Render Settings) 窗口。

渲染

现在你可以渲染你的序列。

点击 渲染(本地)(Render (Local)) 开始序列渲染作业。渲染预览 窗口将显示你当前的渲染进度。

本地移动渲染

渲染完成后,预览窗口将关闭。现在点击作业的链接输出文本,你可以找到输出文件夹并查看输出图像序列。

输出Windows资源管理器

蓝图中的使用

你可以使用 电影渲染队列(Movie Render Queue) 在运行时构建中渲染电影,并使用 蓝图(Blueprints) 将文件输出到用户的计算机。访问 在运行时构建中使用Movie Render Queue 了解更多信息。

本文基于此前的虚幻引擎版本编写,未针对当前的虚幻引擎5.0版本更新过。