開発要件

互換性のあるハードウェア、ソフトウェア、SDK の情報を含む Android の開発要件です。

このページには、Android デバイス用の Unreal Engine (UE) プロジェクトの開発に必要なソフトウェア開発キット (SDK) 要件と、現在のバージョンの UE と互換性のあるハードウェアが含まれています。

現在の開発要件

現在の SDK 情報

  • 現在の UE バージョン:5.1

    • Android Studio バージョン:4.0

    • コンパイルの最小 SDK バージョン:30

      • 推奨:32

      • デバイスでのシッピング用の最小限のターゲット SDK:26

    • NDK バージョン: r25b

    • AGDE v22.2.69+ AGDE デバッグ 用に必要。

現在互換性のあるデバイス

UE 5.0 では、次の仕様に適合した Android デバイスをサポートしています。

  • Android 8 以上

  • 64-bit Arm-based CPU

  • 互換性のある GPU

    • Mali T8xx、G71、G72、G76、G77、G78、および G710 シリーズ

    • Adreno 5xx、6xx、または 7xx シリーズ

    • PowerVR GM9xxx シリーズ

    • Xclipse 920

  • 互換性のあるグラフィック API

    • OpenGL ES 3.2

    • 互換性のあるドライバを含む Android 10 以降のデバイスでサポートされる Vulkan

バージョン履歴

UE バージョン

Android Studio バージョン

Minimum Android SDK バージョン

Android NDK バージョン

注記

5.1

Android Studio 4.0

推奨:SDK 32 最小:SDK 30

NDK r25b

SDK 30 はシステム上でコンパイルするために必要な最小限の SDK ですが、SDK 26 はデバイス上でプロジェクトをシッピングするためにターゲットとすることができる最小限の SDK です。

5.0

Android Studio 4.0

SDK 23

NDK r21e

Android File Server (AFS) の使用に必要な最小 SDK バージョンは 26 です。

4.26.2 - 4.27

Android Studio 4.0

NDK r21b

4.25

Android Studio 3.5.3

NDK r21b

Unreal Engine 4.25 では NDK r21b の使用を推奨しますが、UE 4.25 は幾つかのローエンド デバイスでの互換性問題に対応するために NDK r20b をサポートします。

4.21 - 4.24

NDK r14b

4.19 - 4.20

NDK r12b

Unreal Engine のドキュメントを改善するために協力をお願いします!どのような改善を望んでいるかご意見をお聞かせください。
調査に参加する
キャンセル