Sequencer Editor Reference

UI and Control Reference Page for the Sequencer Editor.

Windows
MacOS
Linux

This page outlines the interface elements and options contained with the Sequencer Editor, and this page will help you gain an understanding of each of the different interface elements within Sequencer and the available options.

Sequencer Editor Interface

SequencerEditorCallouts_4.23.png

The image above is intended for demonstration purposes, since new Level Sequences do not contain any content.

  1. Tool Bar

  2. Sequence Breadcrumbs

  3. Add/Filter Tracks

  4. Timeline

  5. Tree View

  6. Tracks Area

  7. Playback Controls

Tool Bar

Toolbar.png

What follows is a description of each of the toolbar buttons as they appear on the toolbar, from left to right.

Icon

Description

tb_1.png

Saves the current Level Sequence.

tb_2.png

Saves the current Level Sequence under a different name.

SearchIcon.png

Find the currently viewed sequence asset in the Content Browser.

cameraicon.png

Creates a new camera and sets it as the current camera cut.

tb_4.png

Opens the Render Movie Settings window, which allows you to output your sequence as a movie or image sequence.

UndoIcon.png

Restore any objects that have been animated by sequencer back to their original state (Ctrl+R).

tb_5.png

Opens the General Options menu with settings to define functionality for Sequencer.

PlaybackIcon.png

Opens the Playback Options menu.

SelectEditOptions.png

Opens the Select/Edit Options menu.

tb_6.png

Enables/Disables the Key All option. With this and Auto-Key enabled, determines if all properties are keyed for a track when changes are made or if only the changed property is keyed.

tb_7.png

Enables/Disables different Auto-Key options. By default, this option is disabled but can be set to Auto-Key All or Auto-Key Animated.

SequenceEditOptions.png

Opens the Sequence Edit Options menu.

tb_8.png

Enables/Disables grid snapping for the Tracks Area as well as grid snapping options.

tb_9.png

Allows for adjustment of the time snapping interval.

tb_10.png

Opens the Curve Editor, which allows you to fine tune the animation keys placed in the Tracks Area.

Sequencer Curve Editor

When working with tangents inside the Curve Editor, weighted tangents are supported on float curves as depicted below.

WeightedCurves_03.gif

The Curve Editor also supports continuous Euler Angle changes when changing rotations. Euler angles are not limited to -180, 180, which is necessary to avoid flips in animation.

You can turn on Quaternion Rotation on a 3D Transform section through the track's Properties menu to utilize quaternion interpolation to smoothly interpolate between two rotations.

Dockable Curve Editor Window

You can remove and dock the Curve Editor window just like any other panel in the Editor. The position of the Curve Editor saves when you close the Sequencer or Editor, and restores the Curve Editor to the saved position when you reopen the Sequencer.

NewCurveEditorDockable1.png

View Modes

You can choose how to view selected curves by clicking the View Mode button as shown below. There are three View Modes:

  • Absolute View shows all of your curves plotted in absolute space - this matches legacy behavior that everyone is used to.

  • Stacked View normalizes each curve and then draws them non-overlapping.

  • Normalized View normalizes each curve (like Stacked View), but draws them all on top of each other.

Click for full size image.

Filter Menu

You can apply different filters to your selection using the Filter Menu. This menu gets its own floating dialog box, which supports a full Details panel. This provides you with a wide range of settings. It also persists after you click the Apply button, so you can easily iterate on your settings. Adding new options in this dialog is as simple as implementing one function on a new Class, which derives from UCurveEditorFilterBase.

Click for full size image.

Multiple Framing Options

You can use multiple different framing options in the Curve Editor. Frame Selection (or Frame All if there is no selection) is built-in, and defaults to the F key. Frame on Playback Cursor and Frame on Playback Range are new options, and these are good examples of how you can extend the Toolbar using a plugin. The old Frame Horizontal/Frame Vertical options have been replaced with Focus All followed by ALT + SHIFT + RMB (Right Mouse Button) to zoom each axis independently. You can also follow Focus All with ALT + RMB to scale proportionally.

Retiming Tool

The Retiming Tool creates a one-dimensional lattice and lets you adjust the timing of your keys. It supports grid snap, multi-select and other options. This tool is provided by the default plugin.

Click for full size image.

Transform Tool

The Transform tool supports translating selected keys, but also supports scaling them on both X and Y axes (where appropriate). Press Alt to change the anchor point from the opposite edge to the center.

Click for full size image.

Manipulating Curves

There are various ways that you can manipulate curves by manually adjusting curve keys or by entering different values for curve keys.

Snapping the curve to the grid is based on the grid's spacing. You can change the grid spacing at anytime using the dropdown next to the Value Snapping icon and adjust the curve accordingly.

grid spacing and new snap

If you are using the Transform Tool with multiple keys selected, the Tools Options enables you to adjust the Bounds, Scale Center, and Falloff values by changing the values for the Upper Bound, Lower Bound, Left Bound, Right Bound, Scale X and Y, and Falloff Interp. The Upper and Lower Bounds adjusts the upper and lower range of the curve. The Left and Right Bound adjusts the curve Sequence�s start and end times. Scale Center X and Y moves the center of the curve Scale along the X and Y axis of the grid.

The Falloff Interp Type adjusts the falloff rate of the curve using one of the following falloff types: Linear, Sinusoidal, Circular In/Out, and Exp In/Out. You can learn more about these falloff types in Animation Blend Modes.

Click for full size image.

If you are using the Multi Select Tool and have multiple keys selected, the Tools Options enables you to change the X and Y scales and the Pivot Type.

The X and Y Scales adjust the curve on the X and Y axis. There are four Pivot Types you can select:

  • Average: Curve scales against the keys� average location.

  • Bound Center: Curve scales against the �median� keys� average location.

  • First Key: Pivots based on the first key.

  • Last Key: Pivots based on the last key.

Click for full size image.

Storing Curves

If you right-click a curve key, you can Store Curves which enables you to take a snapshot of the curve data.

Store Curve option

You can also Apply Stored Curve data to another curve, which is similar to copy/pasting data. As you adjust the curve, the original snapshot remains in the grid view as a reference point.

Sequence Breadcrumbs

Depending on your workflow, you may have a "master" Level Sequence which contains Shots as part of the Level Sequence. In these cases, you can navigate directly to a specific Shot by double-clicking the Shot in the Tracks Area.

In the image below, we have a Level Sequence inside another Level Sequence which is our "master" sequence. We can click the first breadcrumb to return to our master Level Sequence containing all of our shots. If we select the folder icon, we can navigate to any Level Sequence in the hierarchy.

breadcrumb navigation options

Add / Filter Tracks

The Track button allows you to add Tracks or Actors from your level to Sequencer which you can then use to craft your cinematic.

AddOption.png

When you have an Actor in the Level selected, clicking the Track button and looking under Actor to Sequencer, the Actor you have selected will be displayed at the very top of the context menu, enabling you to quickly add it. If you do not have an Actor in the level selected, when clicking Actor to Sequencer you can still choose any other Actor that exists in the Level from the context menu.

Below are the available tracks you can add to Sequencer, click each link below to view a how-to page for an example using each track.

Tracks

Description

Add Folder

You can add folders to contain your tracks for organizational purposes.

Audio Track

Adds a master audio track which can be used to play sounds.

Event Track

Adds an Event Track which can be used to signal and kick off Blueprint Script.

Camera Cut Track

Allows you to switch between cameras associated with Sequencer and provide a camera perspective.

Shot Track

Allows you to add Level Sequences as "shots" which can have Takes that can be swapped in/out.

Play Rate Track

Adds a track that can be used to manipulate the playback rate of the sequence.

Subscenes Track

Adds a sub-track, which can contain other Level Sequences. This is useful for creating multiple copies of a sequence that different users can work from without altering the original sequence.

Fade Track

Adds a track that will allow you to control the fading in/out of the sequence.

Level Visibility Track

This can be used to keyframe and control the visibility of your level.

Material Parameter Collection Track

This track can be used to drive Material Parameter Collections within Sequencer.

The Filter option is a way to select and view specific tracks that you added to your sequence.

filter.png filters_on.png

You can also Search for tracks, which also filters the Actors in your sequence.

search.png

Timeline

Timeline.png

The Timeline indicates the playback range of your sequence with Green (Start) and Red (End) markers. The current time of your sequence is indicated by the Timeline Marker, which you can scrub by left-click dragging along the timeline.

You can right-click on the timeline to define new Start/Stop points from the context menu as depicted below.

Timeline2.png

Your sequence will continue to play from the start marker all the way to the end marker even if your content does not fully reach the end of the sequence (or exceeds past the end marker). Inside the Playback Options, there is an option to keep your content inside the section bounds, which will ensure there is no dead space during your sequence.

KeepInSectionBounds.png

Tree View

The Tree View is where you determine what types of actions you want to perform during your sequence.

tracks1.png

Above, we have a Camera Cuts track for switching camera angles during our sequence, a Cine Camera Actor to provide the view for a scene, and two Skeletal Mesh Actors, which are the characters in our scene.

Sequencer is context sensitive and will allow you to add sub-tracks (where applicable) to each track that will provide you with additional options. For example, in the image below we have added a CameraComponent track to our Cine Camera Actor, which gives us the ability to add another sub-track to adjust some of the properties of the camera during our scene if we desire.

tracks2.png

You can also add Keyframes from the Tree View for your tracks to define properties at a specific point on the timeline.

AddKeyFrameButton.png

You can click the + keyframe button or press the Enter key with a track selected.

Tracks Area

KeyframeWindow.png

The Tracks Area is where you adjust the content in each of your tracks. You can adjust any keyframes you have added, trim/split or taper in/out of sections as well as several other options that are available from the Right-click context menu (pictured below).

RightClickContext1.png

Above, right-clicking a keyframe for a Transformation track gives the ability to change the key interpolation type as well as other options that can be adjusted from the Properties rollout, which updates based on the type of content your Right-click on.

Below, right-clicking on an animation assigned to an Animation Track and selecting properties gives us the ability to change the currently assigned animation as well as adjust properties related to the animation itself, such as start/end offsets, play rate, and more.

RightClickProperties.png

Below are methods and shortcuts you can use to navigate the Tracks Area.

Command

Description

Right-click Drag

Allows you to move around the Tracks Area.

Ctrl + Mouse Wheel In/Out

Zoom in/out in the Tracks Area.

Home

Resets the zoom/view range of the Tracks Area.

- and =

Zoom into and out of the view range by 10%.

, and .

Moves backwards and forwards between placed keyframes.

Left-click Drag

Creates a selection box around keys in the window.

Left-click on a key

Selects the key.

Right-click on a key

Displays the Context Menu where you can define properties for the key.

Middle Mouse

Creates a key at the mouse position.

Enter

Set a key on the selected tracks at the current time.

Ctrl + G

Go to a set time/frame in the sequence.

I

Sets the start of Selection Range.

O

Sets the end of Selection Range.

M

Adds/Removes a Frame Marker at the current mouse location.

Ctrl + Shift + , (comma key)

Jumps the timeline to the previous marker.

Ctrl + Shift + . (period key)

Jumps the timeline to the next marker.

Ctrl + Left Arrow

Move selected keys and sections 1 frame to the left.

Ctrl + Right Arrow

Move selected keys and sections 1 frame to the right.

For a full list of keyboard bindings and other shortcuts, see the Sequencer Cheat Sheet page.

Playback Controls

PlaybackControls.png

The Playback Controls can be found in the bottom lower-left corner of the Sequencer Editor and are similar to standard media player applications. With the default Unreal Editor layout, the same playback controls also display in the main Level Viewport. Finally, when using a Cinematic Viewport, the playback controls will appear inside the viewport.

Standard playback controls are as follows:

Command

Description

playback1.png

Set the playback start position to the current position indicated by the time marker.

playback2.png

Jump to the playback start position.

playback3.png

Jump to the previous key in the selected track(s).

playback4.png

Jump to the previous frame.

playback5.png

Play or Pause the Level Sequence from the position of the time marker.

playback6.png

Jump forward a frame.

playback7.png

Jump to the next key in the selected track(s).

playback8.png

Jump to the playback end position.

playback9.png

Set the playback end position to the current position indicated by the time marker.

playback10b.png / playback10.png

Toggles between looping the Level Sequence during playback.

The Playback Controls inside a Cinematic Viewport function the same as above.

Tags
Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback