ARKit Prerequisites

Support for iOS devices is not new to the Unreal Engine. If you are already working with Unreal Engine and iOS devices, you may not require any additional configuration to start working with augmented reality and Unreal Engine.

General Prerequisites

The basic configuration of Unreal Engine and iOS devices is covered in detail in the iOS Game Development section of the Unreal Engine documentation.

ARKit 1.5 Prerequisites
  • A development machine that meets our Recommended Specifications.
  • Unreal Engine 4.20 or greater installed.
  • Xcode 9 or greater installed.
  • A supported, configured, and connected handheld iOS device.
ARKit 2.0 Prerequisites
  • A development machine that meets our Recommended Specifications.
  • Unreal Engine 4.20 or greater installed.
  • Xcode 10 or greater installed.
  • A supported, configured, and connected handheld iOS device.

Supported: Use the Supported Devices link to identify the current list of iOS devices supported for ARKit (iOS 12 beta required).