Oculus Development Requirements

Oculus development requirements including hardware, software, and SDK information.

Windows
MacOS
Linux

In this page you'll find hardware and software development kit (SDK) requirements needed to start developing for the Oculus platform. 

Unreal Engine 4.26

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 10 or later

SDK Version

Oculus Runtime v19.0

API Version (Go/Quest)

API Level 23

The Oculus SDK versioning listed on this page has been changed to be consistent with Oculus releases. Version 19.0 is the same as version 1.51.

Unreal Engine 4.25

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 7 or later
MacOS 10.10 or later (x86 only)

SDK Version

Oculus Runtime 1.44

API Version (Go/Quest)

API Level 23

Unreal Engine 4.24

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 7 or later
MacOS 10.10 or later (x86 only)

SDK Version

Oculus Runtime 1.40

API Version (Go/Quest)

API Level 23

Unreal Engine 4.23

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 7 or later
MacOS 10.10 or later (x86 only)

SDK Version

Oculus Runtime 1.37

Unreal Engine 4.22

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 7 or later
MacOS 10.10 or later (x86 only)

SDK Version

Oculus Runtime 1.28

Unreal Engine 4.21

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 7 or later.
MacOS 10.10 or Later (x86 only)

SDK Version

Oculus Runtime 1.28

Unreal Engine 4.20

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 7 or later.
MacOS 10.10 or Later (x86 only)

SDK Version

Oculus Runtime 1.25

Unreal Engine 4.19

Hardware Requirements

Recommended Desktop Hardware

See Oculus' System and Hardware Requirements
Hardware and Software Specifications

Supported VR Headsets

See Oculus' System and Hardware Requirements

Software Requirements

Desktop Operating System

Windows 7 or later.
MacOS 10.10 or Later (x86 only)

SDK Version

Oculus Runtime 1.17

Select Skin
Light
Dark
Help shape the future of Unreal Engine documentation! Tell us how we're doing so we can serve you better.
Take our survey
Dismiss

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback