How to Set up Qt Creator for UE4

CompiledEditor_LinuxIDE.png At the end of this tutorial, you'll have an Integrated Development Environment (IDE) configured to build and run Unreal Engine 4 (UE4).

1. Configuring Qt Creator to Build UE4

While some developers like to use text editors and command line debuggers to modify their game's source code, most developers prefer to use an Integrated Development Environment (IDE) to edit, debug, and compile their code. If you're a game developer looking to set up an IDE to work with Unreal Engine 4 (UE4) in a Linux environment, this guide is for you.

Although we recognize that chosing an IDE is a matter of individual preference, we've configured UE4 to interface with three IDEs in Linux; specifically, Qt Creator, KDevelop, and Codelite. We don't endorse one IDE over another; however, as an example for learning purposes, we've chosen to show you how to configure Qt Creator to build and run UE4. By the end of this guide, you'll know how to configure your IDE to build and run UE4. Finally, you'll also learn how to set up the IDE to build and run new C++ (CPP) projects that you create from the Unreal Editor.

Before we begin, please make sure that you've already set up your workflow using our Linux Quick Start. Also, please make sure that Qt Creator is installed on your machine.

  1. Launch Qt Creator, opening the Qt Welcome menu.
    Click for full image.
  2. Click the Open Project button to open the Qt Project file browser.
    Click for full image.
  3. Navigate to the directory where you built UE4, select the UE4 Qt Project (UE4.pro) file, and click the Open button.
    Click for full image.
  4. At this point, Qt Creator hasn't been configured to build UE4 in Debug and Release Mode. Click the Configure Project button located in the Configure Project menu.
    Click for full image.
  5. Now, click the Projects button to enter into Projects mode, opening the Build Settings menu.
    Click for full image.
    When you open the Build Settings menu, you'll notice that Qt Creator defaults its Edit build configuration: to Debug mode.
    Click for full image.
  6. Under the Build Steps section, clear the qmake build step by clicking on the X button next to the Details drop down menu.
    Click for full image.
  7. Now, clear the Shadow build checkbox to cancel the selection.
    Click for full image.
    Shadow building allows you to build projects in a separate build directory with Qt Creator's qmake utility. Because UE4 is distributed with a custom Make file that makes use of UnrealBuildTool, you don't need to use Qt Creator's qmake utility.
  8. Now, click the Details drop down menu to open the input form for the Make build step.
  9. Enter UE4Editor-Linux-Debug into the Make arguments: text field.
  10. Under the Clean Steps section, click the Details drop down menu to open the input form for the Make clean step.
  11. Replace clean by entering UE4Editor-Linux-Debug ARGS="-clean" into the Make arguments: text field.
  12. Now, click the Edit build configuration: drop down menu and select Release to open the Build Settings for Release mode.
    Click for full image.
  13. Repeat Steps 6 through 11 to edit the build configuration settings for Release mode. Please make sure that your settings match the following image:
    If you'd like to set up additional build configurations for your project, please refer to the Qt Creator Build Settings Documentation, where they show you how to add as many build configurations as you might need.

Section Result

Click for full image.

At this point, you've configured UE4 to build in both Debug and Release mode. Depending on your system's specifications, you may notice that UE4 runs slower while in Debug mode. For more information on the performance characteristics of available build configurations, please read through our Build Configurations Reference page. With this in mind, you're ready to configure Qt Creator to run UE4.

2. Configuring Qt Creator to Run UE4

At this point, you've configured UE4 to build in both Debug and Release mode. Now, you're ready to configure Qt Creator to run UE4.

  1. Click the Run button to open the Run Settings menu.

    Click for full image.

  2. Under the Run section, click the Browse button that is located at the end of the Executable: text field.

    Click for full image.

  3. Navigate to the directory where the Editor's binary path is located, select UE4Editor, and click the Open button.

    Click for full image.

  4. Now, click the Browse button that is located at the end of the Working directory: text field.

    Click for full image.

  5. Navigate to the directory where the Editor's binary path is located, select [UE4ROOT]\Engine\Binaries\Linux, and click the Choose button.

    Click for full image.

Section Result

Click for full image.

You're now ready to build and run UE4 with Qt Creator in both Debug and Release mode.

3. Building UE4 with Qt Creator

Now that you've configured Qt Creator to build and run UE4, you're ready to run UE4 from the IDE. Before you run UE4 from the IDE, you'll want to open some output windows so that you can see UnrealBuildTool at work.

  1. Click the Edit button to enter into Edit mode, opening Qt Creator's editor.
    Click for full image.
    While in Edit mode, you can view, debug, and edit the CPP source code powering UE4.
  2. By default, Qt Creator hides the main toolbar. Hover your mouse cursor over the top of the screen, touching the top edge to reveal the toolbar.
  3. Now, open the Window menu, hovering over the Output Panes sub-menu, clicking Compile Output. Alternatively, you can press the Alt+4 keyboard combination to open the Compile Output window pane.
    Opening the Compile Output window pane allows you to watch for any errors while building UE4 from source.

Building UE4

  1. Hover your mouse cursor over the top of the screen, touching the top edge to reveal the toolbar.

  2. To build UE4, open the Build menu and click the Build Project "UE4" button. Alternatively, you can press the Ctrl+B keyboard combination to build UE4.

Section Result

Click for full image.

At this point, you should see the compiler flushing messages to the Compile Output window inside of the IDE. Depending on your system's specifications, it may take anywhere from ten minutes to over an hour to compile the engine. If you want to shorten the time it takes to compile the engine from source, we recommend compiling the source code on a machine that has at least eight (8) gigabytes of RAM with a multi-core processor having at least eight (8) cores (including hyperthreading).

4. Running UE4 from Qt Creator

Now that you've compiled the engine, you're ready to run the editor. During this step, you're going to use the IDE to run UE4.

  1. If you want to view the status of your application while running UE4, you'll want to open the Application Output window pane. To open the Application Output window pane, press the Alt+3 keyboard combination.

    Click for full image.

  2. To run UE4 from the IDE, click the Run button. Alternatively, you can press the Ctrl+R keyboard combination to run UE4 from the IDE.

    Click for full image.

Section Result

Click for full image.

Congratulations! You should now see UE4 running from your IDE.

5. Creating a Blueprint Project

You can create either Blueprint or CPP projects from the Project Browser in UE4. In this section, we'll show you how to create a new Blueprint project from UE4. For the purposes of this guide, let's suppose that you want to create a new Blueprint game with a flying mechanic. Fortunately, UE4 is shipped with the perfect template for you!

  1. While in the New Project menu, make sure that the Blueprint menu is open.

    Click for full image.

  2. Select the Flying Blueprint project template and name the project FlyingBP_Prj.

    Click for full image.

  3. Finally, click the Create Project button to create your new Blueprint project using the Flying Blueprint project template.

    Click for full image.

    Depending your system specifications, it may take a couple of minutes for UE4 to create your new Blueprint project.

Section Result

Click for full image.

UE4 will launch your new Blueprint project without any additional steps.

Click for full image.

Congratulations! You've just created a new Blueprint project from UE4 with the help of a Blueprint project template. Creating any type of Blueprint project, with or without a project template, is now within your reach. There are times; however, when you'll want to create and modify the source code driving your game. In the next section, we'll show you how to create a new CPP project from UE4.

6. Creating a C++ Project

By now, you've learned how to configure your IDE to run UE4 in a Linux environment. Also, you've learned how to create a new Blueprint project using a Project template. In this section, we'll show you how to create a new C++ (CPP) project from UE4. For the purposes of this demonstration, let's suppose that you want to create a new CPP game with a driving mechanic.

  1. While in the New Project menu, make sure that the C++ menu is open.
    Click for full image.
  2. Select the Vehicle CPP project template and name the project DrivingCPP_Prj.
    Click for full image.
  3. Finally, click the Create Project button to create your new CPP project using the Vehicle CPP project template.
    Click for full image.
    Depending on your system specifications, it may take a couple of minutes for UE4 to create your new CPP project. After UE4 creates your new CPP project, an instance of Qt Creator for your new CPP project will be launched, closing UE4Editor in the process.
  4. At this point, you should see Qt Creator's Configure Project menu in the newly launched instance of Qt Creator. Use what you've learned thus far to configure your new CPP project to have the following Build Settings for Debug Mode; And Release Mode:
    At this time, project settings aren't inherited from the original UE4 Editor project settings. So, when you create a new UE4 CPP project using Qt Creator, you'll need to configure the project settings using the same steps that you learned earlier in this guide.
  5. Now, configure your new CPP project to have the following Run Settings:
  6. Switch to Edit mode in your IDE by clicking on the Edit button in the left panel of your IDE. Alternatively, you can press the Ctrl+2 keyboard combination to open Qt Creator's Edit Mode.
    Click for full image.
  7. Now, click the Run button. Alternatively, you can press the Ctrl+R keyboard combination to run UE4 from the IDE.
    Click for full image.
  8. After the Missing DriveCPP_Prj Modules dialogue box appears, click the Yes button.
    Click for full image.
  9. Depending on your system specifications, it may take several minutes for the IDE to build and launch your new CPP project.
    Click for full image.

Section Result

Click for full image.

Congratulations! You should now see your new CPP project running from inside of Qt Creator. Now that you've created and launched your new CPP project, you've learned everything you need to work on UE4 projects from an IDE in your Linux environment.

Getting Started with Unreal Engine

As you worked your way through this tutorial, you learned:

✓ How to configure your IDE to build and run UE4 in debug and release mode.
✓ How to build and run UE4 from your IDE.
✓ How to create and configure new Blueprint and C++ projects with UE4 from your IDE.

Now, learn how to use Unreal Engine by referring to our Get Started with UE4 documentation! Also, if you're looking to quickly get started producing content with UE4, you can also check out the following tutorials: