Live Link Curve Debugger

Live Link Curve Debugger を使用すると、さまざまな Live Link カーブの出力を簡単にデバッグできます。

Windows
MacOS
Linux

Live Link プラグインを使用して Unreal Engine 4 (UE4) にコンテンツをストリーミングするときに、さまざまな種類のアクティブなカーブや値を表示したいことがあります。Live Link Curve Debugger は、さまざまな Live Link カーブの出力をデバッグしやすい方法で表示できるツールです。 

Live Link Curve Debugger を有効にする

Live Link Curve Debugger を使用するには、最初に [Plugins (プラグイン)] メニューで有効にする必要があります。

  1. [Edit (編集)] メニューから [Plugins] を選択します。 

    01_PluginMenu.png

  2. [Plugins] メニューの [Animation] から [Live Link][Live Link Curve Debug UI] の両方の UI オプションを有効にし、エディタを再起動します。 

    02_EnableLiveLinkOptions.png

  3. [Window] メニューの [Developer Tools (デベロッパーツール)] から [Live Link Curve Debugger] を選択します。 

    03_DebuggerWindow.png

    [Live Link Curve Debugger] ウィンドウが開きます。 

    04_DebuggerWindowOpen.png

Live Link Curve Debugger を使用にする

Maya または Motion Builder に Live Link で接続すると、アニメーション カーブも含めてアプリケーションに含まれるコンテンツに UE4 内からアクセスできるようになります。Live Link Curve Debugger を使用すると、現在選択されている サブジェクト名 のすべてのカーブとカーブの値がリストされます。これは、 [Live Link Subject Name] ドロップダウン メニューをクリックしてサブジェクトを選択することで定義できます。 

DebuggerWindowSubject.png

サブジェクトを選択すると、すべてのカーブとその値がウィンドウに表示されます。 

画像をクリックしてフルサイズで表示

サブジェクト名を指定していない場合は、1 つのカーブに接続するとすぐにデバッカーがその名前に切り替わります。この選択を変更するには、 [Live Link Subject Name] ドロップダウン リスト (エディタ または デスクトップ ビルドで) をクリックするか、コマンドラインに 「LiveLinkDebugger Next」 と入力して、サブジェクト名を順番に切り替えます (他のクライアント ビルド上で)。

クライアント内部では、 「LiveLinkDebugger Show」 というコマンドで Live Link Debugger を表示することもできます。

必要に応じて、 「LiveLinkDebugger Show SubjectName (サブジェクト名前を指定)」というコマンドを使用して、コマンドラインで Live Link サブジェクト名を指定することもできます。

Select Skin
Light
Dark

新しい Unreal Engine 4 ドキュメントサイトへようこそ!

あなたの声を私たちに伝えるフィードバックシステムを含め、様々な新機能について開発をおこなっています。まだ広く使える状態にはなっていないので、準備ができるまでは、ドキュメントフィードバックフォーラムで、このページについて、もしくは遭遇した問題について教えていただけると助かります。

新しいシステムが稼働した際にお知らせします。

フィードバックを送信