プロジェクト ブラウザ

新規プロジェクトを作成し、現行プロジェクトまたはダウンロードしたサンプル プロジェクトを開くためにプロジェクト ブラウザを使用する方法の説明

Windows
MacOS
Linux

アンリアル エディタを最初に実行すると、 プロジェクト ブラウザ が表示されます。

ProjectBrowserBoth.png

プロジェクト ブラウザは、プロジェクトの作成、現行プロジェクトを開く、またはサンプルゲームやショーケースなどのサンプル コンテンツを開くための出発点です。

プロジェクト ブラウザを使用せずにエディタで直ちに特定のゲームを開くために、コマンドライン引数としてゲーム名を実行ファイルへ渡すことが可能です。

プロジェクトを開く

プロジェクト ブラウザにある最初のタブは、 [Projects] タブです。

OpenProject_single.png

エディタで見つかった全プロジェクトがサムネイル化したリストで表示されます。デフォルト設定では、インストール フォルダにある全プロジェクト、エディタで作成したプロジェクト、 もしくは以前開いたプロジェクト全てがリストに表示されます。

プロジェクトを開くにはいずれかのサムネイルを ダブルクリック します。

プロジェクトのサムネイルは、プロジェクト フォルダにあるプロジェクトと同じ名前を持つ 「192x192 .png」ファイルになります。キーを "Update Project Thumbnail" にバインドして、 スクリーンショットを迅速に撮ってプロジェクトのサムネイルにすることができます。プロジェクトのサムネイルを作らないと、プロジェクトに対してエディタを終了するたびにスクリーンショットが自動的に撮られます。

プロジェクトを検索するには、 [Filter Projects... (プロジェクトをフィルタリング)] 検索ボックスにテキストを入力します。

[Browse... (ブラウズ)] ボタンをクリックして、ナビゲートし、「.uproject」ファイルを選択して手動で開くこともできます。

[Projects] タブで [Always load last project on startup (起動時に最後に使用したプロジェクトを常にロード)] チェックボックスにチェックを入れて最近のプロジェクトを自動的に開くようにすることで プロジェクト ブラウザ をスキップすることもできます。エディタでこの設定を変更するには、 以下の手順に従います。

  1. エディタの環境設定 ウィンドウを開きます。

  2. 以下のようにナビゲートします。 [General] > [Loading & Saving]

  3. [Startup] の見出しの下にある、 [Load the Most Recently Loaded Project at Startup] を切り替えます。

このタブは、アンリアル エディタ内から File > Open Project の順に選択した場合にも表示されます。

open_project_menu.png

新規プロジェクトの作成

プロジェクト ブラウザにある 2 つめのタブは、 [New Project] タブです。

NewProject_FPSExample.png

[New Project] タブにプロジェクトを開始するテンプレートが表示されます。[Blank] プロジェクトは完全にブランクのプロジェクトを作成します。 その他のテンプレートは、次の 2 種類に分類されます。Blueprints Only C++ テンプレートです。

例えば、 Side Scroller (ブループリントのみ) テンプレートと Side Scroller (C++) テンプレートがあります。この 2 つのテンプレートで制作されたゲームは、同一のレベルデザイン、キャラクター動作、またはカメラレイアウトをベースにしているため、 同じようにプレイします。違いはプロジェクトの初期フレームワークの作成方法です。

  • Blueprints Only - 最初のゲームプレイはブループリントで定義されます。ブループリントとは、UE4 のビジュアル・スクリプティング・アセットです。ブループリントを使用すると、 C++ のコードを記述する必要なしに、 アンリアル エディタでゲームプレイの動作を作ることができます。しかし、 Blueprints Only テンプレートで開始したプロジェクトに C++ コードを絶対に追加できないわけではありません。これは単に 最初の例がブループリントで提供されることを意味します。

  • C++ - 最初のゲームプレイは C++ コードで定義されます。C++ テンプレートで作成されたプロジェクトはアンリアル エディタで管理できますが、 Visual Studio で編集することもできます。ちょうど、 Blueprints Only プロジェクトが C++ コードで拡張できるように、 C++ テンプレートで開始したプロジェクトにブループリントを追加するのも簡単です。

プロジェクトの新規作成方法

  1. リストからテンプレートを選択します。

  2. starter content をプロジェクトにコピーするかどうかを選択します。

  3. プロジェクト名を入力します。

  4. [Create] をクリックします。

デフォルトの保存場所以外にプロジェクトを保存するには、矢印アイコンをクリックしてフルパスとファイル作成プレビューの表示を切り替えます。

new_project_advanced.png

新規プロジェクトが Blank テンプレートまたはブループリントのテンプレートに基づいたものである場合はエディタで開きます。新規プロジェクトが、 C++ テンプレートに基づいたものである場合は、 Visual Studio または XCode で開きます。

このタブは、アンリアル エディタ内から [File] > [New Project] の順序で選択した場合にも表示されます。

newprojectmenu.png

プロジェクト設定

Project_Options.png プロジェクト設定 を使って、対象のハードウェアの種類に応じて様々なパフォーマンス オプションを設定することができます。設定は [Project Settings - Target Hardware] で、お好きな時に変更することができます。

アイコン

説明

Desktop_Console_Option.png

作成するゲームの対象がデスクトップまたはコンソールの場合に使うオプションです。

Mobile_Option.png

作成するゲームの対象がモバイル デバイスの場合に使うオプションです。

Maximum_Quality_Option.png

作成するゲームの対象が、デスクトップやコンソールといったハイエンド デバイスの場合に使うオプションです。

Scalable_Quality_Option.png

作成するゲームの対象が、モバイル デバイスの場合に使うオプションです。

With_Starter_Content_Option.png

ゲームに スターター コンテンツ を入れたい場合に使うオプションです。

Without_Starter_Content_Option.png

ゲームに スターター コンテンツ を入れたくない場合に使うオプションです。

Starter Content はモバイル デバイス用には最適化されていないため、モバイル デバイス上で使用するとパフォーマンス上の問題を引き起こす可能性があります。

新しい Unreal Engine 4 ドキュメントサイトへようこそ!

あなたの声を私たちに伝えるフィードバックシステムを含め、様々な新機能について開発をおこなっています。まだ広く使える状態にはなっていないので、準備ができるまでは、ドキュメントフィードバックフォーラムで、このページについて、もしくは遭遇した問題について教えていただけると助かります。

新しいシステムが稼働した際にお知らせします。

フィードバックを送信