VRED から Datasmith コンテンツをエクスポートする

Autodesk VRED 用のエクスポート プラグイン スクリプトをインストールする方法と、Datasmith で Unreal にインポート可能な FBX に VRED シーンをエクスポートする方法について説明します。

Windows
MacOS
Linux

エクスポータ プラグイン スクリプトをインストールする

Unreal Engine で VRED のコンテンツを使用した作業を開始する前に、VRED 用のプラグイン スクリプトをインストールする必要があります。

エクスポータ プラグインで現在サポートされている VRED Professional のバージョンについては、「Datasmith でサポートされているソフトウェアとファイル形式」 を参照してください。

次の手順に従って、コンピュータにインストールした、サポートされているバージョンの VRED の Datasmith Exporter プラグイン スクリプトをインストールしてください。

  1. Unreal Engine のインストール フォルダから「Enterprise\Plugins\Editor\DatasmithFBXImporter\Extras\VREDPlugin」フォルダを見つけます。

  2. このフォルダとそのすべてのコンテンツを VRED によるプラグインの検索先にコピーします。
    例えば Windows プラットフォームでは、プライグインの検索先は C:\Users\Documents\Autodesk\VRED-\ScriptPlugins です ( はご使用の Windows ユーザー ID、 はインストールした VRED のバージョンになります)。
    このパスを見つけるための詳細については、VRED のドキュメント を参照してください。

    VRED の [Terminal] ウィンドウからこのパスを見つけることもできます。メイン メニューから [View (表示)] > [Terminal (ターミナル)] を選択して [Terminal] ウィンドウを開き、「Looking for script plugins in」 というテキストで始まる行を見つけます。例:
    vred-terminal.png

  3. VRED を再起動します。

Datasmith にエクスポートする

VRED シーンを仕上げてバリアントを登録したら、次の手順を実行して、シーンを FBX にエクスポートします。

  1. VRED のメイン メニューから次を選択します。

    • [File (ファイル)] > [Export (エクスポート)] > [Export to Datasmith... (Datasmith にエクスポート)] (VRED 2018 の場合)

    • [File (ファイル)] > [Export Scene Data (シーン データのエクスポート)] > [Export to Datasmith... (Datasmith にエクスポート)] (VRED 2019 の場合)
      Datasmith export from VRED

  2. フォルダを参照してファイル名を選択します。

エクスポータによって選択した場所に「.FBX」ファイルが作成されます。

最終結果

これで、新規の「.FBX」ファイルを Unreal Editor にインポートする準備が整いました。[「Datasmith コンテンツを Unreal Engine 4 にインポートする」(Engine/Content/Importing/Datasmith/HowTo/ImportingContent)] を参照してください。

さらに、エクスポータによって「 .FBX 」ファイルの横にシーン内のライトに関する追加情報を含む「 .lights 」ファイルと、登録したバリアントに関する情報を含む「 .var 」ファイルが作成されます。これらのファイルに含まれている情報は Datasmith インポータで必要になります。「 .FBX 」ファイルを別の場所に移動する場合は、必ずこれらのファイルも移動して、同じ相対パスに配置してください。

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback