アーティスト向けクイックスタート

コンテンツ クリエイターのための Unreal Engine 4 入門です。

Windows
MacOS
Linux
Prerequisite Topics

This page assumes you have prior knowledge of the following topics. Please read them before proceeding.

MaterialsHeader_1.png

このクイック スタート ガイドでは、Unreal Engine (UE4) のゲームにアセットを追加する方法について説明します。このガイドの最後まで進むと、 プロジェクト ブラウザ を使って新規プロジェクトを作成し、コンテンツ ブラウザ でコンテンツの確認および追加方法を理解します。マテリアル エディタ を使って スタティックメッシュ アクタ に適用する前に マテリアル を修正する方法を学びながら FBX コンテンツ パイプライン で情報を見つける方法も学びます。

保存は早めに、そして頻繁にしましょう。

1.必要なプロジェクトを設定する

  1. ランチャーから Unreal Engine を開きます。プロジェクト ブラウザ が表示されます。

  2. [Games] > 「Blank」テンプレートを使って、以下の設定で新規プロジェクトを作成します。

    • C++ を有効にする

    • With Starter Content を有効にする

  3. プロジェクト名を入力する必要があるので、ここでは「Artist_QuickStart」とします。

  4. [Create Project (プロジェクトを作成)] をクリックすると開始します。

Unreal Editor が新規プロジェクトを開きます。Visual Studio も開き、プロジェクトが作成したソリューション ファイルをロードします。

2. フォルダを作成する

プロジェクトのコンテンツをいつも整理しておくと便利です。まず最初に、インポートしたコンテンツを格納するフォルダを作成してみましょう。

開始前に、以下のリンクから Quick Start Assets (クイックスタート アセット) をダウンロードしてください。

  1. ダウンロードしたアセットをコンピュータで展開します。

    ExtractedContent.png

    ExtractedContent_Mac.png

  2. エディタの コンテンツ ブラウザ で、[Add New (新規追加)] ボタンをクリックします。

    AddNewButton.png

  3. [New Folder(新規フォルダ)] を選択して '/Game' にフォルダを作成します。

    NewFolderSelection.png

  4. フォルダに「QuickStartContent」という名前をつけます。

    NameQuickStartContentFolder.png

  5. QuickStartContent」フォルダをダブルクリックします。

命名規則は重要です。フォルダとファイルの命名には一貫性を持たせましょう。

3. メッシュをインポートする

コンテンツを UE4 プロジェクトに追加する方法は以下のように何通りかありますが、ここではコンテンツ ブラウザの Import 機能に焦点をあてます。

  1. 現在、「QuickStartContent」フォルダ内になっています。コンテンツ ブラウザの [Import] ボタンをクリックしてファイルのダイアログ ボックスを開きます。

    ContentBrowserImportButton.png

  2. Basic_Asset1Basic_Asset2 の FBX メッシュ ファイルを探して選択します。

    ImportMeshDialogBox.png

    ImportMeshDialogBox_Mac.png

  3. プロジェクトへの FBX メッシュ ファイルのインポートを開始するには、[Open] をクリックします。

  4. エディタ内に、[FBX Import Options] ダイアログ ボックスが表示されます。[Import (インポート)] または [Import All (すべてインポート)] をクリックすると、メッシュがプロジェクトに追加されます。

    FBXImportOptionsDialogBox.png

  5. [Save All (すべて保存)] ボタンをクリックしてインポートしたメッシュを保存します。

    SaveAllMeshesButton.png

  6. [Save Content (コンテンツを保存)] ダイアログ ボックスが表示されます。インポートしたアセットを保存するには、[Save Selected (選択したものを保存)] をクリックします。

    SaveSelectedDialogBox.png

  7. QuickStartContent」フォルダへ移動し、対応する .uasset files が UE4 で作成されたことを確認します。

    QuickStartContentFolder.png

    QuickStartContentFolder_Mac.png

アセットを整理しておけば、簡単に見つけることができます。

4.テクスチャのインポート

  1. [Import] ボタンをクリックしてファイル ダイアログ ボックスを開きます。

    ContentBrowserImportButton.png

  2. T_Rock_04_DT_Rock_04_n Targa (TGA) 画像ファイルを探して選択します。

    ImportTextureDialogBox.png

    ImportTextureDialogBox_Mac.png

  3. [Open] をクリックして TGA 画像ファイルのプロジェクトへのインポートを開始します。

  4. 確認ボックスがアンリアル エディタの右下隅に表示されます。

    TextureNormalConfirmation.png

  5. T_Rock_04_n.TGA 法線マップの設定を受け入れるには、 OK をクリックします。

  6. [Save All (すべて保存)] ボタンをクリックして、インポートした画像を保存します。

    SaveAllTextures.png

  7. [Save Content (コンテンツを保存)] ダイアログ ボックスが表示されます。

    ![](SaveSelectedDialogBox_textures.png)(w:550)

  8. インポートしたアセットを保存するには、[Save Selected (選択したものを保存)] をクリックします。

  9. QuickStartContent」フォルダへ移動し、対応する .uasset files が UE4 で作成されたことを確認します。

    QuickStartContentFolder2.png

    QuickStartContentFolder2_Mac.png

マーケットプレイス (Epic Launcher からアクセスできます) はコンテンツを探したり共有するための素晴らしい場所です。

5.インポートするメッシュを準備する

インポートするメッシュがある場合は、このセクションをご覧ください。

UE4 の FBX インポート パイプラインでは、FBX 2018 を使用します。エクスポート中に他のバージョンを使用すると、互換性がなくなる場合があります。

3D Art Tool を選択してください。

Autodesk Maya

Autodesk 3ds Max

  1. ビューポートでエクスポートするメッシュを選択します。

    maya_export_1.png

  2. [File] メニューから、[Export Selection (選択したメッシュをエクスポート)] を選びます (選択に無関係にシーン内のすべてをエクスポートする必要がある場合は [Export All (すべてをエクスポート)] を選びます)。

    maya_export_2.png

  3. Export ダイアログ ボックスで以下の操作を行います。

    • UE4 Project (1) 内の「Content」フォルダを選択します。

    • ファイル名を入力し、それを FBX Export (2) に設定します。

    • Export Options (3) を設定します。

    • [Export All (すべてエクスポート)] (4) をクリックします。

    maya_export_3.png

    上記の Geometry カテゴリの設定は スタティックメッシュ を Unreal Engine 4 へエクスポートする最も基本的な要件です。

    インポートをデフォルト オプションのままにしておくこともできます。各オプションの詳細については、FBX インポート オプションの参照 を参照してください。

  4. アセットがインポートされたので、コンテンツ ブラウザ からレベル内へドラッグ アンド ドロップすることができます。

    max_export_7.png

    (インポート オプションの一部として) 上の例では、 マテリアルテクスチャ をインポートしました。

  1. ビューポートでエクスポートするメッシュを選択します。

    max_export_1.png

  2. [File] メニューから、 [Export Selected] を選びます (選択に無関係にシーン内のすべてをエクスポートする必要がある場合は [Export] を選びます)。

    max_export_2.png

  3. UE4 Project (1) から「Content」フォルダ、そして FBX file (2) 用の名前を選択し、 max_save_button.jpg ボタンをクリックします。

    max_export_3.png

  4. [FBX Export] ダイアログボックスでオプションをセットし、 max_ok_button.jpg ボタンをクリックして、メッシュを含む FBX ファイルを作成します。

    max_export_4.png

    上記の Geometry カテゴリの設定は スタティックメッシュ を Unreal Engine 4 へエクスポートする最も基本的な要件です。

  5. インポートをデフォルト オプションのままにしておくこともできます。各オプションの詳細については、FBX インポート オプションの参照 を参照してください。

  6. アセットがインポートされたので、コンテンツ ブラウザ からレベル内へドラッグ アンド ドロップすることができます。

    max_export_7.png

    (インポート オプションの一部として) 上の例では、 マテリアルテクスチャ をインポートしました。

完了です!UE4 にインポートするメッシュの準備方法について学習しました。

FBX コンテンツ パイプラインに関する詳細はここをクリック してください。

モデリングを整理するとゲームのパフォーマンスが向上します。

6.マテリアルを作成する

マテリアル はメッシュに適用されるアセットで、シーンに見た目の美しさを加えます。
UE4 プロジェクト用マテリアルを作成、編集する方法は何通りかありますが、ここでは マテリアル エディタ を使う方法を紹介します。

  1. コンテンツ ブラウザ へ移動して [Add New (新規追加)] をクリックし、 [Material] を選びます。

    newCreateMaterial.png

  2. マテリアル名を「Rock」にします。

    materialNaming.png

  3. これで 'Rock' マテリアル が使える状態になりました。

    NewRockMaterial.png

  4. 'Rock' マテリアル をダブルクリックすると、マテリアル エディタ が開きます。

    マテリアル ノードの操作については、マテリアル操作ガイド を参照してください。

2 のべき乗をつかってテクスチャ サイズを調整します。

7.マテリアルの編集

この時点で、新規マテリアルが作成されて マテリアル エディタ が開いていることでしょう。

マテリアル エディタ の中で、マテリアルの色、輝き、透明度をはじめ、マテリアルの様々な定義を設定することができます。それでは、作成した Rock マテリアル の編集を行ってみましょう。

  1. マテリアル グラフ 中央の Main Material ノードを選択します。選択すると、マテリアル エディタ でノードがハイライトされます。

    newMainNode.png

    グラフエリア内にはこのノードしかありません。マテリアルにちなんだ名前が付けられます。

  2. [Details(詳細)] パネルで [Shading Model][Default Lit] から [Subsurface] に変更します。

    selectSubsurface.png

  3. [Subsurface Shading Model] を選択すると、Main Material ノード の Opacity と Subsurface Color のピンがさらに有効になります。

    newMorePins.png

  4. テクスチャをグラフに入れます。エディタのグラフ内で [T] キーを押しながら左クリックします。Texture Sample ノード がグラフ内に表示されます。

    TextureSample.png

  5. テクスチャは最低 2 つはあるといいでしょう。以下のようになるまで、ステップ 4 を繰り返してください。

    newTextureSampleNodes.png

  6. Texture Sample ノード をどれか 1 つ選択し、[Details] パネル[Material Expression Texture Base] カテゴリを見つけてください。

    matExpressionTextureBase.png

    Texture プロパティで、'None' というプルダウン メニューを左クリックして、T_Rock_04_D というカラー テクスチャを選びます。

    検索フィールドに「T_Rock_04_D」と入力して、テクスチャ アセットを検索できます。

  7. もう片方の Texture Sample ノード にも同様のプロセスを行いますが、T_Rock_04_n という法線マップテクスチャを選択します。

    newBothTexturesSelected.png

    マテリアル グラフは上の画像のようになります。

  8. T_Rock_04_D テクスチャ サンプルの カラーピン (白) を Rock マテリアルの Base Color ピン に接続します。

    newConnectColorPin.png

    いま接続した 白いピン にはテクスチャのカラー チャンネルが含まれています。

  9. T_Rock_04_n テクスチャ サンプルの Normal ピン (白) を Rock マテリアルの Normal ピン に接続します。

    newConnectNormalPin.png

    この 白いピン には、テクスチャの Normal Map 情報が含まれています。

  10. プレビュー すると、下の画像のようになっているはずです。

    newPreview_DN.png

  11. [1] キーを押したまま [Graph] パネル内で左クリックすると、Constant ノードが 3 つ作成されます。

    Constants.jpg

    Constant ノード は、変更可能なスカラーの float 変数です。**

  12. [3] キーを押したまま [Graph] パネル内で 左クリック すると、Constant3Vector ノードが 3 つ作成されます。

    Constant3.jpg

    Constant3Vector ノードはアルファ チャンネルのない色に対応する変更可能なベクターです。

    Constant 表現式については、Constant 表現式 を参照してください。

  13. ワイヤーが交差したり重なりあったりせず、簡単に接続できるようにノードを調整してください。

    newMatConstantsAdded.png

  14. すべての Constant ノードと Constant3Vector ノードを 'Rock' Material Main ノードの対応するピンに接続します。

    newAllNodesConnectedNoVal.png

  15. [Details] パネルの Value パラメータを更新することで、ConstantConstant3Vector のそれぞれの値を変更します。

    • Specular Value = 0.0

    • Roughness Value = 0.8

    • Opacity Value = 0.95

    • Subsurface Color = Red(1,0,0)

    newAllConnectedAllAdjusted.png

  16. プレビュー すると、下の画像のようになっているはずです。

    newPreviewAll.png

    マテリアル エディタ を終了する前に、必ずマテリアルを保存してください。

あともう少しです!ここまでで マテリアル エディタ を使って、Rock マテリアル を編集しました。

マテリアル エディタのキーボード ショートカットの一覧は、[Edit Menu (編集メニュー)] -> [Editor Preferences (エディタの環境設定)] -> [Keyboard Shortcuts (キーボードのショートカット)] -> [Material Editor] および [Material Editor - Spawn Nodes] カテゴリで確認できます。

8.マテリアルを Static Mesh アクタへ適用する

いよいよ仕上げの段階です。

このステップの目的は、インポートしたスタティック メッシュに マテリアル を適用することです。具体的には、以下について学習します。

アクタのデフォルト マテリアルを設定する

このセクションでは Static Mesh アクタ のデフォルト マテリアルの設定方法を説明します。アクタ がレベル内に配置される時には必ずデフォルト マテリアルが使われます。

  1. コンテンツ ブラウザ 内で、前のステップでインポートしたアセットをダブルクリックします。

    newBrowserContenAsset.png

    スタティックメッシュ エディタ に編集用のアセットが取り込まれます。

    StaticMeshEditor.jpg

  2. [Details (詳細)] パネルの LOD0 で [Material] ドロップダウン メニューをクリックします。

    LOD0.png

  3. 前のステップで作成した 'Rock' マテリアル を選択します。選択ウィンドウでマテリアルを利用できます。

    selectRockMaterial.png

    新しく適用したマテリアルを有効にするために [Preview (プレビュー)] ペイン が更新されます。

    NewDefaultMaterial.jpg

  4. まず [Save (保存)] ボタンをクリックしてから、 マテリアル エディタ を閉じます。

  5. コンテンツ ブラウザ 内で新しくテクスチャ化した Static Mesh アクタをレベル内にドラッグ&ドロップします。

    newMaterialInLevel.png

    このアセットをレベル内に配置する場合は、指定した マテリアル が使用されます。

アクタが使用するマテリアルを変更する

レベル内に Static Mesh オブジェクトを置く時に、オブジェクト (アクタ ) のインスタンスを作成しました。その アクタ のインスタンスのそれぞれに、マテリアルを指定することができます。

Static Mesh アクタの マテリアルは以下の手順で変更します。

  1. Static Mesh アクタ を選択します。

    newStatisMeshSelected.png

  2. [Details (詳細)] パネルの [Material] セクションで、[Materials] ドロップダウン メニューをクリックします。

    materialDropDown.png

  3. ポップアップ メニューで、別のマテリアルを選択します。

    selectTutorialAssetMat.png

  4. または、新しいマテリアルを Static Mesh アクタ 上にドラッグ&ドロップします。

    newMaterialDrop.png

以下の方法で、Static Mesh アクタにマテリアルを適用しました。

  • アクタのデフォルト マテリアルを設定する。

  • アクタが使用するマテリアルを変更する。

アーティスト向けクイック スタート ガイドが終わりました。ここまでに修得したスキルは以下の通りです。

✓ プロジェクトを設定する
✓ マテリアルを作成する
✓ マテリアルを編集する ✓ スタティックメッシュ アクタにマテリアルを適用する

それでは力を試してみましょう。

9.応用編

ではこれまでの知識を踏まえて、このグラフと同様の マテリアル を作成してみましょう。

PlasticMaterialNetwork.png

Main Material ノード設定で、プラスチック マテリアルのシミュレーションを行います。

Basic_Asset1 をレベルへ追加し、それにマテリアルを適用し、マテリアルを更新して "Brick" のNormal Map テクスチャを追加します。

NormalMapAdded.jpg

このクイックスタート ガイドで扱ったトピックの詳細情報については、Unreal Editor のマニュアル をご覧ください。

以下は、コンテンツの各種タイプのインポートに関する情報です。

このクイックスタートガイドで取り上げている詳細は以下の通りです。

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback