マルチ ユーザー編集入門

プロジェクトでマルチ ユーザー編集を起動、実行するための手順を段階ごとに説明します。

Windows
MacOS
Linux

クイック スタート ページではマルチ ユーザー編集システムを起動し、基本機能を実行します。このチュートリアルでは、以下の習得を目指します。

  • 複数のコンピュータからセッションに参加するための設定方法

  • セッションを管理するサーバーの開始方法

  • チームメンバーと共同作業をするためのセッションの開始および参加方法

  • ローカル コンピュータでセッションで作業中に行った変更をプロジェクト コンテンツで維持する方法

前提条件: このチュートリアルは、Unreal Editor の複数インスタンスを使って同じホストで実行できますが、複数の別々のコンピュータから同じセッションに接続する方がはるかに効果的です。開始方法

  • 各コンピュータに同じバージョンの Unreal Engine をインストールします。

  • すべてのコンピュータが同じローカル エリア ネットワーク (LAN) または仮想プライベート ネットワーク (VPN) に接続されていることを確認します。

この手順の画像は Epic Games Launcher の [Learn (ラーニング)] タブから取得できる Virtual Camera サンプル プロジェクトを使用します。ただし、使用する Unreal Engine プロジェクトにはすべて同じステップを使用できます。

1 - プラグインをアクティベートする

共有セッションで共同作業をするためには、Unreal Editor の複数インスタンスに接続する前に、プロジェクトで **マルチ ユーザー編集**プラグインを有効にする必要があります。

  1. Unreal Editor でプロジェクトを開きます。

  2. メイン メニューから [Edit (編集)] > [Plugins (プラグイン)] を選択します。

  3. [Developer (デベロッパー)] カテゴリで [Multi-User Editing (マルチ ユーザー編集)] プラグインを見つけ、[Enabled (有効)] チェックボックスをオンにします。

  4. 確認画面で [Yes (はい)] をクリックします。

    Confirm

  5. [Restart Now (すぐに再起動)] をクリックしてプロジェクトを再起動し、変更を適用します。

2 - 複数のコンピュータをセットアップする

同じマルチ ユーザー編集セッションに接続する各コンピュータに同じバージョンの Unreal Engine をインストールする必要があります。

各コンピュータにコンテンツがまったく同じである Unreal Engine プロジェクトのコピーが配置されている必要もあります。

  • 一般的な方法として、Perforce、Git、Subversion などのバージョン コントロール システムにプロジェクトを保存し、すべてのコンピュータで同じリビジョンまたは変更リストに同期します。

    Perforce を使用している場合、UnrealGameSync (UGS) を使用してこのプロセスを簡単にすることもできます。詳細は UGS のドキュメント をご参照ください。

  • マルチ ユーザー編集システムでは、ソース コントロールの使用は必須ではありません。1 台のコンピュータから同じセッションに参加する他のすべてのコンピュータにプロジェクト フォルダをコピーするだけです。マルチ ユーザー編集システムの初期テストではこれで十分です。ただし、このアプローチは初期テストのみとしてください。チーム内でバージョン コントロールを効果的に使用することが、プロジェクト コンテンツを最も安全に維持共有する方法です。

各コンピュータにプロジェクトをコピーしたら、いくつかの設定をカスタマイズします。各コンピュータで以下を実行します。

  1. Unreal Editor でプロジェクトを開き、メイン メニューから [Edit (編集)] > [Project Settings... (プロジェクト設定...)] を選択します。

  2. [Project Settings (プロジェクト設定)] ウィンドウで、[Plugins (プラグイン)] > [Multi-User Editing (マルチ ユーザー編集)] セクションを開きます。

    次の設定を変更して、セッションへ接続している間にショートカット ボタンをエディタ UI に追加し、各 Unreal Editor インスタンスで他のインスタンスに表示するプレゼンス情報をカスタマイズします。

    設定

    説明

    Enable Multi-User Toolbar Button

    Unreal Editor のメイン ウィンドウのツールバーに、使用頻度の高いマルチユーザー編集コマンドのショートカット ボタンを追加します。

    Display Name

    対象コンピュータのセッション履歴とプレゼンス情報を表示するときにマルチ ユーザー編集システムが使用する名前を設定します。
    デフォルトでは、マルチ ユーザー編集システムはホスト オペレーティング システムの現在のユーザー ログイン情報を使用します。ただし、複数のコンピュータに同じユーザー アカウントでログインするなどの場合は、この値をオーバーライドできます。

    Avatar Color

    プレゼンス情報とセッション履歴を表示するときに、対象コンピュータにマルチ ユーザー編集システムが関連付ける色を設定します。
    この色はデフォルトではすべてのユーザーが同色 (白) ですが、コンピュータごとに異なる色を割り当てると、自分のセッション履歴をが簡単に分かるようになります。

    このパネルで使用できる設定については、「マルチ ユーザー編集リファレンス」 を参照してください。

  3. 新しい設定を有効にするためにエディタを再起動します。

3 - サーバーを開始する

互いに接続する各コンピュータで Unreal Editor でプロジェクトを開く場合、これらのコンピュータで共有するセッションを管理するためにサーバーを開始する必要があります。一番簡単な実行方法は、これらの Unreal Editor インスタンスのいずれかで開始することです。

  1. ツールバーの [Multi-User Editing] アイコンをクリックします。(セッションには接続されていないことを示す「Browse」となっているはずです)

    Browse

  2. Multi-User Browser ウィンドウが開きます。このパネルから、マルチ ユーザー編集システムでの作業に必要なほとんどのセッション管理ツールへアクセスできます。このウィンドウを頻繁に使うことになります。

    ツールバー アイコンをアクティブにしていない場合でも、Window > Developer Tools > Multi-User Browser をクリックすることで、いつでもこのパネルを開くことができます。

  3. Multi-User Browser ウィンドウで、ツールバーの一番左側にある [Launch] アイコンをクリックして、コンピューター上でマルチ ユーザー編集システムを起動します。

  4. 新しいコマンド ウィンドウが開きます。プロジェクト コンテンツに変更を加えたときやセッションを管理しているときに、サーバーは定期的にステータス メッセージをこのウィンドウに出力します。例:

Unreal Engine がインストールされているコンピュータでコマンド ラインからサーバーを起動することもできます。詳細については、「マルチ ユーザー編集リファレンス」ページのUnrealMultiUserServer コマンドライン パラメータ セクションを参照してください。

4 - セッションを開始する

コンピュータのいずれかでサーバーが動作していますが、Unreal Editor インスタンスはどれもまだサーバーに接続されていません。これを実行するには、新しいセッションを作成する必要があります。すべての接続ユーザーがプロジェクトのアセットとレベルに加えた変更をセッションが管理し共有します。

新規セッションを作成する方法

  1. ご使用のコンピュータの 1 つで [Multi-User Browser] ウィンドウを前のセクションで示したように開きます。

    ここではセッションがまだリストされていません。しかし、サーバーが動作しているコンピュータが、この Unreal Editor のインスタンスが動作しているコンピュータからネットワークを通じて認識できる限り、新しいセッションを作成できます。

  2. [Multi-User Browser] ウインドウのツールバーの Create a New Session アイコンをクリックします。

    リスト ビューに新しいセッションを設定するための行が追加されています。

  3. 新しいセッションの名前を入力し、ドロップダウン リストからセッションを管理するサーバーを選択します。(今現在、このリストで選択できるサーバーは 1 つだけです)次に、一番→のチェックボックス アイコンを選択してセッションを作成します。

    Unreal Editor が動作しているコンピュータが同じ LAN または VPN にあるにもかかわらず、新しいセッションを作成できない、もしくはサーバーが サーバー ドロップダウン リストに表示されない場合、この時点で中断して、追加のネットワーク コンフィギュレーションを実行することをお勧めします。Advanced Multi-User Networking をご参照ください。

新しいセッションに自動接続されます。[Multi-User Browser] ウインドウのレイアウトは、ジョインしたセッションの詳細を表示するために変化します。

さらに、接続状態であることを示すために、メインの Unreal Editor のツールバーのボタンが変化します。

Multi-User Editor connected in the Toolbar

5 - セッションに参加する

サーバーが動作し、1 台のコンピュータで Unreal Editor からサーバーにセッションを作成したので、他のコンピュータで動作している Unreal Editor のインスタンスから同じセッションに接続できます。

セッションに参加する、他のコンピュータで以下を実行します。

  1. [Multi-User Browser (マルチ ユーザー ブラウザ)] ウィンドウを開きます。他のコンピューターで作成したセッションをこのリストで表示されます。

  2. プロジェクトの詳細およびそのセッションに接続中の人を確認するためにセッションを選択します。

    セッションにマウスオーバーすると詳細を確認することができます。

    Session tooltip

  3. ツールバーの [Join the selected session (選択中のセッションにジョインする)] アイコンをクリックします。(またはセッション名をダブルクリックします。)

接続したら、[Multi-User Browser] ウインドウのレイアウトは、ジョインしたセッションの詳細を表示するために変化します。Clients リストの接続された すべての ユーザーとシェアード セッションのすべての参加者による変更履歴を確認することができます。

ユーザー自身が参加する前に、このセッションで他のコンピュータから作業していて、プロジェクトのアセットやレベルに変更を加えている場合、Unreal Editor のインスタンスはサーバーからこれらのトランザクションを自動的に取得し、共有セッション ワークスペースのローカル ビューにそれらの変更を適用します。他のすべての参加メンバーと同じコンテンツを作業するようになりますが、Unreal Editor UI で必要なコンテンツを自由に作業できます。レベル ビューポートでカメラの視点を動き回らせる、コンテンツ ブラウザで新しいフォルダを参照する、ツールを切り替える、新しいウィンドウやパネルを開く、など他のユーザーに影響を与えることなく実行できます。

単一のセッションに複数のコンピュータが接続したので、1 台のコンピュータで変更して、同じセッションの他のコンピュータにどのように変更が伝わるのかを確認できます。

6 - 共同作業する

同じライブ セッションに複数のユーザーが接続されているので、仮想ワールドを共同で構築できます。Unreal Engine プロジェクトで通常通り作業しますが、他のユーザーの変更が適用されたらすぐに結果が反映されます。

ライブで作業しているときの想定される内容については、マルチ ユーザー編集の概要 を参照してください。

7 - セッションの変更を保持する

この時点で、チームメンバーを含めて、プロジェクトのいくつかのアセットやレベルに変更を加えています。しかし、これらのトランザクションは使用するコンピュータのプロジェクト コンテンツを構成する実際のファイルにまだ反映されていません。このライブセッションでチームが実行した作業を保持する場合は、これらの変更を保持する必要があります。つまり、マルチ ユーザー編集システムが管理するすべてのトランザクションをローカル プロジェクト ファイルに適用しなければなりません。

ツールバーの [Source Control (ソース コントロール)] の各ツールを使用して変更を保持します。ソース コントロール プロバイダを使用しているかどうかは関係ありません。

  1. メイン ツールバーの [Source Control (ソース コントロール)] ボタンの隣にある矢印をクリックし、[Persist Session Changes (セッションの変更を保持)] を選択します。
    Persist Session Changes

  2. [Persist & Submit Files (ファイルの保持とサブミット)] ウィンドウで、ライブ セッション中に変更されたすべてのファイルのリストが表示されます。変更されたファイルのチェックボックスで、ローカル コンピュータのプロジェクト ファイルに適用する対象を指定します。
    Persist & Submit Files

  3. セッションを開始する、またはセッションに参加するときにソース コントロール プロバイダがセットアップされている場合、新しい変更リストやリビジョンで保持する変更をそのプロバイダにすぐにサブミットするオプションがあります。

    すぐにサブミットしない場合、マルチユーザー編集システムはソースコントロール プロバイダーから自動的に修正済みのファイルをチェックアウトして、変更内容をご使用のコンピューターのローカル ファイルに保存します。その後、引き続き修正 (セッション中、またはセッションから出てオフライン状態で) が可能です。そして、標準のソース コントロール ワークフローを使用してすべての変更を後でまとめてサブミットすることができます。

    セッションでの変更内容をソース コントロールにすぐにサブミットするには、以下の手順を行います。

    1. ウィンドウの一番下にある [Submit to Source Control (ソース コントロールにサブミット)] チェックボックスをオンにします。

      Submit to Source Control

    2. 通常のソース コントロール ワークフローと同様に、サブミットする変更の説明を入力する必要があります。ウィンドウの一番上にある [Changelist Description (変更リストの説明)] を展開し、このボックスに説明を入力します。

      Set a changelist description

    3. サブミットするファイルにさらに変更を加える必要があることがわかっている場合、通常のソース コントロール ワークフローと同様に [Keep Files Checked Out (ファイルのチェックアウトを維持)] チェックボックスをオンにできます。

      Keep Files Checked Out

  4. ファイルのリストをサブミットする準備ができたら、ソース コントロール オプションを設定して、[Submit (サブミット)] をクリックします。

    Submit

セッションに接続したままで、そのまま作業を続けられます。

8 - クリーン アップ

ライブ セッションでレベルやアセットにチームメンバーも含めて加えた変更をディスクのプロジェクトに適用し、オプションでこれらの変更をソース コントロール システムにコミットしたので、セッションが必要なくなっている可能性があります。離れたセッションに再び参加し、選択できますが、長時間古いセッションで作業を続けるのではなく、更新された変更リストから新しい編集セッションを定期的に開始することをお勧めします。

セッションが必要なくなったら、[Multi-User Browser] を使用して削除できます。

削除できるのは、セッションを作成したユーザーだけです。他のユーザーには、対象のセッションに参加していた場合でも、[Multi-User Browser] のオプションが表示されません。

  1. まだ実行していない場合は、セッションから切断します。接続されている間にセッションは削除できません。

    ツールバーに [Multi-User Editing] ボタンを表示している場合、接続中は [Leave] と表示されます。このボタンをクリックすれば、セッションを去ることができます。

    Leave the current session from the Toolbar

  2. 切断後、[Multi-User Browser] でセッションを選択し、ツールバーの [Delete] アイコンをクリックして削除します。

  3. 削除を確定します。

    Confirm deletion

    削除したセッションに接続している他のユーザーがいる場合は、自動的に切断されます。

  4. 共有セッションにしばらく再接続する必要がないことがわかっている場合は、コンソール ウィンドウで、Ctrl+C を押して、サーバーを停止できます。

    コンソール ウィンドウをそのまま閉じることは避けてください。サーバーで異常シャットダウンと認識します。コンソール ウィンドウを閉じたときアクティブであるセッションは、次にサーバーを開始したときに自動的に復元されます。

ここでチュートリアルの最初に戻りますが、共有セッションですべてのユーザーが行った変更が反映されています。 

9 - 応用編

以上の手順を問題なく完了しました。Unreal Editor での共同作業のワークフローの感触がつかめたと思います。複数のコンピューターでプロジェクトの設定方法、これらのコンピューターを共同編集セッションへ接続する方法、仮想ワールドをビルドするためにチーム メンバーと協力する方法を学習しました。マルチユーザー編集システムを使用すれば、迅速な連携、イタレーション時間なし、創造的な協力など、このワークフローを独自のプロジェクトの自分のチーム内で活かすことができます。

  • チームでマルチ ユーザー編集システムを定期的に使用する場合、[Project Settings (プロジェクト設定)] にデフォルト サーバー名とセッション名を設定すると便利です。設定すると、ツールバー ボタンが更新されて、[Browse][Join] になります。[Toolbar] アイコンを 1 回クリックするとデフォルト セッションに参加できます。プロジェクトを開いたときに、デフォルト セッションに自動的に接続するように選択することもできます。

  • 複数のユーザーが同じアニメーションの同期再生を確認する必要がある場合、マルチ ユーザー編集システムを設定して、異なるユーザー間でシーケンサ UI の操作を同期することができます。一部のコンソール コマンドを設定することで、各ユーザーがこれにオプトインする必要があります。

変更の必要がある設定ついては、マルチ ユーザー編集リファレンス を参照してください。

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback