Level アセットで作業する

UE4 で Level アセットを作成、保存し、開きます。

Windows
MacOS
Linux

UE4 のレベルはほとんど コンテンツ ブラウザ の他のアセットと同じように扱うことができます。レベルを作成、保存し、開くことに関して留意して頂きたいことがいくつかあります。 このガイドでは、そうしたことに関する基本を説明します。

レベルを作成する

Blueprint クラス、マテリアル、パーティクル システムのような 他のアセットを作成する のと同じように、コンテンツ ブラウザ で、 新規レベルを作成することができます。レベルはプロジェクトをどのようにレイアウトし整理するかということにも関連するので、[File] メニューから作成することもできます。

  1. [File] メニューを開きます

    FileMenu_Windows.png

    FileMenu_Mac.png

  2. [New Level (新規レベル)] を選択します。

    NewLevel_Windows.png

    NewLevel_Mac.png

    キーボードのショートカット、Ctrl + N キーを使用して新規レベルを作成することもできます。

    [New Level (新規レベル)] を選択すると、新規レベル作成の基本となる様々なテンプレートを表示するポップアップボックスが表示されます。

    NewLevelWindow_Windows.png

    NewLevelWindow_Mac.png

    • デフォルト: これを使用すると、基本的なセットアップで新規レベルが作成されます。こうした基本的セットアップには、プレイヤー スタート、ライト、天空、およびレベルが適切に機能するために必要な様々なアクタが含まれます。

    • VR-Basic: インタラクションするアクタを含む新規レベルが作成され、VR エディタの制御を学ぶガイドになるように設計されています。

    • Blank: これを使用すると完全に空の新規レベルが作成されます。

  3. 使用を開始したいテンプレート上で左クリックします。

ソース コントロールに接続すると、作成し保存する新規レベルが自動的にソース コントロールに追加されます。

新しいブランク レベルを作成したり、 レベル ウィンドウ を使用して既存のレベルのセクションを分割することもできます。

レベルを保存する

最初に保存した後に、レベルを保存するのは非常にわかりやすいプロセスです。[File] メニューまたは コンテンツ ブラウザ から開始できますが、最初に保存するときに いくつかの追加のステップが必要になります。さらに、レベルを変更すると [Save Content] ダイアログで現在のレベルを保存するように促されます。

SaveContentLevels.png

現在のパーシスタント レベルおよび / またはサブレベルを、 Levels ウィンドウ で保存することもできます。

レベルを初めて保存するには以下の手順に従います。

  1. [File] メニューを開きます

    FileMenu_Windows.png

    FileMenu_Mac.png

  2. [Save] を選択します。

    SaveLevel_Windows.png

    SaveLevel_Mac.png

  3. 新しいレベルの場所と名前を選び、表示される [Save Level As] ウィンドウで [Save] をクリックします。これは、ファイル メニューから [Save As...] を選択または、Ctrl+Shift+S のキーボードのショートカットを使用した場合に 表示されるものと同じメニューです。

    SaveAs_Windows.png

    SaveAs_Mac.png

レベルを開く

コンテンツ ブラウザ で Level アセットをダブルクリックしてレベルを開くことができますが、レベルを作成するのと同じように、[File] メニューで作業することもできます。

  1. [File] メニューを開きます

    FileMenu_Windows.png

    FileMenu_Mac.png

  2. [Open Level] を選択します。

    OpenLevel_Windows.png

    OpenLevel_Mac.png

    キーボードのショートカット、Ctrl + O キーを使用してレベルを開くこともできます。

  1. 表示される [Open Level] ウィンドウからレベルを選択し、[Open] をクリックします。

    OpenLevelMenu_Windows.png

    OpenLevelMenu_Mac.png

Select Skin
Light
Dark

新しい Unreal Engine 4 ドキュメントサイトへようこそ!

あなたの声を私たちに伝えるフィードバックシステムを含め、様々な新機能について開発をおこなっています。まだ広く使える状態にはなっていないので、準備ができるまでは、ドキュメントフィードバックフォーラムで、このページについて、もしくは遭遇した問題について教えていただけると助かります。

新しいシステムが稼働した際にお知らせします。

フィードバックを送信