マチネのユーザーガイド

インゲームのプロパティとアクタのアニメートに使用するマチネエディタのガイドです。

Windows
MacOS
Linux

Unreal Engine 4.23 のリリース以降、マチネはサポートされなくなり、今後のリリースでエンジンから削除される予定です。削除後は、 マチネを実行することもマチネエディタを開くこともできなくなります。 Matinee to Sequencer Conversion Tool (マチネからシーケンサへ変換するツール) を使用して、できるだけ早くマチネのシーケンスをシーケンサのシーケンスに変換を行ってください。

MatineeOverview.png

マチネ シーケンスの作成

マチネ シーケンスを作成するには、Matinee アクタを作成して、シーン内へ配置します。マチネ シーケンスは以下のように様々な方法で作成できます。

  • アンリアルエディタの上の方にあるツールバーから [Matinee] ボタンを押して、 [Add Matinee (マチネを追加)] をクリックします。

    MatineeToolbar.png

  • [Place Mode] パネルで、 All Classes の Matinee を探してビューポートにドラッグします。

Matinee アクタの作成後に、マチネ インターフェースを表示してシネマティックを編集するには、 Matinee アクタを ワールド アウトライナー またはビューポートから選択します。 その後 [Details (詳細)] パネルの [Open Matinee (マチネを開く)] をクリックします。もしくは、アンリアルエディタの上の方にあるツールバーで [Matinee] ボタンを押して、 リストから [Matinee Actor] を選択します。

マチネでキーボード ショートカットのキー バインディングを設定したい方は、 [編集] メニューで [Editor Preferences (エディタの環境設定)] をクリックしてから、[Keyboard Shortcuts] をクリックします。 キー バインディングの表示および設定は、 [Matinee] セクションをスクロールダウンして展開して行います。

グループおよびトラックの操作

マチネは一連のグループを中心に構築されています。各グループには多数のトラックがあります。グループは、レベルの特定アクタと関連付けされます。

トラックやその用途の詳細は、 マチネ トラック リファレンス を参照してください。

新規グループの作成

マチネ シーケンスに新たにグループを作成するには、まずこれから修正を行うレベルでアクタを選択します。マチネの左側にあるグレーのバーを 右クリック して、 [Add New Group (新規グループの追加)] を選択します。

New Group menu

新しいグループ名の入力が求められます。そのマチネシーケンスに固有で、スペースを含まないグループ名にします。[OK] をクリックすると、新規グループの ヘッダが表示されます。ブループリントで [Matinee Action] を見ると、グループ名が付いた新しい変数コネクタと、そのグループを作用させたいアクタへのリファレンスを含んだObject 変数が新たに作成されたのがわかります。 複数のアクタを同一のグループ コネクタと接続することができます。 例えば、時間経過とともに複数のライトの輝度を制御する場合など大変便利です。

薄く色付けされたグループ ヘッダのバーは、エディタの「Group の色」です。シーンでオブジェクトをコントロールしているグループの特定など、 マチネの様々な場面で使用します。[Group] を選択してから、ウィンドウ下部の GroupColor プロパティを修正して色を変更することができます。Group タイトルを 右クリック すると、 グループ全体を「Rename (名前の変更) 」または「Delete (削除) 」することができます。一度グループを選択すると、上下矢印キーでリスト内を移動させることができます。 同様のグループをまとめて管理する際に便利です。

グループ (またはグループのトラック) が選択されると、常にレベルのアクタが選択されることに留意してください (逆もまた同様です)。

新規トラックの作成

グループ単独では、対象としているアクタに対して何の作用もできません。実際にアクタに何らかの変更を加えるには、トラックをそのグループに追加する必要があります。グループのヘッダ上を 右クリック すると、 [New Track] メニューが表示されます。このメニューには、追加可能な Matinee トラックの種類が全てリスト表示されます。希望するトラックを選択すると、そのトラックがグループ内に表示されるようになります。トラック クラスによっては、 追加する前にさらに情報を入力するように促される場合があります。

New Track menu

トラック タイプの中には (Movement Track など) 、グループ 1 つにつき 1 つのトラック タイプしか許されないものがあります。その一方で、同一グループ内に複数タイプのトラックが許されるものもあります (Float Property Track など) 。

マチネにトラックがあるアクタをビューポートで選択して、マチネ エディタを開くと、アクタのトラックがマチネ エディタでハイライトされます。

グループ内のすべてのトラックを非表示にする場合は、グループヘッダ上の矢印を押して、折りたたみます。グループ内でトラックの順番を変えるには、グループを移動する場合と同じように、 トラックを選択して上下の矢印キーを使用します。

トラックのエフェクトのオンとオフを切り替えるには、トラック名の横についているチェックボックスを使用します。例えば、次の画像では、 Movement トラックが無効になっているため、 Matinee シーケンスが実行される際に Movement トラックのエフェクトが見えなくなります。

Track view with Movement track disabled

キーフレーム

Matinee の選択および操作は、アンリアル エンジン 4 の他の部分にあるツールと同様に行います。

キーフレーム上でクリックすると、再生位置がそのキーフレームまで移動し、マチネが録画 (record) モードになります。トラックが制御しているアクタのプロパティを変更すると、 キーフレームの値が変更されます。キーフレームの編集中は、以下のように Matinee の情報ボックス内に赤い小さな丸が表示されます。

Key recording indicator

他の位置にスクラブしたり、再生を開始すると、record モードが解除され、シーン内でアクタに加えた変更は記憶されません。

シーケンスの長さの調整

シーケンスの長さを変更するのは簡単です。シーケンスの終点を示す赤いハンドルをつかみ、想定しているシーケンスの新たな終点時間までドラッグするだけです。 キーフレームをシーケンスの範囲外に出しても全く安全です。

シーケンス内の特定の時点に時間を追加することも可能です。そのためには、再生位置をその時間を挿入する時点まで移動し、[Edit] メニューから
[Insert Space At Current (ここにスペースを挿入する)] を選択します。

ループ セクション

マチネで緑色で強調表示されている部分が、ループ セクションです。これは、マチネ内のいくつかのユーティリティによって使用されます。このループセクションを調整するには、スクラブ バー上で始点と終点を示している 緑色のハンドルをドラッグします。

[Loop preview playback] ボタンを押すと、再生位置がループセクションの始点までジャンプし、そこから最後まで再生し終わると、再び始点までジャンプして戻ります。これによって、 シーケンスの短いセクションを繰り返し見ることができるため、想定したとおりの動作になっているかを確認することができます。

現在のループセクションを、新たな長さに拡張することもできます。そのためには、ループ セクションを必要な範囲をカバーするように設定し、[Edit] メニューから [Stretch Section] を選択します。 テキスト入力ダイアログによって、現在のセクションの長さが表示され、必要な長さを新たに入力することが可能になります。キーフレームは、この新たなセクションの長さに応じて再配置されます。 また、ループ セクション全体を削除するには、[Edit] メニューから [Delete Section] を選択します。

ビューをグループに固定する

マチネでは、シネマティックスを作成している場合は特に、シーン内で制御しているアクタのうちの 1 つに、エディタ ビューを固定すると便利です。グループ タイトルバー上の Lock View (Locking button) ボタンを押すと、あらゆる透視図法のビューポートが、そのグループによって制御されているアクタの位置に固定されます。シーケンスを スクラブすると、カメラはそのオブジェクトともに移動します。また、エディタ カメラを移動させると、アクタがそれに追随して動き回ります。キーフレームを調整して オブジェクトを特定の方向に向ける場合に便利です。

カメラを Director (ディレクター) グループに固定した場合、現在のアクティブなカメラを通して見ることになります。これによって、シーンがインゲームで実際どのように見えるかをプレビューすることができます。常に Director グループを含むマチネ シーケンスを開く場合は、自動的に realtime モードがあらゆる透視図法のビューポートで有効になり、カメラが Director グループに固定されます。

追加された Director グループは、マチネ エディタの上部に表示されます。Director グループの下部にはタイムラインがあります。

各マチネ シーケンスは、1 つだけ Director グループを持つことができます。

Camera アクタ

シネマティック シーケンスを作成する場合は、レベル内に配置されたカメラ アクタを使用すると非常に便利です。グループが制御するアクタであれば、どのアクタを通じても見ることは可能です。しかし、Camera アクタを使用すれば、 カメラの FOV やアスペクト比などの Float Property (浮動プロパティ) トラックを制御できるようになるとともに、エディタ内でカメラ視錐台をグラフィカルに表示できるようになります。

Camera アクタをレベルに追加するには、 クラス ビューア を開いて、 Camera アクタを Actor クラスの階層から選択し、 レベル内で右クリックして [Add CameraActor Here (ここに Camera アクタを追加)] を選択します。

以下の図は、レベル内に追加された Camera アクタです。

Camera Actor

カメラ メッシュと錐台は、エディタ内だけで表示され、ゲーム内では表示されません。マチネ内でスクラブすると、アクティブなカメラ錐台が黄色く強調表示されます。各カメラの錘台は、 グループのエディタ カラーで描画され、どのグループがどのカメラを制御しているかが、わかりやすくなっています。

Constrain Aspect Ratio (アスペクト比を制約する)true に設定された Camera アクタを通して見ると、黒いバーがビューに追加されて、スクリーンの形状にします。エディタ内でこのバーが追加されるのは、 ビューが現在 Camera アクタに固定されている場合に限ります。

マチネの複製

bClientSideOnly が false に設定されている Matinee オブジェクトは、自動的にサーバーからクライアントに複製されます。アクションがサーバー側でアクティベートされた時はいつでも、 サーバーはその情報をクライアントに送信して同期を保ちます。

ただし、次のことに注意してください。 1 つは、この自動複製が機能するのは、 bStatic または bNoDelete が設定されているアクタに対してだけであるということです (つまり、アクタがアンリアル エディタでレベルに配置されていなければならないということです)。 もう 1 つは、マチネに接続されているオブジェクト変数が、アンリアル エディタで (他のアクションによる実行時ではなく) 必要なオブジェクトに設定されているということです。これに該当しないアクタは、ブループリントや C++ の複製コードを使って、 マチネによって生じた変更を複製します。

シネマティックス

作成するゲームには、インゲームのシネマティック シーケンスが多数含まれることがあります。ただし、既存のライト環境を使用すると、キャラクターへの光源処理がやや単純になりすぎることがあり、 モデルの見栄えを良くするのが難しい場合があります。そのような場合は、カスタムのライティング チャンネルを使用したり (個別のライティング チャンネルを個別のキャラクターに使用することによって、キャラクター単位でライトの量を制御する場合もあります) 、 カスタムに配置した動的ライトを使用してクローズアップ ショット時にキャラクターを照らすことができます。

これらのシーケンスのために、リアルな動的ライトを使用すると、もう少し見栄えが良くなり、制御もしやすくなります。それでもライトの使用はごく僅かにすべきです。 多くの場合、シャドウのキャスティングには 1 つだけ使用します。

パフォーマンス上、若干の差異が生じますが、シネマティックスにはさらにスローダウンするようなゲームプレイがなく、大丈夫なはずです。コンソール上でゲーム要素をスムーズに動かすには、 レベルデザイナーにシネマティック マップを調べさせ、最適化を数回行わなければならない場合もあります。大抵の場合、カットシーンの全ての静的ジオメトリ (ただし、キャラクターが立っているグラウンドを除きます。 グランドには、シャドウのためにリアルなライティングが必要です) へのライトマップはまだ可能です。

マチネ データのエクスポートとインポート

マチネには、 [Export] および [Import] のメニュー オプションがあります。これによって、 3D コンテンツ作成パッケージにロードできる FBX ファイルに、マチネ シーケンス全体をエクスポートすることができます。
これにより、外部プログラムを使用して、アクタやカメラ、モーション ブラー量やカメラの FOV といった他のプロパティをアニメートできるようになります。シーンの多様な側面をエクスポートできるため、 アニメートされたシーケンスを操作しながら、ワールドのジオメトリを視覚化できるようになります。

マチネ シーケンスをエクスポートする際、アンリアル エディタは、シーン ジオメトリの大部分をアニメーション カーブデータと併せてエクスポートしようとします。

以下のデータをエクスポートします。

  • マチネ シーケンスにバインドされたカメラ

  • マチネシーケンスにバインドされたアクタ

    • 一定のトラックのためのアニメーション カーブ

    • 移動トラック

  • 浮動プロパティ トラック

  • 現在のレベルのすべてのライト

  • 現在のレベルのすべてのスタティック メッシュ (ポリゴンおよびブラシ ジオメトリ、マテリアルを含む)

  • 現在のレベルのすべてのエミッタ (配置キューのみ)

なお、Landscape アクタ、および、ソースブラシ モデル、一部の他のオブジェクト タイプについては、現在、エクスポートがサポートされていません。

エクスポートされたオブジェクトには、アンリアル エディタでの名前と同様の名前が付けられます。3D モデル パッケージのデータに変更を加えたら、その変更を、マチネにインポートできる
FBX ファイルにエクスポートして戻します。シーンのオブジェクト名が、このプロセス中、同じままであることが重要です!

新たな FBX ファイルをエディタにインポートして戻す時、アクティブなマチネ シーケンスにバインドされているアクタとインポートされた名前が一致するアクタのすべてのアニメーションカーブを インポートしようとします。場合によっては (カメラなどの場合) 新たなオブジェクトを追加することもできます。そのためには、モデリングパッケージでオブジェクトを作成し、 FBX ファイルにエクスポートします。

キーの削減

[Edit] タブにあるキー削減ツールを使用して、単一トラックのアニメーション カーブで不要なキーを削除することが可能です。カーブ内にキーがいくつかあって、 そのすべてがかなり直線的になっている場合があります。このような場合は、最初のキーと最後のキーだけが実際に必要となります。このキー削減ツールを用いて不要なキーを取り除いて 、メモリへの負荷を軽減し、無用な計算の実行を回避することができます。

Key Reduction tool

以下は、このツールのプロパティです。

アイテム

説明

Tolerance

前のキーと次のキーを結ぶ直線から、あるキーがどのくらい離れていると削除できるかを設定します。

Full interval

true に設定されている場合、トラックのキーの最大間隔を使用してキーを削減します。

Interval Start

キーの削減を開始する時間を設定します。

Interval End

キーの削減を終了する時間を設定します。

ブループリントでマチネ シーケンスを操作する

Blueprint グラフで関数の呼び出しによりマチネ シーケンスを再生します。一般的にこの操作は Level ブループリント内でシネマティクスまたはアニメートされたエレメントをレベルに追加して行われます。

Matinee シーケンスを再生するには 以下の手順に従います。

  1. 再生したいシーケンスを含む Matinee アクタワールド アウトライナー から選択します。

  2. Level ブループリント を開きます。ブループリントが Graph モードになっていることを確認してください。

  3. Level ブループリントで、Matinee アクタを選択した状態で、グラフを 右クリック します。コンテキスト メニューが表示されたら、'Call Function on YourMatineeName' を展開し、 [Cinematic] セクションを展開したら、 [Play] をクリックします(または、コンテキスト メニューに「play」を入力して結果をフィルタしたら、リストから [Play] を選択します)。表示される Play ノードには、 既に 'Matinee Actor' ノードがアタッチされています。

    Matinee_Play.png

  4. Play 関数のトリガに使用するイベントの種類を決めます。例えば、 Begin Play event を使用することができます。選んだイベントを追加し、出力実行ピンを
    Play ノードの入力実行ピンへ接続します。

    Matinee_EventBeginPlay.png

  5. Level ブループリントをコンパイルし、レベルを保存します。

関数ノードを個々に使用した場合も、 Matinee アクタを使えば以下の操作が可能です。

  • 再生方向の変更

  • 一時停止

  • 逆再生

  • ループ ステートの設定

  • 位置の設定

  • 停止

関数ノードはマチネの Palette の中にあります。

Select Skin
Light
Dark

新しい Unreal Engine 4 ドキュメントサイトへようこそ!

あなたの声を私たちに伝えるフィードバックシステムを含め、様々な新機能について開発をおこなっています。まだ広く使える状態にはなっていないので、準備ができるまでは、ドキュメントフィードバックフォーラムで、このページについて、もしくは遭遇した問題について教えていただけると助かります。

新しいシステムが稼働した際にお知らせします。

フィードバックを送信