Android の開発要件

Unreal Engine 4 向け製品ドキュメント (リファレンスおよびガイドを含む)

Windows
MacOS
Linux

このページでは、Android プラットフォーム用の開発を開始するために必要なハードウェアおよびソフトウェア開発キット (SDK) の要件が記載されています。 

現在サポートされている UEBuildAndroid.cs で確認できます。それは以下で確認できます。
[UE4 Root Directory]/Engine/Source/Programs/UnrealBuildTool/Platforms/Mobile/Android folder

Unreal Engine 4.24

ハードウェア要件

推奨デスクトップ ハードウェア

ハードウェアとソフトウェア スペック を参照してください。

サポートされているデバイス ハードウェア

Android デバイスの互換性 を参照してください。

ソフトウェア要件

デスクトップ オペレーティング システム

ハードウェアとソフトウェア スペック を参照してください。

NDK バージョン

Android NDK R14b

Codeworks for Android 1R7u1 インストーラは、Windows および Mac 上の以前の Codeworks を置き換えます。Linux は 1R6u1 plus を使用しています。

Codeworks SDK バージョン

Windows と Mac: 1R7u1
Linux: 1R6u1

サポートされている IDE のバージョン

Visual Studio 2017 バージョン 15.6 以降。
Visual Studio 2015 Update 3
Visual Studio 2013

Unreal Engine 4.23

ハードウェア要件

推奨デスクトップ ハードウェア

ハードウェアとソフトウェア スペック を参照してください。

サポートされているデバイス ハードウェア

Android デバイスの互換性 を参照してください。

ソフトウェア要件

デスクトップ オペレーティング システム

ハードウェアとソフトウェア スペック を参照してください。

NDK バージョン

Android NDK R14b

Codeworks for Android 1R7u1 インストーラは、Windows および Mac 上の以前の Codeworks を置き換えます。Linux は 1R6u1 plus を使用しています。

Codeworks SDK バージョン

Windows と Mac: 1R7u1
Linux: 1R6u1

サポートされている IDE のバージョン

Visual Studio 2017 バージョン 15.6 以降。
Visual Studio 2015 Update 3
Visual Studio 2013

Unreal Engine 4.22

ハードウェア要件

推奨デスクトップ ハードウェア

ハードウェアとソフトウェア スペック を参照してください。

サポートされているデバイス ハードウェア

Android デバイスの互換性 を参照してください。

ソフトウェア要件

デスクトップ オペレーティング システム

ハードウェアとソフトウェア スペック を参照してください。

NDK バージョン

Android NDK R14b

Codeworks for Android 1R7u1 インストーラは、Windows および Mac 上の以前の Codeworks を置き換えます。Linux は 1R6u1 plus を使用しています。

Codeworks SDK バージョン

Windows と Mac: 1R7u1
Linux: 1R6u1

サポートされている IDE のバージョン

Visual Studio 2017 バージョン 15.6 以降。
Visual Studio 2015 Update 3
Visual Studio 2013

Unreal Engine 4.21

ハードウェア要件

推奨デスクトップ ハードウェア

ハードウェアとソフトウェア スペック を参照してください。

サポートされているデバイス ハードウェア

Android デバイスの互換性 を参照してください。

ソフトウェア要件

デスクトップ オペレーティング システム

ハードウェアとソフトウェア スペック を参照してください。

NDK バージョン

Android NDK R14b

Codeworks for Android 1R7u1 インストーラは、Windows および Mac 上の以前の Codeworks を置き換えます。Linux は 1R6u1 を使用しています。

Codeworks SDK バージョン

Windows と Mac: 1R7u1
Linux: 1R6u1

サポートされている IDE のバージョン

Visual Studio 2017 バージョン 15.6 以降。
Visual Studio 2015 Update 3
Visual Studio 2013

Unreal Engine 4.20

ハードウェア要件

推奨デスクトップ ハードウェア

ハードウェアおよびソフトウェアのスペック を参照してください。

サポートされているデバイス ヘッドセット

Oculus の再ステムおよびハードウェア要件 をご参照ください。

ソフトウェア要件

デスクトップの OS

ハードウェアおよびソフトウェアのスペック を参照してください。

NDK バージョン

Android NDK R12b

注意:Codeworks for Android 1R6u1 インストーラは、Windows、Mac 、Linux 上の以前の Codeworks を置き換えます。

Codeworks SDK バージョン

1R6u1

サポートされている IDE バージョン

Visual Studio 2017 バージョン 15.6 以降。
Visual Studio 2015 Update 3
Visual Studio 2013

Unreal Engine 4.19

ハードウェア要件

推奨デスクトップ ハードウェア

ハードウェアおよびソフトウェアのスペック を参照してください。

サポートされているデバイス ヘッドセット

Android デバイスの互換性 をご参照ください。

ソフトウェア要件

デスクトップの OS

ハードウェアおよびソフトウェアのスペック を参照してください。

NDK バージョン

Android NDK R12b

Codeworks for Android 1R6u1 インストーラは、Windows、Mac 、Linux 上の以前の Codeworks を置き換えます。

Codeworks SDK バージョン

1R6u1

サポートされている IDE バージョン

Visual Studio 2015 Update 3
Visual Studio 2013

Select Skin
Light
Dark

新しい Unreal Engine 4 ドキュメントサイトへようこそ!

あなたの声を私たちに伝えるフィードバックシステムを含め、様々な新機能について開発をおこなっています。まだ広く使える状態にはなっていないので、準備ができるまでは、ドキュメントフィードバックフォーラムで、このページについて、もしくは遭遇した問題について教えていただけると助かります。

新しいシステムが稼働した際にお知らせします。

フィードバックを送信