ゲームコードの管理

コードの追加とプロジェクトファイルの生成

Windows
MacOS
Linux

[/VAR]

[VAR:OSSelect_Linux]

プロジェクトにコードを追加する方法

C++クラスウィザード

C++ Class Wizard では、独自の機能で拡張するために、ネイティブ C++ コードクラスを 高速かつ簡単に追加することができます。コンテンツのみのプロジェクトをコードプロジェクトへ変換することができます。C++ Class Wizard を利用することができます。

作業を開始する前に、インストールされている Visual Studio 2015 (以降) for Windows Desktop を実行していることを確認してください。Mac を使用している場合、Xcode 8 以降をインストール済みであることを確認してください。

  1. メインエディタで [File] > [New C++ Class...] の順に選択します。

    FileCPP.png

  2. [C++ Class Wizard] に一般的に追加されるクラスが表示されます。探しているクラスが見つからない場合、クラスの階層リスト全体を表示する必要があります。ウィンドウの右上隅にある [Show All Classes] チェックボックスをクリックします。

    デフォルトのクラス

    すべてのクラス

    追加したいクラスを選択して [Next >] ボタンをクリックします。

  3. 新しいクラスの 名前 の入力を求められます。名前を入力して [Create Class] ボタンをクリックします。ヘッダファイル (.h) とソースファイル (.cpp) が作成されました。

    クラス名には英数字のみを使用してください。スペースを含むことはできません。無効な名前を入力すると、通知が表示されます。

  4. Visual Studio で直接コードが開いて編集が可能となります。

    CodeEditing.png

    Xcode で直接コードが開いて編集が可能となります。

    CodeEditing_xcode.png

編集終了時のクラスのコンパイルに関する説明は、 プロジェクトのコンパイルのドキュメント を参照してください。

開発環境

コード ファイルは Visual Studio で作成され、通常の方法で Solution Explorer からゲームプロジェクトへ追加されます。Visual Studio 外部の適切なフォルダへコードファイルを追加したり、 ソリューションやプロジェクトファイルを自動的に再ビルドすることができます。オペレーティングシステムの UI を通じてたくさんのファイルを素早く簡単に追加可能になり、 チームメンバー間でソリューションやプロジェクトファイルの同期も不要となるためチームの作業が容易になります。各自が、 コードファイルの同期とプロジェクトファイルの再ビルドをローカルで行うだけで済みます。

コードファイルは Xcode で作成し、[Project Navigator] から通常の方法でゲームプロジェクトへ追加できます。 Xcode 外部の適切なフォルダへコード ファイルを追加したり、自動的にプロジェクトファイルを再ビルドすることができます。 オペレーティング システムの UI を通じてたくさんのファイルを簡単に素早く追加することができ、 チームメンバー間でソリューションやプロジェクトファイルの同期も不要になるためチーム作業が容易になります。各自が、 コードファイルの同期とプロジェクトファイルの再ビルドをローカルで行うのみです。

開発環境でプロジェクトを開く

プロジェクトを既にエディタで開いている場合、[File] メニューから [Open in Visual Studio] を選択すると、プロジェクトを Visual Studio で簡単に開くことができます。

open_visual_studio.png

プロジェクトは、Windows Explorer 経由で Visual Studio で開いたり、Visual Studio の [File > Open > Project/Solution] を選択して開くことも出来ます。

  • そのプロジェクトのディレクトリのルートにある [ProjectName].sln Visual Studio ソリューションを開きます。

プロジェクトを既にエディタで開いている場合、 [ファイル] メニューから [Open in Xcode] を選択すると、プロジェクトを Xcode で簡単に開くことができます。

open_xcode.png

[Finder] 、または Xcode の [File > Open] からも Xcode でプロジェクトを開くことができます。

  • プロジェクトのディレクトリのルートに格納されている [ProjectName].xcodeproj XcodeXcode プロジェクトを開きます。

プロジェクト ファイルの生成方法

プロジェクト ファイルは [[ProjectDirectory]\Intermediate\ProjectFiles`] に格納される中間ファイルとみなされます。つまり「Intermediate」フォルダを削除した場合、プロジェクトファイルを再生成しなくてはいけません。

.uproject ファイル

  1. Windows Explorer で [ProjectName].uproject の保存場所へ移動します。

  2. [ProjectName].uproject ファイルを 右クリック して [Generate Visual Studio Files] を選択します。

    Generate_Visual_Studio_Files.png

  3. UnrealbuildTool が、Intellisense データの生成も含めてプロジェクト ファイルとソリューションを更新します。

    generate_project_files.png

  4. プロジェクト ディレクトリのルートに格納されている [ProjectName].sln」 Visual Studio ソリューションのファイルを開いて、Visual Studio で作成したゲームプロジェクト表示します。

  1. Finder から [ProjectName].uproject が保存されている場所へ移動します。

  2. [ProjectName].uproject ファイルを 右クリック して Generate Xcode Files を選択します。

    Generate_Xcode_Files.png

  3. UnrealBuildTool が、プロジェクトを更新します。

    generate_project_files_xcode.png

  4. プロジェクト ディレクトリのルートに格納されている [ProjectName].xcodeproj Xcode プロジェクトを開いて、Xcode で作成したゲームプロジェクト表示します。

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback