UnrealVS 拡張機能

Visual Studio に対応する UnrealVS 拡張のインストール、設定、使用方法

Windows
MacOS
Linux

Visual Studio に対応する UnrealVS 拡張により、アンリアル エンジン 4 (UE4) を使った開発では、一般的な操作に簡単にアクセスできるようになりました。本ページでは拡張ファイルのインストール方法ならびにプロジェクトでの使用方法について説明します。

以下の機能があります。

  • スタートアップ プロジェクトの設定

  • スタートアップ プロジェクトをビルドする結合コマンド

  • コマンド ライン引数の設定

  • プロジェクトのバッチビルド

  • クイックビルド プロジェクト メニュー

UnrealVS 拡張は Visual Studio Express と連動しません。Visual Studio Community と Visual Studio Professional とのみ互換性があります。

インストールと設定

UnrealVS 拡張機能:

  1. ご利用 のVisual Studio バージョンの拡張を以下で探してください。

    [UE4RootLocation]/Engine/Extras/UnrealVS/<VS-Version>/UnrealVS.vsix

  2. 「UnrealVS.vsix」ファイルをダブルクリックして実行しインストールを開始します。

  3. UnrealVS 拡張は、特定の Visual Studio バージョンをターゲットにしています。インストーラがご利用のバージョンをターゲットにしていること、およびそのボックスにチェックが入っていることを確認します。次に、[Install] ボタンをクリックします。

    UnrealVSExtension-InstallSetup-03.png

  4. インストールが完了したら、 [Close] ボタンをクリックします。

    Install Complete

  5. Visual Studio を実行すると、 Tools->Extensions and Updates... で拡張が表示されます。

    Extension Manager

    Visual Studio が既に実行中の場合、拡張のロードおよび表示前に再起動する必要があります。拡張は Help->About Microsoft Visual Studio ダイアログの [Installed Products] リストにも表示されます。

  6. View->Toolbars に進むか、または Visual Studio のツールバー エリアで 右クリック して、UnrealVS を選択して拡張のツールバーを表示します。

    UnrealVS Toolbar

  7. デフォルトで、ツールバーは上の図のように表示されますが、その内容は以下の手順でカスタマイズできます。Tools->Customize... で、[Commands (コマンド)] タブにある [UnrealVS] ツールバーを選択します。

    UnrealVS Customize Toolbar

  8. [Customize] のダイアログで、[Add Command...] を選択し、カテゴリ リストから UnrealVS を選択し、ツールバーに追加可能な UnrealVS コマンドのリストを表示します。コマンドを追加したら [OK] をクリックします。

    UnrealVS Customize Commands

スタートアップ プロジェクトの設定

[Startup Project] ドロップダウンはスタートアップ プロジェクトを迅速に設定したり切り替える手段です。このソリューションで実行ファイルをビルドする利用可能なすべてのプロジェクトの一覧が自動的に表示されます。リストで選択したプロジェクトは、現在のスタートアップ プロジェクトとして設定されます。

startup_project_menu.png

UnrealVS オプションにどのプロジェクトをリスト化するかを変更することができます。Game プロジェクトだけを表示するには、 [Tools] > [Options...] に進み UnrealVS を選択します。[Sim Target (ターゲットのシミュレーション)] の横にあるドロップダウンをクリックして True を選択します。[Ok] をクリックします。

Set Startup Project

スタートアップ プロジェクトの設定

拡張には、現在のスタートアップ プロジェクトをビルドするコマンドも含まれ、ホットキーやカスタム コマンドを実行する他の手段に結合することができます。

コマンドをホットキーに結合する

  1. [ツール] > [オプション] を選択後、[Environment] ツリーに表示される [Keyboard] を選択します。[Apply the following additional keyboard mapping scheme] でドロップダウンをクリックし [Visual C++ 6] を選択します。 Filtered Keyboard Mapping List

  2. コマンドリストから UnrealVS.BuildStartupProject コマンドを選択します。

    Filtered Command List

    検索ボックスに「UnrealVS」と入力してリストをフィルタにかけます。

  3. コマンドを選択後、[Press Shortcut Keys] ボックスをクリックして、コマンドの実行に使用するキーの組み合わせを選択します。以下の例では、Ctrl + Alt + Shift + B となっています。

    Shortcut Keys

    既に割り当て済みのキーの組み合わせは選択しないでください。[Shortcut currently used by] ボックスは、選択したキーの組み合わせが使用済みであることを警告します。

  4. [Assign] ボタンを押すと、キーとコマンドが結合されます。[Shortcuts for selected command (選択したコマンドのショートカット)] ボックスに表示されます。

    Assigned Keys

  5. 変更を保存するには、[OK] ボタンを押します。これで、次回ショートカットを使用するとスタートアップ プロジェクトとして設定されたプロジェクトが自動的にビルドされます。

シングル ソースファイルを統合する

Visual Studio で Ctrl+F7 を使用して更新を単一のソース (.cpp) ファイルにイタレートすることに慣れている場合、Ctrl+F7UnrealVS.CompileSingleFile コマンドにバインドすることができます。アクティブなプロジェクトを現在のソリューション設定、プラットフォーム、-singlefile=<Path to currently open file> 引数にバインドすることができます。

コマンドライン引数

デバッグ セッションの実行時に、現在のプロジェクトに Command Arguments を設定するために Command-Line コントロールを使用します。これはプロジェクトの プロパティ で設定するショートカットです。ここで加えられた変更は、自動的に Properties へ反映されます。

テキストボックスに引数を入力するか、ドロップダウン リストを使用して最近の引数のリストから選択します。この引数は、デバッグセッションが開始すると実行ファイルへ渡されます。

Command Arguments

アンリアル エディタをビルドするゲーム プロジェクトのプロジェクト config が、コマンドラインにプロジェクト名を自動的に追加し、アンリアル エディタの実行ファイルに対してどのプロジェクトを使用しているかを自動的に知らせます。例えば、ビルドの config 'Debug Editor' を使用して QAGame をビルドする場合、コマンドラインには、ボックスで入力する必要なしに、QAGame.uproject がコマンド引数に追加されます。QAGame のエディタを起動するには、Command-Line コントロールを空のままにしても、アンリアル エディタはどのプロジェクトが実行中であるかを認識します。

利用可能な全ての引数のリストは、 コマンドライン引数 をご覧ください。

プロジェクトのリフレッシュ

Automatic Project File Generation を使用して、プロジェクト ファイルを Visual Studio 内で生成することができます。.bat ファイルへ移動して手動で実行する必要がないため、すべてのプロジェクト ファイルの同期と更新を速く行うことができます。

プロジェクトファイルをリフレッシュするには以下の手順に従います。

  1. [UnrealVS] ツールバーに表示される [Refresh Projects] ボタンを押します。

    button_refresh_crop.png

  2. プロセスが開始すると、[Output] ウィンドウにプロジェクト生成プロセスが表示されます。

    Project Generator Output

  3. 促されたら必要なプロジェクトを再ロードします。

Batch Builder

UnrealVS Batch Builder で、ビルド ジョブのカスタム セットを作成および実行します。Visual Studio の [Build->Batch Build...] オプションよりも多用途に使用できます。

Batch Builder ウィンドウを開くには以下の手順に従います。

  1. UnrealVS ツールバー上の [Batch Builder] ボタンを押すか、コマンド UnrealVS.BatchBuilder に割り当てたキーボードのショートカットを使用します (UnrealVS コマンドを使用したキーボード ショートカットの設定に関する説明は前述の Build Startup Project をご参照ください)。

    Batch Builder

  2. UnrealVS Batch Builder ウィンドウが表示されます。

    Batch Builder Window

    • Project、Config、Platform、ジョブ タイプを設定して Build Job を作成し、ジョブ タイプのラジオボタンをクリックします。

    • > および < ボタンでジョブを追加/削除します。

    • Build Jobs リストで、選択したジョブを矢印ボタンで上下に移動します。

    • Build Jobs リストのドロップダウンで編集する Job Set を選択します。

    • 新規の Job Set を作成するには、新しい名前を入力フィールドに入力します。

    • [Delete] ボタンで、選択した ジョブセット をリストから削除します。

    • [Start (開始)] ボタンで現在のジョブセットのバッチ ビルド タスクを開始/終了します。

    • ジョブセットは、ロードされたソリューションについて .suo ファイルに次回のために格納されます。

  3. [Start (開始)] をクリックすると、バッチビルドの進捗を表す [Output] タブが表示されます。

    Batch Builder Window running

    • 実行しているセットの Build Jobs が出力リストに表示されます。現在、実行中のビルド ジョブが太字で表示されます

    • Queued Build Job = Queued job

    • Succeeded Build Job = Job complete, succeeded

    • Failed Build Job = Failed job

    • Cancelled Build Job = Cancelled job

    バッチ ビルド実行中にビジーのアニメーションと Stop ボタンが表示されます。

  4. Build Jobs から、[Output] タブ のアイテムを ダブルクリックするか、または 右クリック してコンテキストメニューから [Show Output] を選択して出力を見ることができます。

    BatchBuild Output Pane

    各アイテムに対する Batch Builder 出力の表示は、UnrealVS - BatchBuild という名前のペインにある Visual Studio Output ウィンドウに表示されます。これを、現在の/最後のビルド ジョブの出力を表示する Build ペインと間違わないようにしてください。

クイックビルドメニュー

[Quick Build (クイックビルド)] メニューは、メインのソリューション ビルド config を変更する必要なく、どの config とプラットフォームの組み合わせでもプロジェクトをビルドする簡単な方法を提供します。

Quick Build Menu

  1. [Solution Explorer] でプロジェクト ノードを 右クリック します。

  2. [UnrealVS Quick Build] メニューには、アンリアル エンジン ソリューションで利用可能なプラットフォームとビルド config のサブメニューがあります。

  3. 選択したプロジェクト、プラットフォーム、config をビルドするためのアイテムを選択します。これは、IDE でソリューションのコンフィギュレーション、ソリューションのプラットフォームを変更し、 ビルドを開始し、次に config とプラットフォームを再度切り替えることに比べるとはるかに迅速です。

UnrealVS ソースコードでの作業

UnrealVS のソースコードは [UE4RootLocation]/Engine/Source/Programs/UnrealVS/ フォルダにあります。

Visual Studio で UnrealVS プロジェクトファイルをロードするためには、UnrealVS をコンパイルする Visual Studio の適切なバージョンの Visual Studio SDK をインストール済である必要があります。例えば、Visual Studio 2015 までをサポートする場合、Visual Studio 2015 SDK をインストールしてから、UnrealVS プロジェクト ファイルを Visual Studio 2015 にロードする必要があります。

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback