Unreal Engine 用に Visual Studio をセットアップする

Unreal Engine 4 と連携するように Visual Studio をセットアップするためのヒント、コツ、テクニックを説明します。

Windows
MacOS
Linux

Unreal Engine は Visual Studio とスムーズに統合するように設計されており、プロジェクトのコードをすばやく簡単に変更してコンパイル後にすぐ結果を確認できます。Visual Studio を Unreal Engine と連携するように設定すると、Unreal Engine を使用するデベロッパーの効率と全体的なユーザー エクスペリエンスが向上します。

本ページでは、Unreal Engine から Visual Studio へのワークフロー設定の基本も説明します。

Unreal Engine から Visual Studio へのワークフローを設定する前に

Visual Studio 2017 (VS2017) では、現在 C++ のサポートはオプションのワークロードの一部となっており、デフォルトではインストールされません。既にインストールされた Visual Studio に C++ ツールを追加する詳細な手順は、Microsoft サポートページの「Install C++ support in Visual Studio 」を参照してください。Visual Studio や Unreal Engine をまだインストールしていない場合は、このページの 「新しく Visual Studio をインストールするときのオプション 」セクションを参照してください。

次の表に、バイナリ バージョンの Unreal Engine に統合された Visual Studio のバージョンを示します。

Unreal Engine のバージョン

Visual Studio のバージョン

4.22 以降

VS 2017

4.15 以降

VS 2017

4.10 から 4.14

VS 2015

4.2 から 4.9

VS 2013

Unreal Engine はバージョン 4.22 の時点で VS 2015 を サポートしていません。Unreal Engine は現在もデフォルトで VS 2017 を使用していますが、VS 2019 もサポートしています。

バージョン 4.20 以降の Unreal Engine はデフォルトで VS 2017 を使用します。しかし、VS2015 もサポートしています。VS 2017 はインストールされていない場合でも、VS 2015 がインストールされていれば Unreal Engine 4.20 は動作します。ただし、VS 2015 と VS 2017 が両方インストールされている場合、Unreal Engine 4.20 はデフォルトで VS 2017 IDE とコンパイラを使用し、VS 2017 のプロジェクト ファイルを生成します。

VS 2015 のソリューションとプロジェクトファイルを生成するように Unreal Engine 4.20 を構成するには、次のいずれかを実行します。

  • エディタの [Editor Preferences (エディタの環境設定)] ウィンドウで、優先的に使用するソースコード IDE として Visual Studio のバージョンを選択

  • 「BuildConfiguration.xml」ファイルの関連するセクションを変更

GitHub や Perforce から入手できる Unreal Engine のオープン ソース バージョンには、VS 2013 が統合されています。また、古いバージョンの Visual Studio と統合した以前のバージョンの Unreal Engine は、このドキュメントでは取り扱いません。

Unreal Engine の Pre-Requisite Installer (必須コンポーネント インストーラー) を実行する

Epic Launcher から Unreal Engine をインストールする場合、または GitHub からクローンする場合、Unreal Engine の Pre-Requisite Installer (必須コンポーネント インストーラー) が自動的に起動します。ただし、Perforce から Unreal Engine をインストールまたは同期する場合は、Unreal Engine の Pre-Requisite Installer (必須コンポーネント インストーラー) を手動で実行する必要があります。これは、ローカルでビルドした Unreal Engine ツールを実行する前に行う必要があります。

新しく Visual Studio をインストールするときのオプション

Visual Studio を初めてインストールする場合は、次のオプションを有効化する必要があります。

C++ ツール

Visual Studio のインストールに C++ ツールを追加するには、[Workloads] から [Game development with C++] を選択します。

VS2017_SettingsNoInstaller.png

UE4 インストーラーを含める

Visual Studio のインストール時に UE4 インストーラーを含めるには、右側の [Summary (概要)] サイドバーから [Game Development with C++ (C++ でゲーム開発)] を展開し、[Optional (オプション)][Unreal Engine installer (Unreal Engine インストーラー)] のボックスを確実にチェックします。

VS2017_SettingsInstaller.png

推奨設定

Unreal Engine 4 で Visual Studio を使用するデベロッパー向けの推奨設定を以下に示します。

ソリューション設定用のドロップダウン メニューの幅を広げる

  1. ツールバーを右クリックして、表示されるメニューの下部で [Customize (カスタマイズ)] を選択します。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep01.png

  2. [Commands (コマンド)] タブをクリックします。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep02.png

  3. [Toolbar (ツールバー)]オプション ボタンを選択します。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep03.png

  4. [Toolbar (ツールバー)] の横のドロップダウンで、[Standard (標準)] を選択します。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep04.png

  5. [Preview] リストで [Solution Configurations (ソリューション設定)] コントロールを選びます。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep05.png

  6. 右側の [Modify Selection (選択を変更)] を選択します。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep06.png

  7. [Width (幅)]200 に設定します。[OK] をクリックします。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep07.png

  8. [Close (閉じる)] をクリックします。すぐにツールバーが更新されます。
    SetUpVisualStudio-RecommendSettings-SolutionConfigStep08.png

ソリューション プラットフォーム用のドロップダウンを追加する

  1. [Standard (標準)] ツールバーでマウスの右ボタンを押します (マウスのカーソルを合わせると [Standard Toolbar Options (標準ツールバー オプション)] というラベルが表示されます)。 SetUpVisualStudio-RecommendSettings-SolutionPlatformsStep01.png

  2. ドロップダウン ボタン > [Add (追加)] または [Remove (追加)] ボタン > [Solution Platforms (ソリューション プラットフォーム)] の順にクリックしてツールバーにメニューを追加します。

SetUpVisualStudio-RecommendSettings-SolutionPlatformsStep02.png

エラーリスト ウィンドウをオフにする

通常、コードにエラーがあると エラー リスト(Error List) ウィンドウが自動的にポップアップします。しかし、Unreal Engine の作業中に誤ったエラー情報が エラー リスト ウィンドウに表示され場合があります。Unreal Engine で作業する際は、この エラー リスト ウィンドウをオフにして、出力 (Output) ウィンドウを使用して実際のコード エラーを確認することを推奨します。エラー リスト ウィンドウをオフにするには、次の手順に従ってください。

  1. [Error List (エラー リスト)] ウィンドウが開いている場合は閉じます。

  2. [Tools (ツール)] メニューから [Options (オプション)] ダイアログを開きます。
    SetUpVisualStudio-RecommendSettings-ErrorListOffStep02.png

  3. [Projects and Solutions (プロジェクトとソリューション)] を選択して [Always show error list if build finishes with error (ビルドがエラーで終わった場合、常にエラー リストを表示する)] のチェックを外します。
    SetUpVisualStudio-RecommendSettings-ErrorListOffStep03.png

  4. [OK]をクリックします。

その他の便利な構成設定を次に示します。

  • [Show Inactive Blocks (非アクティブなブロックを表示)] をオフにします。このオプションをオンにすると、コードの一部がテキスト エディタでグレーアウトされる場合があります。設定をオフにするには、[Tools (ツール)] > [Options (オプション)] > [Text Editor (テキスト エディタ)] > [C/C++] > [View (表示)] の順に選択します。

  • [Disable External Dependencies Folders (外部依存関係フォルダを無効にする)] を「True」に設定して、[Solution Explorer (ソリューション エクスプローラー)] で不要なフォルダを非表示にします。[Disable External Dependencies Folders (外部依存関係フォルダを無効にする)][Tools (ツール)] > [Options (オプション)] > [Text Editor (テキスト エディタ)] > [C/C]++ > [Advanced (詳細設定)] にあります。

  • 必要がなければ [Edit & Continue (編集して続行)] 機能をオフにします。次に [Tools (ツール)] > [Options (オプション)] > [Debugging (デバッグ)] > [Edit & Continue (編集して続行)] を選択します。

  • [IntelliSense] をオンにします。本ページの「Intellisense、Live Errors、および Squiggles 」を参照してください。

Visual Assist X ユーザー

Visual Assist X をインストールしている場合の推奨設定です。

  • [Format After Paste (貼り付け後に書式設定)] をオフにします。[VAssistX] > [Visual Assist X Options] > [Advanced] > [Corrections] を選択して設定を変更します。

  • このオプションを無効化しない場合、Visual Assist X がソースコードを自動的に書式設定します。その結果、ドキュメントが適切にフォーマット化されない場合があります。

Intellisense (ライブ エラーおよび波線)

UE4 プロジェクトにライブ エラー リストや波線など、IntelliSense のサポートが正式に追加されました。有効化する方法は以下を参照してください。有効化する方法は以下を参照してください。

IntelliSense は入力時に C++ を再コンパイルします。これは、コードの行をすべて検証する完全な C++ コンパイラを使用するため、VAX の構文チェックよりはるかに強力です。これはワークフローを劇的に高速化します。

VC++ Intellisense Squiggles

波線以外にも、開いたファイルのエラーリストに IntelliSense エラーを表示します。エラー リストの [Right-Click Menu (右クリック メニュー)] でオンオフを切り替えることが出来ます。

Error List

UE4 プロジェクトでは動作しなかったので、すでに波線を無効化している可能性もあります。[C/C++] > [Advanced (詳細説明)] をクリックして、設定を以下のようにしてください。

VC++ Advanced Options

C++ ファイルを開いた時の次に示すアイコンは IntelliSense コンパイラが動作していることを示します。

Intellisense Progress Indicator

実装の詳細

  • コードの編集時に波線が表示されるまで数秒かかる場合があります。これはインクルードするファイルが多数あり、現在 IntelliSense が PCH を使用していないことが原因です。

  • IntelliSense が「False Positive (誤検出)」のエラーを表示する場合があります。これには理由がいくつか考えられます。 * IntelliSense コンパイラー (EDG) は、MSVC コンパイラーよりも厳密です。

    • IntelliSense に対する一部の #defines が、通常のビルドとは別に設定されています。

    • IntelliSense でコンパイルした C++ が常に 32 ビットとして扱われています。

  • 絶対に必要な場合は ##ifdef <strong>INTELLISENSE</strong> でコードをラップして波線を取り除くことができます。

  • IntelliSense エラーと VC++ コンパイラのエラーはメッセージが若干異なります。

  • ヘッダー ファイルの波線は、そのヘッダーをインクルードする既知の .cpp とともにコンパイルすると機能します。IntelliSense が原因でこれが失敗すると、ヘッダーに波線が表示されます。

  • Max Cached Translation Units 設定を上げることで、反応性を高めることができます。* ただし、メモリの消費が多くなります。

  • 現在 C++ ファイルの一部は IntelliSense と互換性がありません。

  • Unreal Build Tool には新しい -IntelliSense オプションがあります。 * このオプションは、プロジェクト ファイルすべてに対して IntelliSense プロパティ シートを生成します。

    • このオプションを再実行する必要があるのは、新しいモジュールを追加したときと、プロジェクトのインクルードを変更しときのみです。

UnrealVS 拡張

Visual Studio 用の UnrealVS 拡張 を使用して、Unreal Engine 4 での開発で共通のアクションに簡単にアクセスできます。本ページでは、拡張のインストール方法およびプロジェクトでの使用方法を説明します。

以下の機能を含みます。

  • スタートアップ プロジェクトの設定

  • スタートアップ プロジェクトをビルドするバインド可能なコマンド

  • コマンド ライン引数の設定

  • プロジェクトのバッチ ビルド

  • クイックビルド プロジェクト メニュー

UnrealVS 拡張は Visual Studio Express エディションに対応していません。Visual Studio Community および Professional エディションのみと互換性があります。

デバッグ

Visual Studio はデバッガーの拡張をサポートしており、FName や動的配列といった Unreal の一般的な型を簡単に検査できるビジュアライザを提供します。

UE4 Visualizer for Visual Studio 2013 をインストールする

UE4.natvis を以下のいずれかの場所にコピーします。

  • [VisualStudioInstallPath]/Common7/Packages/Debugger/Visualizers/UE4.natvis

  • [UserProfile]/My Documents/Visual Studio 2013/Visualizers/UE4.natvis

ファイルを Visual Studio のインストール ディレクトリにコピーするには、管理者権限が必要な場合があります。

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback