아티스트 퀵 스타트

콘텐츠 제작자로 언리얼 엔진 4 시작하는 법을 배워봅니다.

Windows
MacOS
Linux
필요한 사전지식

이 글은 다음 주제에 대한 지식이 있는 분들을 대상으로 합니다. 계속하기 전 확인해 주세요.

MaterialsHeader_1.png

언리얼 엔진 (UE4) 게임에 애셋을 추가하는 법을 보여드리는 퀵스타트 가이드입니다. 이 가이드를 마칠 즈음엔 프로젝트 브라우저 를 사용하여 새 프로젝트를 만드는 법과, 콘텐츠 브라우저 조작을 통해 콘텐츠를 찾아 추가하는 법을 배우게 됩니다. FBX 콘텐츠 파이프라인 관련 정보를 찾을 수 있는 곳과 함께, 머티리얼 에디터 를 사용하여 머티리얼 을 변경하고 스태틱 메시 액터 에 적용시키는 법을 알아봅니다.

자주 저장하고 하루를 구원받자!

1. 필수 프로젝트 구성

  1. 런처에서 언리얼 엔진 을 엽니다. 프로젝트 브라우저 가 나타납니다.

  2. 새 프로젝트 탭에 클릭한 다음 C++ 탭을 선택합니다. 거기서 기본 코드 를 선택해서 깨끗한 시작점을 만들고, 시작용 콘텐츠 포함 인지 확인합니다. 프로젝트 이름은 "QuickStart" 라 하겠습니다. 이제 프로젝트 생성 을 눌러 시작합니다.

    CreateProject.png

언리얼 에디터 에 새 프로젝트가 열립니다. Visual Studio 역시 열리고 프로젝트가 생성한 솔루션 파일을 로드합니다.

2. 폴더 생성

언제나 프로젝트의 콘텐츠를 체계적으로 정리해 두는 습관을 들이는 것이 좋습니다. 먼저 배워볼 것은, 중요한 콘텐츠를 저장할 폴더를 만드는 법입니다.

시작하기 전, 다음 링크에서 퀵스타트 애셋을 다운로드하세요.

  1. 다운로드한 애셋 압축을 아래 그림처럼 컴퓨터에 풉니다.

    ExtractedContent.png

    ExtractedContent_Mac.png

  2. 에디터의 콘텐츠 브라우저 에서 신규 추가 버튼을 클릭합니다.

  3. 새 폴더 를 선택하여 '/Game' 아래 새 폴더를 만듭니다.

    NewFolderSelection.png

  4. 폴더 이름을 'QuickStartContent' 라 합니다.

    QuickStartContentFolder.png

  5. 'QuickStartContent' 폴더를 더블클릭합니다.

작명 규칙이 중요합니다! 폴더와 파일 이름은 일관되게 지어주세요.

3. 메시 임포트

UE4 프로젝트에 콘텐츠를 추가하는 방법은 몇 가지 있지만, 여기서는 콘텐츠 브라우저의 임포트 기능에 초점을 맞추겠습니다.

  1. 'QuickStartContent' 폴더 안에서 콘텐츠 브라우저의 임포트 버튼을 눌러 파일 열기 대화창을 엽니다.

    ContentBrowserImportButton.png

  2. Basic_Asset1Basic_Asset2 FBX 메시 파일을 찾아 선택합니다.

    ImportMeshDialogBox.png

  3. 열기 를 눌러 FBX 메시 파일을 프로젝트로 임포트 시작합니다.

  4. 에디터에 들어가면 FBX 임포트 옵션 대화창이 뜹니다. 임포트 또는 모두 임포트 를 클릭하면 메시가 프로젝트에 추가됩니다.

    FBXImportOptionsDialogBox.png

  5. 모두 저장 버튼을 클릭하여 임포트된 메시를 저장합니다.

    SaveAllMeshesButton.png

  6. 콘텐츠 저장 대화창이 뜹니다. 선택 저장 을 클릭하여 임포트된 애셋을 저장합니다.

    SaveSelectedDialogBox.png

  7. 'QuickStartContent' 폴더로 이동하여 .uasset 파일이 제대로 생성되었는지 확인합니다.

    QuickStartContentFolder.png

애셋을 쉽게 찾을 수 있도록 체계적으로 정리하세요.

4. 텍스처 임포트

  1. 에디터에서 'QuickStartContent' 폴더로 이동하여, 콘텐츠 브라우저의 임포트 버튼을 클릭하면 파일 열기 창이 열립니다.

    ContentBrowserImportButton.png

  2. T_Rock_04_DT_Rock_04_n Targa (TGA) 이미지 파일을 찾아 선택합니다.

    ImportTextureDialogBox.png

  3. 열기 를 클릭하여 TGA 이미지 파일을 프로젝트에 임포트 시작합니다.

  4. 언리얼 에디터 우하단 구석에 확인창이 뜹니다.

    TextureNormalConfirmation.png

  5. OK 를 클릭하여 T_Rock_04_n.TGA 노멀 맵 세팅을 수락합니다.

  6. 모두 저장 버튼을 클릭하여 임포트된 이미지를 저장합니다.

    SaveAllTextures.png

  7. 콘텐츠 저장 대화창이 뜹니다.

    SaveSelectedDialogBox.png

  8. 선택 저장 을 클릭하여 임포트된 애셋을 저장합니다.

  9. 'QuickStartContent' 폴더로 이동, .uasset 파일이 제대로 만들어졌는지 확인합니다.

    QuickStartContentFolder.png

(에픽 런처에서 접근 가능한) 마켓플레이스는 콘텐츠를 찾아 공유하기에 좋은 곳입니다.

5. 임포트할 메시 준비

별도로 임포트할 메시가 있다면, 지금이 딱입니다.

UE4 FBX 임포트 파이프라인은 FBX 2018 버전을 사용합니다. 다른 버전을 사용하면 호환성에 문제가 생길 수 있습니다.

3D 아트 툴 선택

Autodesk Maya

Autodesk 3ds Max

  1. 뷰포트에서 익스포트할 메시를 선택합니다.

    maya_export_1.png

  2. File 메뉴에서 Export Selection (또는 선택과 무관하게 씬의 모든 것을 익스포트하려면 Export All) 을 선택합니다.

    maya_export_2.png

  3. 익스포트 대화창에서:

    • UE4 프로젝트 안의 Content 폴더를 선택합니다 (1)

    • 파일 이름을 입력하고 FBX 익스포트로 설정합니다 (2)

    • 익스포트 옵션을 설정합니다 (3)

    • 모두 익스포트 를 선택합니다. (4)

    maya_export_3.png

    위의 지오메트리 세팅은 언리얼 엔진 4 에 스태틱 메시 를 익스포트하기 위한 가장 기본적인 요건입니다.

  4. 프로젝트의 Content 폴더를 탐색합니다. FBX 파일이 추가된 것을 볼 수 있을 것입니다.

    maya_export_4.png

    임포트 옵션은 기본으로 놔둬도 됩니다. 각 옵션 관련 상세 정보는 FBX 임포트 옵션 레퍼런스 문서를 참고하세요.

  5. 이제 애셋이 임포트되었으니 콘텐츠 브라우저 에서 끌어 레벨에 놓으면 됩니다.

    max_export_7.png

    위 (임포트 옵션의 일부인) 예제에서는, 머티리얼텍스처 를 임포트했습니다.

  1. 뷰포트에서 익스포트할 메시 선택

    max_export_1.png

  2. File 메뉴에서 Export Selected (또는 선택에 상관없이 씬의 모든 것을 익스포트하려면 Export) 를 선택합니다.

    max_export_2.png

  3. UE4 프로젝트 내 Content 폴더(1)와 FBX 파일 이름(2)을 선택한 다음 max_save_button.jpg 버튼을 누릅니다.

    max_export_3.png

  4. FBX Export 대화창에 옵션을 설정한 다음 max_ok_button.jpg 버튼을 눌러 메시를 포함하는 FBX 파일 생성

    max_export_4.png

    위의 지오메트리 세팅은 언리얼 엔진 4 에 스태틱 메시 를 익스포트하기 위한 가장 기본적인 요건입니다.

  5. 임포트 옵션은 기본으로 놔둬도 됩니다. 각 옵션 관련 상세 정보는 FBX 임포트 옵션 레퍼런스 문서를 참고하세요.

  6. 이제 애셋이 임포트되어 콘텐츠 브라우저 에서 레벨로 끌어놓는 것이 가능합니다.

  7. 애셋이 임포트되어 이제 콘텐츠 브라우저 에서 레벨로 드래그할 수 있습니다.

    max_export_7.png

    (임포트 옵션의 일부인) 위 예제에서, 머티리얼텍스처 를 임포트했습니다.

잘하셨습니다! UE4 로 임포트할 메시를 준비하는 법을 배우셨습니다.

FBX 콘텐츠 파이프라인에 대해 좀 더 자세히 알아보려면 여기를 클릭하세요..

깔끔한 모델링은 게임의 퍼포먼스를 향상시킵니다.

6. 머티리얼 제작

머티리얼은 메시에 적용시켜 씬의 시각미에 기여하는 애셋입니다.
UE4 프로젝트에 쓸 머티리얼을 만들고 편집하는 방법은 몇 가지 있는데, 여기서는 머티리얼 에디터 를 사용하는 방법에 초점을 맞춰보겠습니다.

  1. 콘텐츠 브라우저 로 가서 신규 추가 버튼을 클릭한 다음 머티리얼 을 선택합니다.

    newCreateMaterial.png

  2. 머티리얼 이름을 'Rock' 이라 짓습니다.

    materialNaming.png

  3. 'Rock' 머티리얼 이 사용할 준비가 되었습니다.

    NewRockMaterial.png

  4. 'Rock' 머티리얼 을 더블클릭하면 머티리얼 에디터 가 열립니다.

    머티리얼 - 하우투 문서를 통해 머티리얼 노드에 대해 자세히 알아보실 수 있습니다.

텍스처 크기는 2 제곱수로 하세요.

7. 머티리얼 편집

이제 머티리얼도 새로 만들고 머티리얼 에디터 도 열려있을 것입니다.

머티리얼의 색, 광택, 투명도, 그 외 많은 것들을 머티리얼 에디터 에서 정의할 수 있습니다. 이제 아까 만든 'Rock' 머티리얼 을 편집할 준비가 되었습니다.

  1. 머티리얼 그래프 중앙의 메인 머티리얼 노드 를 선택합니다. 머티리얼 에디터 에서 선택된 노드가 강조되어 표시됩니다.

    newMainNode.png

    그래프에 있는 유일한 노드입니다 (머티리얼 이름을 땄습니다).

  2. 디테일 패널 에서 Shading ModelDefault Lit 에서 Subsurface 로 변경합니다.

    selectSubsurface.png

  3. Subsurface Shading Model메인 머티리얼 노드 의 핀 두 개를 활성화시킵니다: 오파시티서브서피스 컬러 입니다.

    newMorePins.png

  4. 그래프에 텍스처를 가져올 차례입니다. T 키를 누르고 에디터 그래프 영역에 좌클릭합니다. 그래프 안에 Texture Sample 노드가 나타날 것입니다.

    TextureSample.png

  5. 텍스처는 최소 두 개 필요합니다. 그래프가 아래 그림같아 보일 때까지 4 단계를 반복합니다.

    newTextureSampleNodes.png

  6. Texture Sample 노드 중 하나를 선택한 다음 디테일 패널 에서 Material Expression Texture Base 카테고리를 찾습니다.

    matExpressionTextureBase.png

    텍스처 프로퍼티 아래 없음 이라 되어있는 풀다운 메뉴를 클릭한 뒤 T_Rock_04_D 라는 컬러 텍스처를 선택합니다.

    검색창에 T_Rock_04_D 라 입력하여 텍스처 애셋을 찾을 수도 있습니다.

  7. 다른 Texture Sample 노드에 대해서도 6 단계를 반복, T_Rock_04_n 노멀 맵 텍스처를 선택하도록 합니다.

    newBothTexturesSelected.png

    머티리얼 그래프가 위 그림과 비슷할 것입니다.

  8. T_Rock_04_D Texture Sample 의 Color 핀 (하양) 을 Rock 머티리얼의 베이스 컬러 핀 에 연결합니다.

    newConnectColorPin.png

    새로 연결된 하양 핀 에는 텍스처의 컬러 채널이 들어있습니다.

  9. T_Rock_04_n Texture Sample 의 Normal 핀 (하양) 을 Rock 머티리얼의 노멀 핀 에 연결합니다.

    newConnectNormalPin.png

    새로 연결된 하양 핀 에는 텍스처의 노멀 맵에 대한 정보가 들어있습니다.

  10. 미리보기 가 아래 그림과 비슷해 보일 것입니다.

    newPreview_DN.png

  11. 1 키를 누르고 그래프 패널 을 세 번 좌클릭하여 Constant 노드를 셋 만듭니다.

    Constants.jpg

    Constant 노드는 변경 가능한 스칼라 float 변수입니다.*

  12. 3 키를 누르고 그래프 패널에 좌클릭하여 Constant3Vector 를 하나 만듭니다.

    Constant3.jpg

    Constant3Vector 노드는 변경 가능한 벡터로, 알파 채널 없는 컬러에 해당합니다.*

    Constant 표현식 작업 관련 상세 정보는 Constant 표현식 문서를 참고하세요.

  13. 선이 서로 꼬이거나 노드 아래 깔리지 않도록 깔끔히 정리해 줘야 할 것입니다.

    newMatConstantsAdded.png

  14. ConstantConstant3Vector 노드 전부 Rock 머티리얼 메인 노드 의 해당 핀에 연결합니다.

    newAllNodesConnectedNoVal.png

  15. ConstantConstant3Vector 각각에 대한 디테일 패널에서 Value 파라미터를 업데이트하여 값을 변경합니다.

    • Specular Value = 0.0

    • Roughness Value = 0.8

    • Opacity Value = 0.95

    • Subsurface Color = Red(1,0,0)

    newAllConnectedAllAdjusted.png

  16. 미리보기 가 아래 그림과 비슷해 보일 것입니다.

    newPreviewAll.png

    머티리얼 에디터 종료 전 반드시 머티리얼을 저장하도록 하세요.

거의 다 됐습니다! 방금 머티리얼 에디터 를 사용해서 Rock 머티리얼 을 편집했습니다.

머티리얼 에디터 키보드 단축키 전체 일람은 편집 메뉴 > 에디터 개인설정 > 키보드 단축키 > 머티리얼 에디터 의 "머티리얼 에디터-노드 스폰" 카테고리에서 찾을 수 있습니다.

8. 스태틱 메시 액터에 머티리얼 적용

이제 합칠 준비가 됐습니다!

이 단계의 목표는 우리 머티리얼 을 임포트한 스태틱 메시에 적용하는 것입니다. 구체적으로 배우게 될 내용은 다음과 같습니다:

액터의 기본 머티리얼 설정

여기서는 스태틱 메시 액터 의 기본 머티리얼 설정법을 보여드리겠습니다. 기본 머티리얼은 레벨에 액터 가 배치될 때마다 사용됩니다.

  1. 콘텐츠 브라우저 에서 이 가이드 전부분에 임포트했던 애셋을 더블클릭합니다.

    newBrowserContenAsset.png

    스태틱 메시 에디터 에 애셋이 로드되어 편집 가능합니다.

    StaticMeshEditor.jpg

  2. 디테일 패널에서 LOD0 아래, 머티리얼의 드롭다운 메뉴를 좌클릭합니다.

    LOD0.png

  3. 앞서 만든 Rock 머티리얼을 선택합니다. 선택 창에 머티리얼이 있을 것입니다.

    selectRockMaterial.png

    미리보기 패널 이 새로 적용된 머티리얼을 반영하도록 업데이트될 것입니다.

    NewDefaultMaterial.jpg

  4. 저장 버튼을 먼저 누르고, 머티리얼 에디터 를 닫습니다.

  5. 콘텐츠 브라우저 에서 텍스처를 새로 입힌 스태틱 메시 액터 를 끌어 레벨에 놓습니다.

    newMaterialInLevel.png

    레벨에 이 애셋을 배치할 때마다 지정된 머티리얼 이 사용됩니다.

액터에 사용되는 머티리얼 변경

레벨에 스태틱 메시 오브젝트를 배치할 때, 오브젝트 (액터) 의 인스턴스를 생성합니다. 모든 액터 인스턴스에 대해, 그 머티리얼 을 지정할 수 있습니다.

스태틱 메시 액터 의 머티리얼 변경 방법은 이렇습니다.

  1. 스태틱 메시 액터 를 선택합니다.

    newStatisMeshSelected.png

  2. 디테일 패널에서 Materials 섹션 위치를 찾은 다음 머티리얼 드롭다운 메뉴를 클릭합니다.

    materialDropDown.png

  3. 팝업 메뉴에서 다른 머티리얼을 선택합니다.

    selectTutorialAssetMat.png

  4. 또는 스태틱 메시 액터 에 새 머티리얼을 끌어 놓아도 됩니다.

    newMaterialDrop.png

스태틱 메시 액터에 머티리얼을 적용한 방법은 다음과 같습니다:

  • 액터의 기본 머티리얼 설정

  • 액터에 사용되는 머티리얼 변경

아티스트 퀵스타트 가이드를 떼셨습니다. 이제 다음과 같은 작업을 하실 수 있게 되셨습니다:

✓ 프로젝트 구성
✓ 머티리얼 제작
✓ 머티리얼 편집
✓ 스태틱 메시 액터에 머티리얼 적용

직접 한 번 연습해 보시겠어요?

9. 직접 해보기!

지금까지 배운 것을 토대로, 이 그래프와 비슷한 머티리얼 을 새로 만듭니다:

PlasticMaterialNetwork.png

메인 머티리얼 노드 세팅은 플라스틱 머티리얼에 대한 시뮬레이션입니다.

레벨에 Basic_Asset1 을 추가하고, 머티리얼을 적용한 뒤, "Brick" 노멀 맵 텍스처를 적용시켜 머티리얼을 업데이트합니다.

NormalMapAdded.jpg

이 퀵스타트 가이드에 다룬 주제 관련 상세 정보는, 언리얼 엔진 매뉴얼 을 참고하시기 바랍니다.

다양한 콘텐츠 임포트 관련 정보:

이 퀵스타트 가이드의 내용 중 구체적인 정보:

Select Skin
Light
Dark

새로운 언리얼 엔진 4 문서 사이트에 오신 것을 환영합니다!

문서 사이트에 대한 의견을 모을 수 있는 피드백 시스템을 포함해서 여러가지 새로운 기능을 준비하고 있습니다. 아래 Documentation Feedback 포럼(영문) 또는 언리얼 엔진 네이버 공식 카페(한글) 중 편하신 곳에 의견이나 문제점을 알려 주세요.

새 시스템이 준비되면 알려 드리겠습니다.

네이버 카페
공식 포럼