리깅 툴

애니메이션 & 리깅 툴세트, ART 에 포함된 리깅 툴 설명서입니다.

Windows
MacOS
Linux

애니메이션 리깅 툴세트 사용 프로세스의 첫 부분은 초기 스켈레톤 생성 작업입니다. ART 에서는 스켈레톤을 빠르게 생성하여 캐릭터 볼륨을 채우도록 조절하거나, 심지어 애니메이션 작업을 바로 시작할 수 있도록 캐릭터의 외양을 "스케치"할 수도 있습니다.

스켈레톤 생성

다음은 캐릭터 스켈레톤 생성 단계별 안내입니다.

초기 캐릭터 셋업

  1. 캐릭터를 생성하려면, Maya 인터페이스에서 Epic Games 메뉴로 가 Character Rig Creator (캐릭터 릭 생성기)를 선택합니다.

    ART_CreateCharacter.png

    세팅이 Maya 에서 Y 를 위로 사용하도록 (기본값) 설정된 경우, 월드 세팅이 Z-Up 으로 조정되었다 알리는 대화창이 뜰 것입니다. 언리얼 좌표계와 일치하기 위한 것입니다. 하지만 뷰포트 조작 시작이 이상할 수 있습니다. 이는 Maya 작동방식이 원래 그런 것으로, 이 툴세트와는 무관합니다. 해결책으로는 Alt+Home 키를 누르거나, 마우스를 View Cube 에 올리면 보이는 Home 버튼을 좌클릭 하면 됩니다.

    ART_ViewCube.png

  1. 캐릭터 릭 생성기 인터페이스 UI 상단에 있는 플로우 차트를 통해 어느 단계에 있는지, 다음 단계는 무엇인지 알 수 있습니다.

    ART_TopButtons.png

  2. 스켈레톤 생성 단계 도중, 각 사지의 여러 칸에 값을 입력하여 캐릭터의 조인트 셋업을 정의할 수 있습니다. 여분 조인트가 필요한 경우에도 걱정 마세요! 곧 그에 대해 다루겠습니다. 이 인터페이스 대부분은 꽤나 직관적입니다. 척추, 손가락 등의 조인트 수를 원하는 만큼 입력하세요. 생성 프로세스를 가속시키는 데 도움이 되는 몇 가지 것들이 있습니다. 오른쪽 다리와 오른쪽 팔 양쪽 모두 체크박스를 통해 왼쪽 사지 세팅으로 미러링할 수 있습니다:

    ART_BoneSetup.png

칸이 주황으로 변하면, 그 값은 툴 기본 값에서 변경되었다는 뜻입니다. 기본값과 다르다는 것을 쉽게 알 수 있는 방법입니다. 언제든 사지 영역에 우클릭 한 뒤 Reset to Defaults 를 선택하면 기본값으로 리셋시킬 수 있습니다. ART_ResetToDefaults.png

여분 조인트 추가

캐릭터에 여분 조인트를 추가하려면, Add Rig Modules 섹션에서 릭 모듈을 찾아 선택하여 추가합니다:

ART_ExtraJoints.png

현재 캐릭터에 추가할 수 있는 여분 조인트 유형은 세 가지입니다 (이 목록은 앞으로 늘어날 것입니다).

  • ART_LeafJointIcon.png Leaf Joint: 리프 조인트 - 용도가 많아 가장 자주 사용될 옵션일 것입니다. 리프 조인트는 아무 데나 배치할 수 있는 싱글 조인트입니다. 생성하려면 버튼을 좌클릭 한 뒤 인터페이스에 정보를 채우면 됩니다. TranslationRotation 을 선택하면 리깅 방식을 결정할 수 있습니다. 본이 회전만 필요한 경우, Rotation 만 체크하면 됩니다. 그 외의 경우 례를 들어 이동 채널도 풀린 채 빌드됩니다.

    ART_LeafJointInfo.png

  • ART_JiggleJointIcon.png Jiggle Joint: 지글 조인트 - 리프 조인트와 거의 같지만 피직스 시뮬레이션이 내장되어 있습니다. 지글 조인트는 캐릭터에 이차 모션을 추가하는 데 좋습니다. 리프 조인트와 마찬가지로 추가하는 방법은, 인터페이스에 조인트 이름과 부모를 채우기면 하면 됩니다.

    ART_JiggleJointInfo.png

  • ART_ChainIcon.png Dynamic Joint Chain: 다이내믹 조인트 체인 - 마지막 여분 조인트 옵션으로, 조인트를 원하는 개수만큼 조인트 체인으로 만들 수 있습니다. 조인트 체인은 FK 셋업, 스플라인 IK 셋업, 헤어 모낭을 사용하는 피직스 릭으로 리깅됩니다. 다이내믹 조인트 체인을 추가할 때 (ponytail 식으로) 베이스 이름, 체인 루트 조인트의 부모, 체인의 조인트 개수를 지정해 줘야 합니다.

    ART_DynChainJointInfo.png

커스텀 조인트 중 하나를 생성하고나면, 스켈레톤 셋업 패널 하단 Added Modules 목록에 나타납니다. Added Modules 오른편에는 선택된 모듈의 세팅이 있습니다. 여기서 부모나 조인트 개수같은 초기 세팅을 변경할 수 있습니다.

ART_CustomJointChains.png

목록에서 추가된 모듈을 제거하려면, 제거하고자 하는 것에서 [Delete] 키를 치기만 하면 됩니다.

모듈의 접두사 또는 접미사 작명 규칙을 지정할 수도 있습니다. (다음 단계의) 조인트 무버 대칭 모드에서 지정한 작명 규칙으로 모듈 작업을 할 수 있습니다.

ART_SkelCreationMirrorSettings.png

예를 들어, 골반 자손인 리프 모듈을 [pouch_a_l] 와 [pouch_a_r], 두 개 추가했습니다. 미러 세팅에서 지정한 작명 규칙을 사용했으므로, 다음 단계에서 대칭 모드를 켜면 이 모듈은 서로의 미러임을 압니다!

템플릿 사용

스켈레톤 생성 세팅을 위한 템플릿을 저장하고 로드할 수 있습니다.

  1. 템플릿 저장을 위해서는, 원하는 대로 세팅을 셋업하고 Template좌클릭 한 뒤 Save 를 선택합니다.

    ART_SaveLoad.png

  2. 템플릿을 로드하려면, 로드 옵션을 선택한 뒤 UI 에서 템플릿을 선택합니다:

    ART_LoadWindow.png

  3. 템플릿을 제거하려면, 제거하고자 하는 템플릿을 선택한 뒤 File -> Remove Selected Template 을 선택합니다:

    ART_RemoveTemplate.png

스켈레톤 배치

스켈레톤 세팅이 마음에 들면, 스켈레톤을 빌드하고 메시에 조인트를 배치할 차례입니다.

  1. UI 상단의 Skeleton Placement (스켈레톤 배치) 버튼을 좌클릭 합니다.

    ART_BuildSkel.png

  2. 그러면 Joint Mover (조인트 무버)라는 것이 빌드됩니다. 조인트 무버는 일종의 릭으로, 메시에 조인트를 빠르게 배치할 수 있도록 해줍니다. 뷰포트에 보면 전형적인 Maya 조인트 대신 프록시 메시가 보일 것입니다. 프록시 메시는 최종 애셋 없이도 애니메이터가 작업을 시작할 수 있도록 대략의 캐릭터 모습을 잡아주기 위해 있는 것입니다.

    ART_JointMover.png

조인트 무버 UI

조인트 무버에는 컨트롤 선택기와 커스텀 아웃라이너는 물론 여러가지 유용한 툴을 통해 프로세스 속도를 높일 수 있습니다. 왼쪽 툴바의 이들 각 툴에 대해서는 물론, 컨트롤과 선택기에 대해 간략히 설명해 드리겠습니다.

ART_JointMover_UI.png

툴바

툴바에는 캐릭터의 스켈레톤 및 프록시 지오메트리의 셋업에 필요한 기능이 전부 들어있습니다.

버튼

이름

설명

ART_button_SaveLoadTemplate.png

Save/Load Templates

템플릿 저장/로드 - 스켈레톤 생성 툴에서와 마찬가지로, 조인트 위치에 대한 템플릿을 저장한 뒤 다른 캐릭터에서 다시 로드할 수 있습니다. 스켈레톤 공유가 필요한 캐릭터가 여럿 있는 프로젝트에 정말 유용합니다.

ART_button_AimMode.png

Aim Mode

조준 모드 - 각 부모 무버를 자손에 조준하여, 항상 무버를 이동하여 부모가 자손을 향하도록 유지할 수 있습니다. 조준 모드를 끄면 영향받은 전체 조인트 배치가 유지됩니다.

ART_button_SymmetryMode.png

Symmetry Mode

대칭 모드 - 이동이 캐릭터 반대편에 미러링되도록 합니다. 왼편에 배치한 후 이 옵션을 켜면 오른편 배치에 미러링되도록 하거나, 처음부터 켜면 배치 도중 실시간 대칭 배치가 가능합니다. 대칭 모드가 켜져 있으면, 여러 다른 모드는 꺼집니다. 다른 툴을 다시 사용하려면 대칭 모드를 끄세요. 대칭 모드를 끄면 지금까지 미러링된 전체 조인트 배치가 유지됩니다.

ART_button_ResetToDefaults.png

Reset to Defaults

기본으로 리셋 - 전체 조인트 무버를 원래 생성 포즈로 (씬에 들어왔던 상태로) 리셋시킵니다. Ctrl + 좌클릭 은 현재 선택된 컨트롤만 리셋시키는 반면, Alt + 좌클릭 은 선택한 것과 그 이하 계층구조를 리셋시킵니다.

ART_button_GlobalMode.png

Global Mover Mode

글로벌 무버 모드 - 이 모드에서 조인트 무버는 선택된 조인트와 그 이하 계층구조를 이동시킵니다.

ART_button_OffsetMode.png

Offset Mover Mode

오프셋 무버 모드 - 이 모드에서 조인트 무버는 선택된 조인트 외 다른 것은 아무 것도 움직이지 않습니다.

ART_button_GeometryMode.png

Geometry Mover Mode

지오메트리 무버 모드 - 이 모드에서 조인트 무버는 프록시 지오메트리에만 영향을 끼치며, 조인트 배치에는 영향을 끼치지 않습니다. 지오메트리 무버는 캐릭터의 비율과 볼륨 윤곽을 잡기 위해 있는 것입니다.

ART_button_ProxyPhysique.png

Proxy Physique Shaper

프록시 피지크 셰이퍼 - 프록시 지오메트리의 모양을 다시 잡을 수 있도록 해 주는 슬라이더 시리즈가 표시됩니다. 바디 각 파트는 이런 식으로 변경 가능합니다. 고도로 전문화된 인간형 모양에 좋습니다.

ART_button_ToggleProxy.png

Toggle Proxy Mesh Visibility

프록시 메시 표시여부 토글 - 프록시 메시를 표시하고 숨깁니다. 조인트 방향 시각화에 좋습니다.

ART_button_Help.png

Help

도움말 - docs.unrealengine.com 의 도움말 문서를 엽니다.

조인트 무버 선택

툴바 옆의 커다란 캐릭터 그래프는 조인트 무버 선택 프로세스 단순화를 위해 쓰입니다. 이동하고자 하는 컨트롤 위치에 좌클릭 하면 선택됩니다.

ART_JointMoverSelection.png

참고로 손이나 발처럼 노랑 컨트롤 선택 박스에 클릭하면, 컨트롤 창에 그 조인트 체인에 표시되도록 업데이트되어, 척추 마디, 발가락, 손가락과 같은 조인트 체인 부분이나 사지를 빠르게 선택할 수 있습니다. 참고로 이 작업을 할 때는, 좌상단 구석에 파랑 화살표가 나타나 웹 브라우저 스타일로 이전 선택 화면으로 돌아갈 수 있습니다.

ART_HandJointMover.png

아웃라이너 뷰

UI 의 Outliner (아웃라이너) 탭을 클릭하면, 조인트 무버 릭의 커스텀 아웃라이너에 접근할 수 있습니다. 항목을 선택하면 글로벌 무버 컨트롤을 선택합니다. 선택 오른쪽의 파랑 박스를 클릭하면 오프셋 무버 컨트롤을 선택합니다. 분홍 박스를 클릭하면 선택 항목의 지오메트리 무버 컨트롤을 선택합니다.

ART_Outliner_View.png

잠금

대칭 모드 또는 조준 모드를 사용할 때, 특정 조인트에는 영향을 끼치지 않도록 하고플 때가 있습니다. 그럴 때 내장된 lock (잠금) 기능을 사용하면 됩니다. 아웃라이너에서 영향을 끼치지 않도록 하고자 하는 조인트/무버를 선택한 뒤, 우클릭 후 "Lock Selected" (선택 잠금)을 선택하면 됩니다:

ART_LockSelected.png

선택을 잠그도록 선택한 이후에는, 텍스트가 이탤릭으로 변하는게 보이며, 이름 옆에 빨강 원이 나타나 잠겼음을 알 수 있습니다. 잠금을 해제하려면, 우클릭 후 "Unlock Selected" (선택 잠금해제) 또는 "Unlock All" (모두 잠금해제) 하면 됩니다.

조인트 위치

프로세스 이 시점에서 실제 스켈레톤은 없습니다. 결국 스켈레톤이 될 표현물만 있는 상태입니다. 각 조인트에서 여기 보이는 컨트롤은 정확한 최종 조인트 생성 위치 및 그 로컬 회전 축을 알려줍니다.

ART_jointRep.png

조인트를 확인하려는 경우, Joint Mover Tools (조인트 무버 툴) 메뉴의 옵션을 통해 프리뷰 스켈레톤을 빌드하면 됩니다:

ART_BuildPreviewSkeleton.png

그러면 최종 스켈레톤 생성에 사용되는 동일한 코드로 조인트 임시 프리뷰를 생성합니다. 원한다면 같은 메뉴에서 프리뷰 스켈레톤을 지우거나 리빌드할 수도 있습니다.

글로벌로 굽기

조인트 무버 툴 메뉴 아래에서 찾을 수 있는 툴입니다:

ART_BakeToGlobal.png

오프셋 무버에 있는 값을 취해 글로벌 무버에 구은 뒤 오프셋 무버는 제로 설정하여 놔둡니다. 오프셋 작업을 다시 할 수 있도록 깔끔하게 정리하고자 할 때 편리합니다. 이 기능은 Aim Mode 를 사용하면 자동으로 일어납니다. Aim Mode 를 끄면 Bake To Global 이 자동 실행되어 오프셋 컨트롤 값을 글로벌 컨트롤에 넣습니다.

손과 발 피벗

조인트 무버 릭의 조인트 위치에 영향을 끼치지 않는 것 같은 컨트롤이 몇몇 보일 수 있습니다. 이 컨트롤은 툴에서 릭을 빌드할 때 손과 발의 피벗으로 사용하는 것입니다:

ART_PivotControls.png

이 피벗은 손과 발 롤, 사이드 투 사이드 롤, 다양한 피벗 회전고리 지점과 같은 릭의 특성에 사용됩니다:

ART_PivotExample.png

최종 스켈레톤 생성

조인트 무버로 조인트를 배치하는 작업이 끝났으면, UI 상단의 Deformation Setup 버튼을 눌러 툴에게 최종 스켈레톤을 생성하도록 하면, Rig Pose (릭 포즈)를 생성할 수 있고, 그 후 스킨 웨이팅 툴을 사용할 수 있습니다.

ART_SkinWeight.png

릭 포즈

Deformation Setup 버튼을 좌클릭 하면 대화창이 몇 개 뜹니다. 첫 번째는 릭 포즈 대화창입니다:

ART_RigPoseDialog.png

Rig Pose (릭 포즈)는 애니메이터가 작업하고자 바라는 포즈로, 최소 여기 에픽에서는 거의 T 포즈입니다. 가끔 이 부분은 위상 흐름(topological flow), 레퍼런스 머티리얼, 텍스처, 심지어 모델러의 개인 취향에 따라 모델링된 포즈와 다를 수 있습니다. 릭 포즈 생성 목적은 모델러와 애니메이터가 선호하는 포즈가 달라 생기는 문제를 줄이기 위해서입니다.

모델이 이미 리깅에 좋은 포즈에 있으면, Create Rig Pose (릭 포즈 생성) 버튼을 클릭하세요. 하지만 다음 대화창에서 툴이 캐릭터를 T 포즈로 만들도록 하겠냐고 물어오면, "No" 를 치면 됩니다.

릭 포즈 생성 을 선택했으면, 툴이 캐릭터를 미리 정의된 T 포즈로 만들도록 시도하겠냐고 묻는 창이 다시 뜹니다.

ART_AutoRigPose.png

이 이후에도 릭 포즈를 편집할 수 있으며, 좋은 시작점이 됩니다. "No" 를 치고 처음부터 원하는 릭 포즈 정의 작업을 해도 됩니다.

포즈 생성을 완료했으면, Save Rig Pose (릭 포즈 저장** 버튼에 좌클릭하면 별도의 대화창이 뜹니다.

ART_CreateRigPoseDone.png

조인트 무버 툴을 사용하여 릭 포즈를 생성하게 됩니다. 걱정하지 마세요, 원래 배치는 Model Pose (모델 포즈)라는 곳에 아직 저장 보존되어 있습니다. 스켄 웨이팅 프로세스 도중 Reference Pose Manager (레퍼런스 포즈 매니저) 메뉴를 통한 툴 안에서 모델 포즈릭 포즈 둘 다 확인할 수 있습니다.

릭 포즈를 저장한 이후 자동으로 프록시 메시 웨이팅 작업을 하겠냐고 묻는 대화창이 뜹니다. 이는 아직 최종 모델이 없는 경우 추천하는 옵션이며, 프로토타입 목적으로 프록시 메시를 사용할 것입니다:

ART_AutoSkin.png

캐릭터 스키닝

캐릭터 스키닝 작업은 기본 Maya 작업 방식입니다. 새로 생성된 ART 조인트( 또는 루트 조인트)와 바인딩하고자 하는 메시를 선택하고, 애니메이션 메뉴 세트에서 Skin menu -> Smooth Bind -> Smooth Bind 를 선택합니다.

ART_NormalizeWeights_settings.pngMaya 2013 에서 Skin menu -> Smooth Bind -> Smooth Bind Options 의 기본 Normalize Weights 세팅이 Post 로 설정되어 있는데, 작동방식이 마음에 들지 않을 수 있습니다. 마음에 들지 않는 부분을 최소화시키거나 Maya 이전 버전에서처럼 작업하는 것을 선호하는 경우, 옵션을 Interactive 로 설정하세요.

스킨 웨이트 툴

대부분의 경우 스킨 웨이트 UI 는 Maya 기본과 매우 비슷한데, 작업 속도를 높여주는 툴과 기능이 다수 추가되었다는 차이가 있습니다.

ART_SkinningWindow.png

스킨 웨이트 툴 툴바

버튼

이름

설명

ART_button_PaintMode.png

Paint Skin Weights

스킨 웨이트 페인트 - 메시에 스킨 웨이트를 칠할 수 있는 페인트 툴에 들어갑니다. Maya 의 Paint Skin Weights 툴과 본질적으로 같습니다.

ART_button_ROM.png

Range of Motion

모션 범위 - 모션 범위 대화창을 띄워, 모션 키프레임 범위를 빠르게 만들어 스키닝을 테스트할 수 있습니다. 아래 모션범위 섹션을 참고하세요.

ART_button_TabSens.png

Toggle Tablet Sensitivity

태블릿 감도 토글 - 페인트 모드에서의 태블릿 감도 활용 여부 토글입니다.

ART_button_MirrorSkin.png

Mirror Skin Weights

스킨 웨이트 미러링 - Maya 의 Mirror Skin Weights 명령 대화창을 띄웁니다.

ART_button_Prune.png

Prune Skin Weights

스킨 웨이트 쳐내기 - Maya 의 Prune Weights 명령 옵션을 열어, 사소한 웨이트 값을 없앨 수 있습니다. 사소한 스키닝 오차를 정리합니다.

ART_button_AddInfl.png

Add Influence

인플루언스 추가 - 지오메트리 조각에 스키닝 인플루언스를 추가하는 데 사용됩니다. 예를 들어 지오메트리에 영향을 끼치는 조인트가 기본으로 가능한 것보다 더욱 많이 필요한 경우입니다.

ART_button_RemoveInfl.png

Remove Influence

인플루언스 제거 - 지오메트리 조각에서, 표면을 변형시키지 말아야 하는 본처럼 원하지 않는 인플루언스를 제거할 수 있습니다. 웨이트가 0 인 인플루언스를 자동 제거하는 기능도 포함되어 있습니다.

ART_button_ExportWeights.png

Export Weights

웨이트 익스포트 - 스킨 웨이트 맵을 익스포트합니다. 스킨 웨이트 익스포트에는 파일 이름이 필요하며, 각 버텍스의 웨이팅 정보를 저장합니다.

ART_button_ImportWeight.png

Import Skin Weights

스킨 웨이트 임포트 - 스킨 웨이트 파일 선택 인터페이스를 띄우고 해당 웨이트 값을 상응하는 버텍스에 임포트합니다.

ART_button_Help.png

Help

도움말 - docs.unrealengine.com 에서 도움말 문서를 엽니다.

스킨 웨이트 페인트

툴 세팅

ART_SkinningToolSettings.png

툴 세팅 영역은 Profile (프로파일), Skin Tools (스킨 툴), Mode (모드) 세 가지 핵심 영역으로 이루어져 있습니다.

  • 프로파일 - 페인트 브러시 모양을 제어합니다. 여러가지 감쇠 모양의 둥근 브러시가 셋, 입체 사각형 브러시가 하나 있습니다.

  • 스킨 툴 - 스키닝 프로세스 속도 향상을 위한 다양한 전문 툴이 포함되어 있습니다. 아래 스킨 툴 섹션을 참고하세요.

  • 모드 - 웨이트 페인팅 모드 / 선택 모드 전환이 가능합니다. 아래 모드 섹션을 참고하세요.

스킨 툴

버튼

이름

설명

ART_button_copyWeight.png

Copy Skin Weight

스킨 웨이트 복사 - 단일 선택 버텍스에서 스킨 웨이트를 복사합니다.

ART_button_PasteWeight.png

Paste Skin Weight

스킨 웨이트 붙여넣기 - 단일 버텍스에서 복사한 스킨 웨이트를 다수의 선택된 버텍스에 붙여넣습니다.

ART_button_WeightHammer.png

Hammer Weights Tool

웨이트 해머링 툴 - 선택된 버텍스에 주변 버텍스의 평균 웨이트 값을 주어 예상치 못한 동작을 보이는 도둑(rogue) 버텍스를 빠르게 청소하는 툴입니다.

ART_button_MoveInfluences.png

Move Influences Tool

인플루언스 이동 툴 - 한 인플루언스에서 다른 인플루언스로 웨이트를 옮길 수 있도록 해줍니다.

ART_button_ShowInflVerts.png

Show Influenced Vertices

인플루언스 적용 버텍스 표시 - 선택된 인플루언스에 영향받은 버텍스를 강조해 보여줍니다.

모드

Paint (페인트)와 Select (선택) 두 가지 모드가 있습니다. Maya 의 웨이트 페인트 툴과 달리, 선택 툴은 엄청나게 유용한 UI 옵션이 추가 제공됩니다.

이 선택 툴 대부분은 메시의 엘리먼트 선택을 위한 것이거나, 쉬운 플러딩을 위해 그 선택을 버텍스로 변환하는 것 아니면 그 일레먼트를 고립시키고 페인트 모드로 돌아가 그것만 보이도록 하는 것입니다.

선택

animationTool_ModeSelection_select.png

ART_SelectionTools.png

이 모드에서는 Maya 의 폴리곤 선택 툴 전체 기능이 제공됩니다.

이름

설명

Isolate Element From Selection

선택에서 엘리먼트 고립 - 컴포넌트를 선택한 상태에서, 이 옵션은 엘리먼트 (붙은 면 세트)를 선택하고 View -> Isolate Selection -> View Selection 을 토글합니다. 이 버튼은 클릭하면 Exit Isolation Mode (고립 모드 종료)로 변경됩니다.

Select Element

엘리먼트 선택 - 선택된 컴포넌트에 따라 이 옵션은 엘리먼트 (단수 또는 복수)를 선택합니다.

Isolate Selection

선택 고립 - Isolate Element From Selection 와 비슷하지만 전체 엘리먼트 를 선택하지는 않고, 컴포넌트에 연결된 면만 선택한 뒤 View -> Isolate Selection -> View Selection 를 토글시킵니다. 이 버튼은 클릭하면 Exit Manual Isolation Mode (수동 고립 모드 종료)로 변경됩니다.

Convert Selection To Verts

선택을 버텍스로 변환 - 면, 선, UV 를 선택한 상태에서, 선택을 버텍스로 변환합니다.

선택 고립 모드에서 Undo (되돌리기)를 하지 말고, Exit Isolation Mode 또는 Exit Manual Isolation Mode 버튼을 사용하세요. 되돌리기 를 하면 Isolate Selection -> View Selected 가 종료되지만, 버튼 클릭은 되돌리기 되지 않아 Exit 버튼만 남게 되는데, 여기서 이걸 클릭하면 Isolate Selection -> View Selected 로 돌아는 가지만 아무것도 선택되지 않아 씬의 모든 것이 숨겨진 것처럼 보일 것입니다. 이 때 되돌리기 를 다시 하면 모든 것이 표시됩니다.

인플루언스 (페인트)

ART_ModeSelection.png

ART_skinning_InfluencesSection.png

Influence List (인플루언스 리스트)는 페인트 모드 ART_button_PaintMode.png 에서 스키닝된 지오메트리를 선택해야 채워집니다.

인플루언스 리스트는 인플루언스 이름별, 또는 잠금/해제된 인플루언스 별로도 소팅 가능합니다:

Paint Operations (페인트 작업)은 Maya 에서와 똑같습니다.

ART_Skin_PaintOps.png

그 외의 툴 변경사항은 오파시티 빠른 설정 버튼 및 값 슬라이더 추가입니다. 해당 특성에 일반적인 값을 빠르게 설정하는 버튼입니다.

ART_Skin_Opacity.png

디스플레이 세팅

ART_Skin_DisplaySettings.png

이름

설명

Draw Brush

브러시 그리기 - 웨이트 브러시 표시여부 토글입니다.

Show Wireframe

와이어프레임 표시 - 모델의 와이어프레임 표시여부 토글입니다.

Color Feedback

컬러 피드백 - 스키닝의 컬러 피드백 표시여부 토글입니다.

모션 범위 툴

Range of Motion (모션 범위) 버튼을 누르면 모션 범위 툴이 열리는데, 특별히 언급할 가치가 있는 툴입니다. 모델의 애니메이션 모션 범위를 자동으로 생성하여, 타임 슬라이더만 끄튼 것으로 스킨 웨이팅 퀄리티를 테스트해 볼 수 있습니다.

ART_RangeOfMotion.png

인터페이스는 스켈레톤에 있는 모든 조인트 목록으로 구성됩니다. 애니메이션을 적용하고자 하는 조인트를 선택하고 Generate Range of Motion Keys (키 모션 범위 생성) 버튼을 클릭합니다.

일반적으로는 개별 회전시킬 필요가 없는 척추 관절처럼, 어떤 조인트들을 하나의 단위로 회전시키고자 하는 경우, 그 조인트들을 선택한 뒤 Solve as One Item 박스를 체크합니다. 그러면 설정된 각각의 키가 하나의 조인트가 아닌 전체 척추용인 것처럼 취급됩니다.

모션 범위 애니메이션 제거는, 컨트롤 릭 빌드 전 항상 해 줘야 할 텐데, 모션 범위 버튼에 우클릭 후 clear (지우기) 옵션을 선택하면 됩니다:

레퍼런스 포즈 매니저

ART_ReferencePoseManager.png

이름

설명

Assume Model Pose

모델 포즈 가정 - 스켈레톤이 모델 포즈를 가정합니다. 모델 포즈는 배치 편집 모드에서 모델 포즈 리셋 옵션을 사용하여 컨트롤 오브젝트의 회전을 편집하는 것으로 설정할 수 있습니다.

Assume Rig Pose

릭 포즈 가정 - 스켈레톤이 릭 포즈를 가정합니다. 릭 포즈는 배치 편집 모드에서 릭 포즈 리셋 옵션을 사용하여 컨트롤 오브젝트의 회전을 편집하는 것으로 설정할 수 있습니다.

Reset Model Pose

모델 포즈 리셋 - 모델 포즈를 현재 컨트롤 오브젝트가 있는 포즈로 설정합니다. 배치 편집 모드에서 가장 유용합니다.

Reset Rig Pose

릭 포즈 리셋 - 릭 포즈를 현재 컨트롤 오브젝트가 있는 포즈로 설정합니다. 배치 편집 모드를 떠나면 시스템에서는 현재 포즈를 릭 포즈로 사용하여 일반적인 사례를 적용하겠냐고 묻습니다. 배치 편집 모드에서 가장 유용합니다.

컨트롤 릭 빌드하기

이 시점에서 헐크 야수같은 거친 모양의 프록시 셰이프 다수가 있을 수도 있고, 조인트에 스키닝까지 완벽하게 된 현실 캐릭터가 있을 수도 있습니다. 무엇이든, Control Rig (컨트롤 릭)을 만들 차례입니다.

  1. Build Control Rig Button (컨트롤 릭 빌드) 버튼을 클릭합니다.

    ART_BuildControlRig_full.png

  2. Publish Character (캐릭터 퍼블리싱) 인터페이스가 나타납니다.

    ART_PublishCharacter_empty.png

    이제 캐릭터를 퍼블리싱할 프로젝트를 선택할 수 있습니다. 또는 프로젝트가 아직 없는 경우, 프로젝트 드롭다운 왼편의 새 프로젝트 버튼을 클릭하면 됩니다:

    ART_AddNewProject.png

    그런 다음 캐릭터에 이름을 짓거나, 목록에서 이름을 선택하여 그 캐릭터 이름을 덮어씁니다:

    ART_PublishCharacter_full.png

    MEL 또는 Python 스크립트를 통해 릭에 별도로 추가하고자 하는 사용자를 위한 고급 섹션이 있습니다. 커브상의 CV 스케일 조절같은 단순한 변경에서부터 보다 복잡한 커스텀 작업까지 가능합니다. 단순히 스크립트 파일을 로드하면 툴이 릭 빌드를 마친 후 실행해 줍니다. 어떤 이유로든 실행에 실패하면 알림이 뜨지만, 그냥 스크립트 없이 릭은 여전히 빌드됩니다.

    ART_Advanced.png

  1. 다음 단계는 캐릭터에 썸네일을 지정하는 것입니다. 미니 뷰포트를 표준 Maya 카메라 조작법 또는 왼편의 조작 버튼을 사용하여 사용하고자 하는 썸네일 구도를 잡습니다. 만족스러우면 Camera 버튼을 클릭하여 썸네일을 캡처합니다. 그러면 릭 빌드 프로세스가 발동됩니다.

    ART_CharacterPortrait.png

  2. 전체 프로세스는 보통 1 분이 채 걸리지 않으며, 완료되면 Operation Complete 대화창이 표시됩니다.

    ART_OperationComplete.png

    드라이브에 생성된 파일은 각 파일 경로 옆 돋보기 아이콘을 클릭하여 확인할 수 있습니다. 릭 파일을 직접 편집하여 원하는 대로 수동 조정할 수도 있습니다.

  3. Close 를 클릭하면 이 씬이 지워지는데, 의도된 것입니다.

이 시점에서 캐릭터 애니메이션 준비가 완료되었으며, 그 파일은 다음 위치에서 찾을 수 있습니다:

/MayaTools/General/ART/Projects/YourProject/ExportFiles

익스포트 파일에서 레퍼런스되는 애니메이션 릭 파일이 생성되었으며 다음 위치에서 찾을 수 있습니다:

/MayaTools/General/ART/Projects/YourProject/AnimRigs

캐릭터 추가

캐릭터가 퍼블리싱된 상태 또는 소스 컨트롤에서 받아오는 애니메이터라면, 씬에 가져와 애니메이션을 시작할 수 있습니다. 씬에 캐릭터를 추가하려면, Epic Games -> Add Character For Animation 메뉴 항목을 사용합니다.

ART_AddCharacter.png

캐릭터가 들어있는 프로젝트와 캐릭터 자체를 선택한 뒤, Add 또는 Add and Close 를 눌러 이후의 UI 를 닫습니다.

ART_AddCharacterUI.png

ART 애니메이션 인터페이스 사용 방법 관련 상세 정보는, 애니메이션 툴 문서를 참고하세요.

캐릭터 편집

언제든 파이프라인으로 돌아가 조인트 배치나 심지어 스켈레톤 세팅을 편집할 수도, 조인트를 추가 또는 제거할 수도 있습니다.

게다가 Build Control Rig 프로세스를 통해 이미 퍼블리싱된 캐릭터를 편집할 수 있습니다.

씬에서 작업중이고 Epic Games -> Edit Existing Character 옵션으로 캐릭터를 편집할 필요가 있는 경우, 반드시 씬을 저장 하세요. 편집하려고 선택한 캐릭터는 Maya 에 강제 로드되어 현재 씬의 진행상황이 저지될 것입니다.

계속하기 전 반드시 작업 내용을 저장하세요.

퍼블리싱된 캐릭터를 편집하려면, Epic Games -> Animation Rigging Toolset -> Edit Existing Character 로 갑니다:

ART_EditCharacter.png

그러면 편집할 캐릭터 선택을 위한 인터페이스가 뜹니다. 툴이 생성한 모든 익스포트 파일 리스트입니다:

ART_EditCharacter_interface.png

캐릭터를 선택하고 Edit Export File 에 클릭했으면, 캐릭터의 익스포트 파일을 열어 리깅 파이프라인에 사용되는 UI 가 뜹니다. 로드가 완료되면, ART 리깅 툴세트 인터페이스를 사용하여 원하는 대로 변경할 수 있습니다. 스킨 웨이팅 이상의 변경을 가한 경우 컨트롤 릭을 다시 빌드해줘야 합니다. 편집이 완료되면 Build Control Rig 버튼을 누르면 됩니다.

Maya 의 참조 시스템은 탄탄해서, 원하는 대로 모두 변경해도 이후의 (애니메이션, 스키닝 등의) 작업에 끼치는 영향은 거의 없을 것입니다. 여기에는 단 한가지, 릭의 이름이나 체계가 크게 변하지 않았다는 가정이 있는데, 크게 변한 경우 변화가 레퍼런스 체인 위로 전파될 것입니다.

크게 변한 경우의 예라면 캐릭터에 꼬리가 있었는데, 그 꼬리를 새로운 이름으로 다시 빌드한 경우, 그 조인트의 모든 애니메이션 및 스키닝 데이터를 잃게 됩니다.

그 외 사소한 변경사항도 애니메이션 재작업을 요할 수 있습니다.

캐릭터가 로드되고나면, ART 리깅 툴세트는 Deformation Setup 모드에 있을 것이나, Skeleton Placement 또는 Skeleton Creation 모드로 가 원하는 대로 변경해도 됩니다.

ART_EditCharacter_SkelPlac.png

Skin Weight 모드에서 Skeleton Placement 모드에 들어갈 때 스켈레톤에 스키닝된 메시가 있습니다 (자동 스키닝된 프록시 메시는 치지 않습니다). 그 경우 툴에서 스킨 데이터를 보존해 보려 노력은 하겠지만 완벽하지 않을 수 있다고 알리는 확인 창이 뜰 것입니다.

Skeleton Creation 모드에서 추가된 조인트는 이전에 스켈레톤에 스키닝되었던 캐릭터 메시의 스키닝 데이터에 자동 추가되지 않습니다. 추가하려면 단지 Add Influences 버튼을 누른 뒤 목록에서 새 조인트를 선택하면 됩니다.

ART_AddInf.png

ART_AddInf_post.png

새 조인트는 고정 상태 및 메시에 인플루언스가 없는 상태로 시작합니다.

Deformation Setup 모드로 돌아오자마자, 저장된 스킨 데이터가 스키닝된 메시에 다시 적용됩니다.

커스터마이제이션

시각화에 도움을 주기 위해, 프록시 지오메트리와 유저 인터페이스 그래픽 양쪽의 커스터마이제이션이 가능합니다.

조인트 무버 프록시 지오메트리용 커스텀 컬러 팔레트

조인트 무버 프록시 지오메트리는 UV 가 적용되어 있어서 캐릭터의 컬러 팔레트 프로토타입 작업을 빠르게 할 수 있습니다. PSD 파일 위치는 다음과 같습니다: /UE4/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Icons/ART/jointMover.psd

이 PSD 모든 부분에는 라벨과 컬러 코딩이 되어 있어 쉽게 선택하고 버킷을 채울 수 있습니다:

ART_CharacterProxyUV.png

이렇게 하면 조인트 무버의 파트의 커스텀 컬러 견본을 추가하여 모양 커스터마이징이나 엠블렘 추가같은 작업이 가능합니다:

ART_CharacterColorPrototyping.png

부가 자료

추가적인 도움말은 Epic Games -> Help -> Learning Videos 섹션의 Lerning Videos 부분을 참고하세요:

ART_Help.png

리깅 및 애니메이션 관련 주제에 대한 비디오 목록이 뜹니다:

ART_Videos.png

새로운 언리얼 엔진 4 문서 사이트에 오신 것을 환영합니다!

문서 사이트에 대한 의견을 모을 수 있는 피드백 시스템을 포함해서 여러가지 새로운 기능을 준비하고 있습니다. 아래 Documentation Feedback 포럼(영문) 또는 언리얼 엔진 네이버 공식 카페(한글) 중 편하신 곳에 의견이나 문제점을 알려 주세요.

새 시스템이 준비되면 알려 드리겠습니다.

네이버 카페
공식 포럼