게임 코드 관리

코드를 추가하고 프로젝트 파일을 생성하는 법입니다.

Windows
MacOS
Linux

[/VAR]

[VAR:OSSelect_Linux]

프로젝트에 코드 추가하기

C++ 클래스 마법사

C++ 클래스 마법사 (C++ Class Wizard)는 자신만의 함수성을 원하는 대로 확장할 수 있도록 프로젝트에 네이티브 C++ 코드 클래스를 쉽고 빠르게 추가시켜 줍니다. 콘텐츠 전용 프로젝트를 코드 프로젝트로 변환해 주기도 하구요. C++ 클래스 마법사를 여는 방법은 다음과 같습니다:

Windows에서는 Visual Studio 2015 이상, Mac에서는 Xcode 8 이상 버전이 설치되었는지 확인해 주시기 바랍니다.

  1. 메인 에디터에서 파일 > 새 C++ 클래스... 를 선택합니다.

    FileCPP.png

  2. C++ 클래스 마법사 가 뜨며, 흔히 추가되는 클래스를 표시합니다. 찾고 있는 클래스가 보이지 않는 경우, 전체 클래스 족보를 봐야 합니다. 창 우상단 구석의 모든 클래스 표시 박스를 체크하세요.

    기본 클래스

    모든 클래스

    추가하고자 하는 클래스를 선택한 뒤 다음 > 버튼을 누르세요.

  3. 새로운 클래스에 이름 을 입력하라는 창이 뜹니다. 입력한 다음 클래스 생성 버튼을 누릅니다. 그러면 헤더(.h) 와 소스(.cpp) 파일이 생성됩니다.

    클래스 이름은 알파벳과 숫자만 가능하며, 공백은 불가능합니다. 잘못된 이름을 입력하면 입력칸을 통해 알 수 있습니다.

  4. 코드가 Visual Studio 에서 바로 편집 가능한 상태로 열릴 것입니다.

    CodeEditing.png

    코드가 바로 Xcode 에 편집가능한 상태로 열립니다.

    CodeEditing_xcode.png

편집이 끝난 후 클래스를 컴파일하는 법에 대한 안내는, 프로젝트 컴파일 관련 문서 를 참고해 주시기 바랍니다.

개발 환경

코드 파일은 Visual Studio 를 통해 생성하여 솔루션 탐색기 를 통해 일반적인 방식으로 게임 프로젝트에 추가시킬 수 있습니다. Visual Studio 외부에서 적합한 폴더에 코드 파일을 추가한 다음 솔루션과 프로젝트 파일을 자동으로 리빌드할 수도 있습니다. 운영체제 UI 를 통해 다수의 파일을 빠르게 추가하는 작업을 쉽게 할 수 있으며, 팀원간에 솔루션과 프로젝트 파일을 동기화시킬 필요도 없기에 팀 작업도 편해집니다. 각 개인은 그저 코드 파일을 동기화시키고 로컬에서 프로젝트 파일을 리빌드하면 되는 것입니다.

코드 파일은 Xcode 를 통해 생성하여 Project Navigator 를 통해 일반적인 방식으로 게임 프로젝트에 추가시킬 수 있습니다. Xcode 외부에서 적합한 폴더에 코드 파일을 추가한 다음 프로젝트 파일을 자동으로 리빌드할 수도 있습니다. 운영체제 UI 를 통해 다수의 파일을 빠르게 추가하는 작업을 쉽게 할 수 있으며, 팀원간에 솔루션과 프로젝트 파일을 동기화시킬 필요도 없기에 팀 작업도 편해집니다. 각 개인은 그저 코드 파일을 동기화시키고 로컬에서 프로젝트 파일을 리빌드하면 되는 것입니다.

개발 환경에서 프로젝트 열기

프로젝트가 이미 에디터에 열려있는 경우, 파일 메뉴의 Visual Studio 에서 열기 를 선택하여 Visual Studio 에서 쉽게 열 수 있습니다.

open_visual_studio.png

프로젝트를 Visual Studio 에서 여는 것은 Windows 탐색기나 Visual Studio 의 File > Open > Project/Solution 을 통해서도 가능합니다.

  • 프로젝트의 루트 디렉터리에 있는 [프로젝트명].sln Visual Studio 솔루션 파일을 엽니다.

프로젝트가 이미 에디터에 열려있는 경우, 파일 메뉴의 Xcode 에서 열기 를 선택하여 Xcode 에서 쉽게 열 수 있습니다.

open_xcode.png

Finder 또는 Xcode 의 File > Open 을 통해 Xcode 에서 프로젝트를 열 수도 있습니다.

  • 프로젝트의 루트 디렉터리에 위치한 [ProjectName].xcodeproj Xcode 프로젝트를 엽니다.

프로젝트 파일 생성

프로젝트 파일은 중간 파일로 간주되며, [ProjectDirectory]\Intermediate\ProjectFiles 에 위치합니다. 즉 Intermediate 폴더를 지우면 프로젝트 파일을 재생성해야 한다는 뜻입니다.

.uproject 파일

  1. Windows 탐색기에서 [ProjectName].uproject 위치로 이동합니다.

  2. [ProjectName].uproject 파일에 우클릭한 다음 Generate Visual Studio Files 를 선택합니다.

    Generate_Visual_Studio_Files.png

  3. UnrealBuildTool 이 프로젝트 파일과 솔루션 업데이트는 물론, Intellisense 데이터 생성까지 해 줍니다.

    generate_project_files.png

  4. 프로젝트의 루트 디렉터리에 위치한 [ProjectName].sln Visual Studio 솔루션 파일을 열어 Visual Studio 에서 게임 프로젝트를 봅니다.

  1. Finder 에서 [ProjectName].uproject 위치로 이동합니다.

  2. [ProjectName].uproject 파일에 우클릭하고 Generate Xcode Files 를 선택합니다.

    Generate_Xcode_Files.png

  3. UnrealBuildTool 이 프로젝트를 업데이트합니다.

    generate_project_files_xcode.png

  4. 프로젝트의 루트 디렉터리에 있는 [ProjectName].xcodeproj Xcode 프로젝트를 열면 Xcode 에서 게임 프로젝트를 볼 수 있습니다.

Select Skin
Light
Dark

Welcome to the new Unreal Engine 4 Documentation site!

We're working on lots of new features including a feedback system so you can tell us how we are doing. It's not quite ready for use in the wild yet, so head over to the Documentation Feedback forum to tell us about this page or call out any issues you are encountering in the meantime.

We'll be sure to let you know when the new system is up and running.

Post Feedback