Language:
Share
此中文页面内容对应的英文页面有后续更新,如需浏览最新文档可切换至英文页面浏览。

Matinee编辑器参考指南

概述

以下屏幕截图显示了Matinee编辑器:

Matinee Interface

  1. 菜单栏

  2. 工具栏

  3. 曲线编辑器

  4. 轨迹视图

  5. 详细信息

您可以通过点击选卡右上角的小 "X" 来关闭任何面板。您也可以通过右击面板,然后在弹出的关联菜单中点击 Hide Tab(隐藏选卡),来隐藏任何面板。要想再次显示您已经关闭的面板,在 Window(窗口) 菜单中点击那个面板的名称即可。

关于Matinee的更多信息,请参照Matinee 用户指南

菜单栏

文件

项目

描述

Import(导入)

导入 FBX 文件或场景。

Export All(全部导出)

将整个场景(虽然有些项不能导出)导出到一个FBX 文件中,以便在外部 3D 内容创建包中进行编辑。

Export Sound Cue Info(导出声效信息)

将 Matinee 序列的所有 SoundCue 信息导出到一个 CSV 文件。

Export Animation Track Info(导出动画轨迹信息)

将该Matinee序列的所有动画轨迹信息导出到一个CSV文件中。

Bake Transforms on Export(导出时烘焙变换)

切换在导出场景之前是否烘焙变换。

Save All(保存所有)

保存您的关卡。

Choose Files to Save(选择要保存的文件)

供您选择要保存哪个已修改的关卡资源。

Connect to Source Control(连接到源码控制)

如果您的项目正在使用源码控制系统,那么则连接到那个源码控制系统。

请参照导出及导入Matinee元数据 页面获得关于这些主题的更多信息。

编辑

项目

描述

Undo(取消)

取消上一次完成的操作。

Redo(重复)

重复执行上一次取消的操作。

Delete Selected Keys

删除当前在时间轴中选择的关键帧。在曲线编辑器中选择关键帧不会在时间轴中选择它们。

Duplicate Selected Keys

复制(使用细微的时间偏移)在时间轴中当前选中的帧。

Insert Space(插入空间)

在当前时间光标位置处向matinee序列中插入指定的时间量。

Stretch Section(拉伸部分)

  • 拉伸(或收缩)循环区中包含的序列部分,使其与指定的时间量匹配。

Stretch Selected Key Frames(拉伸选中的关键帧)

拉伸由选中的关键帧定义的时间段部分,使其和指定的时间量相匹配。

Delete Section(删除部分)

删除循环区中包含的序列部分。

Select In Section(选择循环区中的关键帧)

选择循环区中包含的所有关键帧。

Reduce Keys(减少关键帧)

减少当前选中轨迹中的关键帧的数量。这对于在外部应用程序中编辑的轨迹,以及对于获得期望动画来说有少量冗余帧的轨迹,是有用的。请参照关键帧简化 页面获得更多详细信息。

Save Path Time(保存路径时间)

保存在构建路径时要使用的移动 actor的当前时间和位置。

Jump To Path Time(跳转到路径时间)

将时间光标移动到保存的路径构建位置处。

Editor Preferences(编辑器偏好设置)

允许您配置虚幻编辑器的行为及功能。注意,这里提供的选项和虚幻编辑器的 Edit(编辑) 菜单中的 Editor Preferences(编辑器偏好设置) 选项一样。

Project Settings(项目设置)

允许您修改您的当前项目的设置。注意,这里提供的选项和虚幻编辑器的 Edit(编辑) 菜单中的 Project Settings(项目设置) 选项一样。

视图

项目

描述

Draw 3D Trajectories(描画3D轨迹)

切换是否在视窗中显示 3D 运动路径。通过点击轨迹列表中轨迹上的togglepath_button.jpg按钮可以打开或关闭单个轨迹的路径显示。

Show All 3D Trajectories(显示所有3D轨迹)

开启序列中所有运动轨迹的 3D 运动路径显示。

Hide All 3D Trajectories(隐藏所有3D轨迹)

禁用序列中所有运动轨迹的 3D 运动路径。

Snap(对齐)

切换时间光标和关键帧的对齐状态。

Time to Frames(对齐时间到帧)

将时间轴光标对齐到 Snap Size(对齐大小)下拉菜单中指定的帧速率。只有在捕捉大小设置是以帧每秒为单位的情况下才启用。

Fixed Time(固定时间)

将播放速率锁定为Snap Size下拉菜单中指定的帧速率。只有在捕捉大小设置是以帧每秒为单位的情况下才启用。

Prefer Frame Numbers(倾向使用的帧数量)

切换显示帧数量,而不是显示 Anim Control 轨迹的当前光标位置的时间(以秒为单位)。

Show Time Cursor Position(显示时间光标位置)

切换是为当前选中的 Anim Control 轨迹显示 Anim Control 轨迹的光标位置信息,还是为序列中的所有 Anim Control 轨迹显示该信息。

Zoom To Time Cursor Position(缩放到时间光标位置处)

启用时间轴是应该在当前光标位置还是在可视时间轴的中心上缩放。

View Frame Stats(查看关键帧统计数据)

切换在视窗中显示帧统计数据。

Editing Crosshair(编辑十字准线)

切换视口中心处十字准线的显示状态。

Editing Grid(编辑网格)

在视口上启用并设置网格覆盖层的分辨率。

Safe Frame Settings(安全帧设置)

定义在游戏运行过程中从当前相机看到的Matinee序列的区域,考虑到它的设置,包括屏幕高宽比和视场。

Sequence(序列)

缩放时间轴到整个序列。

Selected(缩放到选中项)

缩放时间轴到选中的关键帧。

Loop(循环)

缩放时间轴到循环区。

Loop Sequence(循环序列)

设置虚幻部分的起点和终点为整个序列的起点和终点。

End(结束)

移动该时间到选中轨迹的最后一帧。

Gore(血腥)

切换是否在编辑器预览中显示血腥。

Pan Invert(平移反转)

切换在时间轴上平移是按照鼠标移动方向运动还是鼠标移动方向的反方向移动。

Allow Keyframe Bar Selection(允许关键帧条选择)

如果启用该项,那么则可以通过点击关键帧条来选择关键帧。

Allow Keyframe Text Selection(允许关键帧文本选择)

如果启用该项,则可以通过点击关键帧的文本来选择关键帧。

Lock Camera Pitch(锁定相机倾斜度)

如果启用该项,那么在编辑时则将相机倾斜度锁定到 -90到+90之间。

窗口

项目

描述

UnrealMatinee Curve Editor(UnrealMatinee 曲线编辑器)

切换曲线编辑器的显示状态。

Details(详细信息)

切换 Details(详细信息) 面板的显示状态。

工具栏

以下是工具条上每个按钮的描述,按照它们在工具条上的出现顺序从左到右介绍。

图标

描述

Add Key button

在选中轨迹的当前位置处添加一个关键帧。

Interpolation mode button

设置在添加新关键帧时使用默认插值模式。

Play button

从当前位置开始预览播放。

Loop button

循环播放循环区的预览效果。

Stop button

停止预览播放。

Reverse button

启动反向预览播放。

Camera button

在场景相机的当前位置处创建一个相机Actor。

Playback Speed button

调整预览效果的播放速度。

Snap Setting button

设置用于对齐及可视化处理的时间轴间隔尺寸。

Curves button

切换曲线编辑器。

Snap button

切换时间光标和关键帧的对齐状态。

Time to Frames button

将时间轴光标对齐到 Snap Size(对齐大小)下拉菜单中指定的帧速率。只有在捕捉大小设置是以帧每秒为单位的情况下才启用。

Fixed Time button

将播放速率锁定为Snap Size下拉菜单中指定的帧速率。只有在捕捉大小设置是以帧每秒为单位的情况下才启用。

Zoom Sequence button

缩放时间轴到整个序列。

Zoom Selected button

缩放时间轴到选中的关键帧。

Zoom Loop button

缩放时间轴到循环区域。

Loop Sequence button

设置虚幻部分的起点和终点为整个序列的起点和终点。

End button

移动到轨迹的末端。

Record button

打开Matinee Recorder(Matinee录制器)窗口。

Movie button

从该Matinee序列创建一个视频。

曲线编辑器

曲线编辑器允许您图形化地显示并编辑Matinee 序列中的轨迹使用的动画曲线。在 Matinee 中,其中具有可以在曲线编辑器中进行编辑的动画曲线的轨迹中包含 curve_send_button.jpg 开启按钮。点击这个按钮会将这个轨迹的曲线信息发送到曲线编辑器中,曲线在这里将会变为可见的,同时轨迹信息将会显示在轨迹列表中。

Curve Editor

请参阅 曲线编辑器用户指南 页面了解更多有关使用曲线编辑器中的曲线信息的详细情况。

轨迹视图

轨迹视图中包含了Matinee序列中所具有的所有文件夹、组及轨迹的列表,并在时间轴上显示了它们的关键帧信息,您可以在时间轴上编辑这些信息。它由以下几个部分组成:

Timeline Pane

  1. 组选卡

  2. 组和轨迹列表

  3. 时间轴信息

  4. 时间轴

组选卡

Group Tabs

时间轴面板的顶部的选卡,显示了当前Matinee序列中存在的所有Group Tabs(组选卡)。组选项卡是一种根据组和轨迹的功能组织它们的简便方法。是否使用它们完全是一个可选项。对于非常简单的序列,您可能只需将所有组和轨迹保留在默认的 All(所有) 选项卡中。但是对于复杂的序列,像那些用于创建游戏中过场动画的序列,您要尽量充分利用这些选项卡,因为序列中组和轨迹数量可能会快速增加并变得很难进行导航。All(所有) 选项卡通常会显示序列中的所有组和轨迹,所以向一个对应的组选项卡中添加相关轨迹将会是查找并编辑这些组和轨迹的快捷简便方法。除那些默认情况下提供的选项卡外,您还可以创建您自己定义的选项卡,根据您所选择的标准条件组织您的组和轨迹。

组和轨迹列表

Group and Track List

组和轨迹列表会显示当前选中的组选项卡中的所有组和轨迹。在一个新的 Matinee 序列中默认情况下为空。

时间轴信息

时间轴信息面板显示了关于时间轴的信息,包括时间轴光标的当前位置和当前场景的总长度。

时间轴

Timeline

时间轴是对序列中所有轨迹的全部关键帧的图形表示形式。它沿着底部水平方向显示了时间,其中还包含循环区(绿色)和序列本身(红色)的开始和结束标记。您可以直接在时间轴上选择并修改关键帧。有些关键帧只简单地显示为三角形,而其他关键帧则显示为后面带有颜色条的三角形。这些是具有特定持续时间的动画、声音等的关键帧。颜色条可以显示关键帧所触发的动作的持续时间。

详细信息

Properties Pane

Details(详细信息) 面板是一个标准的虚幻引擎详细信息窗口,显示了时间轴面板的轨迹列表中当前选中的文件夹、组或轨迹的详细信息。

操作

鼠标操作

操作

动作

点击拖拽背景

到处移动序列

鼠标滚轮

缩放控制

Click on key(点击按键)

选择关键帧

键盘操作

操作

动作

Ctrl-点击对象

切换对象的选择状态。

Ctrl-拖拽

移动当前的选项。

Ctrl-Alt-拖拽

盒式选择。

Ctrl-Alt-Shift-拖拽

盒式选择 (添加到当前选项)

热键

操作

动作

Enter(进入)

在已选定轨迹上的当前位置添加关键帧

Ctrl-W

复制已选定的关键帧

Delete(删除)

删除已选定的关键帧

Left/Right Cursor(左右行光标)

跳至已选定轨迹上的前一个/下一个关键帧

Up/Down Cursor(上下行光标)

在列表中上下移动已选定 Group(组)

Ctrl-Z

取消

Ctrl-Y

重复

R

Razor Tool(剃刀工具)(适用于 AnimControl 轨迹 - 参阅下文)