Language:
Page Info
Engine Version:
Share
此中文页面内容对应的英文页面有后续更新,如需浏览最新文档可切换至英文页面浏览。

材质编辑器 UI

材质编辑器 UI 由菜单栏、工具栏和默认的四个开启面板组成。

UpdatedUI.jpg

  1. 菜单栏 - 列出当前材质的菜单选项。

  2. 工具栏 - 含材质使用工具。

  3. 视口面板(Viewport Panel) - 预览材质在网格体上的效果。

  4. 细节面板(Details Panel) - 列出材质、所选材质表现或函数节点的属性。

  5. 图表面板(Graph Panel) - 显示创建材质着色器指令的材质表现和函数节点。

  6. 调色板面板(Palette Panel) - 列出所有材质表现和函数节点。

此外还有一个默认不显示的 HLSL 代码面板。在 Window 菜单中点击 HLSL Code 即可显示。如需了解更多内容,请查阅 HLSL 代码

您可以通过点击选卡右上角的小 "X" 来关闭任何面板。您也可以通过右击面板,然后在弹出的关联菜单中点击 Hide Tab(隐藏选卡),来隐藏任何面板。要想再次显示您已经关闭的面板,在 Window(窗口) 菜单中点击那个面板的名称即可。

菜单栏

File

  • Save - 保存您的当前处理的资源。

  • Save All(保存所有) - 保存您的项目中所有未保存的关卡及资源。

  • Choose Files to Save(选择要保存的文件) - 弹出一个对话框,允许您选择您想为您的项目保存的关卡及资源。

  • Connect To Source Control(连接到源码控制) - 弹出一个对话框,允许选择一个虚幻编辑器可以集成的源码控制系统或者同其进行交互。

Edit

  • Undo(取消) - 取消最近的操作。

  • Redo(重复) - 如果最后一次操作是取消操作,则重复执行最近一次取消的操作。

  • Editor Preferences(编辑器偏好设置) - 提供了一个选项列表,其中点击任何一个选项都会打开 Editor Preferences(编辑器偏好设置) 的相应部分,在那里,您可以修改您的虚幻编辑偏好设置。

  • Project Settings(项目设置) - 提供了一个选项列表,点击其中任何一项都会打开 Project Settings(项目设置) 窗口的对应部分,在那里您可以修改您的虚幻引擎项目的各种设置。

Assets

  • Find in Content Browser(在内容浏览器中查找) - 在内容浏览器中定位并选择当前资源。

Window

  • Toolbar(工具条) - 切换工具条的显示状态。

  • Viewport(视口) - 切换 Viewport(视口) 面板的显示状态。

  • Graph - 开关 Graph 面板的显示。

  • Details(详细信息) - 切换 Details(详细信息) 面板的显示状态。

  • Palette - 开关 Palette 面板的显示。

  • Stats - 开关 Stats 面板的显示。

  • HLSL Code - 开关 HLSL Code 面板的显示(默认为关闭)。

  • Content Browser(内容浏览器) - 在一个单独的窗口中打开内容浏览器。

  • Developer Tools(开发者工具) - 在单独的视口中打开选中的开发者工具(相机调试器、碰撞分析器、调试工具、模块、控件映射器)

    • Blueprint Debugger(蓝图调试器) - 在一个单独的窗口中打开蓝图调试器。

    • Collision Analyzer - Brings up the Collision Analyzer in a separate window.

    • Debug Tool - Brings up the Debug Tool in a separate window.

    • Message Log(消息日志) - 在一个单独的窗口中打开消息日志。

    • Output Log(输出日志) - 在一个单独的窗口中打开输出日志。

    • Visual Logger - Bring up the Visual Logger tool in a separate window.

    • Class Viewer(类别查看器) - 在一个单独的窗口中打开类别查看器。

    • Device Manager(设备管理器) - 在一个单独的窗口中打开设备管理器。

    • Device Profiles - Brings up the Device Profiles in a separate window.

    • Modules - Brings up Modules in a separate window.

    • Session Frontend(会话前端) - 在一个单独的窗口中打开Unreal Frontend。

    • Widget Reflector - Brings up Widget Reflector in a separate window.

  • Undo History - Brings up the Undo History panel in a separate window.

  • Plugins(插件) - 弹出插件窗口。

  • Reset Layout - Resets your layout to a default arrangement. Requires the editor to restart after saving your changes and creating a backup of your settings.

  • Save Layout(保存布局) - 将面板的当前布局保存作为新的默认布局。

  • Enable Fullscreen(启用全屏) - 为该应用程序启用全屏模式,在整个显示器上展开应用程序。

Help

  • Browse documentation(浏览文档) - 打开一个浏览器窗口,并导航到关于该工具的文档处。

  • Forums - Opens a browser window to the Unreal Engine Forums where you can discuss the Unreal Engine with other users.

  • Answer Hub - Opens a browser window to the Unreal Engine 4 Answer Hub where you can ask questions and find useful answers provided by other users and experts.

  • Wiki - Opens a browser window to the official Unreal Engine 4 Wiki where you can find useful tutorials and examples made by both users and experts here at Epic.

  • Visit EpicGames.com(访问EpicGames.com) - 在浏览器窗口中打开EpicGames.com。

  • About Unreal Editor(关于虚幻编辑器) - 显示应用程序的制作人员、版权信息、及版本信息。

工具栏

Material Editor Toolbar

下表列出了工具栏中的选项以及它们的功能。

图标

描述

Common_Toolbar_Save.png

保存当前资源。

Common_Toolbar_CB.png

在内容浏览器中查找并选中当前资源。

toolbar_apply.png

应用材质编辑器中对原始材质进行的变更,以及该材质在世界场景中的使用。

toolbar_search.png

找到当前材质中的表现和注解。

toolbar_home.png

Graph 面板中使基础材质节点居中。

toolbar_clean.png

删除未与材质连接的材质节点。

toolbar_show.png

显示或隐藏未连接的材质节点。

toolbar_live_nodes.png

启用后将实时更新每个材质节点中的材质。禁用此项后材质编辑器性能更佳。请查阅 实时节点和实时更新 部分。

toolbar_live_update.png

启用后,在节点被添加、被删除、被连接、被断开连接,或其属性值发生改变时对所有子表现的着色器进行编译。禁用此项后材质编辑器性能更佳。请查阅 实时节点和实时更新 部分。

toolbar_stats.png

隐藏或显示 Graph 面板中的材质统计。

toobar_release_stats

在状态报告中切换使用发布着色器或开发着色器。

toolbar_built_in_stats

切换空材质的状态显示。有助于确定图表中变更的开销。

toolbar_mobile_stats

切换移动平台材质状态和汇编错误。

视口面板

Material Editor Preview Panel

视口 面板显示应用到网格体的材质(正处于编辑中)。

可使用下表中的选项在 视口 面板中导航。

操作

描述

鼠标左键拖动

旋转网格体

鼠标中键拖动

平移

鼠标右键拖动

缩放

长按 L 鼠标左键拖动

旋转光源方向

使用相关工具栏功能按钮(形状按钮、选择预览网格体(Select Preview Mesh) 组合按钮、使用所选静态网格体(Use Selected StaticMesh) 按钮)可变更视口网格体。视口网格体和材质一同保存, 材质下次在材质编辑器中打开时即可在相同的网格体上进行预览。

预览(Preview) 面板顶部有数个图标,下表为它们的用法细节。

图标

描述

toolbar_cylinder.pngtoolbar_sphere.pngtoolbar_plane.pngtoolbar_cube.png

Preview 面板中显示当前材质在各个原始形态上的效果。

toolbar_mesh.png

Content Browser 中选中的静态网格体设为预览网格体。

toolbar_grid.png

开关 Preview 面板中的背景网格。

toolbar_realtime_preview.png

启用后将实时更新预览网格体上的材质。禁用此项后材质编辑器性能更佳。

Details 面板

Material Editor Details Panel

此面板包含所有当前选中材质表现和函数节点。如未选中节点,将显示 编辑中材质的属性。

可在 材质属性 中查阅所有材质属性 的描述。

Graph 面板

MaterialGraph1.jpg

此面板包含属于此材质的所有材质表现的图表。每个材质默认包含一个单独基础材质节点。此节点拥有一系列输入,每个都和材质的一个不同方面 (其他材质节点可进行连接)相关。

Material Editor Material Node

可在 材质输入 中查阅基础材质节点 诸多输入的描述。

Palette 面板

Palette 面板包含可通过“拖放”放置到材质中的材质节点列表。如需放置一个新的材质节点, 将其拖入 Graph 面板即可。

可在 Category 下拉列表中选择 ExpressionsFunctions,对 Palette 面板中列出的材质节点进行过滤。

如需了解材质函数的更多内容,请查阅 材质函数

Stats 面板

StatsPanel.jpg

此面板显示材质中使用的着色器指令数量和 编译器错误 。指令数越少,材质的开销越低。未和基础材质节点连接的材质表现节点不计算在材质的指令数(开销)以内。

HLSL 代码面板

MaterialEditor_HLSLPanel.png

此面板显示当前材质生成的 高级着色器语言(High Level Shader Language)(HLSL) 代码。注意:这并非是一个编辑器;无法修改 HLSL 代码。这只是一个查看器,显示材质网络定义的代码。

Code View 面板默认不显示。在 Window 菜单中点击 HLSL Code 即可显示。

图表功能键

材质编辑器中的功能键通常和虚幻编辑器中其他工具的功能键相匹配。例如以其他连接对象编辑器的方式在材质表现图表中导航,材质预览网格体可根据其他网格体进行导向,等等。

鼠标功能键

功能键

操作

在背景上拖动鼠标左键或右键

平移材质表现图表

旋转鼠标滚轮

放大缩小

鼠标左键加右键拖动

放大缩小

在对象上按下鼠标左键

选择表现/注释

在对象上按下 Ctrl + 鼠标左键

切换选择表现/注释

Ctrl + 鼠标左键拖动

移动当前选择/注释

Ctrl + Alt + 鼠标左键拖动

框选

Ctrl + Alt + Shift + 鼠标左键拖动

框选(添加到当前选择)

在接头上拖动鼠标左键

创建连接(在接头上松开)

从连接拖动鼠标左键

移动连接(在同类接头上松开)

在接头上 Shift + 鼠标左键双击

标记接头。在已标记的接头上再次执行此操作将在两个接头之间建立连接。通过此法可快速创建长距离连接。

在背景上按下鼠标右键

呼出 New Expression 菜单

在对象上按下鼠标右键

呼出 Object 菜单

在接头上按下鼠标右键

呼出 Object 菜单

在接头上按下 Alt + 鼠标左键

断开到接头的所有连接

键盘功能键

功能键

操作

Ctrl + B

在 Content Browser 中进行寻找

Ctrl + C

复制选中的表现

Ctrl + S

全部保存

Ctrl + V

粘贴

Ctrl + W

生成选中对象的副本

Ctrl + Y

重做

Ctrl + Z

撤销

Delete

删除选中的对象

空格键

强制更新所有材质表现预览

Enter

(和点击应用相同)

热键

可使用热键放置常用的材质表现类型。长按热键并 单击左键 在节点中进行放置。热键如下:

热键

表现

A

Add

B

BumpOffset

C

Comment

D

Divide

E

Power

F

MaterialFunctionCall

I

If

L

LinearInterpolate

M

Multiply

N

Normalize

O

OneMinus

P

Panner

R

ReflectionVector

S

ScalarParameter

T

TextureSample

U

TexCoord

V

VectorParameter

1

Constant

2

Constant2Vector

3

Constant3Vector

4

Constant4Vector

Shift + C

ComponentMask