Language:
Page Info
Engine Version:
Share
此中文页面内容对应的英文页面有后续更新,如需浏览最新文档可切换至英文页面浏览。

管理游戏代码

选择操作系统

Windows

Mac OS

添加代码到项目

C++类向导

C++类向导 提供了快速和简单的方法来添加native C++代码类到您的项目,以按您所需来扩展功能。 这会把仅有内容的项目转化为代码项目。 您可以按如下方式使用C++类向导:

在Windows操作系统,请在继续前确认您安装了Visual Studio 2013 Express、Community或Professional版。 在Mac,请确认您安装了Xcode 6.1或更高版本。

  1. 在主编辑器中,选择 File > Add Code to Project... (文件>添加代码到项目...)

    FileCPP.png

  2. C++类向导 将会出现, 显示通常所添加的类。 如果您没有看到您正在搜寻的类,那么您需要查看整个类的层次列表。 勾选窗口右上角的button_ShowAllClasses.png复选框。

    默认类

    所有类

    选择您想要添加的类并点击 button_Next.png 按钮。

  3. 您会被提示是否要为您的新类输入一个 名称。 输入名称后点击button_Create.png按钮。 这样会创建头文件(.h)和源文件(.cpp)文件。

    类名称仅能包含字母,数字字符并且不能包含空格。 如果名称无效,此处会提示您。

  4. 代码将会立即在 Visual Studio 2013 中打开,等待编辑。

    CodeEditing.png

    此代码将马上在 Xcode 中打开,以供编辑。

    CodeEditing_xcode.png

关于如何在完成编辑后编译类,请查阅 编译项目文件

开发环境

一般情况下,代码文件可以通过Visual Studio来创建,并通过 Solution Explorer (解决方案浏览器)来添加到游戏项目中。 您也可以添加代码文件到Visual Studio外的合适文件夹中,并自动重建解决方案和项目文件。 这使得通过操作系统UI来快速添加许多文件变得方便,并使得团队工作更为方便,因为解决方案和项目文件不需要在团队成员间同步。 每个人都可以同步代码文件并在本地重建项目文件。

一般情况下,代码文件可以通过Xcode来创建,并通过 **Project Navigator* (项目导航程序)来添加到游戏项目中。 您也可以添加代码文件到Xcode外的合适文件夹中,并自动重建项目文件。 这使得通过操作系统UI来快速添加许多文件变得方便,并使得团队工作更为方便,因为解决方案和项目文件不需要在团队成员间同步。 每个人都可以同步代码文件并在本地重建项目文件。

在开发环境中打开项目

如果您的项目已经在编辑器中打开,您可以通过选择 文件 菜单的 在Visual Studio中打开 来很方便地在Visual Studio中打开它。

open_visual_studio.png

您也可以通过Windows Explorer浏览器或 Visual Studio的 文件 > 打开 > 项目/解决方案 来打开Visual Studio中的项目。

  • 请打开位于项目根目录的[ProjectName].sln Visual Studio解决方案文件。

如果您的项目已经在编辑器中打开,您可以通过选择 文件 菜单的 在Xcode中打开 来很方便地在Xcode中打开它。

open_xcode.png

您也可以通过搜寻程序或Xcode的 文件 > 打开 来打开Xcode中的项目。

  • 请打开位于项目根目录的[ProjectName].xcodeproj Xcode项目文件。

生产项目文件

项目文件是中间文件 - 位于[ProjectDirectory]\Intermediate\ProjectFiles。 这表示,如果您删除Intermediate文件夹,您必须重新生成项目文件。

.uproject文件

  1. 在资源管理器中浏览至[ProjectName].uproject的位置。

  2. 右击 [ProjectName].uproject文件并选择 生成Visual Studio文件

    Generate_Visual_Studio_Files.png

  3. UnrealBuildTool会更新项目文件和解决方案,包括生成智能提示数据。

    generate_project_files.png

  4. 请打开位于项目根目录的[ProjectName].sln Visual Studio解决方案文件,以查看Visual Studio中的游戏项目。

  1. 在搜寻程序中浏览至[ProjectName].uproject的位置。

  2. 右击 [ProjectName].uproject文件并选择生成 Xcode文件。

    Generate_Xcode_Files.png

  3. UnrealBuildTool会更新项目

    generate_project_files_xcode.png

  4. 请打开位于项目根目录的[ProjectName].xcodeproj Xcode项目,以查看Xcode中的游戏项目。