Language:
Page Info
Skill Level:
Engine Version:

1.1 - Setting up your Project

During this step, we're going to create a starting point for our First Person Shooter (FPS) game by using Unreal Engine 4's Project Browser.

  1. After opening Unreal Engine from the Epic Launcher, a Project Browser will appear.

  2. Click on the New Project tab and then select the C++ tab.

  3. Now, select the Basic Code project.

  4. Name your project "FPSProject", making sure No Starter Content is set.

    UnrealPrjBrowser_Cpp.png

    Some of the code samples in this tutorial will need to be updated if you name your project differently.

  5. After you've named your project, go ahead and click the Create Project button.

  6. At this point, your project is open in the Unreal Editor. This is a good time to click the Play button to enter Play in Editor (PIE) mode.

    ClickPlayButton.png

    Use the WASD keys to move around the level while using your mouse to aim the camera.

  7. Press the Escape key or click the Stop button in the Level Editor to exit PIE mode.

    ClickStopButton.png

  8. Now that you're done exploring the level, go ahead and create a Maps folder within the Content folder.

    MapsFolder.png

  9. In the File menu, select Save as... to save your level as "FPSMap" within the Maps folder.

    SaveLevelAs.png

  10. From the Edit menu, click on Project Settings.

    EditProjectSettings.png

  11. Under the Project heading on the left side of the Project Settings tab, click on Maps & Modes.

    ProjectMaps_Modes.png

  12. Using the dropdown menu, select FPSMap as the Editor Startup Map.

    EditorDefaultMap.png

    From now on, the editor will automatically load FPSMap as the default map.

  13. Finally, close the Project Settings menu and save your project before moving onto the next step.