Language:
Page Info
Tags:
Engine Version:
The translation of this page is out of date. Please see the English version for the latest version of the page.

カスケード パーティクル エディタのリファレンス

カスケードは、アンリアル エンジンでエミッタを使用してモジュール式のパーティクル ベースのエフェクトを作成するためのツールです。

カスケードの開き方

カスケード パーティクル エディタは、いずれかのパーティクル システム アセットをダブルクリック、もしくは コンテンツブラウザ 内のパーティクル システム アセットのコンテキスト メニューを右クリックして開きます。カスケード内の特定のパーティクル システムの編集が可能になります。

カスケード インターフェース

カスケードには、以下の 6 つの主要領域があります。

Cascade_Interface.png

  1. メニューバー - コンテンツ ブラウザ でアセットの保存、現在のパーティクル システムの検索にアクセスします。

  2. ツールバー -可視化とナビゲーションのツールです。

  3. ビューポート パネル - 現在のパーティクル システムを表示します (そのシステムにあるすべてのエミッタを含みます)。Sim ツールバーのオプション設定のシミュレーション速度で制御します。

  4. Emitters パネル -現在のパーティクル システム内にあるすべてのエミッタのリストと、これらのエミッタ内のすべてのモジュールのリストがあります。

  5. 詳細パネル -現在のパーティクル システム、パーティクル エミッタ、パーティクル モジュールを表示したり、修正できます。

  6. カーブ エディタ - 相対時間または絶対時間のいずれかで修正されたプロパティを表示するグラフ エディタです。グラフ エディタにはモジュールが追加と、表示を調節できます (このドキュメントの後半で説明します)。

メニューバー

Cascade_Menubar.png

ファイル

コマンド

説明

ロードと保存

Save

現在のパーティクル システムのアセットを保存します。

Save All

すべてのアセットを保存します。

Choose Files to Save

アセットの保存オプションを付けてダイアログを開きます。

アプリケーション

Switch Project

使用可能なすべてのゲーム プロジェクトを切り替えます。

Exit

エディタを閉じます。

編集

コマンド

説明

アクション

Undo

最後の動作を元に戻します。

Redo

最後に元に戻した動作をやり直します。

アセット

コマンド

説明

アクション

Find in Content Browser

コンテンツ ブラウザ で選択中のパーティクル システムを検索します。

ウィンドウ

コマンド

説明

アセット エディタ TabsEditor タブ

Viewport

ビューポートパネル タブを開きます。このタブには、結果として得られるパーティクル システムが表示されます。

Emitters

エミッタ リスト タブを開きます。このタブで、各種エミッタをパーティクル システムに追加できます。

Details

詳細パネル タブを開きます。このタブで、各パーティクル モジュールのプロパティを編集できます。

Curve Editor

カーブ エディタ を開きます。ここで、アニメーション カーブでプロパティの調節ができます。

Toolbar

ツールバー を開きます。一般的な操作用の一連のショートカットが横方向に並びます。

ツールバー

ツールバーには以下の操作機能が含まれます。

Cascade_ToolBar.png

ツールバーには、以下のコントロールがあります (ツールバーの左から右へ)。

アイコン

名前

説明

Cascade_Toolbar_Save.png

Save

現在のパーティクル システムのアセットを保存します。

Cascade_Toolbar_FindInCB.png

Find in Content Browser

コンテンツ ブラウザ で選択中のパーティクル システムを検索します。

Cascade_Toolbar_RestartSim.png

Restart Sim

ビューポート ウィンドウのシミュレーションをリセットします。スペースバー を押しても同じ操作を行うことができます。

Cascade_Toolbar_RestartLevel.png

Restart in Level

レベル内のパーティクル システムとシステムのインスタンスをリセットします。

Cascade_Toolbar_Undo.png

Undo

直前の操作を元に戻します。Ctrl + Z を使用しても同じ操作を行うことができます。

Cascade_Toolbar_Redo.png

Redo

直前の元に戻した操作をやり直します。Ctrl + Y を使用しても同じ操作を行うことができます。。

Cascade_Toolbar_Thumbnail.png

Save Thumbnail Image

コンテンツ ブラウザのパーティクル システムのサムネイルとして、ビューポート ペインのカメラからビューポートを保存します。

Cascade_Toolbar_Bounds.png

Toggle Bounds

ビューポート ペインで、パーティクル システムの現在の境界の表示を切り替えます。

Cascade_Toolbar_BoundsOptions.png

Bounds Options

クリックすると、GPU スプライトパーティクル システムに対して固定の境界をセットアップできます。固定された境界が GPU スプライト パーティクルの移動可能距離を制限します。

Cascade_Toolbar_OriginAxis.png

Toggle Origin Axis

パーティクル ビューポート ウィンドウで、原点軸の表示、非表示を切り替えます。

Cascade_Toolbar_RegenLOD.png

Regenerate lowest LOD duplicating highest

最高 LOD を複製して最低 LOD を再生成します。

Cascade_Toolbar_RegenLODPer.png

Regenerate lowest LOD

最高 LOD 値の設定済みパーセントである値を使って最低 LOD を再生成します。

Cascade_Toolbar_HighestLOD.png

Jump to Highest LOD Level

最高 LOD をロードします。

Cascade_Toolbar_AddLOD_Before.png

Add LOD before current

現在ロードした LOD の直前に新しい LOD を追加します。

Cascade_Toolbar_AddLOD_After.png

Add LOD after current

現在ロードした LOD の直後に新しい LODを追加します。

Cascade_Toolbar_LowerLOD.png

Jump to Lower LOD Level

次に低い LOD をロードします。

Cascade_Toolbar_LowestLOD.png

Jump to Lowest LOD Level

最低 LOD をロードします。

Cascade_Toolbar_DeleteLOD.png

Delete LOD

現在ロードした LOD を削除します。

Cascade_Toolbar_CurrentLOD.png

Current LOD Slider

プレビューする LOD を選択できます。値を手入力、もしくはマウスをドラッグして数字を編集します。

ビューポート パネル

PreviewPane.png

[Viewport] ペインには、インゲームのレンダリング時に表示されるとおりに、現在のパーティクル システムをレンダリングしたプレビューが表示されます。カスケードでパーティクル システムに加えた変更がリアルタイムでフィードバックされます。完全にレンダリングされたプレビューに加えて、ビューポート ペインには unlit (ライティング無し)、テクスチャ密度、オーバードロー、ワイヤーフレームのビューモードもレンダリングできます。また、パーティクル システムの現在の領域などの情報も表示します。

ビューポート ペインのナビゲーション

[Viewport] ペインはマウスを使用して次のような方法でナビゲーションできます。

ボタン

操作

マウスの左ボタン

パーティクル システムの周囲でカメラをタンブル (回転) させます。

マウスホイール

パーティクル システムの周囲でカメラをパンさせます。

マウスの右ボタン

カメラを回転させます。

Alt キーとマウスの左ボタン

パーティクル システムを周回させます。

Alt キーとマウスの右ボタン

パーティクル システムに向かって、およびパーティクル システムから離れてカメラをドリーさせます。

F

パーティクル システムにフォーカスします。

L + 左マウス

ライティングを回転させます。Lit (ライティング有り) マテリアルを使用しているパーティクルでのみ機能します。Unlit (ライティング無し) パーティクル (ほとんどのフレーム、スパークなど) では機能しません。

ビューポート ペイン メニュー

PreviewPaneMenus.png

[Viewport] ペインの左上隅には、2 つのメニューがあります。この 2 つのメニューによって、ビューポート ペインのいくつかの機能を表示、非表示にしたり、プレビューの設定を制御できます。

View メニュー

ViewMenu.png

[View (表示)] メニューでは、ビューポート ペインの様々な診断と可視化機能の表 / 非表示が可能になります。[View (表示)] メニューには以下のオプションが含まれます。

アイテム

説明

View メニュー

View Overlays

[View Overlays] サブメニューにアクセスします。下記参照。

View Modes

[View Modes] サブメニューにアクセスします。下記参照。

Detail Modes

[Detail Modes] サブメニューにアクセスします。下記参照。

Background Color

ビューポート ペインの背景色を変更できるカラーピッカーを呼び出します。

Orbit Mode

ビューポート ペインでパーティクル システムを周回、自由移動するカメラの動作を切り替えます。

Origin Axis

原点軸ギズモ、特に左下隅にある原点軸ギズモのの可視性を切り替えます。

Vector Fields

パーティクル システムに適用されるベクター フィールドの可視性を切り替えます。

Grid

グリッドの可視性を切り替えます。

Wireframe Sphere

球半径を表すパーティクル システムのワイヤーフレーム球体を呼び出します。

Post Process

グローバルなポストプロセスの可視性を切り替えます。

Motion

パーティクル システムを固定、またはグリッドの中心周囲を回転させるかを切り替えます。

Motion Radius

モーション設定の回転半径を設定できる入力欄を呼び出します。

Geometry

デフォルトのテスト メッシュを表示または非表示にします。

Geometry Properties

[Geometry Properties (ジオメトリ プロパティ)] ウィンドウを呼び出します。このウィンドウでは、配置の調整、使用したメッシュの交換、デフォルトのジオメトリを調整することができ、他の多くのオプションがあります。

Bounds

パーティクル システムの可視性を切り替えます。バウンディング ボックスとバウンディング球の両方で表示されます。

Set Fixed Bounds

パーティクル システムの固定境界を有効にし、自動的に値をそれまでに計算された最大設定に設定します。

View Overlay サブメニュー

ViewOverlaysMenu.png

[View Overlay] サブメニューでは、現在のパーティクルシステムのステータスについて様々な情報を与えてくれる一連のデータの読み出しを切り替えることができます。

アイテム

説明

View Overlay サブメニュー

Particle Counts

パーティクル カウントのオーバーレイを切り替えます。これは、システムで各エミッタからエミットされているパーティクル数を示します。

Particle Event Counts

イベント数オーバーレイの可視性を切り替えます。各エミッタ内でトリガーされたイベント数を示します。

Particle Distance

TODO (今後解説予定)

Particle Times

パーティクルのエミッタ時間のフィードバック表示を切り替えます。これは、各エミッタがアクティブであった時間を示します。

Particle Memory

テンプレートと各インスタンスの両方について、パーティクル システムのメモリ使用の表示を切り替えます。

View Modes サブメニュー

ViewModeMenu.png

[View Modes] サブメニューでは、ビューポート ペインで様々な描画モード間を切り替えることができます。

Wireframe

[Wireframe] ビューモードでは、パーティクルのワイヤーフレームが表示されます。スプライトの場合、各スプライトを構成する 2 つのポリゴンが表示されます。

Wireframe.png

Unlit (ライティング無し)

[Unlit] ビューモードでは、ライティングまたはポストプロセスなしのパーティクルが表示されます。

Unlit.png

Lit (ライティング有り)

[Lit] ビューモードでは、ライティングまたはポストプロセスが付いたパーティクルが表示されます。

Lit.png

Shader Complexity (シェーダーの複雑度)

Shader Complexity (シェーダの複雑度) では、特定のシェーダに対して必要な命令数についてのフィードバックが表示されます。緑は最低値で、命令値が大きくなるに従い次第に赤に近づきます。

ShaderComplexity.png

Detail Modes サブメニュー

[Detail Modes (詳細モード)] のサブメニューでは、lowmediumhigh の詳細の間でビューポート ウィンドウを切り替えることができます。こうした詳細は、エンジンの詳細モードと相関関係があり、それぞれのモードでのパーティクル システムの見え方を表示することができます。

DetailModesMenu.png

アイテム

説明

Detail Modes サブメニュー

Low

システムの詳細モードを low に設定した場合に表示されるパーティクル システムをプレビューします。

Medium

システムの詳細モードを medium に設定した場合に表示されるパーティクル システムをプレビューします。

High

システムの詳細モードを high に設定した場合に表示されるパーティクル システムをプレビューします。

Time メニュー

TimeMenu.png

[Time ] メニューでは、ビューポート ペインの再生スピードを調整することができます。

アイテム

説明

Time メニュー

Play/Pause

チェックを入れるとシミュレーションが再生されます。チェックを外すと、シミュレーションが停止します。

Realtime

チェックを入れるとシミュレーションがリアルタイムで再生されます。チェックを外すと、Viewport ペインが更新された場合のみシミュレーションが再生されます。

Loop

チェックを入れると、サイクルの終わりに到達すると、パーティクル システムが再スタートします。チェックを外すと、一回に限り再生します。

AnimSpeed

100%, 50%、 25%, 10%、1 % の間で再生速度の割合を調整できるサブメニューを開きます。

Emitters パネル

EmitterList.png

[Emitters] パネルには、カスケードで現在開いているパーティクル システム内の各パーティクル エミッタがあります。ユーザーは、パーティクル システムの外観とビヘイビアを制御する様々なパーティクル モジュールをここで追加、選択、作業を行います。

エミッタ リストには、現在のパーティクル システム内のすべてのエミッタが横方向に配置されています。パーティクル システムあたりのエミッタ数に制限はなく、エフェクト全体でそれぞれが別々の側面を処理するのが一般的です。

1 カラムにつきパーティクル エミッタ 1 つを表します。上部にエミッタブロック、その下に任意の数のモジュールブロックが表示されます。エミッタ ブロックには、エミッタの名前、タイプなどのエミッタの主要なプロパティが含まれます。その下にあるモジュールは、それぞれパーティクルの動作の様々な側面を制御します。

エミッタ リストのインターフェイスは、比較的簡単なものですが、右マウスボタンからアクセスできるコンテキスト依存のメニューもあります。

パーティクル システム内にあるエミッタは、エミッタ リストに沿って左から右に計算されます。エミッタをクリックし、左右の矢印キー を使用してリストに沿ってエミッタを再配置します。

ナビゲーションおよび制御

以下の制御とコマンドは、エミッタ リストで適用されます。

ボタン

操作

マウスの左ボタンをクリック

エミッタまたはモジュールを選択します。

(モジュール上で) Ctrl + 左クリックしてドラッグ

モジュールをあるエミッタから他のエミッタに移動します。

(モジュール上で) Shift + 左クリックしてドラッグ

エミッタ間にインスタンスが作成されます。このモジュールインスタンスは名前の横の + 記号で示され、2 つのモジュールは同じ色を共有します。

(モジュール上で) Ctrl + 左クリックしてドラッグ

ソース エミッタからターゲット エミッタにモジュールをコピーします。

右クリック

コンテキスト メニューを開きます。空のカラムで 右クリック すると、新しいエミッタを作成することができます。エミッタ上で 右クリック すると、そのエミッタ自体で様々な関数を実行したり、新しいモジュールを追加することができます。

左右の矢印キー

エミッタを選択すると、エミッタ リスト内でエミッタをさらに左側または右側に再配置します。

エミッタ

エミッタ リストを使用する場合、リスト内にあるエミッタの基本的なアナトミー (分析) を理解することが重要です。詳細です。

EmitterCallout.png

  1. エミッタ カラム - 各カラムは別個のエミッタを表します。

  2. エミッタ ブロック - 各エミッタの上部にあるこのボックスには、他の主要プロパティと共に、エミッタのタイプ、名前などそのエミッタ自体の主要プロパティと制御が含まれます。

  3. モジュール リスト - エミッタ ブロックの下に当該エミッタの外観と動作を定義するすべてのモジュールのリストが表示されます。すべてのエミッタには [Required] モジュールがあり、その中にビヘイビアを細かく定義するモジュールが付いている場合もあります。

spacer.png

パーティクル モジュールに関する詳細は、モジュール リファレンスのセクション を参照してください。

エミッタ リストのコンテキスト メニュー

空のカラムで 右クリック すると、新しいエミッタを作成することができます。エミッタ上で右クリックすると、エミッタの名前、タイプの変更、およびエミッタに対して様々な動作のモジュールを追加するなど、そのエミッタに対して直接行うことができるアクションのリストを呼び出します。

EmitterListMenu.png

詳細パネル

PropertiesWindow.png

[Details (詳細)] パネルには、標準の UnrealEd 4 の [Details (詳細)] ウィンドウが含まれます。[Details (詳細)] ペインに表示されるプロパティは、カスケードで現在何を選択しているかによって決まります。例えば、あるパーティクル モジュールを選択している場合、そのパーティクル モジュールに対するプロパティが表示されます。

パーティクル システム全体のメイン プロパティにアクセスするには、エミッタ リストで「nothing」 を選択するか、またはエミッタ リストで 右クリック し、コンテキスト メニューから [Particle System > Select Particle System] の順序で選択します。

カーブ エディタ

Curve_Editor.png

カスケード インターフェイスには、標準のアンリアル エディタの [Curve Editor (カーブ エディタ)] ウィンドウが含まれます。このウィンドウで、ユーザーはパーティクルの寿命中またはエミッタの寿命中に変更すべき値も調整が可能です。つまり、時間の経過に伴い変化する値を定義します。カーブ エディタ内でプロパティを (一般的にパーティクル モジュール内から) 編集可能にするには、そのプロパティはカーブを利用する DistributionFloatConstantCurve などの Distribution タイプでなければなりません。Distributions (ディストリビューション) の操作については、ディストリビューションのセクション を参照してください。

詳細は カーブ エディタのユーザーガイド ドキュメントを参照してください。

カーブ エディタにモジュールを追加するには、モジュールの左側に表示される緑色のボックスをクリックしてください。グラフ エディタに表示されるモジュールの色は、モジュール作成時にランダムに決定されます。色を変更するには、各モジュールの [Property] ウィンドウの Module Editor Color プロパティを開いて行います。

ナビゲーション

ボタン

操作

PanMode.png Pan モードのナビゲーション

左クリックしてドラッグ

正投影ビューをパンしているかのように、カーブ ビューが移動します。

マウスホイール

一定の率でズームイン / アウトします。

ZoomMode.png ズーム モードのナビゲーション

左クリックしてドラッグ

水平方向にのみビューをズームします。

右クリックしてドラッグ

垂直方向にのみビューをズームします。

グラフにカーブを追加

グラフエディタには、カーブは自動的に表示されません。グラフを編集できるようにするには、先に送信する必要があります。各パーティクルのモジュール ブロック上に小さな緑色のカーブのアイコン SendToCurveEditor_button.png があります。このアイコンをクリックすると、そのモジュールに対して利用可能なカーブが調整のためにカーブ エディタに送信されます。

グラフからカーブを削除

カーブの編集が終了したら、カーブをグラフから削除する必要が生じる場合があります。カーブの削除は、単にカーブ エディタで該当するカーブに対するブロックを 右クリック し、 Remove Curve を選択することで行うことができます。

RemoveCurve.png

グラフ上に点を作成

複数点などを追加する前に、編集対象の Distribution (分布) が「カーブ」 タイプ (例、DistributionFloatConstantCurve) であることを確認してください。

グラフエディタで点を作成するには、目的の値に対するスプラインを Ctrl + 左クリック します。一番簡単な方法は、前述のチェックボックスを使い他のモジュールをすべてオフにすることです。すべてのモジュールは、時間 0 の単一キーとしてゼロの位置から開始します。タイムライン内でスプラインの任意の位置を Ctrl + 左クリック すると、そこに点が作成されます。この点は自由自在にドラッグできますが、既に述べたようにスプラインがベクトル (XYZ) を表す場合は、そのベクトルの 3 つのキーすべての時間が移動するのに対し、値は変動しません。

キーポイントを 右クリック して表示されるメニューに、キーポイントの時間と値を手動で入力することができます。キーがカラーカーブ内にある場合は、カラーピッカーを使って色を選択できます。

モジュールが ColorOverLife の場合、描かれるスプラインはその時点の色を反映しますが、点はそのスプラインの特定のチャネルを反映する色で描かれます。

CurveEditor_1.png

モジュール

モジュールはパーティクルの動作を定義する重要なものです。各モジュールは、パーティクルがどこでスポーンするか、どのように移動するか、その色などシステムにパーティクルの動作の新たな側面を付加します。

モジュールを追加するには、エミッタのブランク エリアで 右クリック し、コンテキスト メニューからエミッタを選択します。

ModuleMenu.png

モジュールの相互作用

モジュールがどのように計算されるかを理解することは重要です。モジュールの動作は付加的なものですが、同じ値に影響を与える初期モジュールは、特に指定しない限り互いにオーバーライドします。例えば、Scale Color/Life モジュールは、現在のパーティクルの色を置き換えるというよりは、影響 を与えます。

この計算は、エミッタのスタック内で上から下に実行されます。例えば、パーティクルの色に影響を与えるモジュールは、その上に存在する類似モジュールをオーバーライドします。従って、最も重要なモジュールをスタックの最上部により近い場所で維持することは一般的に得策です。

ディストリビューションの種類

ディストリビューション (Distribution) は特殊なデータ型であり、非常に専門的な方法で数を定めるように設計されています。パーティクル モジュール内で利用可能な主要プロパティのほとんどは、割り当てられたディストリビューションを持ちます。こうしたディストリビューションは、プロパティが単一の値、範囲を持つ、またはカーブに沿って補間されるものとして定義する場合があります。

使用するディストリビューションのタイプは、プロパティに基づき変わります。例として、すべてのパーティクルのライフタイムを 5 秒にするには、DistributionFloatConstant のディストリビューションで単一の値を保持することができます。パーティクルのライフタイムを 2 秒から 5 秒の間のランダムな値にするのであれば、そうした範囲の指定が可能な DistributionFloatUniform に切り替えます。

新規ユーザーはディストリビューションが最初は複雑に感じるかもしれません。しかし、パーティクル システム内で各種プロパティの使用によって自由度が増す事にすぐ気が付くでしょう。詳細は ディストリビューションのリファレンス ページを参照してください。

Tags